source: projects/specs/trunk/g/gnucash/gnucash-vl.spec @ 12202

Revision 12202, 8.5 KB checked in by tomop, 5 years ago (diff)

updated gnucash and friends

Line 
1Name:           gnucash
2Summary:        GnuCash is an application to keep track of your finances.
3Summary(ja):    個人用財務管理アプリケーション
4Version:        3.7
5Release:        1%{?_dist_release}
6
7License:        GPL/LGPL/GFDL
8Group:              Applications/Productivity
9URL:            https://www.gnucash.org/
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13Packager:       kenta, inagaki
14
15Source:         https://github.com/Gnucash/gnucash/releases/download/%{version}/%{name}-%{version}.tar.bz2
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires: libappstream-glib-devel
19BuildRequires: aqbanking-devel >= 3.7.2
20BuildRequires: bzip2-devel
21BuildRequires: cmake
22BuildRequires: desktop-file-utils
23BuildRequires: expat-devel
24BuildRequires: gwenhywfar-devel
25BuildRequires: gettext
26BuildRequires: gmock-devel
27BuildRequires: gtest-devel
28BuildRequires: gtk3-devel
29BuildRequires: guile-devel
30BuildRequires: libappstream-glib
31BuildRequires: libboost-date-time
32BuildRequires: libboost-devel
33BuildRequires: libboost-locale
34BuildRequires: libboost-regex
35BuildRequires: libboost-filesystem
36BuildRequires: libicu-devel
37BuildRequires: libofx-devel
38BuildRequires: libdbi-devel
39BuildRequires: libjpeg-devel
40BuildRequires: libsecret-devel
41BuildRequires: libtool-ltdl-devel
42BuildRequires: libxslt-devel
43BuildRequires: pcre-devel
44BuildRequires: popt-devel
45BuildRequires: python3-devel
46BuildRequires: swig
47BuildRequires: webkitgtk4-devel
48#BuildRequires: slib
49
50BuildRequires: libdbi-dbd-pgsql
51BuildRequires: libdbi-dbd-mysql
52BuildRequires: libdbi-dbd-sqlite
53
54Requires:      aqbanking
55Requires:      perl-DateManip
56Requires:      yelp
57Requires(post,postun): gtk3
58Requires(postun,posttrans): glib2
59Obsoletes:     gnucash-backend-postgres
60
61
62%description
63GnuCash is a personal finance manager. A check-book like
64register GUI allows you to enter and track bank accounts,
65stocks, income and even currency trades. The interface is
66designed to be simple and easy to use, but is backed with
67double-entry accounting principles to ensure balanced books.
68
69%description -l ja
70GnuCashは 個人用財務管理をするアプリケーションです.
71預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
72グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
73使用できるようにデザインされています.
74
75%prep
76%setup -q
77
78%build
79%global optflags %{optflags} -Wno-parentheses
80
81%cmake . \
82        -DCMAKE_INSTALL_DOCDIR=%{_datadir}/doc/gnucash-%{version} \
83        -DWITH_SQL=OFF
84
85%make_build
86
87
88%install
89[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
90
91%make_install
92
93%find_lang %name
94
95rm -rf $RPM_BUILD_ROOT%{_infodir} \
96        $RPM_BUILD_ROOT%{_includedir} \
97        $RPM_BUILD_ROOT%{_datadir}/aclocal \
98        $RPM_BUILD_ROOT%{_libdir}/lib*.a \
99        $RPM_BUILD_ROOT%{_libdir}/gnucash/lib*.a \
100        $RPM_BUILD_ROOT%{_bindir}/gnc-test-env \
101        $RPM_BUILD_ROOT%{_bindir}/gnc-fq-update
102
103find $RPM_BUILD_ROOT%{_libdir} -name *.la -exec rm -f {} \;
104
105
106%clean
107[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
108
109
110%post
111/sbin/ldconfig
112touch --no-create %{_datadir}/icons/hicolor || :
113gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
114
115%postun
116if [ $1 -eq 0 ] ; then
117        /sbin/ldconfig
118        touch --no-create %{_datadir}/icons/hicolor || :
119        gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
120        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
121fi
122
123%posttrans
124glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
125
126%files -f %{name}.lang
127%defattr(-,root,root,755)
128%doc %{_docdir}/gnucash-%{version}/*
129%license LICENSE
130%dir %{_sysconfdir}/%{name}
131%{_bindir}/*
132%{_libdir}/*
133%{_datadir}/glib-2.0/schemas/*
134%{_datadir}/%{name}
135%{_datadir}/metainfo/*
136%{_datadir}/applications/*
137%{_datadir}/icons/hicolor/*/apps/*
138%{_mandir}/man*/*
139%config %{_sysconfdir}/%{name}/*
140
141%changelog
142* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7-1
143- new upstream release.
144
145* Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.12-1
146- new upstream release
147
148* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
149- new upstream release
150
151* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
152- remove *.la files
153
154* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
155- new upstream release
156- add BuildRequires: libtool-ltdl-devel
157
158* Mon Mar  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
159- rebuilt with libofx 0.9.10
160- added Vendor and Distribution tag
161
162* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
163- update to 2.6.5
164- remove old patches
165- add BuildRequires: libdbi-devel
166- change BuildRequires: goffice08-devel instead of goffice-devel
167
168* Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
169- rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
170- added Patch1 for building with aqbanking-4.2.4
171- added Patch2 for building with goffice-0.8.10
172
173* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
174- added slib to BuildRequires: and Requires:
175
176* Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
177- new upstream release
178
179* Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
180- new upstream release
181
182* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
183- rebuild with guile-1.8.6
184- add BuildRequires: gwenhywfar-devel
185
186* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
187- new upstream release
188- applied new versioning policy
189- built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
190
191* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
192- new upstream release
193- rebuilt with goffice-0.6.0
194
195* Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
196- new upstream release
197
198* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
199- new upstream release
200- enable HBCI (Home Banking Computer Interface)
201
202* Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
203- rebuild with libofx-0.8.3 (libofx.so.3)
204
205* Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
206- new upstream release
207- disable postgresql backend, as it is unmaintained upstream
208- added Patch0: gnucash-2.2.0-quiet.patch
209
210* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
211- new upstream release
212- remove BuildRequiers: autoconf213
213- update ja.po
214
215* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
216- new upstream release
217- added BuildPrereq: libtool-ltdl-devel
218
219* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
220- rebuild with new toolchains
221- update ja.po
222
223* Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
224- new upstream release
225
226* Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
227- merged gnucash-docs-1.8.3
228- added patch from Redhat Rawhide 1.8.7-1
229- changed Group, License
230
231* Mon Oct  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
232- updated to 1.8.7
233- updated print.patch
234- overwrite prefs.scm
235- s/Copyright/License/
236
237* Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
238- updated to 1.8.3
239- added datelength.patch
240- separated devel packages
241  (and ofx, hbci, backend-postgres. But default is off)
242
243* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
244- Build against with new gal.
245
246* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
247- Fixed printing issue.
248
249* Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
250- New upstream release.
251
252* Thu Jul 26 2001 <sagami@vinelinux.org>
253- 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
254
255* Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
256- %%make line is now commented out (bash2 complains it)
257  (BTW, what the hell is the macro %%make anyway? I don't even know...)
258
259* Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
260- update to 1.6.0 (stable release version)
261
262* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
263- update to 1.5.96 ( pre beta for 1.6.0 )
264
265* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
266- added japanese patch for reporting and printing (thanx tagoh-san)
267
268* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
269- updated to 1.5.6
270
271* Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
272- added translation messages to ja.po
273- enable guppi
274
275* Mon Apr  2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
276- upstream update
277- fixed broken ja.po
278
279* Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
280- fixed registor window cursor position problem(gnucash-cursor_pos.patch)
281
282* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
283- initial relese package
Note: See TracBrowser for help on using the repository browser.