source: projects/specs/trunk/g/gnucash/gnucash-vl.spec @ 10105

Revision 10105, 8.7 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define ver 2.6.12
2%define rel 1%{?_dist_release}
3%define __libtoolize /bin/true
4
5Name:           gnucash
6Summary:        GnuCash is an application to keep track of your finances.
7Summary(ja):    個人用財務管理アプリケーション
8Version:        %{ver}
9Release:        %{rel}
10
11License:        GPL/LGPL/GFDL
12Group:          Applications/Productivity
13URL:            http://www.gnucash.org/
14
15Source:         %{name}-%{version}.tar.bz2
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires: aqbanking-devel >= 3.7.2
19BuildRequires: bzip2-devel
20BuildRequires: expat-devel
21BuildRequires: gettext
22BuildRequires: goffice08-devel >= 0.8
23BuildRequires: gtk2-devel
24BuildRequires: WebKit-gtk-devel
25BuildRequires: guile-devel
26BuildRequires: libofx-devel
27BuildRequires: libgnomeui-devel
28BuildRequires: libdbi-devel
29BuildRequires: libjpeg-devel
30BuildRequires: libtool-ltdl-devel
31BuildRequires: pcre-devel
32BuildRequires: popt-devel
33BuildRequires: swig
34#BuildRequires: slib
35BuildRequires: gwenhywfar-devel
36BuildRequires: desktop-file-utils
37
38BuildRequires: libdbi-dbd-pgsql
39BuildRequires: libdbi-dbd-mysql
40BuildRequires: libdbi-dbd-sqlite
41
42Requires:      aqbanking
43Requires:      perl-DateManip
44Requires:      yelp
45Requires(post,postun): gtk2
46Requires(postun,posttrans): glib2
47Obsoletes:     gnucash-backend-postgres
48
49Vendor:        Project Vine
50Distribution:  Vine Linux
51Packager:      kenta, inagaki
52
53
54%description
55GnuCash is a personal finance manager. A check-book like
56register GUI allows you to enter and track bank accounts,
57stocks, income and even currency trades. The interface is
58designed to be simple and easy to use, but is backed with
59double-entry accounting principles to ensure balanced books.
60
61%description -l ja
62GnuCashは 個人用財務管理をするアプリケーションです.
63預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
64グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
65使用できるようにデザインされています.
66
67%prep
68%setup -q
69
70%build
71%configure \
72                --enable-error-on-warning=no \
73                --disable-sql \
74                --enable-ofx  \
75                --enable-aqbanking \
76                --disable-static \
77                --enable-dbi \
78                --with-html-engine=webkit \
79                --docdir=%{_datadir}/doc/gnucash-%{version}
80
81make LIBTOOL=%{_bindir}/libtool
82
83%configure
84make
85
86
87%install
88[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
91
92%find_lang %name
93
94# vfolder desktop file install stuff
95mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
96desktop-file-install --vendor gnome --delete-original \
97  --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
98  --add-category X-Red-Hat-Extra                      \
99  --add-category Application                          \
100  --add-category Office                               \
101  $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
102echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
103
104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105
106rm -rf $RPM_BUILD_ROOT/%{_infodir} \
107       $RPM_BUILD_ROOT/%{_includedir} \
108       $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
109       $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
110
111%clean
112[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
113
114
115%post
116/sbin/ldconfig
117touch --no-create %{_datadir}/icons/hicolor || :
118gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
119
120%postun
121if [ $1 -eq 0 ] ; then
122        /sbin/ldconfig
123        touch --no-create %{_datadir}/icons/hicolor || :
124        gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
125        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
126fi
127
128%posttrans
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131%files -f %{name}.lang
132%defattr(-,root,root,755)
133%config %{_sysconfdir}/%{name}
134%{_bindir}/*
135%{_libexecdir}/%{name}
136%{_libdir}/*
137%{_datadir}/appdata/%{name}.appdata.xml
138%{_datadir}/applications/*
139%{_datadir}/glib-2.0/schemas/*.xml
140%{_datadir}/%{name}
141%{_datadir}/icons/hicolor/*/apps/*
142%{_docdir}/%{name}
143%{_mandir}/man*/*
144%doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
145%doc doc/README.german doc/README.francais doc/guile-hackers.txt
146%doc doc/README.OFX
147
148%changelog
149* Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.12-1
150- new upstream release
151
152* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
153- new upstream release
154
155* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
156- remove *.la files
157
158* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
159- new upstream release
160- add BuildRequires: libtool-ltdl-devel
161
162* Mon Mar  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
163- rebuilt with libofx 0.9.10
164- added Vendor and Distribution tag
165
166* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
167- update to 2.6.5
168- remove old patches
169- add BuildRequires: libdbi-devel
170- change BuildRequires: goffice08-devel instead of goffice-devel
171
172* Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
173- rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
174- added Patch1 for building with aqbanking-4.2.4
175- added Patch2 for building with goffice-0.8.10
176
177* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
178- added slib to BuildRequires: and Requires:
179
180* Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
181- new upstream release
182
183* Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
184- new upstream release
185
186* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
187- rebuild with guile-1.8.6
188- add BuildRequires: gwenhywfar-devel
189
190* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
191- new upstream release
192- applied new versioning policy
193- built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
194
195* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
196- new upstream release
197- rebuilt with goffice-0.6.0
198
199* Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
200- new upstream release
201
202* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
203- new upstream release
204- enable HBCI (Home Banking Computer Interface)
205
206* Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
207- rebuild with libofx-0.8.3 (libofx.so.3)
208
209* Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
210- new upstream release
211- disable postgresql backend, as it is unmaintained upstream
212- added Patch0: gnucash-2.2.0-quiet.patch
213
214* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
215- new upstream release
216- remove BuildRequiers: autoconf213
217- update ja.po
218
219* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
220- new upstream release
221- added BuildPrereq: libtool-ltdl-devel
222
223* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
224- rebuild with new toolchains
225- update ja.po
226
227* Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
228- new upstream release
229
230* Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
231- merged gnucash-docs-1.8.3
232- added patch from Redhat Rawhide 1.8.7-1
233- changed Group, License
234
235* Mon Oct  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
236- updated to 1.8.7
237- updated print.patch
238- overwrite prefs.scm
239- s/Copyright/License/
240
241* Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
242- updated to 1.8.3
243- added datelength.patch
244- separated devel packages
245  (and ofx, hbci, backend-postgres. But default is off)
246
247* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
248- Build against with new gal.
249
250* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
251- Fixed printing issue.
252
253* Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
254- New upstream release.
255
256* Thu Jul 26 2001 <sagami@vinelinux.org>
257- 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
258
259* Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
260- %%make line is now commented out (bash2 complains it)
261  (BTW, what the hell is the macro %%make anyway? I don't even know...)
262
263* Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
264- update to 1.6.0 (stable release version)
265
266* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
267- update to 1.5.96 ( pre beta for 1.6.0 )
268
269* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
270- added japanese patch for reporting and printing (thanx tagoh-san)
271
272* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
273- updated to 1.5.6
274
275* Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
276- added translation messages to ja.po
277- enable guppi
278
279* Mon Apr  2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
280- upstream update
281- fixed broken ja.po
282
283* Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
284- fixed registor window cursor position problem(gnucash-cursor_pos.patch)
285
286* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
287- initial relese package
Note: See TracBrowser for help on using the repository browser.