source: projects/specs/trunk/g/gnucash/gnucash-vl.spec @ 9800

Revision 9800, 8.6 KB checked in by Takemikaduchi, 9 years ago (diff)

R, glabels: rebuild
others: new upstream release

RevLine 
[9800]1%define ver 2.6.9
2%define rel 1%{?_dist_release}
[521]3%define __libtoolize /bin/true
4
5Name:           gnucash
6Summary:        GnuCash is an application to keep track of your finances.
[1804]7Summary(ja):    個人用財務管理アプリケーション
[521]8Version:        %{ver}
9Release:        %{rel}
[1804]10
[521]11License:        GPL/LGPL/GFDL
12Group:          Applications/Productivity
13URL:            http://www.gnucash.org/
[1804]14
[521]15Source:         %{name}-%{version}.tar.bz2
[1804]16
[521]17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires: aqbanking-devel >= 3.7.2
19BuildRequires: bzip2-devel
20BuildRequires: expat-devel
21BuildRequires: gettext
[9291]22BuildRequires: goffice08-devel >= 0.8
[521]23BuildRequires: gtk2-devel
[9291]24BuildRequires: WebKit-gtk-devel
[521]25BuildRequires: guile-devel
26BuildRequires: libofx-devel
27BuildRequires: libgnomeui-devel
[9291]28BuildRequires: libdbi-devel
[521]29BuildRequires: libjpeg-devel
[9487]30BuildRequires: libtool-ltdl-devel
[521]31BuildRequires: pcre-devel
[1804]32BuildRequires: popt-devel
[521]33BuildRequires: swig
[9291]34#BuildRequires: slib
[521]35BuildRequires: gwenhywfar-devel
[1804]36BuildRequires: desktop-file-utils
[521]37
[9291]38BuildRequires: libdbi-dbd-pgsql
39BuildRequires: libdbi-dbd-mysql
40BuildRequires: libdbi-dbd-sqlite
41
42Requires:      aqbanking
[521]43Requires:      perl-DateManip
44Requires:      yelp
[9291]45Requires(post,postun): gtk2
46Requires(postun,posttrans): glib2
[521]47Obsoletes:     gnucash-backend-postgres
48
[9426]49Vendor:        Project Vine
50Distribution:  Vine Linux
[1804]51Packager:      kenta, inagaki
52
53
[521]54%description
55GnuCash is a personal finance manager. A check-book like
56register GUI allows you to enter and track bank accounts,
57stocks, income and even currency trades. The interface is
58designed to be simple and easy to use, but is backed with
59double-entry accounting principles to ensure balanced books.
60
61%description -l ja
62GnuCashは 個人用財務管理をするアプリケーションです.
63預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
64グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
65使用できるようにデザインされています.
66
67%prep
[9291]68%setup -q
[521]69
70%build
[9291]71%configure \
72                --enable-error-on-warning=no \
73                --disable-sql \
74                --enable-ofx  \
75                --enable-aqbanking \
76                --disable-static \
77                --enable-dbi \
78                --with-html-engine=webkit \
79                --docdir=%{_datadir}/doc/gnucash-%{version}
[521]80
81make LIBTOOL=%{_bindir}/libtool
82
83%configure
84make
85
86
87%install
88[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
91
92%find_lang %name
93
94# vfolder desktop file install stuff
95mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
96desktop-file-install --vendor gnome --delete-original \
97  --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
98  --add-category X-Red-Hat-Extra                      \
99  --add-category Application                          \
100  --add-category Office                               \
101  $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
102echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
103
[9560]104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105
[521]106rm -rf $RPM_BUILD_ROOT/%{_infodir} \
107       $RPM_BUILD_ROOT/%{_includedir} \
108       $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
109       $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
110
111%clean
112[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
113
114
115%post
116/sbin/ldconfig
[9291]117touch --no-create %{_datadir}/icons/hicolor || :
118gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
[521]119
[9291]120%postun
121if [ $1 -eq 0 ] ; then
122        /sbin/ldconfig
123        touch --no-create %{_datadir}/icons/hicolor || :
124        gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
125        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]126fi
127
[9291]128%posttrans
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]130
131%files -f %{name}.lang
132%defattr(-,root,root,755)
[9291]133%config %{_sysconfdir}/%{name}
[521]134%{_bindir}/*
[9291]135%{_libexecdir}/%{name}
[521]136%{_libdir}/*
[9291]137%{_datadir}/appdata/%{name}.appdata.xml
[521]138%{_datadir}/applications/*
[9291]139%{_datadir}/glib-2.0/schemas/*.xml
140%{_datadir}/%{name}
[521]141%{_datadir}/icons/hicolor/*/apps/*
[9291]142%{_docdir}/%{name}
[521]143%{_mandir}/man*/*
[9291]144%doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
[521]145%doc doc/README.german doc/README.francais doc/guile-hackers.txt
146%doc doc/README.OFX
147
148%changelog
[9800]149* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
150- new upstream release
151
[9560]152* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
153- remove *.la files
154
[9487]155* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
156- new upstream release
157- add BuildRequires: libtool-ltdl-devel
158
[9426]159* Mon Mar  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
160- rebuilt with libofx 0.9.10
161- added Vendor and Distribution tag
162
[9291]163* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
164- update to 2.6.5
165- remove old patches
166- add BuildRequires: libdbi-devel
167- change BuildRequires: goffice08-devel instead of goffice-devel
168
[1804]169* Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
170- rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
171- added Patch1 for building with aqbanking-4.2.4
172- added Patch2 for building with goffice-0.8.10
173
[521]174* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
175- added slib to BuildRequires: and Requires:
176
177* Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
178- new upstream release
179
180* Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
181- new upstream release
182
183* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
184- rebuild with guile-1.8.6
185- add BuildRequires: gwenhywfar-devel
186
187* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
188- new upstream release
189- applied new versioning policy
190- built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
191
192* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
193- new upstream release
194- rebuilt with goffice-0.6.0
195
196* Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
197- new upstream release
198
199* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
200- new upstream release
201- enable HBCI (Home Banking Computer Interface)
202
203* Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
204- rebuild with libofx-0.8.3 (libofx.so.3)
205
206* Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
207- new upstream release
208- disable postgresql backend, as it is unmaintained upstream
209- added Patch0: gnucash-2.2.0-quiet.patch
210
211* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
212- new upstream release
213- remove BuildRequiers: autoconf213
214- update ja.po
215
216* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
217- new upstream release
218- added BuildPrereq: libtool-ltdl-devel
219
220* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
221- rebuild with new toolchains
222- update ja.po
223
224* Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
225- new upstream release
226
227* Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
228- merged gnucash-docs-1.8.3
229- added patch from Redhat Rawhide 1.8.7-1
230- changed Group, License
231
232* Mon Oct  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
233- updated to 1.8.7
234- updated print.patch
235- overwrite prefs.scm
236- s/Copyright/License/
237
238* Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
239- updated to 1.8.3
240- added datelength.patch
241- separated devel packages
242  (and ofx, hbci, backend-postgres. But default is off)
243
244* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
245- Build against with new gal.
246
247* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
248- Fixed printing issue.
249
250* Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
251- New upstream release.
252
253* Thu Jul 26 2001 <sagami@vinelinux.org>
254- 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
255
256* Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
257- %%make line is now commented out (bash2 complains it)
258  (BTW, what the hell is the macro %%make anyway? I don't even know...)
259
260* Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
261- update to 1.6.0 (stable release version)
262
263* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
264- update to 1.5.96 ( pre beta for 1.6.0 )
265
266* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
267- added japanese patch for reporting and printing (thanx tagoh-san)
268
269* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
270- updated to 1.5.6
271
272* Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
273- added translation messages to ja.po
274- enable guppi
275
276* Mon Apr  2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
277- upstream update
278- fixed broken ja.po
279
280* Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
281- fixed registor window cursor position problem(gnucash-cursor_pos.patch)
282
283* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
284- initial relese package
Note: See TracBrowser for help on using the repository browser.