source: projects/specs/trunk/g/gnomemm/gnomemm-vl.spec @ 521

Revision 521, 4.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name gnomemm
2%define version 1.2.4
3%define release 0vl4
4
5Summary:        A C++ interface for Gnome libs (a GUI library for X).
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9License:        LGPL
10Group:          System Environment/Libraries
11Source:         ftp://prdownloads.sourceforge.net/gtkmm/%{name}-%{version}.tar.gz
12Patch:          gnomemm-gcc3.patch
13URL:            http://gtkmm.sourceforge.net/
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15Requires:       gtk+ >= 1.2.7, gnome-libs, db4
16BuildPrereq:    libsigc++10-devel >= 1.0.3, gtkmm-devel >= 1.2.5, gnome-libs-devel, db4-devel
17
18%description
19This package provides a C++ interface for GnomeUI.  It is a subpackage
20of the Gtk-- project.  The interface provides a convenient interface for C++
21programmers to create Gnome GUIs with GTK+'s flexible object-oriented
22framework.
23
24%package        devel
25Summary:        Headers for developing programs that will use Gnome--.
26Group:          Development/Libraries
27Requires:       %{name}, gnome-libs-devel
28
29%description    devel
30This package contains the headers that programmers will need to develop
31applications which will use Gnome--, part of Gtk-- the C++ interface to
32the GTK+ (the Gimp ToolKit) GUI library.
33
34%prep
35%setup -q
36%patch0 -p1 -b .gcc3
37
38%build
39
40# ...hope this can be removed soon
41%ifarch alpha
42        ARCH_FLAGS="--host=alpha-linux-gnu"
43%endif
44
45# Needed for snapshot releases.
46if [ ! -f configure ]; then
47        CFLAGS="%{optflags}" ./autogen.sh $ARCH_FLAGS \
48                --prefix=%{_prefix} \
49                --disable-static \
50                --enable-shared --enable-docs
51else
52        CC="$CC" CXX="$CXX" CPP="$CPP" \
53        CFLAGS="%{optflags}" ./configure  $ARCH_FLAGS \
54                --prefix=%{_prefix} \
55                --disable-maintainer-mode \
56                --disable-static \
57                --enable-shared --enable-docs
58fi
59
60if [ "$SMP" != "" ]; then
61  make -j$SMP "MAKE=make -j$SMP"
62  make
63else
64  make
65fi
66
67%install
68if [ -d %{buildroot} ]; then rm -rf %{buildroot}; fi
69make DESTDIR=%{buildroot} install
70
71# replace examples.conf by a really simple one
72(
73  echo 'CXXBUILD = g++ -O2 $< -o $@ `gnome-config gnomemm --cflags --libs` '
74  echo 'CXXCOMPILE = g++ -O2 -c $< -o $@ `gnome-config gnomemm --cflags` '
75  echo 'CXXLINK = g++ -O2 -o $@ `gnome-config gnomemm --libs` '
76) > examples/examples.conf
77
78rm examples/Makefile.am examples/Makefile.in examples/Makefile
79rm examples/examples.conf.in
80
81## strip down the docs
82#find docs/ \
83#\(     -name 'Makefile' -or    \
84#       -name 'Makefile.in' -or \
85#       -name 'Makefile.am' -or \
86#       -name '*.m4' -or        \
87#       -name 'html' -or        \
88#       -name 'header' -or      \
89#       -name '*.h'             \
90#\)     -exec rm -rf {} \;
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%clean
97rm -rf %{buildroot}
98
99%files
100%defattr(-, root, root)
101%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
102%{_libdir}/*.so.*
103
104%files  devel
105%defattr(-, root, root)
106%doc examples/ docs/  AUTHORS COPYING ChangeLog INSTALL NEWS README
107%{_includedir}/*.h
108%{_includedir}/gnome--
109%{_libdir}/*.la
110#{_libdir}/*.a # uncomment this one for static libs
111%{_libdir}/*.sh
112%{_libdir}/*.so
113%{_datadir}/aclocal/gnome--.m4
114
115###########################################################################
116
117%changelog
118* Wed May 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl4
119- rebuild for VineSeedPlus
120
121* Tue May 17 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.2.4-0vl3
122- fix 'BuildPrereq:'.
123
124* Tue May 17 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.2.4-0vl2
125- add Patch0.
126
127* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
128- new upstream release
129- rebuild to remove dependancy
130- s/Copyright/License/
131
132* Mon Dec  2 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
133- new upstream release
134- build with new toolchain
135
136* Mon Jun 10 2002 Tomoya TAKA <taka@vinelinux.org> 1.2.2-0vl1
137- build for Vine Linux
138- arrange Requires and BuildPrereq
139- use rpm macros
140
141* Sat Mar 10 2001 Herbert Valerio Riedel <hvr@gnu.org>
142- improved examples.conf
143- fixed example build problems
144
145* Thu May 11 2000 Herbert Valerio Riedel <hvr@gnu.org>
146- removed lib/gtkmm from files section
147- removed empty obsolete tags
148
149* Sun Jan 30 2000 Karl Einar Nelson <kenelson@sourceforge.net>
150- adapted from gtk--.spec
Note: See TracBrowser for help on using the repository browser.