source: projects/specs/trunk/g/gnome-volume-manager/gnome-volume-manager-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The GNOME Volume Manager
2Summary(ja): GNOME ボリュームマネージャ
3Name: gnome-volume-manager
4Version: 2.24.0
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8
9Source0: gnome-volume-manager-%{version}.tar.bz2
10Source1: magicdev-wrapper
11Source2: gthumb-import
12Source3: gnome-cdda-handler
13Source4: cdda-url-handler.schemas
14
15Patch2: gnome-volume-manager-2.17.0-add-console-user-check.patch
16Patch3: gnome-volume-manager-2.15.0-check-screensaver.patch
17
18# vine default
19Patch10: gnome-volume-manager-1.5.14-vine.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: libgnomeui-devel, libglade2-devel
23BuildRequires: hal-devel >= 0.5
24BuildRequires: dbus-devel >= 0.60
25BuildRequires: dbus-glib-devel >= 0.60
26BuildRequires: libnotify-devel
27BuildRequires: desktop-file-utils
28Requires: gnome-mime-data
29Requires: control-center >= 2.0
30Requires: dbus >= 0.60
31Requires: hal
32Requires: gthumb
33Requires: gnome-media
34Requires(post,pre,preun): GConf2
35
36Obsoletes: magicdev
37Provides: magicdev
38Obsoletes: murasaki-usb-mount
39
40%description
41The GNOME Volume Manager monitors volume-related events and responds with
42user-specified policy.  The GNOME Volume Manager can automount hot-plugged
43drives, automount inserted removable media, autorun programs, automatically
44play audio CDs and video DVDs, and automatically import photos from a digital
45camera.  The GNOME Volume Manager does this entirely in user-space and without
46polling.
47
48The GNOME Voume Manager sits at the top end of a larger picture that aims to
49integrate the Linux system from the kernel on up through the desktop and its
50applications.
51
52%prep
53%setup -q
54%patch2 -p1 -b .add-console-user-check
55#patch3 -p0 -b .screensaver
56%patch10 -p1 -b .vine
57
58%build
59%configure
60make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
65%makeinstall
66unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
67
68desktop-file-install --delete-original --vendor=gnome  \
69  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
70  --add-category=HardwareSettings               \
71  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-volume-properties.desktop
72
73mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
74
75install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/magicdev
76install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/gthumb-import
77install -d $RPM_BUILD_ROOT%{_libexecdir}/
78install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_libexecdir}/gnome-cdda-handler
79install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/cdda-url-handler.schemas
80
81%find_lang %name
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88SCHEMAS="gnome-volume-manager.schemas cdda-url-handler.schemas"
89for S in $SCHEMAS; do
90  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
91done
92
93%pre
94if [ "$1" -gt 1 ]; then
95  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96  SCHEMAS="gnome-volume-manager.schemas cdda-url-handler.schemas"
97  for S in $SCHEMAS; do
98    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
99  done
100fi
101
102%preun
103if [ "$1" -eq 0 ]; then
104  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105  SCHEMAS="gnome-volume-manager.schemas cdda-url-handler.schemas"
106  for S in $SCHEMAS; do
107    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
108  done
109fi
110
111%files -f %{name}.lang
112%defattr(-,root,root)
113%doc AUTHORS ChangeLog COPYING INSTALL NEWS README TODO
114%{_bindir}/*
115%{_datadir}/applications/gnome-volume-properties.desktop
116%{_datadir}/gnome-volume-manager
117#{_datadir}/gnome/autostart/gnome-volume-manager.desktop
118%{_sysconfdir}/gconf/schemas/*.schemas
119%{_sysconfdir}/xdg/autostart/gnome-volume-manager.desktop
120%{_libexecdir}/gnome-cdda-handler
121%{_libexecdir}/gnome-volume-manager
122
123%changelog
124* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
125- new upstream release
126
127* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.5-1vl5
128- new upstream release
129
130* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
131- new upstream release
132- added %%pre and %%preun section
133
134* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-0vl1
135- new upstream release
136
137* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-0vl1
138- new upstream release
139
140* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.15-0vl3
141- update Patch0 to add "--unique" to gnome-cd option (<BTS:294>)
142
143* Wed Oct 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.15-0vl2
144- update Patch10 to fix audio cd settings. (<BTS:236>)
145
146* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.15-0vl1
147- new upstream release
148
149* Fri Mar 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.14-0vl2
150- add Patch10 to change default settings for Vine Linux
151
152* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.14-0vl1
153- new upstream release
154
155* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-0vl1
156- new upstream release
157
158* Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl2
159- Obosletes murasaki-usb-mount
160
161* Mon Jul 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
162- new upstream release
163
164* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
165- initial build for Vine Linux based on FC package.
166- new upstream release
167- drop all fc patches
168
169* Mon Mar 07 2005 John (J5) Palmieri <johnp@redhat.com> - 1.1.3-3
170- Fixed up hal-api patch
171
172* Fri Feb 25 2005 John (J5) Palmieri <johnp@redhat.com> - 1.1.3-2
173- Reenable BuildPrereq for hal-devel
174
175* Wed Feb 23 2005 John (J5) Palmieri <johnp@redhat.com> - 1.1.3-1
176- Update to upstream version
177- add patch to update to the new hal-0.5.0 API
178- took out locking patch as it was added upstream
179- took out policy-after-explicit-mount-only patch as it was added
180  upstream
181- removed %{_datadir}/control-center-2.0/capplets/* glob
182- added %{_datadir}/applications/gnome-volume-properties.desktop
183
184* Mon Oct 18 2004 John (J5) Palmieri <johnp@redhat.com> - 1.1.0-5
185- Merged the photo-defaults patch with a new rh-defaults patch
186- Shut off autorun by default as it is a security concern and we
187  currently don't have any use for it
188- Added policy-after-explicit-mount-only patch which fixes problems
189  such as a user mounting a removable drive from the command line
190  and a Nautilus window pops up, and two Nautilus windows popping
191  up in browser mode when a device is mounted through Nautilus.
192
193* Fri Oct 08 2004 John (J5) Palmieri <johnp@redhat.com> - 1.1.0-4
194- exclude building on s390 and s390x
195
196* Wed Oct 06 2004 John (J5) Palmieri <johnp@redhat.com> - 1.1.0-3
197- Added gnome-cdda-handler and associated schema to cause the
198  cdda url handler to use the values in g-v-m's gconf key for
199  audio cd's.  This causes the g-v-m selected application for
200  audio cd's to launch when double clicking on an audio cd icon
201  in Nautilus.
202
203* Thu Sep 30 2004 John (J5) Palmieri <johnp@redhat.com>
204- Added patch to add the dbus-glib-lowlevel.h header
205
206* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com>
207- Update to upstream version 1.1.0
208- Fix requirement for gnome-cd to be the gnome-media package
209
210* Mon Sep 20 2004 David Zeuthen <davidz@redhat.com>
211- Add locking patch
212
213* Fri Sep 17 2004 John (J5) Palmieri <johnp@redhat.com>
214- Update to upstream 1.0.2
215- Readd patches I took out by accident
216- Add a requirement for gthumb and gnome-cd
217
218* Mon Sep 13 2004 John (J5) Palmieri <johnp@redhat.com>
219- Update to upstream 1.0
220
221* Fri Sep 03 2004 John (J5) Palmieri <johnp@redhat.com>
222- gthumb-import now checks to see if there is a DCIM directory
223  and open up to that directory if so
224
225* Wed Sep 01 2004 Davidz Zeuthen <davidz@redhat.com>
226- Fix a few issues to keep up with hal
227
228* Tue Aug 31 2004 John (J5) Palmieri <johnp@redhat.com>
229- Update to upstream release 0.9.10
230- Add gthumb-import wrapper to import photos correctly
231- Add patch to set gthumb-import as the default photo importer
232- Add patch to put desktop file in the X-Red-Hat-Base Catagory
233- Fixes RH Bug 130866
234
235* Fri Aug 20 2004 John (J5) Palmieri <johnp@redhat.com>
236- Added Provides: magicdev to fix conflict
237
238* Tue Aug 17 2004 David Zeuthen <davidz@redhat.com>
239- Update to upstream release 0.9.9
240- Apply mount-unmount patch
241
242* Mon Jul 26 2004 Ray Strode <rstrode@redhat.com>
243- Add magicdev compatibility wrapper script and obsolete magicdev.
244
245* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
246- Upstream CVS
247
248* Wed May 05 2004 John (J5) Palmieri <johnp@redhat.com>
249- Made sure GConf Schemas are installed
250
251* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
252- initial packaging of 0.9.2
253
Note: See TracBrowser for help on using the repository browser.