source: projects/specs/trunk/g/gnome-vfs2/gnome-vfs2-vl.spec @ 521

Revision 521, 18.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define libbonobo_version 2.24.1
2%define gconf2_version 2.26.0
3%define gtkdoc_version 1.1
4%define gnome_mime_data_version 2.18.0
5%define gamin_version 0.1.10
6%define vine_menus_version 3.0
7%define samba_version 3.2.5
8%define hal_version 0.5.11
9%define gnome_mount_version 0.8
10%define avahi_version 0.6.23
11%define dbus_version 1.0
12%define dbus_glib_version 0.73
13
14%define po_package gnome-vfs-2.0
15
16%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
17
18Summary: The GNOME virtual file-system libraries.
19Summary(ja): GNOME 仮想ファイルシステムライブラリ
20Name: gnome-vfs2
21Version: 2.24.2
22Release: 1%{?_dist_release}
23License: LGPL
24Group: System Environment/Libraries
25Source: gnome-vfs-%{version}.tar.bz2
26URL: http://www.gnome.org/
27
28BuildRoot:     %{_tmppath}/%{name}-%{version}-root
29Requires:      gnome-mime-data >= %{gnome_mime_data_version}
30Requires:      shared-mime-info
31Requires:      gamin >= %{gamin_version}
32Requires:      vine-menus >= %{vine_menus_version}
33Requires(post,pre,preun): GConf2 >= %{gconf2_version}
34
35BuildRequires: libbonobo-devel >= %{libbonobo_version}
36BuildRequires: GConf2-devel >= %{gconf2_version}
37BuildRequires: gnome-mime-data >= %{gnome_mime_data_version}
38BuildRequires: gamin-devel >= %{gamin_version}
39BuildRequires: glib2-devel, libxml2-devel, zlib-devel
40BuildRequires: popt-devel, bzip2-devel, ORBit2-devel, openjade
41BuildRequires: pkgconfig
42BuildRequires: gnome-mime-data >= %{gnome_mime_data_version}
43BuildRequires: gtk-doc >= %{gtkdoc_version}
44BuildRequires: libsmbclient-devel >= %{samba_version}
45BuildRequires: hal-devel >= %{hal_version}
46BuildRequires: gnome-mount-devel >= %{gnome_mount_version}
47BuildRequires: avahi-glib-devel >= %{avahi_version}
48BuildRequires: dbus-devel >= %{dbus_version}
49BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
50BuildRequires: automake, autoconf
51
52Patch3: gnome-vfs-2.9.90-modules-conf.patch
53
54# send to upstream
55Patch101: gnome-vfs-2.8.2-schema_about_for_upstream.patch
56
57Patch201: gnome-vfs-2.8.1-console-mount-opt.patch
58
59# RH bug #197868
60Patch6: gnome-vfs-2.15.91-mailto-command.patch
61
62# https://bugzilla.redhat.com/show_bug.cgi?id=333041
63# https://bugzilla.redhat.com/show_bug.cgi?id=335241
64Patch300: gnome-vfs-2.20.0-ignore-certain-mountpoints.patch
65
66# vine default
67Patch1000: gnome-vfs2-2.22.0-vine.patch
68
69
70%description
71GNOME VFS is the GNOME virtual file system. It is the foundation of
72the Nautilus file manager. It provides a modular architecture and
73ships with several modules that implement support for file systems,
74http, ftp, and others. It provides a URI-based API, backend
75supporting asynchronous file operations, a MIME type manipulation
76library, and other features.
77
78%package devel
79Summary: Libraries and include files for developing GNOME VFS applications.
80Summary(ja): GNOME VFS アプリケーション開発用ライブラリ
81Group: Development/Libraries
82Requires:  %{name} = %{version}-%{release}
83Requires:  GConf2-devel >= %{gconf2_version}
84Requires:  libbonobo-devel >= %{libbonobo_version}
85Conflicts: bonobo-devel < 1.0.8
86Conflicts: gnome-vfs-devel < 1.0.2
87
88%description devel
89This package provides the necessary development libraries for writing
90GNOME VFS modules and applications that use the GNOME VFS APIs.
91
92%package smb
93Summary: Windows fileshare support for gnome-vfs
94Summary(ja): gnome-vfs の Windows ファイル共有サポート
95Group: System Environment/Libraries
96Requires:  %{name} = %{version}
97Requires:  samba-common >= %{samba_version}
98Obsoletes: gnome-vfs2-extras
99Provides:  gnome-vfs2-extras
100
101%description smb
102This package provides support for reading and writing files on windows
103shares (SMB) to applications using GNOME VFS.
104
105# compat32
106%package -n compat32-%{name}
107Summary: The GNOME virtual file-system libraries.
108Summary(ja): GNOME 仮想ファイルシステムライブラリ
109Group: System Environment/Libraries
110Requires:  %{name} = %{version}-%{release}
111
112%description -n compat32-%{name}
113GNOME VFS is the GNOME virtual file system. It is the foundation of
114the Nautilus file manager. It provides a modular architecture and
115ships with several modules that implement support for file systems,
116http, ftp, and others. It provides a URI-based API, backend
117supporting asynchronous file operations, a MIME type manipulation
118library, and other features.
119
120%package -n compat32-%{name}-devel
121Summary: Libraries and include files for developing GNOME VFS applications.
122Summary(ja): GNOME VFS アプリケーション開発用ライブラリ
123Group: Development/Libraries
124Requires:  %{name}-devel = %{version}-%{release}
125Requires:  compat32-%{name} = %{version}-%{release}
126Requires:  compat32-GConf2-devel >= %{gconf2_version}
127Requires:  compat32-libbonobo-devel >= %{libbonobo_version}
128
129%description -n compat32-%{name}-devel
130This package provides the necessary development libraries for writing
131GNOME VFS modules and applications that use the GNOME VFS APIs.
132
133
134%prep
135%setup -q -n gnome-vfs-%{version}
136 
137%patch3 -p1 -b .modules-conf
138%patch6 -p1 -b .mailto-command
139
140# send to upstream
141%patch101 -p1 -b .schema_about
142
143%patch201 -p0 -b .console
144
145%patch300 -p1 -b .ignore-certain-mount-points
146
147# Vine
148%patch1000 -p1 -b .browser_default
149
150# for patch 10
151autoheader
152autoconf
153
154%build
155if pkg-config openssl ; then
156        CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
157        LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
158fi
159
160%configure --disable-gtk-doc --enable-hal
161
162export tagname=CC
163make LIBTOOL=/usr/bin/libtool
164
165%install
166rm -fr $RPM_BUILD_ROOT
167
168export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
169export tagname=CC
170make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
171unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
172
173# remove unpackaged files
174rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/lib*.{a,la}
175rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
176rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.{a,la}
177
178%find_lang %{po_package}
179
180%clean
181rm -fr $RPM_BUILD_ROOT
182
183%post
184/sbin/ldconfig
185export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
186SCHEMAS="system_http_proxy.schemas system_dns_sd.schemas system_smb.schemas \
187         desktop_gnome_url_handlers.schemas \
188         desktop_default_applications.schemas"
189for S in $SCHEMAS; do
190  gconftool-2 --makefile-install-rule \
191      %{_sysconfdir}/gconf/schemas/$S > /dev/null || :
192done
193
194%pre
195if [ "$1" -gt 1 ]; then
196  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
197  SCHEMAS="system_http_proxy.schemas system_dns_sd.schemas system_smb.schemas \
198           desktop_gnome_url_handlers.schemas \
199           desktop_default_applications.schemas"
200  for S in $SCHEMAS; do
201      gconftool-2 --makefile-uninstall-rule \
202          %{_sysconfdir}/gconf/schemas/$S > /dev/null || :
203  done
204fi
205
206%preun
207if [ "$1" -eq 0 ]; then
208  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
209  SCHEMAS="system_http_proxy.schemas system_dns_sd.schemas system_smb.schemas \
210           desktop_gnome_url_handlers.schemas \
211           desktop_default_applications.schemas"
212  for S in $SCHEMAS; do
213      gconftool-2 --makefile-uninstall-rule \
214          %{_sysconfdir}/gconf/schemas/$S > /dev/null || :
215  done
216fi
217
218%postun -p /sbin/ldconfig
219
220%post -n compat32-%{name} -p /sbin/ldconfig
221
222%postun -n compat32-%{name} -p /sbin/ldconfig
223
224%files -f %{po_package}.lang
225%defattr(-, root, root)
226%doc AUTHORS COPYING ChangeLog NEWS README
227%dir %{_sysconfdir}/gnome-vfs-2.0
228%dir %{_sysconfdir}/gnome-vfs-2.0/modules
229%config %{_sysconfdir}/gnome-vfs-2.0/modules/*.conf
230%exclude %{_sysconfdir}/gnome-vfs-2.0/modules/smb-module.conf
231%{_bindir}/*
232%{_libexecdir}/*
233%{_libdir}/*.so.*
234%{_libdir}/gnome-vfs-2.0/modules
235%exclude %{_libdir}/gnome-vfs-2.0/modules/libsmb.so
236%dir %{_libdir}/gnome-vfs-2.0
237%{_sysconfdir}/gconf/schemas/*
238%{_datadir}/dbus-1/services/gnome-vfs-daemon.service
239
240%files devel
241%defattr(-, root, root)
242%{_libdir}/lib*.so
243%{_libdir}/pkgconfig/*.pc
244%{_libdir}/gnome-vfs-2.0/include/*.h
245%{_includedir}/*
246%{_datadir}/gtk-doc/html/*
247
248%files smb
249%defattr(-, root, root)
250%{_libdir}/gnome-vfs-2.0/modules/libsmb.so
251%config %{_sysconfdir}/gnome-vfs-2.0/modules/smb-module.conf
252
253# compat32
254%if %{build_compat32}
255%files -n compat32-%{name}
256%defattr(-, root, root)
257%{_libdir}/*.so.*
258%{_libdir}/gnome-vfs-2.0/modules
259%exclude %{_libdir}/gnome-vfs-2.0/modules/libsmb.so
260%dir %{_libdir}/gnome-vfs-2.0
261
262%files -n compat32-%{name}-devel
263%defattr(-, root, root)
264%{_libdir}/lib*.so
265%{_libdir}/pkgconfig/*.pc
266%{_libdir}/gnome-vfs-2.0/include/*.h
267%endif
268
269
270%changelog
271* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
272- new upstream release
273
274* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
275- added compat32 package for x86_64 arch support
276- removed static libraries
277
278* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
279- new upstream release
280
281* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
282- new upstream release
283
284* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
285- added Patches from Fedora Core
286  * Tue Oct 16 2007 David Zeuthen <davidz@redhat.com> - 2.20.0-3
287  - Also avoid showing /var/tmp as an icon on the desktop (#335241)
288  * Wed Sep 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.91-2
289  - Fix a small memory leak
290- updated Patch1000
291
292* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
293- new upstream release(Patch31 was merged into upstream)
294
295* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
296- new upstream release
297
298* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.1-0vl2
299- rebuilt with new toolchain and openssl-0.9.8e
300
301* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
302- new upstream release
303- add Paatch31/32 from fedora
304
305* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
306- rebuild with dbus-1.0/dbus-glib-0.73
307- add BuildRequires: dbus-devel >= 1.0, dbus-glib-devel >= 0.73
308
309* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
310- new upstream release
311
312* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl4
313- add Requires: gamin and BuildRequires: gamin-devel
314- remove fam dependency (replaced by gamin)
315
316* Fri Jul 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.2-0vl3
317- add BuildRequires: samba-libsmbclient-devel instead of samba-libsmbclient
318
319* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
320- remove Patch10 to fix smb browsing
321
322* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
323- new upstream release
324
325* Mon May 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
326- new upstream release
327- add BuildRequires: avahi-glib-devel instead of avahi-glib
328
329* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
330- new upstream release
331- build with avahi, add BuildRequires: avahi
332
333* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl3
334- re-numbering patches
335- update Patch100 to change default url-handlers for vine
336
337* Fri Mar 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
338- use "make install DESTDIR.." instead of "%%makeinstall" to remove
339  bogus buildroot path from server location in GNOME_VFS_Daemon.server
340- remove unneeded files
341
342* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
343- new upstream release
344
345* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
346- new upstream release
347
348* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1.1-0vl1
349- new upstream release
350
351* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
352- new upstream release
353
354* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
355- new upstream release
356
357* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
358- new upstream release
359
360* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
361- new upstream release
362
363* Mon Jul 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
364- new upstream release
365- build with hal
366
367* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
368- remove bonobo-activation dependency
369
370* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
371- add Patch1000 from ubuntu package
372
373* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
374- new upstream version
375
376* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.4-0vl1
377- new upstream release
378
379* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-0vl1
380- new upstream release
381- add smb subpackage and obsolete gnome-vfs2-extras
382
383* Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl2
384- update vine patch to add missing patch for preferences vfolder.
385
386* Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
387- new upstream release
388- update vine patch
389
390* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
391- new upstream release
392
393* Sun Dec 28 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl2
394- rebuild with new toolchain
395
396* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
397- new upstream release
398
399* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
400- new upstream release
401
402* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
403- new upstream release
404
405* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-0vl2
406- update applications-all-users.vfolder-info
407
408* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-0vl1
409- new upstream release
410
411* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.5-0vl1
412- new upstream release
413
414* Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl2
415- modified vfolder-info for Vine Linux.
416
417* Wed May 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
418- new upstream release
419- drop redhat customized patches.
420
421* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
422- new upstream release
423
424* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
425- rebuild
426
427* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
428- new upstream release
429
430* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
431- new upstream release
432
433* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
434- new upstream release
435
436* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
437- fixed dependancy.
438
439* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
440- new upstream release
441
442* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
443- build for Vine Linux
444
445* Sun Nov 10 2002 Havoc Pennington <hp@redhat.com>
446- 2.1.3
447- update moved-menu-files patch
448
449* Wed Oct 23 2002 Havoc Pennington <hp@redhat.com>
450- add patch for OnlyShowIn support
451- use plain menu files for .vfolder-info-default
452- don't install unused vfolder-info files
453
454* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
455- require new gnome-mime-data in proper libdir
456- 2.0.4
457- drop most patches as they are now upstream or
458  don't apply to new vfolder code
459
460* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
461- Backport a gnome-vfs locking fix from CVS
462  (Hopefully fixes #71419)
463
464* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
465- make vfolder method read-only #72208
466
467* Mon Aug 19 2002 Jonathan Blandford <jrb@redhat.com>
468- notice when new files are installed
469
470* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
471- don't include pointless .a files
472
473* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
474- 2.0.2
475- use vfolders for system-settings and server-settings
476
477* Tue Jul 16 2002 Havoc Pennington <hp@redhat.com>
478- fix OnlyShowIn
479
480* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
481- Version 2.0.1, fix missing po files
482
483* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
484- 2.0.0
485- put schema files in file list, and install them
486- put libdir/vfs in file list
487
488* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
489- rebuild in different environment
490
491* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
492- look for menus in redhat-menus
493
494* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
495- rebuild in different environment
496
497* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
498- 1.9.16
499
500* Sun May 26 2002 Tim Powers <timp@redhat.com>
501- automated rebuild
502
503* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
504- rebuild in different environment
505
506* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
507- 1.9.15
508- comment out docdir patch for now
509
510* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
511- 1.9.14
512
513* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
514- 1.9.11
515- update file list
516
517* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
518- 1.9.7
519
520* Thu Jan 31 2002 Owen Taylor <otaylor@redhat.com>
521- Fix location of installed docs not to conflict with gnome-vfs1
522
523* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
524- Rebuild with new libs
525
526* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
527- automated rebuild
528
529* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
530- 1.0.4.91 snap
531
532* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
533- 1.9.4.90 snap
534- require gnome-mime-data
535
536* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
537- new snap, rebuild for glib 1.3.10
538
539* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
540- cvs snap
541
542* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
543- rebuild cvs snap with changes merged upstream
544- fix a requires
545- fix up requires/buildrequires a bit
546
547* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
548- initial gnome-vfs2 build, remove all patches
549- change config files not to be noreplace
550
551* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
552- Add po files from sources.redhat.com
553
554* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
555- fix #51864 (Gimp can't handle file: URIs)
556
557* Mon Aug 20 2001 Alexander Larsson <alexl@redhat.com> 1.0.1-15
558- Moved gnome-conf and pkgconfig files to the devel package
559- Fixes SHOULD-FIX bug #49795
560
561* Mon Aug  6 2001 Alexander Larsson <alexl@redhat.com> 1.0.1-14
562- Added a patch that fixed AbiWord mimetype handling.
563
564* Fri Jul 27 2001 Jonathan Blandford <jrb@redhat.com>
565- Add .desktop file sniffing
566
567* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
568- don't do the giant trash scan thing; did not play nice
569  with NFS.
570
571* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
572- fix desktop-file.conf file
573
574* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
575- change some URI scheme names
576
577* Fri Jul 20 2001 Alexander Larsson <alexl@redhat.com>
578- Add pkgconfig and gnome-libs-devel build reqs.
579- Remove dependency on gnome-vfs-devel by doing some
580- CPPFLAGS and LDFLAGS magic
581
582* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
583- add missing directories
584
585* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
586- fix a segv
587- change which dirs the desktop VFS module points to
588
589* Sun Jul 08 2001 Havoc Pennington <hp@redhat.com>
590- add desktop VFS module hack
591
592* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
593- Remove Distribution and Vendor
594- Make the config files noreplace
595- Move .so links to devel subpackage
596- langify
597- Add BuildRequires
598- Don't mess with /etc/ld.so.conf
599- Use %%{_tmppath}
600- s/Copyright/License/
601
602* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
603- Bump release + rebuild.
604
605* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
606- New Version.
607
608* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
609- New Version.
610- clean up spec file some.
611
612* Mon Feb 19 2001 Gregory Leblanc <gleblanc@cu-portland.edu>
613- fix paths and macros
614
615* Tue Feb 22 2000 Ross Golder <rossigee@bigfoot.com>
616- Integrate into source tree
Note: See TracBrowser for help on using the repository browser.