source: projects/specs/trunk/g/gnome-user-share/gnome-user-share-vl.spec @ 4616

Revision 4616, 5.6 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Summary: Gnome user file sharing
2Summary(ja): Gnome ユーザファイル共有
3Name: gnome-user-share
4Version: 3.0.0
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Libraries
8URL: http://www.gnome.org
9Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-user-share/3.0/%{name}-%{version}.tar.bz2
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12Requires: httpd >= 2.2.0
13Requires: gnome-bluetooth-libs >= 2.28.0
14BuildRequires: GConf2-devel avahi-glib-devel >= 0.6 pkgconfig
15BuildRequires: gtk3-devel >= 3.0.0
16BuildRequires: httpd >= 2.2.0
17BuildRequires: libglade2-devel >= 2.0.0
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: perl(XML::Parser)
21BuildRequires: libnotify-devel
22BuildRequires: libcanberra-gtk3-devel
23BuildRequires: gnome-bluetooth-devel >= 2.32.0
24BuildRequires: unique3-devel
25BuildRequires: nautilus-devel
26BuildRequires: libSM-devel
27BuildRequires: gnome-doc-utils
28Requires(post,pre,preun): GConf2
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34gnome-user-share is a small package that binds together various free
35software projects to bring easy to use user-level file sharing to the
36masses.
37
38%prep
39%setup -q
40
41%build
42%configure
43%__make %{?_smp_mflags}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
48export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
49%__make install DESTDIR=$RPM_BUILD_ROOT
50unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
51
52rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.la
53
54desktop-file-install --vendor gnome --delete-original                   \
55  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
56  --add-only-show-in GNOME                                              \
57  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
58
59%find_lang %{name}
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post
65export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
66gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
67
68%pre
69if [ "$1" -gt 1 ]; then
70  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
71  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
72fi
73
74%preun
75if [ "$1" -eq 0 ]; then
76  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
77  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_file_sharing.schemas > /dev/null || :
78fi
79
80%files -f %{name}.lang
81%defattr(-,root,root,-)
82%doc README ChangeLog
83%{_bindir}/*
84%{_libexecdir}/*
85%{_libdir}/nautilus/extensions-3.0/*.so
86%{_datadir}/applications/*
87%{_datadir}/gnome-user-share
88%{_datadir}/gnome/*
89%{_datadir}/icons/hicolor/*/apps/*
90%{_datadir}/omf/*
91%{_sysconfdir}/gconf/schemas/*
92%{_sysconfdir}/xdg/autostart/gnome-user-share.desktop
93
94%changelog
95* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
96- new upstream release
97- change BuildRequires: gtk3-devel instead of gtk2-devel
98- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
99- change BuildRequires: unique3-devel instead of unique-devel
100- add BuildRequires: libSM-devel
101
102* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
103- new upstream release
104
105* Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
106- new upstream release
107- add BuildRequires: nautilus-devel
108
109* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
110- new upstream release
111- add BuildRequires: libnotify-devel, libcanberra-devel, gnome-bluetooth-devel, unique-devel, gnome-doc-utils
112- add Requires: gnome-bluetooth-libs
113
114* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11-0vl1
115- initial build for Vine Linux
116
117* Fri Mar 23 2007 Matthias Clasen  <mclasen@redhat.com> - 0.11-2
118- Don't hardwire invisible char (#233676)
119
120* Tue Mar  6 2007 Alexander Larsson <alexl@redhat.com> - 0.11-1
121- Update to 0.11 with xdg-user-dirs support
122
123* Wed Jan 24 2007 Matthias Clasen <mclasen@redhat.com> 0.10-6
124- Add better categories to the desktop file
125
126* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 0.10-5
127- rebuilt for unwind info generation, broken in gcc-4.1.1-21
128
129* Thu Sep 21 2006 Nalin Dahyabhai <nalin@redhat.com> - 0.10-4
130- add missing BuildRequires: on httpd, so that the configure script can find
131  the binary
132
133* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.10-3.1
134- rebuild
135
136* Mon May 29 2006 Alexander Larsson <alexl@redhat.com> - 0.10-3
137- buildrequire gettext and perl-XML-Parser (#193391)
138
139* Thu Apr 20 2006 Matthias Clasen <mclasen@redhat.com> 0.10-2
140- Update to 0.10
141
142* Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 0.9-3
143- BuildRequires: gtk2-devel, libglade2-devel, libselinux-devel
144
145* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9-2.2
146- bump again for double-long bug on ppc(64)
147
148* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9-2.1
149- rebuilt for new gcc4.1 snapshot and glibc changes
150
151* Fri Feb  3 2006 Alexander Larsson <alexl@redhat.com> 0.9-2
152- Patch config for apache 2.2
153
154* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
155- rebuilt
156
157* Tue Nov 22 2005 Alexander Larsson <alexl@redhat.com> - 0.9-1
158- New release with avahi 0.6 support
159
160* Mon Nov 14 2005 Alexander Larsson <alexl@redhat.com> - 0.8-1
161- update to 0.8
162
163* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.7-1
164- New version, with desktop file
165
166* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.6-1
167- New version, switch to avahi
168- Handle translations
169
170* Fri Dec  3 2004 Alexander Larsson <alexl@redhat.com> - 0.4-1
171- New version
172
173* Fri Nov 26 2004 Alexander Larsson <alexl@redhat.com> - 0.3-1
174- New version
175
176* Thu Sep  9 2004 Alexander Larsson <alexl@redhat.com> - 0.2-1
177- New version
178
179* Wed Sep  8 2004 Alexander Larsson <alexl@redhat.com> - 0.1-1
180- Initial Build
181
Note: See TracBrowser for help on using the repository browser.