source: projects/specs/trunk/g/gnome-system-tools/gnome-system-tools-vl.spec @ 521

Revision 521, 7.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define backendsver     2.6.0
3%define ver             2.22.0
4%define rel             1%{?_dist_release}
5
6Summary:        GNOME System Tools
7Summary(ja):    GNOMEシステムツール
8Name:           gnome-system-tools
9Version:        %ver
10Release:        %rel
11License:        LGPL
12Group:          Applications/System
13
14Source:         %{name}-%{version}.tar.bz2
15#Source100:     %{name}-2.14.0-ja.po
16
17# patches for vine
18#Patch100:      %{name}-2.14.0-wider-window.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21URL:            http://www.gnome.org/projects/gst/
22Requires:       system-tools-backends >= %{backendsver}
23Requires:       usermode
24BuildRequires:  PolicyKit-devel >= 0.8
25BuildRequires:  liboobs-devel >= 2.21.3
26BuildRequires:  nautilus >= 2.22.0
27
28%description
29Day-to-day system management on Unix systems is a chore. Even when you're
30using a friendly graphical desktop, seemingly basic tasks like setting the
31system time, changing the network setup, importing and exporting network
32shared filesystems and configuring swap partitions requires editing
33configuration files by hand, and the exact procedure varies between different
34operating systems and distributions.
35
36The GNOME System Tools solve all these problems, giving you a simple graphical
37interface for each task, which uses an advanced backend to edit all the
38relevant files and apply your changes. The interface looks and acts in exactly
39the same way regardless of what platform you're using.
40
41%prep
42%setup -q
43
44#%patch100 -p1 -b .wider
45
46#cp -f po/ja.po po/ja.po.orig
47#cp -f %{SOURCE100} po/ja.po
48
49%build
50%configure --disable-scrollkeeper
51make %{?_smp_mflags}
52
53%install
54rm -rf %{buildroot}
55export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
56make DESTDIR=$RPM_BUILD_ROOT install
57unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
58
59# console-helper
60mv %{buildroot}/%{_bindir} %{buildroot}/%{_sbindir}
61mkdir -p %{buildroot}/%{_bindir}
62mkdir -p %{buildroot}/%{_sysconfdir}/security/console.apps
63mkdir -p %{buildroot}/%{_sysconfdir}/pam.d
64
65for wrappedapp in boot network services time users shares
66do
67  ln -sf consolehelper %{buildroot}/%{_bindir}/${wrappedapp}-admin
68  cat << EOF > %{buildroot}/%{_sysconfdir}/security/console.apps/${wrappedapp}-admin
69USER=root
70PROGRAM=/usr/sbin/${wrappedapp}-admin
71SESSION=true
72EOF
73  chmod 644 %{buildroot}/%{_sysconfdir}/security/console.apps/${wrappedapp}-admin
74  cat << EOF > %{buildroot}/etc/pam.d/${wrappedapp}-admin
75#%PAM-1.0
76auth            include         config-util
77account         include         config-util
78session         include         config-util
79EOF
80done
81
82# Get rid of stuff we don't want
83rm -rf $RPM_BUILD_ROOT%{_libdir}/debug
84rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/X11
85
86rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/*.*a
87
88rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
89rm -rf $RPM_BUILD_ROOT%{_localstatedir}/lib/scrollkeeper
90
91%find_lang %{name}
92
93%clean
94rm -rf %{buildroot}
95
96%post
97scrollkeeper-update > /dev/null 2>&1 || :
98export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99SCHEMAS="gnome-system-tools.schemas"
100for S in $SCHEMAS; do
101  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
102done
103
104
105%files -f %{name}.lang
106%defattr(-,root,root)
107%doc README AUTHORS COPYING HACKING NEWS ChangeLog
108%config(noreplace) %{_sysconfdir}/security/console.apps/*
109%config(noreplace) %{_sysconfdir}/pam.d/*
110%{_bindir}/*
111%{_sbindir}/*
112%{_sysconfdir}/gconf/schemas/*.schemas
113%{_datadir}/%{name}
114%{_datadir}/applications/*.desktop
115%{_datadir}/gnome/help/*
116%{_datadir}/omf/*
117%{_datadir}/icons/hicolor/*/*/*
118%{_libdir}/nautilus/extensions-2.0/*.so
119%{_libdir}/pkgconfig/*
120
121
122%changelog
123* Thu Jul  3 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-1
124- updated to new upstream release
125- new versioning policy; spec in UTF-8
126
127* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.1-0vl4
128- add BuildRequires: nautilus
129
130* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
131- remove Patch22
132- use console-helper instead of gksu
133
134* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
135- add Patch22 from ubuntu to use gksu
136
137* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
138- new upstream release
139
140* Thu Oct 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
141- add some services to visible on services-admin
142- update ja.po
143
144* Thu Jun 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
145- enable disks-admin
146- import Patch10-14 from ubuntu
147
148* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
149- new upstream release
150
151* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.2-0vl1
152- new upstream release
153
154* Thu Sep 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
155- new upstream release
156
157* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.0.1-0vl1
158- new upstream release
159
160* Sat Mar 26 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
161- new upstream release
162
163* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-0vl2
164- drop consolehelper support.
165  The g-s-t have internal authentication system.
166
167* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-0vl1
168- new upstream release
169- update ja.po
170- add shares-admin
171
172* Sat Oct 30 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.0-0vl2
173- disable boot-admin on ppc (TODO: make boot-admin compatible with ppc)
174
175* Tue Sep 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
176- new upstream release
177- temporally removed 'default gateway device' combobox from network-admin.
178  it generate broken GATEWAYDEV entry.
179
180* Thu Sep 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.92.0-0vl2
181- drop disks-admin
182
183* Thu Sep 02 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.92.0-0vl1
184- new upstream release
185- update ja.po
186- remove vine patch which is merged in upstream
187
188* Sat Jul 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.90.0-0vl1
189- new upstream release
190- update vine patch
191
192* Mon Jul 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.33.0-0vl6
193- fixed bogus consolehelper symlinks.
194
195* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.33.0-0vl5
196- set "last_version" to (really) disable warning in first run.
197
198* Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.33.0-0vl4
199- don't show warning in first run.
200
201* Tue Jun 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.33.0-0vl3
202- update ja.po
203- update Patch10 to support Vine Linux more.
204
205* Thu Jun 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.33.0-0vl2
206- update ja.po
207- add Patch10 to fix network-admin problem
208
209* Wed May 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.33.0-0vl1
210- new upstream release
211- s/Copyright/License/
212
213* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.31.1-0vl1
214- new upstream release
215
216* Wed Dec 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.30.0-0vl1
217- new upstream release
218
219* Tue Oct 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.28.0-0vl1
220- new upstream release
221
222* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.27.0-0vl2
223- update ja.po
224
225* Tue Aug 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.27.0-0vl1
226- new upstream release
227
228* Sat May 31 2003 Tomoya TAKA <taka@vinelinux.org> 0.26.0-0vl2
229- add %%defattr into %%file section
230
231* Mon May 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.0-0vl1
232- new upstream release
233
234* Tue May 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.25.0-0vl1
235- new upstream release
236
237* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23.0-0vl1
238- new upstream release
239
240* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.22.0-0vl1
241- initial release
Note: See TracBrowser for help on using the repository browser.