source: projects/specs/trunk/g/gnome-specimen/gnome-specimen-vl.spec @ 5701

Revision 5701, 4.0 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           gnome-specimen
4Version:        0.4
5Release:        2%{?_dist_release}
6Summary:        A simple tool to view and compare fonts installed on your system
7Summary(ja):        システムにインストールされているフォントを閲覧・比較するシンプルなツール
8
9Group:          Applications/System
10License:        GPLv2+
11URL:            http://uwstopia.nl/geek/projects/gnome-specimen/
12Source0:        http://uwstopia.nl/geek/projects/gnome-specimen/releases/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch:      noarch
15
16BuildRequires:  GConf2-devel
17BuildRequires:  gnome-python
18BuildRequires:  pygtk2-libglade
19BuildRequires:  perl-XML-Parser
20BuildRequires:  pkgconfig
21BuildRequires:  gettext
22BuildRequires:  desktop-file-utils
23Requires(pre): GConf2
24Requires(post): GConf2
25Requires(preun): GConf2
26
27%description
28Gnome Specimen is a simple tool to view and compare fonts installed on
29your system
30
31%description -l ja
32Gnome Specimen はあなたのシステムにインストールされているフォントを
33閲覧・比較するためのシンプルなツールです。
34
35%prep
36%setup -q
37
38
39%build
40%configure
41%__make %{?_smp_mflags}
42
43
44%install
45%__rm -rf $RPM_BUILD_ROOT
46export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
47## %__make install DESTDIR=$RPM_BUILD_ROOT
48%__make install DESTDIR=$RPM_BUILD_ROOT pyexecdir=%{python_sitelib}
49
50desktop-file-install --vendor="vine" --delete-original \
51    --dir $RPM_BUILD_ROOT%{_datadir}/applications        \
52    $RPM_BUILD_ROOT%{_datadir}/applications//%{name}.desktop
53
54
55%find_lang %{name}
56
57%clean
58%__rm -rf $RPM_BUILD_ROOT
59
60
61%pre
62if [ "$1" -gt 1 ]; then
63    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
64    gconftool-2 --makefile-uninstall-rule \
65      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
66    killall -HUP gconfd-2 || :
67fi
68
69%post
70touch --no-create %{_datadir}/icons/hicolor || :
71%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
72export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
73gconftool-2 --makefile-install-rule \
74  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
75killall -HUP gconfd-2 || :
76
77%postun
78touch --no-create %{_datadir}/icons/hicolor || :
79%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
80
81
82%preun
83if [ "$1" -eq 0 ]; then
84    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85    gconftool-2 --makefile-uninstall-rule \
86      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
87    killall -HUP gconfd-2 || :
88fi
89
90%files -f %{name}.lang
91%defattr(-,root,root,-)
92%doc AUTHORS ChangeLog COPYING NEWS README
93%{_bindir}/%{name}
94%{python_sitelib}/specimen
95%{_datadir}/%{name}
96%{_datadir}/applications/*.desktop
97%{_datadir}/icons/hicolor/*/apps/%{name}.*
98%config(noreplace) %{_sysconfdir}/gconf/schemas/%{name}.schemas
99
100%changelog
101* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
102- rebuild with python-2.7.2
103
104* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
105- new upstream release
106
107* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 0.3-2
108- rebuilt with python-2.6.4-3
109- fixed install directory
110
111* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.3-1
112- initial build
113
114* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.3-3
115- Rebuild for Python 2.6
116
117* Wed Jul 23 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3-2
118- fix license tag
119
120* Wed Jul 18 2007 Damien Durand <splinux@fedoraproject.org> - 0.3-1
121- Update to 0.3
122
123* Wed Jul 11 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-4
124- Fix desktop-file section
125
126* Wed Jun 27 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-3
127- Fix owned directories
128
129* Fri Jun 09 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-2
130- Fix gconf shemas
131- Set BuildArch to noarch
132- Fix wrong entries from desktop file
133
134* Fri Jun 08 2007 Damien Durand <splinux@fedoraproject.org> - 0.2-1
135- Initial RPM release
Note: See TracBrowser for help on using the repository browser.