source: projects/specs/trunk/g/gnome-software/gnome-software-vl.spec @ 12468

Revision 12468, 27.7 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

gnome-session-3.36.0-2

gnome-shell-3.36.5-1

gnome-software-3.36.1-2

gtk3-3.24.22-1

Line 
1%global glib2_version 2.56.0
2%global gtk3_version 3.22.4
3%global json_glib_version 1.2.0
4%global packagekit_version 1.1.1
5%global appstream_glib_version 0.7.14-3
6%global libsoup_version 2.52.0
7%global gsettings_desktop_schemas_version 3.12.0
8%global gnome_desktop_version 3.18.0
9%global fwupd_version 1.0.7
10%global flatpak_version 0.9.4
11
12Summary:        A software center for GNOME
13Name:           gnome-software
14Version:        3.36.1
15Release:        2%{?_dist_release}
16Group:          admin-tools,desktop-gnome
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20License:        GPLv2+
21URL:            https://wiki.gnome.org/Apps/Software
22%global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
23Source0:        https://download.gnome.org/sources/gnome-software/%{shortver}/%{name}-%{version}.tar.xz
24# /usr/share/pixmaps/backgrounds/Vine/vinelinux7-7-1920x1200.jpg from vine-backgrounds
25Source1:        vine.jpg
26
27BuildRequires: gcc
28BuildRequires: gettext
29BuildRequires: libxslt
30BuildRequires: docbook-style-xsl
31BuildRequires: desktop-file-utils
32#BuildRequires: fwupd-devel >= %{fwupd_version}
33BuildRequires: glib2-devel >= %{glib2_version}
34BuildRequires: gnome-desktop3-devel
35BuildRequires: gnome-online-accounts-devel
36BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_version}
37BuildRequires: gspell-devel
38BuildRequires: gtk3-devel >= %{gtk3_version}
39BuildRequires: gtk-doc
40BuildRequires: json-glib-devel >= %{json_glib_version}
41BuildRequires: libappstream-glib-devel >= %{appstream_glib_version}
42BuildRequires: libsoup-devel
43BuildRequires: libxmlb-devel
44BuildRequires: meson
45BuildRequires: PackageKit-devel >= %{packagekit_version}
46BuildRequires: polkit-devel
47BuildRequires: libsecret-devel
48BuildRequires: flatpak-devel >= %{flatpak_version}
49BuildRequires: ostree-devel
50#BuildRequires: rpm-ostree-devel
51BuildRequires: libgudev-devel
52#BuildRequires: valgrind-devel
53
54Requires: appstream-data
55Requires: flatpak%{?_isa} >= %{flatpak_version}
56Requires: flatpak-libs%{?_isa} >= %{flatpak_version}
57#Requires: fwupd%{?_isa} >= %{fwupd_version}
58Requires: glib2%{?_isa} >= %{glib2_version}
59Requires: gnome-desktop3%{?_isa} >= %{gnome_desktop_version}
60# gnome-menus is needed for app folder .directory entries
61Requires: gnome-menus%{?_isa}
62Requires: gsettings-desktop-schemas%{?_isa} >= %{gsettings_desktop_schemas_version}
63Requires: gtk3%{?_isa} >= %{gtk3_version}
64Requires: json-glib%{?_isa} >= %{json_glib_version}
65Requires: iso-codes
66Requires: libappstream-glib%{?_isa} >= %{appstream_glib_version}
67# librsvg2 is needed for gdk-pixbuf svg loader
68Requires: librsvg2%{?_isa}
69Requires: libsoup%{?_isa} >= %{libsoup_version}
70Requires: PackageKit%{?_isa} >= %{packagekit_version}
71
72# this is not a library version
73%define gs_plugin_version               13
74
75%description
76gnome-software is an application that makes it easy to add, remove
77and update software in the GNOME desktop.
78
79
80%package devel
81Summary: Headers for building external gnome-software plugins
82Group:   programming
83Requires: %{name}%{?_isa} = %{version}-%{release}
84
85%description devel
86These development files are for building gnome-software plugins outside
87the source tree. Most users do not need this subpackage installed.
88
89
90%prep
91%autosetup -p1
92
93%build
94%meson \
95    -Dsnap=false \
96    -Dgudev=true \
97    -Dpackagekit=true \
98    -Dexternal_appstream=true \
99%if 0
100    -Drpm_ostree=true \
101%else
102    -Drpm_ostree=false \
103%endif
104    -Dmalcontent=false \
105    -Dtests=false \
106    -Dubuntuone=false \
107    -Dubuntu_reviews=false \
108    -Dfwupd=false \
109    -Dvalgrind=false
110%meson_build
111
112
113%install
114%meson_install
115
116# make the software center load faster
117desktop-file-edit %{buildroot}%{_datadir}/applications/org.gnome.Software.desktop \
118    --set-key=X-AppInstall-Package --set-value=%{name}
119
120%if 0
121# set up for Fedora
122cat >> %{buildroot}%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override << FOE
123[org.gnome.software]
124official-repos = [ 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source' ]
125FOE
126%endif
127
128# Install upgrade background image
129mkdir -p  %{buildroot}%{_datadir}/gnome-software/backgrounds
130cp -a %{SOURCE1} %{buildroot}%{_datadir}/gnome-software/backgrounds/
131
132rm -rf %{buildroot}%{_docdir}/gnome-software
133
134%find_lang %name --with-gnome
135
136
137%check
138desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
139
140
141%post
142if [ $1 -eq 1 ]; then
143  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
144  update-desktop-database -q > /dev/null || :
145fi
146
147%postun
148if [ $1 -eq 0 ]; then
149  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
150  update-desktop-database -q > /dev/null || :
151fi
152
153
154%files -f %{name}.lang
155%doc AUTHORS README.md
156%license COPYING
157%{_bindir}/gnome-software
158%{_datadir}/applications/gnome-software-local-file.desktop
159%{_datadir}/applications/org.gnome.Software.desktop
160%{_mandir}/man1/gnome-software.1.gz
161%{_datadir}/icons/hicolor/*/apps/*
162%{_datadir}/icons/hicolor/scalable/status/software-installed-symbolic.svg
163%dir %{_datadir}/gnome-software
164%{_datadir}/gnome-software/*.png
165%{_datadir}/gnome-software/backgrounds/
166%{_datadir}/gnome-software/featured-*.svg
167%{_datadir}/gnome-software/featured-*.jpg
168%{_datadir}/metainfo/org.gnome.Software.appdata.xml
169%{_datadir}/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
170%if 0
171%{_datadir}/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
172%endif
173%{_datadir}/metainfo/org.gnome.Software.Plugin.Odrs.metainfo.xml
174%{_datadir}/polkit-1/actions/org.gnome.software.external-appstream.policy
175%dir %{_libdir}/gs-plugins-%{gs_plugin_version}
176%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_appstream.so
177%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-categories.so
178%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-menu-path.so
179%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dpkg.so
180%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dummy.so
181%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-pkgdb-collections.so
182%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_flatpak.so
183%if 0
184%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fwupd.so
185%endif
186%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_external-appstream.so
187%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-langpacks.so
188%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_generic-updates.so
189%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-blacklist.so
190%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-popular.so
191%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_icons.so
192%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors-metadata.so
193%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors.so
194%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_modalias.so
195%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_odrs.so
196%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_os-release.so
197%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-history.so
198%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-local.so
199%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-offline.so
200%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-proxy.so
201%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine-repos.so
202%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine.so
203%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refresh.so
204%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-upgrade.so
205%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-url-to-app.so
206%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit.so
207%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance-license.so
208%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance.so
209%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_repos.so
210%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rewrite-resource.so
211%if 0
212%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rpm-ostree.so
213%endif
214%{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_systemd-updates.so
215%{_sysconfdir}/xdg/autostart/gnome-software-service.desktop
216%{_datadir}/app-info/xmls/org.gnome.Software.Featured.xml
217%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
218%{_datadir}/dbus-1/services/org.gnome.Software.service
219%{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
220%{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
221%if 0
222%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override
223%endif
224%{_libexecdir}/gnome-software-cmd
225%{_libexecdir}/gnome-software-install-appstream
226%{_libexecdir}/gnome-software-restarter
227
228%files devel
229%{_libdir}/pkgconfig/gnome-software.pc
230%dir %{_includedir}/gnome-software
231%{_includedir}/gnome-software/*.h
232%{_datadir}/gtk-doc/html/gnome-software
233
234
235%changelog
236* Fri Aug 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-2
237- added R:appstream-data.
238
239* Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-1
240- new upstream release.
241
242* Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.30.6-5
243- initial build for Vine Linux.
244
245* Tue May 07 2019 Kalev Lember <klember@redhat.com> - 3.30.6-4
246- Fix distro upgrade progress bar to actually work
247
248* Sun Apr 28 2019 Kalev Lember <klember@redhat.com> - 3.30.6-3
249- Add artwork for F30 upgrades
250
251* Mon Feb 25 2019 Kalev Lember <klember@redhat.com> - 3.30.6-2
252- Backport various fixes to error messages to avoid the dreaded
253  "Unable to update '(null)'" error
254
255* Tue Dec 18 2018 Kalev Lember <klember@redhat.com> - 3.30.6-1
256- Update to 3.30.6
257
258* Wed Oct 24 2018 Kalev Lember <klember@redhat.com> - 3.30.5-1
259- Update to 3.30.5
260
261* Thu Oct 18 2018 Kalev Lember <klember@redhat.com> - 3.30.3-1
262- Update to 3.30.3
263
264* Fri Oct 05 2018 Kalev Lember <klember@redhat.com> - 3.30.2-1
265- Update to 3.30.2
266
267* Wed Sep 26 2018 Kalev Lember <klember@redhat.com> - 3.30.1-2
268- Add modular repos to official repos list
269
270* Tue Sep 25 2018 Kalev Lember <klember@redhat.com> - 3.30.1-1
271- Update to 3.30.1
272
273* Thu Sep 06 2018 Kalev Lember <klember@redhat.com> - 3.30.0-1
274- Update to 3.30.0
275
276* Tue Aug 28 2018 Richard Hughes <rhughes@redhat.com> - 3.29.92-1
277- Update to 3.29.92
278
279* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.29.1-2
280- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
281
282* Wed May 09 2018 Kalev Lember <klember@redhat.com> - 3.29.1-1
283- Update to 3.29.1
284
285* Mon Apr 09 2018 Kalev Lember <klember@redhat.com> - 3.28.1-1
286- Update to 3.28.1
287
288* Thu Mar 29 2018 Kalev Lember <klember@redhat.com> - 3.28.0-5
289- Fix empty OS Updates showing up
290- Make rpm-ostree update triggering work
291
292* Thu Mar 15 2018 Kalev Lember <klember@redhat.com> - 3.28.0-4
293- Fix opening results from gnome-shell search provider
294
295* Wed Mar 14 2018 Kalev Lember <klember@redhat.com> - 3.28.0-3
296- Fix crash on initial run with no network (#1554986)
297
298* Tue Mar 13 2018 Kalev Lember <klember@redhat.com> - 3.28.0-2
299- Backport an upstream patch to fix shell extensions app ID
300
301* Mon Mar 12 2018 Kalev Lember <klember@redhat.com> - 3.28.0-1
302- Update to 3.28.0
303
304* Sun Mar 11 2018 Kalev Lember <klember@redhat.com> - 3.27.92-3
305- Rebuilt for gspell 1.8
306
307* Wed Mar 07 2018 Kalev Lember <klember@redhat.com> - 3.27.92-2
308- Move org.gnome.Software.Featured.xml from -editor to main package
309
310* Mon Mar 05 2018 Kalev Lember <klember@redhat.com> - 3.27.92-1
311- Update to 3.27.92
312
313* Sun Mar 04 2018 Neal Gompa <ngompa13@gmail.com> - 3.27.90-4
314- Drop obsolete snapd-login-service requirement for snap plugin subpackage
315
316* Mon Feb 19 2018 Adam Williamson <awilliam@redhat.com> - 3.27.90-3
317- Backport fix for RHBZ #1546893 from upstream git
318
319* Mon Feb 19 2018 Kalev Lember <klember@redhat.com> - 3.27.90-2
320- Re-enable rpm-ostree plugin
321
322* Thu Feb 15 2018 Kalev Lember <klember@redhat.com> - 3.27.90-1
323- Update to 3.27.90
324- Temporarily disable the rpm-ostree plugin
325
326* Tue Feb 13 2018 Björn Esser <besser82@fedoraproject.org> - 3.27.4-4
327- Rebuild against newer gnome-desktop3 package
328
329* Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-3
330- Add fedora-workstation-repositories to nonfree-sources schema defaults
331
332* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.27.4-2
333- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
334
335* Mon Jan 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-1
336- Update to 3.27.4
337- Drop unused --without packagekit option
338
339* Fri Jan 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.27.3-2
340- Remove obsolete scriptlets
341
342* Sat Dec 16 2017 Kalev Lember <klember@redhat.com> - 3.27.3-1
343- Update to 3.27.3
344
345* Mon Nov 13 2017 Kalev Lember <klember@redhat.com> - 3.27.2-1
346- Update to 3.27.2
347
348* Thu Nov 09 2017 Kalev Lember <klember@redhat.com> - 3.26.2-1
349- Update to 3.26.2
350- Re-enable fwupd support
351
352* Tue Oct 31 2017 Kalev Lember <klember@redhat.com> - 3.26.1-5
353- Enable the rpm-ostree plugin
354
355* Wed Oct 25 2017 Kalev Lember <klember@redhat.com> - 3.26.1-4
356- Fix "too many results returned" error after distro upgrades (#1496489)
357
358* Tue Oct 10 2017 Kalev Lember <klember@redhat.com> - 3.26.1-3
359- Backport a flatpakref installation fix
360
361* Mon Oct 09 2017 Richard Hughes <rhughes@redhat.com> - 3.26.1-2
362- Disable fwupd support until we get a 3.27.1 tarball
363
364* Sun Oct 08 2017 Kalev Lember <klember@redhat.com> - 3.26.1-1
365- Update to 3.26.1
366
367* Mon Sep 11 2017 Kalev Lember <klember@redhat.com> - 3.26.0-1
368- Update to 3.26.0
369
370* Sun Aug 27 2017 Kalev Lember <klember@redhat.com> - 3.25.91-1
371- Update to 3.25.91
372
373* Tue Aug 15 2017 Kalev Lember <klember@redhat.com> - 3.25.90-1
374- Update to 3.25.90
375
376* Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-6
377- Rebuilt after RPM update (№ 3)
378
379* Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-5
380- Rebuilt for RPM soname bump
381
382* Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-4
383- Rebuilt for RPM soname bump
384
385* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-3
386- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
387
388* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-2
389- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
390
391* Fri Jul 21 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
392- Update to 3.25.4
393
394* Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 3.25.3-6
395- Drop a meson workaround now that meson is fixed
396
397* Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-5
398- Actually properly enable snap subpackage after removing conditional
399
400* Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-4
401- Remove unnecessary arch-specific conditional for snap subpackage
402
403* Tue Jun 27 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-3
404- Ensure snap subpackage is installed if snapd is installed
405
406* Fri Jun 23 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-2
407- Enable the snap subpackage
408
409* Fri Jun 23 2017 Kalev Lember <klember@redhat.com> - 3.25.3-1
410- Update to 3.25.3
411- Switch to the meson build system
412- Add an -editor subpackage with new banner editor
413
414* Mon May 15 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-1
415- Update to 3.23.3
416- Fix a common crash when installing flatpakrepo files
417- Ensure we show the banner when upgrades are available
418
419* Tue May 09 2017 Kalev Lember <klember@redhat.com> - 3.24.2-1
420- Update to 3.24.2
421
422* Tue Apr 25 2017 Adam Williamson <awilliam@redhat.com> - 3.24.1-2
423- Backport crasher fix from upstream (RHBZ #1444669 / BGO #781217)
424
425* Tue Apr 11 2017 Kalev Lember <klember@redhat.com> - 3.24.1-1
426- Update to 3.24.1
427
428* Tue Mar 21 2017 Kalev Lember <klember@redhat.com> - 3.24.0-1
429- Update to 3.24.0
430
431* Thu Mar 16 2017 Kalev Lember <klember@redhat.com> - 3.23.92-1
432- Update to 3.23.92
433
434* Mon Feb 27 2017 Richard Hughes <rhughes@redhat.com> - 3.23.91-1
435- Update to 3.23.91
436
437* Mon Feb 13 2017 Richard Hughes <rhughes@redhat.com> - 3.23.90-1
438- Update to 3.23.90
439
440* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.23.3-2
441- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
442
443* Thu Dec 15 2016 Richard Hughes <rhughes@redhat.com> - 3.23.3-1
444- Update to 3.23.3
445
446* Wed Nov 23 2016 Kalev Lember <klember@redhat.com> - 3.23.2-1
447- Update to 3.23.2
448
449* Tue Nov 08 2016 Kalev Lember <klember@redhat.com> - 3.22.2-1
450- Update to 3.22.2
451
452* Wed Oct 12 2016 Kalev Lember <klember@redhat.com> - 3.22.1-1
453- Update to 3.22.1
454
455* Mon Sep 19 2016 Kalev Lember <klember@redhat.com> - 3.22.0-1
456- Update to 3.22.0
457
458* Wed Sep 14 2016 Kalev Lember <klember@redhat.com> - 3.21.92-1
459- Update to 3.21.92
460- Don't set group tags
461
462* Thu Sep 01 2016 Kalev Lember <klember@redhat.com> - 3.21.91-1
463- Update to 3.21.91
464
465* Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-2
466- Rebuilt for fixed libappstream-glib headers
467
468* Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-1
469- Update to 3.21.90
470- Tighten -devel subpackage dependencies
471
472* Thu Jul 28 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-2
473- Allow building without PackageKit for the atomic workstation.
474
475* Mon Jul 18 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-1
476- Update to 3.21.4
477
478* Thu May 26 2016 Kalev Lember <klember@redhat.com> - 3.21.2-2
479- Build with flatpak support
480
481* Mon May 23 2016 Richard Hughes <rhughes@redhat.com> - 3.21.2-1
482- Update to 3.21.2
483
484* Tue May 10 2016 Kalev Lember <klember@redhat.com> - 3.21.1-2
485- Require PackageKit 1.1.1 for system upgrade support
486
487* Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.21.1-1
488- Update to 3.21.1
489
490* Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.20.2-1
491- Update to 3.20.1
492- Allow popular and featured apps to match any plugin
493- Do not make the ODRS plugin depend on xdg-app
494- Fix many of the os-upgrade issues and implement the latest mockups
495- Make all the plugins more threadsafe
496- Return all update descriptions newer than the installed version
497- Show some non-fatal error messages if installing fails
498- Use a background PackageKit transaction when downloading upgrades
499
500* Wed Apr 13 2016 Kalev Lember <klember@redhat.com> - 3.20.1-1
501- Update to 3.20.1
502
503* Fri Apr 01 2016 Richard Hughes <rhughes@redhat.com> - 3.20.1-2
504- Set the list of official sources
505- Compile with xdg-app support
506
507* Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
508- Update to 3.20.0
509
510* Mon Mar 14 2016 Richard Hughes <rhughes@redhat.com> - 3.19.92-1
511- Update to 3.19.92
512
513* Thu Mar 03 2016 Kalev Lember <klember@redhat.com> - 3.19.91-2
514- Set minimum required json-glib version
515
516* Mon Feb 29 2016 Richard Hughes <rhughes@redhat.com> - 3.19.91-1
517- Update to 3.19.91
518
519* Mon Feb 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.90-1
520- Update to 3.19.90
521
522* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.4-2
523- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
524
525* Fri Jan 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.4-1
526- Update to 3.19.4
527
528* Thu Dec 03 2015 Kalev Lember <klember@redhat.com> - 3.18.3-2
529- Require librsvg2 for the gdk-pixbuf svg loader
530
531* Thu Nov 05 2015 Richard Hughes <rhughes@redhat.com> - 3.18.3-1
532- Update to 3.18.3
533- Use the correct user agent string when downloading firmware
534- Fix a crash in the limba plugin
535- Fix installing web applications
536
537* Mon Oct 26 2015 Kalev Lember <klember@redhat.com> - 3.18.2-2
538- Fix apps reappearing as installed a few seconds after removal (#1275163)
539
540* Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 3.18.2-1
541- Update to 3.18.2
542
543* Tue Oct 13 2015 Kalev Lember <klember@redhat.com> - 3.18.1-1
544- Update to 3.18.1
545
546* Wed Oct 07 2015 Kalev Lember <klember@redhat.com> - 3.18.0-2
547- Backport two crasher fixes from upstream
548
549* Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 3.18.0-1
550- Update to 3.18.0
551
552* Tue Sep 15 2015 Kalev Lember <klember@redhat.com> - 3.17.92-2
553- Update dependency versions
554
555* Tue Sep 15 2015 Richard Hughes <rhughes@redhat.com> - 3.17.92-1
556- Update to 3.17.92
557
558* Thu Sep 10 2015 Richard Hughes <rhughes@redhat.com> - 3.17.91-2
559- Fix firmware updates
560
561* Thu Sep 03 2015 Kalev Lember <klember@redhat.com> - 3.17.91-1
562- Update to 3.17.91
563
564* Wed Aug 19 2015 Kalev Lember <klember@redhat.com> - 3.17.90-1
565- Update to 3.17.90
566
567* Wed Aug 12 2015 Richard Hughes <rhughes@redhat.com> - 3.17.3-1
568- Update to 3.17.3
569
570* Wed Jul 22 2015 David King <amigadave@amigadave.com> - 3.17.2-3
571- Bump for new gnome-desktop3
572
573* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.17.2-2
574- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
575
576* Fri Jun 05 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.2-1
577- Update to 3.17.2
578
579* Mon May 25 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.1-1
580- Update to 3.17.1
581
582* Fri May 15 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-2
583- Fix a crash under Wayland (#1221968)
584
585* Mon May 11 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-1
586- Update to 3.16.2
587
588* Tue Apr 14 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.1-1
589- Update to 3.16.1
590
591* Mon Mar 23 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.0-1
592- Update to 3.16.0
593
594* Mon Mar 16 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
595- Update to 3.15.92
596- Use license macro for the COPYING file
597- Add a patch to adapt to gnome-terminal desktop file rename
598
599* Mon Mar 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91-1
600- Update to 3.15.91
601
602* Sat Feb 21 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-3
603- Export DisplayName property on the packagekit session service
604
605* Thu Feb 19 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-2
606- Backport a crash fix
607
608* Tue Feb 17 2015 Richard Hughes <rhughes@redhat.com> - 3.15.90-1
609- Update to 3.15.90
610
611* Mon Jan 19 2015 Richard Hughes <rhughes@redhat.com> - 3.15.4-1
612- Update to 3.15.4
613
614* Tue Nov 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.15.2-1
615- Update to 3.15.2
616
617* Thu Nov 13 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-3
618- Fix non-Fedora build
619
620* Tue Nov 11 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-2
621- Backport a patch to fix compilation
622
623* Mon Nov 10 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.2-1
624- Update to 3.14.2
625
626* Sat Nov 08 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-3
627- Update the list of system apps
628
629* Sat Nov 01 2014 David King <amigadave@amigadave.com> - 3.14.1-2
630- Rebuild for new libappstream-glib (#1156494)
631
632* Mon Oct 13 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
633- Update to 3.14.1
634
635* Thu Oct 09 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-2
636- Depend on gnome-menus for app folder directory entries
637
638* Mon Sep 22 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
639- Update to 3.14.0
640
641* Wed Sep 17 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-2
642- Set minimum required dependency versions (#1136343)
643
644* Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-1
645- Update to 3.13.92
646- Replace gnome-system-log with gnome-logs in the system apps list
647
648* Tue Sep 02 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.91-1
649- Update to 3.13.91
650
651* Tue Aug 19 2014 Richard Hughes <rhughes@redhat.com> - 3.13.90-1
652- Update to 3.13.90
653
654* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.13.5-0.2.git5c89189
655- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
656
657* Mon Aug 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.5-0.1.git5c89189
658- Update to 3.13.5 git snapshot
659- Ship HighContrast icons
660
661* Sun Aug 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-2
662- Replace Epiphany with Firefox in the system apps list
663
664* Wed Jul 23 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-1
665- Update to 3.13.4
666
667* Wed Jun 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-1
668- Update to 3.13.3
669
670* Thu Jun 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.3-0.2.git7491627
671- Depend on the newly-created appstream-data package and stop shipping
672  the metadata here.
673
674* Sat Jun 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-0.1.git7491627
675- Update to 3.13.3 git snapshot
676
677* Wed May 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.2-2
678- Rebuild with new metadata.
679
680* Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.2-1
681- Update to 3.13.2
682
683* Thu May 15 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-4
684- Depend on gsettings-desktop-schemas
685
686* Mon May 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-3
687- Update the metadata and use appstream-util to install the metadata.
688
689* Wed May 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-2
690- Drop gnome-icon-theme dependency
691
692* Mon Apr 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-1
693- Update to 3.13.1
694
695* Fri Apr 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.1-2
696- Rebuild with new metadata.
697
698* Fri Apr 11 2014 Richard Hughes <rhughes@redhat.com> - 3.12.1-1
699- Update to 3.12.1
700
701* Mon Mar 24 2014 Richard Hughes <rhughes@redhat.com> - 3.12.0-1
702- Update to 3.12.0
703
704* Thu Mar 20 2014 Richard Hughes <rhughes@redhat.com> - 3.11.92-1
705- Update to 3.11.92
706
707* Tue Mar 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-2
708- Rebuild with new metadata.
709
710* Sat Mar 08 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-1
711- Update to 3.11.91
712
713* Tue Feb 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.90-1
714- Update to 3.11.90
715
716* Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-2
717- Require epiphany-runtime rather than the full application
718
719* Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-1
720- Update to 3.11.5
721
722* Thu Jan 30 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-3
723- Rebuild for libpackagekit-glib soname bump
724
725* Wed Jan 22 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-2
726- Rebuild with metadata that has the correct screenshot url.
727
728* Thu Jan 16 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-1
729- Update to 3.11.4
730
731* Tue Dec 17 2013 Richard Hughes <rhughes@redhat.com> - 3.11.3-1
732- Update to 3.11.3
733
734* Tue Nov 19 2013 Richard Hughes <rhughes@redhat.com> - 3.11.2-1
735- Update to 3.11.2
736
737* Tue Oct 29 2013 Richard Hughes <rhughes@redhat.com> - 3.11.1-1
738- Update to 3.11.1
739- Add a gnome shell search provider
740- Add a module to submit the user rating to the fedora-tagger web service
741- Add support for 'missing' codecs that we know exist but we can't install
742- Add support for epiphany web applications
743- Handle offline installation sensibly
744- Save the user rating if the user clicks the rating stars
745- Show a modal error message if install or remove actions failed
746- Show a star rating on the application details page
747- Show font screenshots
748- Show more detailed version numbers when required
749- Show screenshots to each application
750
751* Wed Sep 25 2013 Richard Hughes <richard@hughsie.com> 3.10.0-1
752- New upstream release.
753- New metadata for fedora, updates and updates-testing
754- Add a plugin to query the PackageKit prepared-update file directly
755- Do not clear the offline-update trigger if rebooting succeeded
756- Do not load incompatible projects when parsing AppStream data
757- Lots of updated translations
758- Show the window right away when starting
759
760* Fri Sep 13 2013 Richard Hughes <richard@hughsie.com> 3.9.3-1
761- New upstream release.
762- Lots of new and fixed UI and updated metadata for Fedora 20
763
764* Tue Sep 03 2013 Richard Hughes <richard@hughsie.com> 3.9.2-1
765- New upstream release.
766- Allow stock items in the AppStream XML
767- Extract the AppStream URL and description from the XML
768- Only present the window when the overview is complete
769- Return the subcategories sorted by name
770
771* Mon Sep 02 2013 Richard Hughes <richard@hughsie.com> 3.9.1-1
772- New upstream release which is a technical preview for the alpha.
773
774* Sun Sep 01 2013 Richard Hughes <richard@hughsie.com> 0.1-3
775- Use buildroot not RPM_BUILD_ROOT
776- Own all gnome-software directories
777- Drop gtk-update-icon-cache requires and the mime database functionality
778
779* Thu Aug 29 2013 Richard Hughes <richard@hughsie.com> 0.1-2
780- Add call to desktop-file-validate and fix other review comments.
781
782* Wed Aug 28 2013 Richard Hughes <richard@hughsie.com> 0.1-1
783- First release for Fedora package review
784
Note: See TracBrowser for help on using the repository browser.