source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9791

Revision 9791, 10.6 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define pkg_version 3.18.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.18/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
14Patch103:       gnome-shell-3.16.2-disable-packagekit.patch
15Patch104:       gnome-shell-3.18.1-vine-themes.patch
16
17License:        GPLv2+
18Group:          User Interface/Desktops
19URL:            http://live.gnome.org/GnomeShell
20
21Requires: mutter
22Requires: caribou
23Requires: ca-certificates
24Requires: at-spi2-atk
25Requires: telepathy-logger
26Requires: network-manager-applet
27Requires: gnome-tweak-tool
28
29BuildRequires: gnome-common
30BuildRequires: libtool
31BuildRequires: automake
32BuildRequires: autoconf
33
34BuildRequires: pkgconfig
35BuildRequires: gtk2-devel
36BuildRequires: clutter-devel
37BuildRequires: mutter-devel
38BuildRequires: gjs-devel
39BuildRequires: gnome-desktop3-devel
40BuildRequires: gnome-menus-devel
41BuildRequires: libSM-devel
42BuildRequires: libffi-devel
43BuildRequires: startup-notification-devel
44BuildRequires: gnome-doc-utils
45BuildRequires: desktop-file-utils
46BuildRequires: libcroco-devel
47BuildRequires: librsvg2-devel
48BuildRequires: gobject-introspection-devel
49BuildRequires: control-center-devel
50BuildRequires: gcr-devel
51BuildRequires: gstreamer-devel
52BuildRequires: dbus-glib-devel
53BuildRequires: telepathy-logger-devel
54BuildRequires: polkit-devel
55BuildRequires: pulseaudio-libs-devel
56BuildRequires: evolution-data-server-devel
57BuildRequires: folks-devel
58BuildRequires: NetworkManager-glib-devel
59BuildRequires: libnm-gtk-devel
60BuildRequires: libgudev1-devel
61BuildRequires: libcanberra-gtk3-devel
62BuildRequires: caribou-devel
63BuildRequires: ca-certificates
64BuildRequires: python3-devel
65BuildRequires: intltool
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: Takemikaduchi
72
73
74%description
75GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
76It provides core interface functions like switching to windows and launching
77applications. GNOME Shell takes advantage of the capabilities of modern graphics
78hardware and introduces innovative user interface concepts to provide a delightful
79and easy to use experience.
80
81
82%package        docs
83Summary:        Documentation for %{name}
84Summary(ja):    %{name} 用のドキュメント
85Group:          Documentation
86Requires:       %{name} = %{version}-%{release}
87BuildArch:              noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93
94%prep
95%setup -q
96%patch101 -p1 -b .vine
97%patch102 -p1 -b .vine
98%patch103 -p1 -b .vine
99%patch104 -p1 -b .vine
100
101%build
102%configure \
103        --disable-static \
104        --disable-systemd
105
106%{__make} %{?_smp_mflags} V=1
107
108
109%install
110%{__rm} -rf ${RPM_BUILD_ROOT}
111%{__make} install DESTDIR=${RPM_BUILD_ROOT}
112
113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
114
115rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
116%find_lang %{name}
117
118
119
120%clean
121%{__rm} -rf ${RPM_BUILD_ROOT}
122
123
124%post
125/sbin/ldconfig
126touch --no-create %{_datadir}/icons/hicolor
127if [ -x /usr/bin/gtk-update-icon-cache ]; then
128  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
129fi
130
131%postun
132/sbin/ldconfig
133touch --no-create %{_datadir}/icons/hicolor
134if [ -x /usr/bin/gtk-update-icon-cache ]; then
135  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
136fi
137glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
138
139%posttrans
140glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
141
142
143%files -f %{name}.lang
144%defattr(-,root,root,-)
145%doc COPYING NEWS README
146%{_bindir}/gnome-shell
147%{_bindir}/gnome-shell-extension-tool
148%{_bindir}/gnome-shell-extension-prefs
149%{_bindir}/gnome-shell-perf-tool
150%{_libdir}/%{name}/*
151%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
152%{_libexecdir}/gnome-shell-calendar-server
153%{_libexecdir}/gnome-shell-hotplug-sniffer
154%{_libexecdir}/gnome-shell-perf-helper
155%{_libexecdir}/gnome-shell-portal-helper
156%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
157%{_datadir}/applications/gnome-shell.desktop
158%{_datadir}/applications/gnome-shell-extension-prefs.desktop
159%{_datadir}/applications/evolution-calendar.desktop
160%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
161%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
162%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
163%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
164%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
165%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
166%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
167%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
168%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
169%{_datadir}/%{name}/*
170%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
171%{_mandir}/man1/%{name}.1.gz
172
173%files docs
174%defattr(-,root,root,-)
175%{_datadir}/gtk-doc/html/shell
176%{_datadir}/gtk-doc/html/st
177
178
179%changelog
180* Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
181- new upstream release
182- update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
183
184* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
185- new upstream release
186
187* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
188- add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
189
190* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
191- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
192
193* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
194- new upstream release
195
196* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
197- new upstream release
198
199* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
200- new upstream release
201- add BuildRequires: python3-devel
202- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
203
204* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
205- rebuilt with libical 1.0.1
206
207* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
208- new upstream release
209
210* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
211- new upstream release
212
213* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
214- new upstream release
215- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
216- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
217
218* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
219- new upstream release
220
221* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
222- new upstream release
223
224* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
225- new upstream release
226
227* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
228- new upstream release
229
230* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
231- new upstream release
232
233* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
234- new upstream release
235
236* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
237- new upstream release
238
239* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
240- new upstream release
241
242* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
243- new upstream release
244
245* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
246- new upstream release
247- update Patch101 (gnome-shell-vine-settings.patch)
248- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
249- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
250- create %%{name}-docs subpackage
251
252* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
253- new upstream release
254- remove Source102 (gnome-shell.gnome-3-6.ja.po)
255
256* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
257- new upstream release
258- add Source102 (gnome-shell.gnome-3-6.ja.po)
259
260* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
261- new upstream release
262- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
263
264* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
265- rebuild with telepathy-logger-0.6.0
266- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
267
268* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
269- new upstream release
270
271* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
272- new upstream release
273- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
274- update Patch101 (gnome-shell-vine-settings.patch)
275- change BuildRequires: ca-certificates instead of openssl
276- add BuildRequires: libcanberra-gtl3-devel
277
278* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
279- new upstream release
280- remove Patch103 (gnome-shell-ja.po-date.patch)
281
282* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
283- new upstream release
284- update Patch101,103
285- remove Patch0,102
286- add BuildRequires: gcr-devel
287- remove BuildRequires: GConf2-devel
288- add Requires: at-spi2-atk
289
290* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
291- new upstream release
292- remove Patch1
293
294* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
295- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
296- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
297- rename Patch103 (gnome-shell-ja.po-date.patch)
298- drop Patch102
299
300* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
301- new upstream release
302
303* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
304- new upstream release
305
306* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
307- new upstream release
308- update Patch101
309- update Patch102
310- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
311- add BuildRequires: libgudev1-devel, openssl
312
313* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
314- new upstream release
315- add BuildRequires: folks-devel, NetworkManager-glib-devel
316- add Requires: caribou
317- remove Patch0
318- update Patch101
319- update Patch102
320- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
321
322* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
323- rebuild with gnome-menus-3.1.5
324- add Patch0 (gnome-shell-git20110821.patch)
325
326* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
327- new upstream release
328- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
329- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
330- remove BuildRequires: xulrunner-devel
331- add Patch101 (gnome-shell-vine-settings.patch)
332- add Patch102 (gnome-shell-vine-customize.patch)
333- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
334
335* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
336- add Requires: mutter
337
338* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
339- new upstream release
340
341* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
342- initial build for Vine Linux
343
Note: See TracBrowser for help on using the repository browser.