source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9569

Revision 9569, 10.0 KB checked in by Takemikaduchi, 9 years ago (diff)

cogl: add patch
others: new upstream release

Line 
1%define pkg_version 3.16.2
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
14
15License:        GPLv2+
16Group:          User Interface/Desktops
17URL:            http://live.gnome.org/GnomeShell
18
19Requires: mutter
20Requires: caribou
21Requires: ca-certificates
22Requires: at-spi2-atk
23Requires: telepathy-logger
24Requires: network-manager-applet
25Requires: gnome-tweak-tool
26
27BuildRequires: gnome-common
28BuildRequires: libtool
29BuildRequires: automake
30BuildRequires: autoconf
31
32BuildRequires: pkgconfig
33BuildRequires: gtk2-devel
34BuildRequires: clutter-devel
35BuildRequires: mutter-devel
36BuildRequires: gjs-devel
37BuildRequires: gnome-desktop3-devel
38BuildRequires: gnome-menus-devel
39BuildRequires: libSM-devel
40BuildRequires: libffi-devel
41BuildRequires: startup-notification-devel
42BuildRequires: gnome-doc-utils
43BuildRequires: desktop-file-utils
44BuildRequires: libcroco-devel
45BuildRequires: librsvg2-devel
46BuildRequires: gobject-introspection-devel
47BuildRequires: control-center-devel
48BuildRequires: gcr-devel
49BuildRequires: gstreamer-devel
50BuildRequires: dbus-glib-devel
51BuildRequires: telepathy-logger-devel
52BuildRequires: polkit-devel
53BuildRequires: pulseaudio-libs-devel
54BuildRequires: evolution-data-server-devel
55BuildRequires: folks-devel
56BuildRequires: NetworkManager-glib-devel
57BuildRequires: libnm-gtk-devel
58BuildRequires: libgudev1-devel
59BuildRequires: libcanberra-gtk3-devel
60BuildRequires: caribou-devel
61BuildRequires: ca-certificates
62BuildRequires: python3-devel
63BuildRequires: intltool
64
65BuildRoot: %{_tmppath}/%{name}-%{version}-root
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: Takemikaduchi
70
71
72%description
73GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
74It provides core interface functions like switching to windows and launching
75applications. GNOME Shell takes advantage of the capabilities of modern graphics
76hardware and introduces innovative user interface concepts to provide a delightful
77and easy to use experience.
78
79
80%package        docs
81Summary:        Documentation for %{name}
82Summary(ja):    %{name} 用のドキュメント
83Group:          Documentation
84Requires:       %{name} = %{version}-%{release}
85BuildArch:              noarch
86
87%description    docs
88This package contains documentation for %{name}.
89
90
91
92%prep
93%setup -q
94%patch101 -p1 -b .vine
95%patch102 -p1 -b .vine
96
97%build
98%configure \
99        --disable-static \
100        --disable-systemd
101
102%{__make} %{?_smp_mflags} V=1
103
104
105%install
106%{__rm} -rf ${RPM_BUILD_ROOT}
107%{__make} install DESTDIR=${RPM_BUILD_ROOT}
108
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
110
111rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
112%find_lang %{name}
113
114
115
116%clean
117%{__rm} -rf ${RPM_BUILD_ROOT}
118
119
120%post
121/sbin/ldconfig
122touch --no-create %{_datadir}/icons/hicolor
123if [ -x /usr/bin/gtk-update-icon-cache ]; then
124  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
125fi
126
127%postun
128/sbin/ldconfig
129touch --no-create %{_datadir}/icons/hicolor
130if [ -x /usr/bin/gtk-update-icon-cache ]; then
131  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
132fi
133glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134
135%posttrans
136glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
137
138
139%files -f %{name}.lang
140%defattr(-,root,root,-)
141%doc COPYING NEWS README
142%{_bindir}/gnome-shell
143%{_bindir}/gnome-shell-extension-tool
144%{_bindir}/gnome-shell-extension-prefs
145%{_bindir}/gnome-shell-perf-tool
146%{_libdir}/%{name}/*
147%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
148%{_libexecdir}/gnome-shell-calendar-server
149%{_libexecdir}/gnome-shell-hotplug-sniffer
150%{_libexecdir}/gnome-shell-perf-helper
151%{_libexecdir}/gnome-shell-portal-helper
152%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
153%{_datadir}/applications/gnome-shell.desktop
154%{_datadir}/applications/gnome-shell-extension-prefs.desktop
155%{_datadir}/applications/evolution-calendar.desktop
156%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
157%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
159%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
160%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
161%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
162%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
163%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
164%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
165%{_datadir}/%{name}/*
166%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
167%{_mandir}/man1/%{name}.1.gz
168
169%files docs
170%defattr(-,root,root,-)
171%{_datadir}/gtk-doc/html/shell
172%{_datadir}/gtk-doc/html/st
173
174
175%changelog
176* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
177- new upstream release
178
179* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
180- new upstream release
181
182* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
183- new upstream release
184- add BuildRequires: python3-devel
185- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
186
187* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
188- rebuilt with libical 1.0.1
189
190* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
191- new upstream release
192
193* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
194- new upstream release
195
196* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
197- new upstream release
198- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
199- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
200
201* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
202- new upstream release
203
204* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
205- new upstream release
206
207* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
208- new upstream release
209
210* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
211- new upstream release
212
213* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
214- new upstream release
215
216* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
217- new upstream release
218
219* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
220- new upstream release
221
222* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
223- new upstream release
224
225* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
226- new upstream release
227
228* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
229- new upstream release
230- update Patch101 (gnome-shell-vine-settings.patch)
231- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
232- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
233- create %%{name}-docs subpackage
234
235* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
236- new upstream release
237- remove Source102 (gnome-shell.gnome-3-6.ja.po)
238
239* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
240- new upstream release
241- add Source102 (gnome-shell.gnome-3-6.ja.po)
242
243* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
244- new upstream release
245- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
246
247* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
248- rebuild with telepathy-logger-0.6.0
249- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
250
251* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
252- new upstream release
253
254* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
255- new upstream release
256- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
257- update Patch101 (gnome-shell-vine-settings.patch)
258- change BuildRequires: ca-certificates instead of openssl
259- add BuildRequires: libcanberra-gtl3-devel
260
261* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
262- new upstream release
263- remove Patch103 (gnome-shell-ja.po-date.patch)
264
265* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
266- new upstream release
267- update Patch101,103
268- remove Patch0,102
269- add BuildRequires: gcr-devel
270- remove BuildRequires: GConf2-devel
271- add Requires: at-spi2-atk
272
273* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
274- new upstream release
275- remove Patch1
276
277* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
278- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
279- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
280- rename Patch103 (gnome-shell-ja.po-date.patch)
281- drop Patch102
282
283* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
284- new upstream release
285
286* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
287- new upstream release
288
289* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
290- new upstream release
291- update Patch101
292- update Patch102
293- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
294- add BuildRequires: libgudev1-devel, openssl
295
296* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
297- new upstream release
298- add BuildRequires: folks-devel, NetworkManager-glib-devel
299- add Requires: caribou
300- remove Patch0
301- update Patch101
302- update Patch102
303- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
304
305* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
306- rebuild with gnome-menus-3.1.5
307- add Patch0 (gnome-shell-git20110821.patch)
308
309* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
310- new upstream release
311- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
312- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
313- remove BuildRequires: xulrunner-devel
314- add Patch101 (gnome-shell-vine-settings.patch)
315- add Patch102 (gnome-shell-vine-customize.patch)
316- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
317
318* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
319- add Requires: mutter
320
321* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
322- new upstream release
323
324* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
325- initial build for Vine Linux
326
Note: See TracBrowser for help on using the repository browser.