source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9102

Revision 9102, 9.3 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define pkg_version 3.14.2
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-3.14.1-vine-settings.patch
12Patch102:       gnome-shell-3.14.1.5-revert-loginManager.patch
13
14License:        GPLv2+
15Group:          User Interface/Desktops
16URL:            http://live.gnome.org/GnomeShell
17
18Requires: mutter
19Requires: caribou
20Requires: ca-certificates
21Requires: at-spi2-atk
22Requires: telepathy-logger
23Requires: network-manager-applet
24Requires: gnome-tweak-tool
25
26BuildRequires: gnome-common
27BuildRequires: libtool
28BuildRequires: automake
29BuildRequires: autoconf
30
31BuildRequires: pkgconfig
32BuildRequires: gtk2-devel
33BuildRequires: clutter-devel
34BuildRequires: mutter-devel
35BuildRequires: gjs-devel
36BuildRequires: gnome-desktop3-devel
37BuildRequires: gnome-menus-devel
38BuildRequires: libSM-devel
39BuildRequires: libffi-devel
40BuildRequires: startup-notification-devel
41BuildRequires: gnome-doc-utils
42BuildRequires: desktop-file-utils
43BuildRequires: libcroco-devel
44BuildRequires: librsvg2-devel
45BuildRequires: gobject-introspection-devel
46BuildRequires: control-center-devel
47BuildRequires: gcr-devel
48BuildRequires: gstreamer-devel
49BuildRequires: dbus-glib-devel
50BuildRequires: telepathy-logger-devel
51BuildRequires: polkit-devel
52BuildRequires: pulseaudio-libs-devel
53BuildRequires: evolution-data-server-devel
54BuildRequires: folks-devel
55BuildRequires: NetworkManager-glib-devel
56BuildRequires: libnm-gtk-devel
57BuildRequires: libgudev1-devel
58BuildRequires: libcanberra-gtk3-devel
59BuildRequires: caribou-devel
60BuildRequires: ca-certificates
61BuildRequires: intltool
62
63BuildRoot: %{_tmppath}/%{name}-%{version}-root
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: Takemikaduchi
68
69
70%description
71GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
72It provides core interface functions like switching to windows and launching
73applications. GNOME Shell takes advantage of the capabilities of modern graphics
74hardware and introduces innovative user interface concepts to provide a delightful
75and easy to use experience.
76
77
78%package        docs
79Summary:        Documentation for %{name}
80Summary(ja):    %{name} 用のドキュメント
81Group:          Documentation
82Requires:       %{name} = %{version}-%{release}
83BuildArch:              noarch
84
85%description    docs
86This package contains documentation for %{name}.
87
88
89
90%prep
91%setup -q
92%patch101 -p1 -b .vine
93%patch102 -p1 -b .vine
94
95%build
96%configure \
97        --disable-static \
98        --disable-systemd
99
100%{__make} %{?_smp_mflags} V=1
101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105%{__make} install DESTDIR=${RPM_BUILD_ROOT}
106
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
108
109rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
110%find_lang %{name}
111
112
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117
118%post
119/sbin/ldconfig
120touch --no-create %{_datadir}/icons/hicolor
121if [ -x /usr/bin/gtk-update-icon-cache ]; then
122  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
123fi
124
125%postun
126/sbin/ldconfig
127touch --no-create %{_datadir}/icons/hicolor
128if [ -x /usr/bin/gtk-update-icon-cache ]; then
129  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
130fi
131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
132
133%posttrans
134glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
135
136
137%files -f %{name}.lang
138%defattr(-,root,root,-)
139%doc COPYING NEWS README
140%{_bindir}/gnome-shell
141%{_bindir}/gnome-shell-extension-tool
142%{_bindir}/gnome-shell-extension-prefs
143%{_bindir}/gnome-shell-perf-tool
144%{_libdir}/%{name}/*
145%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
146%{_libexecdir}/gnome-shell-calendar-server
147%{_libexecdir}/gnome-shell-hotplug-sniffer
148%{_libexecdir}/gnome-shell-perf-helper
149%{_libexecdir}/gnome-shell-portal-helper
150%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
151%{_datadir}/applications/gnome-shell.desktop
152%{_datadir}/applications/gnome-shell-extension-prefs.desktop
153%{_datadir}/applications/evolution-calendar.desktop
154%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
155%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
156%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
157%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
159%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
160%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
161%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
162%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
163%{_datadir}/%{name}/*
164%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
165%{_mandir}/man1/%{name}.1.gz
166
167%files docs
168%defattr(-,root,root,-)
169%{_datadir}/gtk-doc/html/shell
170%{_datadir}/gtk-doc/html/st
171
172
173%changelog
174* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
175- new upstream release
176
177* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
178- new upstream release
179- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
180- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
181
182* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
183- new upstream release
184
185* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
186- new upstream release
187
188* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
189- new upstream release
190
191* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
192- new upstream release
193
194* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
195- new upstream release
196
197* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
198- new upstream release
199
200* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
201- new upstream release
202
203* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
204- new upstream release
205
206* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
207- new upstream release
208
209* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
210- new upstream release
211- update Patch101 (gnome-shell-vine-settings.patch)
212- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
213- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
214- create %%{name}-docs subpackage
215
216* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
217- new upstream release
218- remove Source102 (gnome-shell.gnome-3-6.ja.po)
219
220* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
221- new upstream release
222- add Source102 (gnome-shell.gnome-3-6.ja.po)
223
224* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
225- new upstream release
226- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
227
228* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
229- rebuild with telepathy-logger-0.6.0
230- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
231
232* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
233- new upstream release
234
235* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
236- new upstream release
237- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
238- update Patch101 (gnome-shell-vine-settings.patch)
239- change BuildRequires: ca-certificates instead of openssl
240- add BuildRequires: libcanberra-gtl3-devel
241
242* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
243- new upstream release
244- remove Patch103 (gnome-shell-ja.po-date.patch)
245
246* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
247- new upstream release
248- update Patch101,103
249- remove Patch0,102
250- add BuildRequires: gcr-devel
251- remove BuildRequires: GConf2-devel
252- add Requires: at-spi2-atk
253
254* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
255- new upstream release
256- remove Patch1
257
258* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
259- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
260- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
261- rename Patch103 (gnome-shell-ja.po-date.patch)
262- drop Patch102
263
264* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
265- new upstream release
266
267* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
268- new upstream release
269
270* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
271- new upstream release
272- update Patch101
273- update Patch102
274- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
275- add BuildRequires: libgudev1-devel, openssl
276
277* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
278- new upstream release
279- add BuildRequires: folks-devel, NetworkManager-glib-devel
280- add Requires: caribou
281- remove Patch0
282- update Patch101
283- update Patch102
284- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
285
286* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
287- rebuild with gnome-menus-3.1.5
288- add Patch0 (gnome-shell-git20110821.patch)
289
290* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
291- new upstream release
292- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
293- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
294- remove BuildRequires: xulrunner-devel
295- add Patch101 (gnome-shell-vine-settings.patch)
296- add Patch102 (gnome-shell-vine-customize.patch)
297- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
298
299* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
300- add Requires: mutter
301
302* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
303- new upstream release
304
305* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
306- initial build for Vine Linux
307
Note: See TracBrowser for help on using the repository browser.