source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_version 2.28.0
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.bz2
9License:     GPLv2+
10Group:       User Interface/Desktops
11URL:         http://live.gnome.org/GnomeShell
12
13Requires(post,postun): scrollkeeper >= 0.1.4
14Requires(post,pre,preun): GConf2 >= 2.14
15BuildRequires: gnome-common
16BuildRequires: libtool
17BuildRequires: automake
18BuildRequires: autoconf
19
20BuildRequires: pkgconfig
21BuildRequires: gtk2-devel
22BuildRequires: clutter-devel
23BuildRequires: mutter-devel
24BuildRequires: gjs-devel
25BuildRequires: gnome-desktop-devel
26BuildRequires: gnome-menus-devel
27BuildRequires: libSM-devel
28BuildRequires: libffi-devel
29BuildRequires: GConf2-devel
30BuildRequires: startup-notification-devel
31BuildRequires: gnome-doc-utils
32BuildRequires: desktop-file-utils
33BuildRequires: xulrunner-devel
34BuildRequires: libcroco-devel
35BuildRequires: librsvg2-devel
36BuildRequires: gir-repository-devel
37BuildRequires: gobject-introspection-devel
38BuildRequires: gstreamer-devel
39BuildRequires: dbus-glib-devel
40BuildRequires: intltool
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: Takemikaduchi
47
48
49%description
50GNOME Shell is the defining technology of the GNOME 3 desktop user experience. It provides core interface functions like switching to windows and launching applications. GNOME Shell takes advantage of the capabilities of modern graphics hardware and introduces innovative user interface concepts to provide a delightful and easy to use experience.
51
52
53%prep
54%setup -q
55
56
57%build
58%configure --disable-static
59%{__make} %{?_smp_mflags}
60
61
62%install
63%{__rm} -rf ${RPM_BUILD_ROOT}
64%{__make} install DESTDIR=${RPM_BUILD_ROOT}
65
66%find_lang %{name}
67
68%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/*.la
69
70
71%clean
72%{__rm} -rf ${RPM_BUILD_ROOT}
73
74
75%post
76/sbin/ldconfig
77export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
78gconftool-2 --makefile-install-rule \
79    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
80  > /dev/null || :
81/sbin/ldconfig
82touch --no-create %{_datadir}/icons/hicolor
83if [ -x /usr/bin/gtk-update-icon-cache ]; then
84  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
85fi
86
87%pre
88if [ "$1" -gt 1 ]; then
89  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
90  gconftool-2 --makefile-uninstall-rule \
91    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
92    > /dev/null || :
93fi
94
95%preun
96if [ "$1" -eq 0 ]; then
97  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
98  gconftool-2 --makefile-uninstall-rule \
99    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
100    > /dev/null || :
101fi
102
103%postun
104scrollkeeper-update -q || :
105/sbin/ldconfig
106touch --no-create %{_datadir}/icons/hicolor
107if [ -x /usr/bin/gtk-update-icon-cache ]; then
108  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
109fi
110
111
112%files -f %{name}.lang
113%defattr(-,root,root)
114%doc COPYING ChangeLog NEWS README
115%{_bindir}/gnome-shell
116%{_libdir}/gnome-shell/*
117%{_libdir}/mutter/plugins/*
118%{_datadir}/applications/*
119%{_datadir}/gnome-shell/*
120%{_sysconfdir}/gconf/schemas/*
121
122
123%changelog
124* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
125- initial build for Vine Linux
126
Note: See TracBrowser for help on using the repository browser.