source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 7119

Revision 7119, 6.6 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.2

Line 
1%define pkg_version 3.6.2
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:    gnome-shell-vine-settings.patch
12
13License:     GPLv2+
14Group:       User Interface/Desktops
15URL:         http://live.gnome.org/GnomeShell
16
17Requires(post,postun): scrollkeeper >= 0.1.4
18Requires: mutter
19Requires: caribou
20Requires: ca-certificates
21Requires: at-spi2-atk
22
23BuildRequires: gnome-common
24BuildRequires: libtool
25BuildRequires: automake
26BuildRequires: autoconf
27
28BuildRequires: pkgconfig
29BuildRequires: gtk2-devel
30BuildRequires: clutter-devel
31BuildRequires: mutter-devel
32BuildRequires: gjs-devel
33BuildRequires: gnome-desktop3-devel
34BuildRequires: gnome-menus-devel
35BuildRequires: libSM-devel
36BuildRequires: libffi-devel
37BuildRequires: startup-notification-devel
38BuildRequires: gnome-doc-utils
39BuildRequires: desktop-file-utils
40BuildRequires: libcroco-devel
41BuildRequires: librsvg2-devel
42BuildRequires: gobject-introspection-devel
43BuildRequires: gcr-devel
44BuildRequires: gstreamer-devel
45BuildRequires: dbus-glib-devel
46BuildRequires: telepathy-logger-devel
47BuildRequires: polkit-devel
48BuildRequires: pulseaudio-libs-devel
49BuildRequires: evolution-data-server-devel
50BuildRequires: folks-devel
51BuildRequires: NetworkManager-glib-devel
52BuildRequires: libgudev1-devel
53BuildRequires: libcanberra-gtk3-devel
54BuildRequires: ca-certificates
55BuildRequires: intltool
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: Takemikaduchi
62
63
64%description
65GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
66It provides core interface functions like switching to windows and launching
67applications. GNOME Shell takes advantage of the capabilities of modern graphics
68hardware and introduces innovative user interface concepts to provide a delightful
69and easy to use experience.
70
71
72%prep
73%setup -q
74%patch101 -p1 -b .vine
75
76%build
77libtoolize --copy --force
78autoreconf
79%configure \
80        --disable-static
81
82%{__make} %{?_smp_mflags}
83
84
85%install
86%{__rm} -rf ${RPM_BUILD_ROOT}
87%{__make} install DESTDIR=${RPM_BUILD_ROOT}
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
90
91%find_lang %{name}
92
93
94
95%clean
96%{__rm} -rf ${RPM_BUILD_ROOT}
97
98
99%post
100/sbin/ldconfig
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
104fi
105
106%postun
107/sbin/ldconfig
108touch --no-create %{_datadir}/icons/hicolor
109if [ -x /usr/bin/gtk-update-icon-cache ]; then
110  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
111fi
112glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
113
114%posttrans
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117
118%files -f %{name}.lang
119%defattr(-,root,root)
120%doc COPYING NEWS README
121%{_bindir}/gnome-shell
122%{_bindir}/gnome-shell-extension-tool
123%{_bindir}/gnome-shell-extension-prefs
124%{_bindir}/gnome-shell-perf-tool
125%{_libdir}/gnome-shell/*
126%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
127%{_libexecdir}/gnome-shell-calendar-server
128%{_libexecdir}/gnome-shell-hotplug-sniffer
129%{_libexecdir}/gnome-shell-perf-helper
130%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
131%{_datadir}/applications/gnome-shell.desktop
132%{_datadir}/applications/gnome-shell-extension-prefs.desktop
133%{_datadir}/applications/evolution-calendar.desktop
134%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
135%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
136%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
137%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
138%{_datadir}/gnome-shell/*
139%{_datadir}/gtk-doc/html/shell
140%{_datadir}/gtk-doc/html/st
141%{_datadir}/man/man1/*.1.gz
142
143
144%changelog
145* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
146- new upstream release
147- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
148
149* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
150- rebuild with telepathy-logger-0.6.0
151- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
152
153* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
154- new upstream release
155
156* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
157- new upstream release
158- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
159- update Patch101 (gnome-shell-vine-settings.patch)
160- change BuildRequires: ca-certificates instead of openssl
161- add BuildRequires: libcanberra-gtl3-devel
162
163* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
164- new upstream release
165- remove Patch103 (gnome-shell-ja.po-date.patch)
166
167* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
168- new upstream release
169- update Patch101,103
170- remove Patch0,102
171- add BuildRequires: gcr-devel
172- remove BuildRequires: GConf2-devel
173- add Requires: at-spi2-atk
174
175* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
176- new upstream release
177- remove Patch1
178
179* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
180- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
181- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
182- rename Patch103 (gnome-shell-ja.po-date.patch)
183- drop Patch102
184
185* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
186- new upstream release
187
188* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
189- new upstream release
190
191* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
192- new upstream release
193- update Patch101
194- update Patch102
195- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
196- add BuildRequires: libgudev1-devel, openssl
197
198* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
199- new upstream release
200- add BuildRequires: folks-devel, NetworkManager-glib-devel
201- add Requires: caribou
202- remove Patch0
203- update Patch101
204- update Patch102
205- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
206
207* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
208- rebuild with gnome-menus-3.1.5
209- add Patch0 (gnome-shell-git20110821.patch)
210
211* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
212- new upstream release
213- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
214- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
215- remove BuildRequires: xulrunner-devel
216- add Patch101 (gnome-shell-vine-settings.patch)
217- add Patch102 (gnome-shell-vine-customize.patch)
218- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
219
220* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
221- add Requires: mutter
222
223* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
224- new upstream release
225
226* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
227- initial build for Vine Linux
228
Note: See TracBrowser for help on using the repository browser.