source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 6619

Revision 6619, 6.0 KB checked in by Takemikaduchi, 12 years ago (diff)

cairo: add Requires: mesa-libEGL-devel
others: new upstream release

Line 
1%define pkg_version 3.4.2
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:    gnome-shell-vine-settings.patch
12
13License:     GPLv2+
14Group:       User Interface/Desktops
15URL:         http://live.gnome.org/GnomeShell
16
17Requires(post,postun): scrollkeeper >= 0.1.4
18Requires: mutter
19Requires: caribou
20Requires: openssl
21Requires: at-spi2-atk
22
23BuildRequires: gnome-common
24BuildRequires: libtool
25BuildRequires: automake
26BuildRequires: autoconf
27
28BuildRequires: pkgconfig
29BuildRequires: gtk2-devel
30BuildRequires: clutter-devel
31BuildRequires: mutter-devel
32BuildRequires: gjs-devel
33BuildRequires: gnome-desktop3-devel
34BuildRequires: gnome-menus-devel
35BuildRequires: libSM-devel
36BuildRequires: libffi-devel
37BuildRequires: startup-notification-devel
38BuildRequires: gnome-doc-utils
39BuildRequires: desktop-file-utils
40BuildRequires: libcroco-devel
41BuildRequires: librsvg2-devel
42BuildRequires: gobject-introspection-devel
43BuildRequires: gcr-devel
44BuildRequires: gstreamer-devel
45BuildRequires: dbus-glib-devel
46BuildRequires: telepathy-logger-devel
47BuildRequires: polkit-devel
48BuildRequires: pulseaudio-libs-devel
49BuildRequires: evolution-data-server-devel
50BuildRequires: folks-devel
51BuildRequires: NetworkManager-glib-devel
52BuildRequires: libgudev1-devel
53BuildRequires: openssl
54BuildRequires: intltool
55
56BuildRoot: %{_tmppath}/%{name}-%{version}-root
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: Takemikaduchi
61
62
63%description
64GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
65It provides core interface functions like switching to windows and launching
66applications. GNOME Shell takes advantage of the capabilities of modern graphics
67hardware and introduces innovative user interface concepts to provide a delightful
68and easy to use experience.
69
70
71%prep
72%setup -q
73%patch101 -p1 -b .vine
74
75%build
76libtoolize --copy --force
77autoreconf
78%configure \
79        --disable-static \
80        --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
81
82%{__make} %{?_smp_mflags}
83
84
85%install
86%{__rm} -rf ${RPM_BUILD_ROOT}
87%{__make} install DESTDIR=${RPM_BUILD_ROOT}
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
90
91%find_lang %{name}
92
93
94
95%clean
96%{__rm} -rf ${RPM_BUILD_ROOT}
97
98
99%post
100/sbin/ldconfig
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
104fi
105
106%postun
107/sbin/ldconfig
108touch --no-create %{_datadir}/icons/hicolor
109if [ -x /usr/bin/gtk-update-icon-cache ]; then
110  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
111fi
112glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
113
114%posttrans
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117
118%files -f %{name}.lang
119%defattr(-,root,root)
120%doc COPYING NEWS README
121%{_bindir}/gnome-shell
122%{_bindir}/gnome-shell-extension-tool
123%{_bindir}/gnome-shell-extension-prefs
124%{_libdir}/gnome-shell/*
125%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
126%{_libexecdir}/gnome-shell-calendar-server
127%{_libexecdir}/gnome-shell-hotplug-sniffer
128%{_libexecdir}/gnome-shell-perf-helper
129%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
130%{_datadir}/applications/gnome-shell.desktop
131%{_datadir}/applications/gnome-shell-extension-prefs.desktop
132%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
133%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
134%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
135%{_datadir}/glib-2.0/schemas/org.gnome.shell.evolution.calendar.gschema.xml
136%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
137%{_datadir}/gnome-shell/*
138%{_datadir}/gtk-doc/html/shell
139%{_datadir}/gtk-doc/html/st
140%{_datadir}/man/man1/*.1.gz
141
142
143%changelog
144* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
145- new upstream release
146- remove Patch103 (gnome-shell-ja.po-date.patch)
147
148* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
149- new upstream release
150- update Patch101,103
151- remove Patch0,102
152- add BuildRequires: gcr-devel
153- remove BuildRequires: GConf2-devel
154- add Requires: at-spi2-atk
155
156* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
157- new upstream release
158- remove Patch1
159
160* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
161- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
162- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
163- rename Patch103 (gnome-shell-ja.po-date.patch)
164- drop Patch102
165
166* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
167- new upstream release
168
169* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
170- new upstream release
171
172* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
173- new upstream release
174- update Patch101
175- update Patch102
176- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
177- add BuildRequires: libgudev1-devel, openssl
178
179* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
180- new upstream release
181- add BuildRequires: folks-devel, NetworkManager-glib-devel
182- add Requires: caribou
183- remove Patch0
184- update Patch101
185- update Patch102
186- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
187
188* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
189- rebuild with gnome-menus-3.1.5
190- add Patch0 (gnome-shell-git20110821.patch)
191
192* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
193- new upstream release
194- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
195- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
196- remove BuildRequires: xulrunner-devel
197- add Patch101 (gnome-shell-vine-settings.patch)
198- add Patch102 (gnome-shell-vine-customize.patch)
199- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
200
201* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
202- add Requires: mutter
203
204* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
205- new upstream release
206
207* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
208- initial build for Vine Linux
209
Note: See TracBrowser for help on using the repository browser.