source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 6011

Revision 6011, 5.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkg_version 3.4.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:    gnome-shell-vine-settings.patch
12Patch103:    gnome-shell-ja.po-date.patch
13
14License:     GPLv2+
15Group:       User Interface/Desktops
16URL:         http://live.gnome.org/GnomeShell
17
18Requires(post,postun): scrollkeeper >= 0.1.4
19Requires: mutter
20Requires: caribou
21Requires: openssl
22Requires: at-spi2-atk
23
24BuildRequires: gnome-common
25BuildRequires: libtool
26BuildRequires: automake
27BuildRequires: autoconf
28
29BuildRequires: pkgconfig
30BuildRequires: gtk2-devel
31BuildRequires: clutter-devel
32BuildRequires: mutter-devel
33BuildRequires: gjs-devel
34BuildRequires: gnome-desktop3-devel
35BuildRequires: gnome-menus-devel
36BuildRequires: libSM-devel
37BuildRequires: libffi-devel
38BuildRequires: startup-notification-devel
39BuildRequires: gnome-doc-utils
40BuildRequires: desktop-file-utils
41BuildRequires: libcroco-devel
42BuildRequires: librsvg2-devel
43BuildRequires: gobject-introspection-devel
44BuildRequires: gcr-devel
45BuildRequires: gstreamer-devel
46BuildRequires: dbus-glib-devel
47BuildRequires: telepathy-logger-devel
48BuildRequires: polkit-devel
49BuildRequires: pulseaudio-libs-devel
50BuildRequires: evolution-data-server-devel
51BuildRequires: folks-devel
52BuildRequires: NetworkManager-glib-devel
53BuildRequires: libgudev1-devel
54BuildRequires: openssl
55BuildRequires: intltool
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: Takemikaduchi
62
63
64%description
65GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
66It provides core interface functions like switching to windows and launching
67applications. GNOME Shell takes advantage of the capabilities of modern graphics
68hardware and introduces innovative user interface concepts to provide a delightful
69and easy to use experience.
70
71
72%prep
73%setup -q
74%patch101 -p1 -b .vine
75%patch103 -p1 -b .old_po2
76
77%build
78libtoolize --copy --force
79autoreconf
80%configure \
81        --disable-static \
82        --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
83
84%{__make} %{?_smp_mflags}
85
86
87%install
88%{__rm} -rf ${RPM_BUILD_ROOT}
89%{__make} install DESTDIR=${RPM_BUILD_ROOT}
90
91find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
92
93%find_lang %{name}
94
95
96
97%clean
98%{__rm} -rf ${RPM_BUILD_ROOT}
99
100
101%post
102/sbin/ldconfig
103touch --no-create %{_datadir}/icons/hicolor
104if [ -x /usr/bin/gtk-update-icon-cache ]; then
105  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
106fi
107
108%postun
109/sbin/ldconfig
110touch --no-create %{_datadir}/icons/hicolor
111if [ -x /usr/bin/gtk-update-icon-cache ]; then
112  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
113fi
114glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
115
116%posttrans
117glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
118
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%doc COPYING NEWS README
123%{_bindir}/gnome-shell
124%{_bindir}/gnome-shell-extension-tool
125%{_bindir}/gnome-shell-extension-prefs
126%{_libdir}/gnome-shell/*
127%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
128%{_libexecdir}/gnome-shell-calendar-server
129%{_libexecdir}/gnome-shell-hotplug-sniffer
130%{_libexecdir}/gnome-shell-perf-helper
131%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
132%{_datadir}/applications/gnome-shell.desktop
133%{_datadir}/applications/gnome-shell-extension-prefs.desktop
134%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
135%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
136%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
137%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
138%{_datadir}/gnome-shell/*
139%{_datadir}/gtk-doc/html/shell
140%{_datadir}/gtk-doc/html/st
141%{_datadir}/man/man1/*.1.gz
142
143
144%changelog
145* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
146- new upstream release
147- update Patch101,103
148- remove Patch0,102
149- add BuildRequires: gcr-devel
150- remove BuildRequires: GConf2-devel
151- add Requires: at-spi2-atk
152
153* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
154- new upstream release
155- remove Patch1
156
157* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
158- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
159- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
160- rename Patch103 (gnome-shell-ja.po-date.patch)
161- drop Patch102
162
163* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
164- new upstream release
165
166* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
167- new upstream release
168
169* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
170- new upstream release
171- update Patch101
172- update Patch102
173- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
174- add BuildRequires: libgudev1-devel, openssl
175
176* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
177- new upstream release
178- add BuildRequires: folks-devel, NetworkManager-glib-devel
179- add Requires: caribou
180- remove Patch0
181- update Patch101
182- update Patch102
183- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
184
185* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
186- rebuild with gnome-menus-3.1.5
187- add Patch0 (gnome-shell-git20110821.patch)
188
189* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
190- new upstream release
191- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
192- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
193- remove BuildRequires: xulrunner-devel
194- add Patch101 (gnome-shell-vine-settings.patch)
195- add Patch102 (gnome-shell-vine-customize.patch)
196- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
197
198* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
199- add Requires: mutter
200
201* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
202- new upstream release
203
204* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
205- initial build for Vine Linux
206
Note: See TracBrowser for help on using the repository browser.