source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 12005

Revision 12005, 11.8 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define pkg_version 3.30.2
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
14Patch103:       gnome-shell-3.16.2-disable-packagekit.patch
15Patch104:       gnome-shell-3.20.3-vine-themes.patch
16Patch105:       ja_po.patch
17
18License:        GPLv2+
19Group:          User Interface/Desktops
20URL:            http://live.gnome.org/GnomeShell
21
22Requires: mutter
23Requires: caribou
24Requires: ca-certificates
25Requires: at-spi2-atk
26Requires: telepathy-logger
27Requires: network-manager-applet
28Requires: gnome-tweak-tool
29
30BuildRequires: meson
31BuildRequires: gnome-common
32
33BuildRequires: pkgconfig
34BuildRequires: gtk2-devel
35BuildRequires: clutter-devel
36BuildRequires: mutter-devel
37BuildRequires: gjs-devel
38BuildRequires: gnome-desktop3-devel
39BuildRequires: gnome-menus-devel
40BuildRequires: libSM-devel
41BuildRequires: libffi-devel
42BuildRequires: startup-notification-devel
43BuildRequires: gnome-doc-utils
44BuildRequires: desktop-file-utils
45BuildRequires: libcroco-devel
46BuildRequires: librsvg2-devel
47BuildRequires: gobject-introspection-devel
48BuildRequires: control-center-devel
49BuildRequires: gcr-devel
50BuildRequires: gstreamer1-devel
51BuildRequires: dbus-glib-devel
52BuildRequires: telepathy-logger-devel
53BuildRequires: polkit-devel
54BuildRequires: pulseaudio-libs-devel
55BuildRequires: evolution-data-server-devel
56BuildRequires: folks-devel
57BuildRequires: NetworkManager-glib-devel
58BuildRequires: NetworkManager-libnm-devel
59BuildRequires: libnm-gtk-devel
60BuildRequires: libgudev1-devel
61BuildRequires: libcanberra-gtk3-devel
62BuildRequires: caribou-devel
63BuildRequires: ca-certificates
64BuildRequires: python3-devel
65BuildRequires: intltool
66BuildRequires: ibus-devel
67BuildRequires: gnome-bluetooth-devel
68BuildRequires: sassc
69
70BuildRoot: %{_tmppath}/%{name}-%{version}-root
71
72Vendor: Project Vine
73Distribution: Vine Linux
74
75
76%description
77GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
78It provides core interface functions like switching to windows and launching
79applications. GNOME Shell takes advantage of the capabilities of modern graphics
80hardware and introduces innovative user interface concepts to provide a delightful
81and easy to use experience.
82
83
84%package        docs
85Summary:        Documentation for %{name}
86Summary(ja):    %{name} 用のドキュメント
87Group:          Documentation
88Requires:       %{name} = %{version}-%{release}
89BuildArch:              noarch
90
91%description    docs
92This package contains documentation for %{name}.
93
94
95
96%prep
97%setup -q
98#%patch101 -p1 -b .vine
99#%patch102 -p1 -b .vine
100#%patch103 -p1 -b .vine
101#%patch104 -p1 -b .vine
102%patch105 -p1 -b .ja
103
104%build
105export LANG=ja_JP.UTF-8
106%meson \
107  -Dsystemd=false \
108  -Dgtk_doc=true
109
110%meson_build
111
112%install
113export LANG=ja_JP.UTF-8
114%{__rm} -rf %{buildroot}
115%meson_install
116
117%find_lang %{name}
118
119
120
121%clean
122%{__rm} -rf ${RPM_BUILD_ROOT}
123
124
125%post
126/sbin/ldconfig
127touch --no-create %{_datadir}/icons/hicolor
128if [ -x /usr/bin/gtk-update-icon-cache ]; then
129  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
130fi
131
132%postun
133/sbin/ldconfig
134touch --no-create %{_datadir}/icons/hicolor
135if [ -x /usr/bin/gtk-update-icon-cache ]; then
136  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
137fi
138glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
139
140%posttrans
141glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
142
143
144%files -f %{name}.lang
145%defattr(-,root,root,-)
146%license COPYING
147%doc NEWS README.md
148%dir %{_sysconfdir}/xdg
149%dir %{_sysconfdir}/xdg/autostart
150%{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
151%{_bindir}/gnome-shell
152%{_bindir}/gnome-shell-extension-tool
153%{_bindir}/gnome-shell-extension-prefs
154%{_bindir}/gnome-shell-perf-tool
155%{_libdir}/%{name}/*
156%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
157%{_libexecdir}/gnome-shell-calendar-server
158%{_libexecdir}/gnome-shell-hotplug-sniffer
159%{_libexecdir}/gnome-shell-overrides-migration.sh
160%{_libexecdir}/gnome-shell-perf-helper
161%{_libexecdir}/gnome-shell-portal-helper
162%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
163%{_datadir}/applications/org.gnome.Shell.desktop
164%{_datadir}/applications/gnome-shell-extension-prefs.desktop
165%{_datadir}/applications/evolution-calendar.desktop
166%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
167%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
168%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
169%{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
170%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
171%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
172%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
173%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
174%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
175%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
176%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
177%{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
178%{_datadir}/%{name}/*
179%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
180%dir %{_datadir}/xdg-desktop-portal
181%dir %{_datadir}/xdg-desktop-portal/portals
182%{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
183%{_mandir}/man1/%{name}.1.gz
184
185%files docs
186%defattr(-,root,root,-)
187%{_datadir}/gtk-doc/html/shell
188%{_datadir}/gtk-doc/html/st
189
190
191%changelog
192* Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.2-1
193- new upstream release.
194- dropped Patch102: session tracker was switched to elogind.
195- added Patch105.
196
197* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-1
198- new upstream release.
199
200* Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
201- new upstream release
202- add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
203
204* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
205- new upstream release
206- update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
207
208* Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
209- new upstream release
210
211* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
212- new upstream release
213
214* Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
215- new upstream release
216- update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
217
218* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
219- new upstream release
220
221* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
222- add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
223
224* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
225- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
226
227* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
228- new upstream release
229
230* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
231- new upstream release
232
233* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
234- new upstream release
235- add BuildRequires: python3-devel
236- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
237
238* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
239- rebuilt with libical 1.0.1
240
241* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
242- new upstream release
243
244* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
245- new upstream release
246
247* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
248- new upstream release
249- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
250- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
251
252* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
253- new upstream release
254
255* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
256- new upstream release
257
258* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
259- new upstream release
260
261* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
262- new upstream release
263
264* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
265- new upstream release
266
267* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
268- new upstream release
269
270* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
271- new upstream release
272
273* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
274- new upstream release
275
276* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
277- new upstream release
278
279* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
280- new upstream release
281- update Patch101 (gnome-shell-vine-settings.patch)
282- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
283- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
284- create %%{name}-docs subpackage
285
286* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
287- new upstream release
288- remove Source102 (gnome-shell.gnome-3-6.ja.po)
289
290* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
291- new upstream release
292- add Source102 (gnome-shell.gnome-3-6.ja.po)
293
294* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
295- new upstream release
296- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
297
298* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
299- rebuild with telepathy-logger-0.6.0
300- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
301
302* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
303- new upstream release
304
305* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
306- new upstream release
307- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
308- update Patch101 (gnome-shell-vine-settings.patch)
309- change BuildRequires: ca-certificates instead of openssl
310- add BuildRequires: libcanberra-gtl3-devel
311
312* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
313- new upstream release
314- remove Patch103 (gnome-shell-ja.po-date.patch)
315
316* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
317- new upstream release
318- update Patch101,103
319- remove Patch0,102
320- add BuildRequires: gcr-devel
321- remove BuildRequires: GConf2-devel
322- add Requires: at-spi2-atk
323
324* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
325- new upstream release
326- remove Patch1
327
328* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
329- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
330- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
331- rename Patch103 (gnome-shell-ja.po-date.patch)
332- drop Patch102
333
334* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
335- new upstream release
336
337* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
338- new upstream release
339
340* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
341- new upstream release
342- update Patch101
343- update Patch102
344- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
345- add BuildRequires: libgudev1-devel, openssl
346
347* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
348- new upstream release
349- add BuildRequires: folks-devel, NetworkManager-glib-devel
350- add Requires: caribou
351- remove Patch0
352- update Patch101
353- update Patch102
354- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
355
356* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
357- rebuild with gnome-menus-3.1.5
358- add Patch0 (gnome-shell-git20110821.patch)
359
360* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
361- new upstream release
362- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
363- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
364- remove BuildRequires: xulrunner-devel
365- add Patch101 (gnome-shell-vine-settings.patch)
366- add Patch102 (gnome-shell-vine-customize.patch)
367- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
368
369* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
370- add Requires: mutter
371
372* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
373- new upstream release
374
375* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
376- initial build for Vine Linux
377
Note: See TracBrowser for help on using the repository browser.