source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 11447

Revision 11447, 11.1 KB checked in by tomop, 6 years ago (diff)

gnome-shell-3.20.4-1

Line 
1%define pkg_version 3.20.4
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
10
11# settings for Vine
12Patch101:       gnome-shell-3.14.1-vine-settings.patch
13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
14Patch103:       gnome-shell-3.16.2-disable-packagekit.patch
15Patch104:       gnome-shell-3.20.3-vine-themes.patch
16
17License:        GPLv2+
18Group:          User Interface/Desktops
19URL:            http://live.gnome.org/GnomeShell
20
21Requires: mutter
22Requires: caribou
23Requires: ca-certificates
24Requires: at-spi2-atk
25Requires: telepathy-logger
26Requires: network-manager-applet
27Requires: gnome-tweak-tool
28
29BuildRequires: gnome-common
30BuildRequires: libtool
31BuildRequires: automake
32BuildRequires: autoconf
33
34BuildRequires: pkgconfig
35BuildRequires: gtk2-devel
36BuildRequires: clutter-devel
37BuildRequires: mutter-devel
38BuildRequires: gjs-devel
39BuildRequires: gnome-desktop3-devel
40BuildRequires: gnome-menus-devel
41BuildRequires: libSM-devel
42BuildRequires: libffi-devel
43BuildRequires: startup-notification-devel
44BuildRequires: gnome-doc-utils
45BuildRequires: desktop-file-utils
46BuildRequires: libcroco-devel
47BuildRequires: librsvg2-devel
48BuildRequires: gobject-introspection-devel
49BuildRequires: control-center-devel
50BuildRequires: gcr-devel
51BuildRequires: gstreamer-devel
52BuildRequires: dbus-glib-devel
53BuildRequires: telepathy-logger-devel
54BuildRequires: polkit-devel
55BuildRequires: pulseaudio-libs-devel
56BuildRequires: evolution-data-server-devel
57BuildRequires: folks-devel
58BuildRequires: NetworkManager-glib-devel
59BuildRequires: libnm-gtk-devel
60BuildRequires: libgudev1-devel
61BuildRequires: libcanberra-gtk3-devel
62BuildRequires: caribou-devel
63BuildRequires: ca-certificates
64BuildRequires: python3-devel
65BuildRequires: intltool
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: Takemikaduchi
72
73
74%description
75GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
76It provides core interface functions like switching to windows and launching
77applications. GNOME Shell takes advantage of the capabilities of modern graphics
78hardware and introduces innovative user interface concepts to provide a delightful
79and easy to use experience.
80
81
82%package        docs
83Summary:        Documentation for %{name}
84Summary(ja):    %{name} 用のドキュメント
85Group:          Documentation
86Requires:       %{name} = %{version}-%{release}
87BuildArch:              noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93
94%prep
95%setup -q
96#%patch101 -p1 -b .vine
97%patch102 -p1 -b .vine
98%patch103 -p1 -b .vine
99%patch104 -p1 -b .vine
100
101%build
102%configure \
103        --disable-static \
104        --disable-systemd
105
106%{__make} %{?_smp_mflags} V=1
107
108
109%install
110%{__rm} -rf ${RPM_BUILD_ROOT}
111%{__make} install DESTDIR=${RPM_BUILD_ROOT}
112
113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
114
115%find_lang %{name}
116
117
118
119%clean
120%{__rm} -rf ${RPM_BUILD_ROOT}
121
122
123%post
124/sbin/ldconfig
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
129
130%postun
131/sbin/ldconfig
132touch --no-create %{_datadir}/icons/hicolor
133if [ -x /usr/bin/gtk-update-icon-cache ]; then
134  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
135fi
136glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
137
138%posttrans
139glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
140
141
142%files -f %{name}.lang
143%defattr(-,root,root,-)
144%doc COPYING NEWS README
145%{_bindir}/gnome-shell
146%{_bindir}/gnome-shell-extension-tool
147%{_bindir}/gnome-shell-extension-prefs
148%{_bindir}/gnome-shell-perf-tool
149%{_libdir}/%{name}/*
150%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
151%{_libexecdir}/gnome-shell-calendar-server
152%{_libexecdir}/gnome-shell-hotplug-sniffer
153%{_libexecdir}/gnome-shell-perf-helper
154%{_libexecdir}/gnome-shell-portal-helper
155%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
156%{_datadir}/applications/org.gnome.Shell.desktop
157%{_datadir}/applications/gnome-shell-extension-prefs.desktop
158%{_datadir}/applications/evolution-calendar.desktop
159%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
160%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
161%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
162%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
163%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
164%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
165%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
166%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
167%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
168%{_datadir}/%{name}/*
169%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
170%{_mandir}/man1/%{name}.1.gz
171
172%files docs
173%defattr(-,root,root,-)
174%{_datadir}/gtk-doc/html/shell
175%{_datadir}/gtk-doc/html/st
176
177
178%changelog
179* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-1
180- new upstream release.
181
182* Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
183- new upstream release
184- add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
185
186* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
187- new upstream release
188- update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
189
190* Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
191- new upstream release
192
193* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
194- new upstream release
195
196* Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
197- new upstream release
198- update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
199
200* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
201- new upstream release
202
203* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
204- add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
205
206* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
207- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
208
209* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
210- new upstream release
211
212* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
213- new upstream release
214
215* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
216- new upstream release
217- add BuildRequires: python3-devel
218- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
219
220* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
221- rebuilt with libical 1.0.1
222
223* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
224- new upstream release
225
226* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
227- new upstream release
228
229* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
230- new upstream release
231- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
232- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
233
234* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
235- new upstream release
236
237* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
238- new upstream release
239
240* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
241- new upstream release
242
243* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
244- new upstream release
245
246* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
247- new upstream release
248
249* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
250- new upstream release
251
252* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
253- new upstream release
254
255* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
256- new upstream release
257
258* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
259- new upstream release
260
261* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
262- new upstream release
263- update Patch101 (gnome-shell-vine-settings.patch)
264- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
265- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
266- create %%{name}-docs subpackage
267
268* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
269- new upstream release
270- remove Source102 (gnome-shell.gnome-3-6.ja.po)
271
272* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
273- new upstream release
274- add Source102 (gnome-shell.gnome-3-6.ja.po)
275
276* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
277- new upstream release
278- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
279
280* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
281- rebuild with telepathy-logger-0.6.0
282- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
283
284* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
285- new upstream release
286
287* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
288- new upstream release
289- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
290- update Patch101 (gnome-shell-vine-settings.patch)
291- change BuildRequires: ca-certificates instead of openssl
292- add BuildRequires: libcanberra-gtl3-devel
293
294* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
295- new upstream release
296- remove Patch103 (gnome-shell-ja.po-date.patch)
297
298* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
299- new upstream release
300- update Patch101,103
301- remove Patch0,102
302- add BuildRequires: gcr-devel
303- remove BuildRequires: GConf2-devel
304- add Requires: at-spi2-atk
305
306* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
307- new upstream release
308- remove Patch1
309
310* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
311- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
312- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
313- rename Patch103 (gnome-shell-ja.po-date.patch)
314- drop Patch102
315
316* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
317- new upstream release
318
319* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
320- new upstream release
321
322* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
323- new upstream release
324- update Patch101
325- update Patch102
326- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
327- add BuildRequires: libgudev1-devel, openssl
328
329* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
330- new upstream release
331- add BuildRequires: folks-devel, NetworkManager-glib-devel
332- add Requires: caribou
333- remove Patch0
334- update Patch101
335- update Patch102
336- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
337
338* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
339- rebuild with gnome-menus-3.1.5
340- add Patch0 (gnome-shell-git20110821.patch)
341
342* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
343- new upstream release
344- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
345- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
346- remove BuildRequires: xulrunner-devel
347- add Patch101 (gnome-shell-vine-settings.patch)
348- add Patch102 (gnome-shell-vine-customize.patch)
349- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
350
351* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
352- add Requires: mutter
353
354* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
355- new upstream release
356
357* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
358- initial build for Vine Linux
359
Note: See TracBrowser for help on using the repository browser.