source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 7712

Revision 7712, 8.2 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define pkg_version 3.8.3
2%define pkg_release 1%{?_dist_release}
3
4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:       gnome-shell-vine-settings.patch
12
13License:        GPLv2+
14Group:          User Interface/Desktops
15URL:            http://live.gnome.org/GnomeShell
16
17Requires: mutter
18Requires: caribou
19Requires: ca-certificates
20Requires: at-spi2-atk
21Requires: telepathy-logger
22Requires: network-manager-applet
23Requires: gnome-tweak-tool
24
25BuildRequires: gnome-common
26BuildRequires: libtool
27BuildRequires: automake
28BuildRequires: autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: gtk2-devel
32BuildRequires: clutter-devel
33BuildRequires: mutter-devel
34BuildRequires: gjs-devel
35BuildRequires: gnome-desktop3-devel
36BuildRequires: gnome-menus-devel
37BuildRequires: libSM-devel
38BuildRequires: libffi-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
45BuildRequires: control-center-devel
46BuildRequires: gcr-devel
47BuildRequires: gstreamer-devel
48BuildRequires: dbus-glib-devel
49BuildRequires: telepathy-logger-devel
50BuildRequires: polkit-devel
51BuildRequires: pulseaudio-libs-devel
52BuildRequires: evolution-data-server-devel
53BuildRequires: folks-devel
54BuildRequires: NetworkManager-glib-devel
55BuildRequires: libnm-gtk-devel
56BuildRequires: libgudev1-devel
57BuildRequires: libcanberra-gtk3-devel
58BuildRequires: caribou-devel
59BuildRequires: ca-certificates
60BuildRequires: intltool
61
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64Vendor: Project Vine
65Distribution: Vine Linux
66Packager: Takemikaduchi
67
68
69%description
70GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
71It provides core interface functions like switching to windows and launching
72applications. GNOME Shell takes advantage of the capabilities of modern graphics
73hardware and introduces innovative user interface concepts to provide a delightful
74and easy to use experience.
75
76
77%package        docs
78Summary:        Documentation for %{name}
79Summary(ja):    %{name} 用のドキュメント
80Group:          Documentation
81Requires:       %{name} = %{version}-%{release}
82BuildArch:              noarch
83
84%description    docs
85This package contains documentation for %{name}.
86
87
88
89%prep
90%setup -q
91%patch101 -p1 -b .vine
92
93%build
94libtoolize --copy --force
95autoreconf
96%configure \
97        --disable-static
98
99%{__make} %{?_smp_mflags}
100
101
102%install
103%{__rm} -rf ${RPM_BUILD_ROOT}
104%{__make} install DESTDIR=${RPM_BUILD_ROOT}
105
106find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
107
108%find_lang %{name}
109
110
111
112%clean
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115
116%post
117/sbin/ldconfig
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x /usr/bin/gtk-update-icon-cache ]; then
120  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
121fi
122
123%postun
124/sbin/ldconfig
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131%posttrans
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
133
134
135%files -f %{name}.lang
136%defattr(-,root,root,-)
137%doc COPYING NEWS README
138%{_bindir}/gnome-shell
139%{_bindir}/gnome-shell-extension-tool
140%{_bindir}/gnome-shell-extension-prefs
141%{_bindir}/gnome-shell-perf-tool
142%{_libdir}/%{name}/*
143%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
144%{_libexecdir}/gnome-shell-calendar-server
145%{_libexecdir}/gnome-shell-hotplug-sniffer
146%{_libexecdir}/gnome-shell-perf-helper
147%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
148%{_datadir}/applications/gnome-shell.desktop
149%{_datadir}/applications/gnome-shell-extension-prefs.desktop
150%{_datadir}/applications/evolution-calendar.desktop
151%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
152%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
153%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
154%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
155%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
156%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
157%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
158%{_datadir}/%{name}/*
159%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-screenshot.xml
160%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
161%{_mandir}/man1/%{name}.1.gz
162
163%files docs
164%defattr(-,root,root,-)
165%{_datadir}/gtk-doc/html/shell
166%{_datadir}/gtk-doc/html/st
167
168
169%changelog
170* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
171- new upstream release
172
173* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
174- new upstream release
175
176* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
177- new upstream release
178- update Patch101 (gnome-shell-vine-settings.patch)
179- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
180- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
181- create %%{name}-docs subpackage
182
183* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
184- new upstream release
185- remove Source102 (gnome-shell.gnome-3-6.ja.po)
186
187* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
188- new upstream release
189- add Source102 (gnome-shell.gnome-3-6.ja.po)
190
191* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
192- new upstream release
193- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
194
195* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
196- rebuild with telepathy-logger-0.6.0
197- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
198
199* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
200- new upstream release
201
202* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
203- new upstream release
204- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
205- update Patch101 (gnome-shell-vine-settings.patch)
206- change BuildRequires: ca-certificates instead of openssl
207- add BuildRequires: libcanberra-gtl3-devel
208
209* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
210- new upstream release
211- remove Patch103 (gnome-shell-ja.po-date.patch)
212
213* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
214- new upstream release
215- update Patch101,103
216- remove Patch0,102
217- add BuildRequires: gcr-devel
218- remove BuildRequires: GConf2-devel
219- add Requires: at-spi2-atk
220
221* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
222- new upstream release
223- remove Patch1
224
225* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
226- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
227- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
228- rename Patch103 (gnome-shell-ja.po-date.patch)
229- drop Patch102
230
231* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
232- new upstream release
233
234* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
235- new upstream release
236
237* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
238- new upstream release
239- update Patch101
240- update Patch102
241- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
242- add BuildRequires: libgudev1-devel, openssl
243
244* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
245- new upstream release
246- add BuildRequires: folks-devel, NetworkManager-glib-devel
247- add Requires: caribou
248- remove Patch0
249- update Patch101
250- update Patch102
251- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
252
253* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
254- rebuild with gnome-menus-3.1.5
255- add Patch0 (gnome-shell-git20110821.patch)
256
257* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
258- new upstream release
259- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
260- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
261- remove BuildRequires: xulrunner-devel
262- add Patch101 (gnome-shell-vine-settings.patch)
263- add Patch102 (gnome-shell-vine-customize.patch)
264- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
265
266* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
267- add Requires: mutter
268
269* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
270- new upstream release
271
272* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
273- initial build for Vine Linux
274
Note: See TracBrowser for help on using the repository browser.