source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 4616

Revision 4616, 4.6 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pkg_version 3.1.4
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:    gnome-shell-vine-settings.patch
12Patch102:    gnome-shell-vine-customize.patch
13Patch103:    gnome-shell-3.1.4-ja.po.patch
14
15License:     GPLv2+
16Group:       User Interface/Desktops
17URL:         http://live.gnome.org/GnomeShell
18
19Requires(post,postun): scrollkeeper >= 0.1.4
20Requires(post,pre,preun): GConf2 >= 2.14
21Requires: mutter
22
23BuildRequires: gnome-common
24BuildRequires: libtool
25BuildRequires: automake
26BuildRequires: autoconf
27
28BuildRequires: pkgconfig
29BuildRequires: gtk2-devel
30BuildRequires: clutter-devel
31BuildRequires: mutter-devel
32BuildRequires: gjs-devel
33BuildRequires: gnome-desktop3-devel
34BuildRequires: gnome-menus-devel
35BuildRequires: libSM-devel
36BuildRequires: libffi-devel
37BuildRequires: GConf2-devel
38BuildRequires: startup-notification-devel
39BuildRequires: gnome-doc-utils
40BuildRequires: desktop-file-utils
41BuildRequires: libcroco-devel
42BuildRequires: librsvg2-devel
43BuildRequires: gobject-introspection-devel
44BuildRequires: gstreamer-devel
45BuildRequires: dbus-glib-devel
46BuildRequires: telepathy-logger-devel
47BuildRequires: polkit-devel
48BuildRequires: pulseaudio-libs-devel
49BuildRequires: evolution-data-server-devel
50BuildRequires: intltool
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53
54Vendor: Project Vine
55Distribution: Vine Linux
56Packager: Takemikaduchi
57
58
59%description
60GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
61It provides core interface functions like switching to windows and launching
62applications. GNOME Shell takes advantage of the capabilities of modern graphics
63hardware and introduces innovative user interface concepts to provide a delightful
64and easy to use experience.
65
66
67%prep
68%setup -q
69%patch101 -p1 -b .vine
70%patch102 -p1 -b .vine
71%patch103 -p1 -b .old_po
72
73%build
74%configure --disable-static
75%{__make} %{?_smp_mflags}
76
77
78%install
79%{__rm} -rf ${RPM_BUILD_ROOT}
80%{__make} install DESTDIR=${RPM_BUILD_ROOT}
81
82find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
83
84%find_lang %{name}
85
86
87
88%clean
89%{__rm} -rf ${RPM_BUILD_ROOT}
90
91
92%post
93/sbin/ldconfig
94export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95gconftool-2 --makefile-install-rule \
96    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
97    > /dev/null || :
98touch --no-create %{_datadir}/icons/hicolor
99if [ -x /usr/bin/gtk-update-icon-cache ]; then
100  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
101fi
102
103%pre
104if [ "$1" -gt 1 ]; then
105  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
106  gconftool-2 --makefile-uninstall-rule \
107    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
108    > /dev/null || :
109fi
110
111%preun
112if [ "$1" -eq 0 ]; then
113  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
114  gconftool-2 --makefile-uninstall-rule \
115    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
116    > /dev/null || :
117fi
118
119%postun
120scrollkeeper-update -q || :
121/sbin/ldconfig
122touch --no-create %{_datadir}/icons/hicolor
123if [ -x /usr/bin/gtk-update-icon-cache ]; then
124  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
125fi
126glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
127
128%posttrans
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131
132%files -f %{name}.lang
133%defattr(-,root,root)
134%doc COPYING NEWS README
135%{_sysconfdir}/gconf/schemas/gnome-shell.schemas
136%{_bindir}/gnome-shell
137%{_bindir}/gnome-shell-extension-tool
138%{_libdir}/gnome-shell/*
139%{_libexecdir}/gnome-shell-calendar-server
140%{_libexecdir}/gnome-shell-hotplug-sniffer
141%{_libexecdir}/gnome-shell-perf-helper
142%{_datadir}/applications/gnome-shell.desktop
143%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
144%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
145%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
146%{_datadir}/gnome-shell/*
147%{_datadir}/man/man1/*.1.gz
148
149
150%changelog
151* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
152- new upstream release
153- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
154- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
155- remove BuildRequires: xulrunner-devel
156- add Patch101 (gnome-shell-vine-settings.patch)
157- add Patch102 (gnome-shell-vine-customize.patch)
158- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
159
160* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
161- add Requires: mutter
162
163* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
164- new upstream release
165
166* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
167- initial build for Vine Linux
168
Note: See TracBrowser for help on using the repository browser.