source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9646

Revision 9646, 10.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

RevLine 
[9646]1%define pkg_version 3.16.3
2%define pkg_release 1%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
[9376]5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
[7474]6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
[9475]9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
[4616]10
11# settings for Vine
[9073]12Patch101:       gnome-shell-3.14.1-vine-settings.patch
[9484]13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
[9585]14Patch103:       gnome-shell-3.16.2-disable-packagekit.patch
[9630]15Patch104:       gnome-shell-3.16.2-vine-themes.patch
[4616]16
[7474]17License:        GPLv2+
18Group:          User Interface/Desktops
19URL:            http://live.gnome.org/GnomeShell
[521]20
[915]21Requires: mutter
[4704]22Requires: caribou
[6890]23Requires: ca-certificates
[6011]24Requires: at-spi2-atk
[7633]25Requires: telepathy-logger
26Requires: network-manager-applet
27Requires: gnome-tweak-tool
[915]28
[521]29BuildRequires: gnome-common
30BuildRequires: libtool
31BuildRequires: automake
32BuildRequires: autoconf
33
34BuildRequires: pkgconfig
35BuildRequires: gtk2-devel
36BuildRequires: clutter-devel
37BuildRequires: mutter-devel
38BuildRequires: gjs-devel
[4616]39BuildRequires: gnome-desktop3-devel
[521]40BuildRequires: gnome-menus-devel
41BuildRequires: libSM-devel
42BuildRequires: libffi-devel
43BuildRequires: startup-notification-devel
44BuildRequires: gnome-doc-utils
45BuildRequires: desktop-file-utils
46BuildRequires: libcroco-devel
47BuildRequires: librsvg2-devel
48BuildRequires: gobject-introspection-devel
[7633]49BuildRequires: control-center-devel
[6011]50BuildRequires: gcr-devel
[521]51BuildRequires: gstreamer-devel
52BuildRequires: dbus-glib-devel
[4616]53BuildRequires: telepathy-logger-devel
54BuildRequires: polkit-devel
55BuildRequires: pulseaudio-libs-devel
56BuildRequires: evolution-data-server-devel
[4704]57BuildRequires: folks-devel
58BuildRequires: NetworkManager-glib-devel
[7633]59BuildRequires: libnm-gtk-devel
[4812]60BuildRequires: libgudev1-devel
[6890]61BuildRequires: libcanberra-gtk3-devel
[7633]62BuildRequires: caribou-devel
[6890]63BuildRequires: ca-certificates
[9475]64BuildRequires: python3-devel
[521]65BuildRequires: intltool
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: Takemikaduchi
72
73
74%description
[4616]75GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
76It provides core interface functions like switching to windows and launching
77applications. GNOME Shell takes advantage of the capabilities of modern graphics
78hardware and introduces innovative user interface concepts to provide a delightful
79and easy to use experience.
[521]80
81
[7633]82%package        docs
83Summary:        Documentation for %{name}
84Summary(ja):    %{name} 用のドキュメント
85Group:          Documentation
86Requires:       %{name} = %{version}-%{release}
87BuildArch:              noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93
[521]94%prep
95%setup -q
[4616]96%patch101 -p1 -b .vine
[9073]97%patch102 -p1 -b .vine
[9585]98%patch103 -p1 -b .vine
[9630]99%patch104 -p1 -b .vine
[521]100
101%build
[4812]102%configure \
[8353]103        --disable-static \
104        --disable-systemd
[4812]105
[9073]106%{__make} %{?_smp_mflags} V=1
[521]107
108
109%install
110%{__rm} -rf ${RPM_BUILD_ROOT}
111%{__make} install DESTDIR=${RPM_BUILD_ROOT}
112
[4616]113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
114
[9073]115rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
[521]116%find_lang %{name}
117
118
119
120%clean
121%{__rm} -rf ${RPM_BUILD_ROOT}
122
123
124%post
125/sbin/ldconfig
126touch --no-create %{_datadir}/icons/hicolor
127if [ -x /usr/bin/gtk-update-icon-cache ]; then
128  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
129fi
130
131%postun
132/sbin/ldconfig
133touch --no-create %{_datadir}/icons/hicolor
134if [ -x /usr/bin/gtk-update-icon-cache ]; then
135  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
136fi
[4616]137glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]138
[4616]139%posttrans
140glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]141
[4616]142
[521]143%files -f %{name}.lang
[7633]144%defattr(-,root,root,-)
[4616]145%doc COPYING NEWS README
[521]146%{_bindir}/gnome-shell
[4616]147%{_bindir}/gnome-shell-extension-tool
[6011]148%{_bindir}/gnome-shell-extension-prefs
[6890]149%{_bindir}/gnome-shell-perf-tool
[7633]150%{_libdir}/%{name}/*
[4812]151%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]152%{_libexecdir}/gnome-shell-calendar-server
153%{_libexecdir}/gnome-shell-hotplug-sniffer
154%{_libexecdir}/gnome-shell-perf-helper
[9073]155%{_libexecdir}/gnome-shell-portal-helper
[6011]156%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[4616]157%{_datadir}/applications/gnome-shell.desktop
[6011]158%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]159%{_datadir}/applications/evolution-calendar.desktop
[9073]160%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
[6011]161%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]162%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]163%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
164%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]165%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
166%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
[9073]167%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
[4616]168%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]169%{_datadir}/%{name}/*
170%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
171%{_mandir}/man1/%{name}.1.gz
172
173%files docs
174%defattr(-,root,root,-)
[6011]175%{_datadir}/gtk-doc/html/shell
176%{_datadir}/gtk-doc/html/st
[521]177
178
179%changelog
[9646]180* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
181- new upstream release
182
[9630]183* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
184- add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
185
[9585]186* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
187- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
188
[9569]189* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
190- new upstream release
191
[9520]192* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
193- new upstream release
194
[9484]195* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
[9475]196- new upstream release
197- add BuildRequires: python3-devel
[9484]198- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
[9475]199
[9376]200* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
201- rebuilt with libical 1.0.1
202
[9178]203* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
204- new upstream release
205
[9102]206* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
207- new upstream release
208
[9073]209* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
210- new upstream release
211- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
212- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
213
[8447]214* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
215- new upstream release
216
[8369]217* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
218- new upstream release
219
[8353]220* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
221- new upstream release
222
[8219]223* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
224- new upstream release
225
[8011]226* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
227- new upstream release
228
[7938]229* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
230- new upstream release
231
[7756]232* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
233- new upstream release
234
[7712]235* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
236- new upstream release
237
[7681]238* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
239- new upstream release
240
[7633]241* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
242- new upstream release
243- update Patch101 (gnome-shell-vine-settings.patch)
244- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
245- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
246- create %%{name}-docs subpackage
247
[7516]248* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
249- new upstream release
250- remove Source102 (gnome-shell.gnome-3-6.ja.po)
251
[7474]252* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
253- new upstream release
254- add Source102 (gnome-shell.gnome-3-6.ja.po)
255
[7119]256* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
257- new upstream release
258- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
259
[7047]260* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
261- rebuild with telepathy-logger-0.6.0
262- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
263
[6951]264* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
265- new upstream release
266
[6890]267* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
268- new upstream release
269- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
270- update Patch101 (gnome-shell-vine-settings.patch)
271- change BuildRequires: ca-certificates instead of openssl
272- add BuildRequires: libcanberra-gtl3-devel
273
[6619]274* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
275- new upstream release
276- remove Patch103 (gnome-shell-ja.po-date.patch)
277
[6011]278* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
279- new upstream release
280- update Patch101,103
281- remove Patch0,102
282- add BuildRequires: gcr-devel
283- remove BuildRequires: GConf2-devel
284- add Requires: at-spi2-atk
285
[5448]286* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
287- new upstream release
288- remove Patch1
289
[5206]290* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
291- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
292- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
293- rename Patch103 (gnome-shell-ja.po-date.patch)
294- drop Patch102
295
[5038]296* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
297- new upstream release
298
[4850]299* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
300- new upstream release
301
[4812]302* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
303- new upstream release
304- update Patch101
305- update Patch102
306- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
307- add BuildRequires: libgudev1-devel, openssl
308
[4704]309* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
310- new upstream release
311- add BuildRequires: folks-devel, NetworkManager-glib-devel
312- add Requires: caribou
313- remove Patch0
314- update Patch101
315- update Patch102
316- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
317
[4650]318* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
319- rebuild with gnome-menus-3.1.5
320- add Patch0 (gnome-shell-git20110821.patch)
321
[4616]322* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
323- new upstream release
324- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
325- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
326- remove BuildRequires: xulrunner-devel
327- add Patch101 (gnome-shell-vine-settings.patch)
328- add Patch102 (gnome-shell-vine-customize.patch)
329- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
330
[915]331* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
332- add Requires: mutter
333
[914]334* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
335- new upstream release
336
[521]337* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
338- initial build for Vine Linux
339
Note: See TracBrowser for help on using the repository browser.