source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9585

Revision 9585, 10.2 KB checked in by Takemikaduchi, 9 years ago (diff)

gnome-shell: add patch
gnome-music: add R: python3-pycairo
dbus-python3: rebuild

RevLine 
[9569]1%define pkg_version 3.16.2
[9585]2%define pkg_release 2%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
[9376]5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
[7474]6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
[9475]9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
[4616]10
11# settings for Vine
[9073]12Patch101:       gnome-shell-3.14.1-vine-settings.patch
[9484]13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
[9585]14Patch103:       gnome-shell-3.16.2-disable-packagekit.patch
[4616]15
[7474]16License:        GPLv2+
17Group:          User Interface/Desktops
18URL:            http://live.gnome.org/GnomeShell
[521]19
[915]20Requires: mutter
[4704]21Requires: caribou
[6890]22Requires: ca-certificates
[6011]23Requires: at-spi2-atk
[7633]24Requires: telepathy-logger
25Requires: network-manager-applet
26Requires: gnome-tweak-tool
[915]27
[521]28BuildRequires: gnome-common
29BuildRequires: libtool
30BuildRequires: automake
31BuildRequires: autoconf
32
33BuildRequires: pkgconfig
34BuildRequires: gtk2-devel
35BuildRequires: clutter-devel
36BuildRequires: mutter-devel
37BuildRequires: gjs-devel
[4616]38BuildRequires: gnome-desktop3-devel
[521]39BuildRequires: gnome-menus-devel
40BuildRequires: libSM-devel
41BuildRequires: libffi-devel
42BuildRequires: startup-notification-devel
43BuildRequires: gnome-doc-utils
44BuildRequires: desktop-file-utils
45BuildRequires: libcroco-devel
46BuildRequires: librsvg2-devel
47BuildRequires: gobject-introspection-devel
[7633]48BuildRequires: control-center-devel
[6011]49BuildRequires: gcr-devel
[521]50BuildRequires: gstreamer-devel
51BuildRequires: dbus-glib-devel
[4616]52BuildRequires: telepathy-logger-devel
53BuildRequires: polkit-devel
54BuildRequires: pulseaudio-libs-devel
55BuildRequires: evolution-data-server-devel
[4704]56BuildRequires: folks-devel
57BuildRequires: NetworkManager-glib-devel
[7633]58BuildRequires: libnm-gtk-devel
[4812]59BuildRequires: libgudev1-devel
[6890]60BuildRequires: libcanberra-gtk3-devel
[7633]61BuildRequires: caribou-devel
[6890]62BuildRequires: ca-certificates
[9475]63BuildRequires: python3-devel
[521]64BuildRequires: intltool
65
66BuildRoot: %{_tmppath}/%{name}-%{version}-root
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: Takemikaduchi
71
72
73%description
[4616]74GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
75It provides core interface functions like switching to windows and launching
76applications. GNOME Shell takes advantage of the capabilities of modern graphics
77hardware and introduces innovative user interface concepts to provide a delightful
78and easy to use experience.
[521]79
80
[7633]81%package        docs
82Summary:        Documentation for %{name}
83Summary(ja):    %{name} 用のドキュメント
84Group:          Documentation
85Requires:       %{name} = %{version}-%{release}
86BuildArch:              noarch
87
88%description    docs
89This package contains documentation for %{name}.
90
91
92
[521]93%prep
94%setup -q
[4616]95%patch101 -p1 -b .vine
[9073]96%patch102 -p1 -b .vine
[9585]97%patch103 -p1 -b .vine
[521]98
99%build
[4812]100%configure \
[8353]101        --disable-static \
102        --disable-systemd
[4812]103
[9073]104%{__make} %{?_smp_mflags} V=1
[521]105
106
107%install
108%{__rm} -rf ${RPM_BUILD_ROOT}
109%{__make} install DESTDIR=${RPM_BUILD_ROOT}
110
[4616]111find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
112
[9073]113rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
[521]114%find_lang %{name}
115
116
117
118%clean
119%{__rm} -rf ${RPM_BUILD_ROOT}
120
121
122%post
123/sbin/ldconfig
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x /usr/bin/gtk-update-icon-cache ]; then
126  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
127fi
128
129%postun
130/sbin/ldconfig
131touch --no-create %{_datadir}/icons/hicolor
132if [ -x /usr/bin/gtk-update-icon-cache ]; then
133  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
134fi
[4616]135glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]136
[4616]137%posttrans
138glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]139
[4616]140
[521]141%files -f %{name}.lang
[7633]142%defattr(-,root,root,-)
[4616]143%doc COPYING NEWS README
[521]144%{_bindir}/gnome-shell
[4616]145%{_bindir}/gnome-shell-extension-tool
[6011]146%{_bindir}/gnome-shell-extension-prefs
[6890]147%{_bindir}/gnome-shell-perf-tool
[7633]148%{_libdir}/%{name}/*
[4812]149%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]150%{_libexecdir}/gnome-shell-calendar-server
151%{_libexecdir}/gnome-shell-hotplug-sniffer
152%{_libexecdir}/gnome-shell-perf-helper
[9073]153%{_libexecdir}/gnome-shell-portal-helper
[6011]154%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[4616]155%{_datadir}/applications/gnome-shell.desktop
[6011]156%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]157%{_datadir}/applications/evolution-calendar.desktop
[9073]158%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
[6011]159%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]160%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]161%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
162%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]163%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
164%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
[9073]165%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
[4616]166%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]167%{_datadir}/%{name}/*
168%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
169%{_mandir}/man1/%{name}.1.gz
170
171%files docs
172%defattr(-,root,root,-)
[6011]173%{_datadir}/gtk-doc/html/shell
174%{_datadir}/gtk-doc/html/st
[521]175
176
177%changelog
[9585]178* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
179- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
180
[9569]181* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
182- new upstream release
183
[9520]184* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
185- new upstream release
186
[9484]187* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
[9475]188- new upstream release
189- add BuildRequires: python3-devel
[9484]190- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
[9475]191
[9376]192* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
193- rebuilt with libical 1.0.1
194
[9178]195* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
196- new upstream release
197
[9102]198* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
199- new upstream release
200
[9073]201* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
202- new upstream release
203- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
204- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
205
[8447]206* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
207- new upstream release
208
[8369]209* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
210- new upstream release
211
[8353]212* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
213- new upstream release
214
[8219]215* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
216- new upstream release
217
[8011]218* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
219- new upstream release
220
[7938]221* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
222- new upstream release
223
[7756]224* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
225- new upstream release
226
[7712]227* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
228- new upstream release
229
[7681]230* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
231- new upstream release
232
[7633]233* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
234- new upstream release
235- update Patch101 (gnome-shell-vine-settings.patch)
236- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
237- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
238- create %%{name}-docs subpackage
239
[7516]240* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
241- new upstream release
242- remove Source102 (gnome-shell.gnome-3-6.ja.po)
243
[7474]244* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
245- new upstream release
246- add Source102 (gnome-shell.gnome-3-6.ja.po)
247
[7119]248* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
249- new upstream release
250- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
251
[7047]252* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
253- rebuild with telepathy-logger-0.6.0
254- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
255
[6951]256* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
257- new upstream release
258
[6890]259* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
260- new upstream release
261- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
262- update Patch101 (gnome-shell-vine-settings.patch)
263- change BuildRequires: ca-certificates instead of openssl
264- add BuildRequires: libcanberra-gtl3-devel
265
[6619]266* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
267- new upstream release
268- remove Patch103 (gnome-shell-ja.po-date.patch)
269
[6011]270* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
271- new upstream release
272- update Patch101,103
273- remove Patch0,102
274- add BuildRequires: gcr-devel
275- remove BuildRequires: GConf2-devel
276- add Requires: at-spi2-atk
277
[5448]278* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
279- new upstream release
280- remove Patch1
281
[5206]282* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
283- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
284- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
285- rename Patch103 (gnome-shell-ja.po-date.patch)
286- drop Patch102
287
[5038]288* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
289- new upstream release
290
[4850]291* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
292- new upstream release
293
[4812]294* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
295- new upstream release
296- update Patch101
297- update Patch102
298- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
299- add BuildRequires: libgudev1-devel, openssl
300
[4704]301* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
302- new upstream release
303- add BuildRequires: folks-devel, NetworkManager-glib-devel
304- add Requires: caribou
305- remove Patch0
306- update Patch101
307- update Patch102
308- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
309
[4650]310* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
311- rebuild with gnome-menus-3.1.5
312- add Patch0 (gnome-shell-git20110821.patch)
313
[4616]314* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
315- new upstream release
316- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
317- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
318- remove BuildRequires: xulrunner-devel
319- add Patch101 (gnome-shell-vine-settings.patch)
320- add Patch102 (gnome-shell-vine-customize.patch)
321- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
322
[915]323* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
324- add Requires: mutter
325
[914]326* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
327- new upstream release
328
[521]329* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
330- initial build for Vine Linux
331
Note: See TracBrowser for help on using the repository browser.