source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9178

Revision 9178, 9.4 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

RevLine 
[9178]1%define pkg_version 3.14.3
[7119]2%define pkg_release 1%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
[9073]8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
[4616]9
10# settings for Vine
[9073]11Patch101:       gnome-shell-3.14.1-vine-settings.patch
12Patch102:       gnome-shell-3.14.1.5-revert-loginManager.patch
[4616]13
[7474]14License:        GPLv2+
15Group:          User Interface/Desktops
16URL:            http://live.gnome.org/GnomeShell
[521]17
[915]18Requires: mutter
[4704]19Requires: caribou
[6890]20Requires: ca-certificates
[6011]21Requires: at-spi2-atk
[7633]22Requires: telepathy-logger
23Requires: network-manager-applet
24Requires: gnome-tweak-tool
[915]25
[521]26BuildRequires: gnome-common
27BuildRequires: libtool
28BuildRequires: automake
29BuildRequires: autoconf
30
31BuildRequires: pkgconfig
32BuildRequires: gtk2-devel
33BuildRequires: clutter-devel
34BuildRequires: mutter-devel
35BuildRequires: gjs-devel
[4616]36BuildRequires: gnome-desktop3-devel
[521]37BuildRequires: gnome-menus-devel
38BuildRequires: libSM-devel
39BuildRequires: libffi-devel
40BuildRequires: startup-notification-devel
41BuildRequires: gnome-doc-utils
42BuildRequires: desktop-file-utils
43BuildRequires: libcroco-devel
44BuildRequires: librsvg2-devel
45BuildRequires: gobject-introspection-devel
[7633]46BuildRequires: control-center-devel
[6011]47BuildRequires: gcr-devel
[521]48BuildRequires: gstreamer-devel
49BuildRequires: dbus-glib-devel
[4616]50BuildRequires: telepathy-logger-devel
51BuildRequires: polkit-devel
52BuildRequires: pulseaudio-libs-devel
53BuildRequires: evolution-data-server-devel
[4704]54BuildRequires: folks-devel
55BuildRequires: NetworkManager-glib-devel
[7633]56BuildRequires: libnm-gtk-devel
[4812]57BuildRequires: libgudev1-devel
[6890]58BuildRequires: libcanberra-gtk3-devel
[7633]59BuildRequires: caribou-devel
[6890]60BuildRequires: ca-certificates
[521]61BuildRequires: intltool
62
63BuildRoot: %{_tmppath}/%{name}-%{version}-root
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: Takemikaduchi
68
69
70%description
[4616]71GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
72It provides core interface functions like switching to windows and launching
73applications. GNOME Shell takes advantage of the capabilities of modern graphics
74hardware and introduces innovative user interface concepts to provide a delightful
75and easy to use experience.
[521]76
77
[7633]78%package        docs
79Summary:        Documentation for %{name}
80Summary(ja):    %{name} 用のドキュメント
81Group:          Documentation
82Requires:       %{name} = %{version}-%{release}
83BuildArch:              noarch
84
85%description    docs
86This package contains documentation for %{name}.
87
88
89
[521]90%prep
91%setup -q
[4616]92%patch101 -p1 -b .vine
[9073]93%patch102 -p1 -b .vine
[521]94
95%build
[4812]96%configure \
[8353]97        --disable-static \
98        --disable-systemd
[4812]99
[9073]100%{__make} %{?_smp_mflags} V=1
[521]101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105%{__make} install DESTDIR=${RPM_BUILD_ROOT}
106
[4616]107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
108
[9073]109rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
[521]110%find_lang %{name}
111
112
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117
118%post
119/sbin/ldconfig
120touch --no-create %{_datadir}/icons/hicolor
121if [ -x /usr/bin/gtk-update-icon-cache ]; then
122  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
123fi
124
125%postun
126/sbin/ldconfig
127touch --no-create %{_datadir}/icons/hicolor
128if [ -x /usr/bin/gtk-update-icon-cache ]; then
129  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
130fi
[4616]131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]132
[4616]133%posttrans
134glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]135
[4616]136
[521]137%files -f %{name}.lang
[7633]138%defattr(-,root,root,-)
[4616]139%doc COPYING NEWS README
[521]140%{_bindir}/gnome-shell
[4616]141%{_bindir}/gnome-shell-extension-tool
[6011]142%{_bindir}/gnome-shell-extension-prefs
[6890]143%{_bindir}/gnome-shell-perf-tool
[7633]144%{_libdir}/%{name}/*
[4812]145%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]146%{_libexecdir}/gnome-shell-calendar-server
147%{_libexecdir}/gnome-shell-hotplug-sniffer
148%{_libexecdir}/gnome-shell-perf-helper
[9073]149%{_libexecdir}/gnome-shell-portal-helper
[6011]150%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[4616]151%{_datadir}/applications/gnome-shell.desktop
[6011]152%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]153%{_datadir}/applications/evolution-calendar.desktop
[9073]154%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
[6011]155%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]156%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]157%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]159%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
160%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
[9073]161%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
[4616]162%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]163%{_datadir}/%{name}/*
164%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
165%{_mandir}/man1/%{name}.1.gz
166
167%files docs
168%defattr(-,root,root,-)
[6011]169%{_datadir}/gtk-doc/html/shell
170%{_datadir}/gtk-doc/html/st
[521]171
172
173%changelog
[9178]174* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
175- new upstream release
176
[9102]177* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
178- new upstream release
179
[9073]180* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
181- new upstream release
182- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
183- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
184
[8447]185* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
186- new upstream release
187
[8369]188* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
189- new upstream release
190
[8353]191* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
192- new upstream release
193
[8219]194* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
195- new upstream release
196
[8011]197* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
198- new upstream release
199
[7938]200* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
201- new upstream release
202
[7756]203* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
204- new upstream release
205
[7712]206* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
207- new upstream release
208
[7681]209* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
210- new upstream release
211
[7633]212* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
213- new upstream release
214- update Patch101 (gnome-shell-vine-settings.patch)
215- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
216- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
217- create %%{name}-docs subpackage
218
[7516]219* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
220- new upstream release
221- remove Source102 (gnome-shell.gnome-3-6.ja.po)
222
[7474]223* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
224- new upstream release
225- add Source102 (gnome-shell.gnome-3-6.ja.po)
226
[7119]227* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
228- new upstream release
229- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
230
[7047]231* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
232- rebuild with telepathy-logger-0.6.0
233- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
234
[6951]235* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
236- new upstream release
237
[6890]238* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
239- new upstream release
240- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
241- update Patch101 (gnome-shell-vine-settings.patch)
242- change BuildRequires: ca-certificates instead of openssl
243- add BuildRequires: libcanberra-gtl3-devel
244
[6619]245* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
246- new upstream release
247- remove Patch103 (gnome-shell-ja.po-date.patch)
248
[6011]249* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
250- new upstream release
251- update Patch101,103
252- remove Patch0,102
253- add BuildRequires: gcr-devel
254- remove BuildRequires: GConf2-devel
255- add Requires: at-spi2-atk
256
[5448]257* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
258- new upstream release
259- remove Patch1
260
[5206]261* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
262- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
263- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
264- rename Patch103 (gnome-shell-ja.po-date.patch)
265- drop Patch102
266
[5038]267* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
268- new upstream release
269
[4850]270* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
271- new upstream release
272
[4812]273* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
274- new upstream release
275- update Patch101
276- update Patch102
277- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
278- add BuildRequires: libgudev1-devel, openssl
279
[4704]280* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
281- new upstream release
282- add BuildRequires: folks-devel, NetworkManager-glib-devel
283- add Requires: caribou
284- remove Patch0
285- update Patch101
286- update Patch102
287- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
288
[4650]289* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
290- rebuild with gnome-menus-3.1.5
291- add Patch0 (gnome-shell-git20110821.patch)
292
[4616]293* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
294- new upstream release
295- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
296- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
297- remove BuildRequires: xulrunner-devel
298- add Patch101 (gnome-shell-vine-settings.patch)
299- add Patch102 (gnome-shell-vine-customize.patch)
300- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
301
[915]302* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
303- add Requires: mutter
304
[914]305* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
306- new upstream release
307
[521]308* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
309- initial build for Vine Linux
310
Note: See TracBrowser for help on using the repository browser.