source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 9073

Revision 9073, 9.2 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

RevLine 
[9073]1%define pkg_version 3.14.1.5
[7119]2%define pkg_release 1%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
5Name:           gnome-shell
6Version:        %{pkg_version}
7Release:        %{pkg_release}
[9073]8Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
[4616]9
10# settings for Vine
[9073]11Patch101:       gnome-shell-3.14.1-vine-settings.patch
12Patch102:       gnome-shell-3.14.1.5-revert-loginManager.patch
[4616]13
[7474]14License:        GPLv2+
15Group:          User Interface/Desktops
16URL:            http://live.gnome.org/GnomeShell
[521]17
[915]18Requires: mutter
[4704]19Requires: caribou
[6890]20Requires: ca-certificates
[6011]21Requires: at-spi2-atk
[7633]22Requires: telepathy-logger
23Requires: network-manager-applet
24Requires: gnome-tweak-tool
[915]25
[521]26BuildRequires: gnome-common
27BuildRequires: libtool
28BuildRequires: automake
29BuildRequires: autoconf
30
31BuildRequires: pkgconfig
32BuildRequires: gtk2-devel
33BuildRequires: clutter-devel
34BuildRequires: mutter-devel
35BuildRequires: gjs-devel
[4616]36BuildRequires: gnome-desktop3-devel
[521]37BuildRequires: gnome-menus-devel
38BuildRequires: libSM-devel
39BuildRequires: libffi-devel
40BuildRequires: startup-notification-devel
41BuildRequires: gnome-doc-utils
42BuildRequires: desktop-file-utils
43BuildRequires: libcroco-devel
44BuildRequires: librsvg2-devel
45BuildRequires: gobject-introspection-devel
[7633]46BuildRequires: control-center-devel
[6011]47BuildRequires: gcr-devel
[521]48BuildRequires: gstreamer-devel
49BuildRequires: dbus-glib-devel
[4616]50BuildRequires: telepathy-logger-devel
51BuildRequires: polkit-devel
52BuildRequires: pulseaudio-libs-devel
53BuildRequires: evolution-data-server-devel
[4704]54BuildRequires: folks-devel
55BuildRequires: NetworkManager-glib-devel
[7633]56BuildRequires: libnm-gtk-devel
[4812]57BuildRequires: libgudev1-devel
[6890]58BuildRequires: libcanberra-gtk3-devel
[7633]59BuildRequires: caribou-devel
[6890]60BuildRequires: ca-certificates
[521]61BuildRequires: intltool
62
63BuildRoot: %{_tmppath}/%{name}-%{version}-root
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: Takemikaduchi
68
69
70%description
[4616]71GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
72It provides core interface functions like switching to windows and launching
73applications. GNOME Shell takes advantage of the capabilities of modern graphics
74hardware and introduces innovative user interface concepts to provide a delightful
75and easy to use experience.
[521]76
77
[7633]78%package        docs
79Summary:        Documentation for %{name}
80Summary(ja):    %{name} 用のドキュメント
81Group:          Documentation
82Requires:       %{name} = %{version}-%{release}
83BuildArch:              noarch
84
85%description    docs
86This package contains documentation for %{name}.
87
88
89
[521]90%prep
91%setup -q
[4616]92%patch101 -p1 -b .vine
[9073]93%patch102 -p1 -b .vine
[521]94
95%build
[4812]96%configure \
[8353]97        --disable-static \
98        --disable-systemd
[4812]99
[9073]100%{__make} %{?_smp_mflags} V=1
[521]101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105%{__make} install DESTDIR=${RPM_BUILD_ROOT}
106
[4616]107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
108
[9073]109rm $RPM_BUILD_ROOT%{_datadir}/applications/gnome-shell-wayland.desktop
[521]110%find_lang %{name}
111
112
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117
118%post
119/sbin/ldconfig
120touch --no-create %{_datadir}/icons/hicolor
121if [ -x /usr/bin/gtk-update-icon-cache ]; then
122  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
123fi
124
125%postun
126/sbin/ldconfig
127touch --no-create %{_datadir}/icons/hicolor
128if [ -x /usr/bin/gtk-update-icon-cache ]; then
129  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
130fi
[4616]131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]132
[4616]133%posttrans
134glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]135
[4616]136
[521]137%files -f %{name}.lang
[7633]138%defattr(-,root,root,-)
[4616]139%doc COPYING NEWS README
[521]140%{_bindir}/gnome-shell
[4616]141%{_bindir}/gnome-shell-extension-tool
[6011]142%{_bindir}/gnome-shell-extension-prefs
[6890]143%{_bindir}/gnome-shell-perf-tool
[7633]144%{_libdir}/%{name}/*
[4812]145%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]146%{_libexecdir}/gnome-shell-calendar-server
147%{_libexecdir}/gnome-shell-hotplug-sniffer
148%{_libexecdir}/gnome-shell-perf-helper
[9073]149%{_libexecdir}/gnome-shell-portal-helper
[6011]150%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[4616]151%{_datadir}/applications/gnome-shell.desktop
[6011]152%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]153%{_datadir}/applications/evolution-calendar.desktop
[9073]154%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
[6011]155%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]156%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]157%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
158%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]159%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
160%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
[9073]161%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
[4616]162%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]163%{_datadir}/%{name}/*
164%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
165%{_mandir}/man1/%{name}.1.gz
166
167%files docs
168%defattr(-,root,root,-)
[6011]169%{_datadir}/gtk-doc/html/shell
170%{_datadir}/gtk-doc/html/st
[521]171
172
173%changelog
[9073]174* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
175- new upstream release
176- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
177- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
178
[8447]179* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
180- new upstream release
181
[8369]182* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
183- new upstream release
184
[8353]185* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
186- new upstream release
187
[8219]188* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
189- new upstream release
190
[8011]191* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
192- new upstream release
193
[7938]194* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
195- new upstream release
196
[7756]197* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
198- new upstream release
199
[7712]200* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
201- new upstream release
202
[7681]203* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
204- new upstream release
205
[7633]206* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
207- new upstream release
208- update Patch101 (gnome-shell-vine-settings.patch)
209- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
210- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
211- create %%{name}-docs subpackage
212
[7516]213* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
214- new upstream release
215- remove Source102 (gnome-shell.gnome-3-6.ja.po)
216
[7474]217* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
218- new upstream release
219- add Source102 (gnome-shell.gnome-3-6.ja.po)
220
[7119]221* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
222- new upstream release
223- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
224
[7047]225* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
226- rebuild with telepathy-logger-0.6.0
227- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
228
[6951]229* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
230- new upstream release
231
[6890]232* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
233- new upstream release
234- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
235- update Patch101 (gnome-shell-vine-settings.patch)
236- change BuildRequires: ca-certificates instead of openssl
237- add BuildRequires: libcanberra-gtl3-devel
238
[6619]239* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
240- new upstream release
241- remove Patch103 (gnome-shell-ja.po-date.patch)
242
[6011]243* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
244- new upstream release
245- update Patch101,103
246- remove Patch0,102
247- add BuildRequires: gcr-devel
248- remove BuildRequires: GConf2-devel
249- add Requires: at-spi2-atk
250
[5448]251* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
252- new upstream release
253- remove Patch1
254
[5206]255* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
256- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
257- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
258- rename Patch103 (gnome-shell-ja.po-date.patch)
259- drop Patch102
260
[5038]261* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
262- new upstream release
263
[4850]264* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
265- new upstream release
266
[4812]267* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
268- new upstream release
269- update Patch101
270- update Patch102
271- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
272- add BuildRequires: libgudev1-devel, openssl
273
[4704]274* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
275- new upstream release
276- add BuildRequires: folks-devel, NetworkManager-glib-devel
277- add Requires: caribou
278- remove Patch0
279- update Patch101
280- update Patch102
281- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
282
[4650]283* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
284- rebuild with gnome-menus-3.1.5
285- add Patch0 (gnome-shell-git20110821.patch)
286
[4616]287* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
288- new upstream release
289- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
290- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
291- remove BuildRequires: xulrunner-devel
292- add Patch101 (gnome-shell-vine-settings.patch)
293- add Patch102 (gnome-shell-vine-customize.patch)
294- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
295
[915]296* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
297- add Requires: mutter
298
[914]299* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
300- new upstream release
301
[521]302* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
303- initial build for Vine Linux
304
Note: See TracBrowser for help on using the repository browser.