source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 4704

Revision 4704, 5.2 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

RevLine 
[4704]1%define pkg_version 3.1.90.1
2%define pkg_release 1%{?_dist_release}
[521]3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
[4616]8Source0:     %{name}-%{version}.tar.xz
9
10# settings for Vine
11Patch101:    gnome-shell-vine-settings.patch
12Patch102:    gnome-shell-vine-customize.patch
[4704]13Patch103:    gnome-shell-3.1.90.1-ja.po.patch
[4616]14
[521]15License:     GPLv2+
16Group:       User Interface/Desktops
17URL:         http://live.gnome.org/GnomeShell
18
19Requires(post,postun): scrollkeeper >= 0.1.4
20Requires(post,pre,preun): GConf2 >= 2.14
[915]21Requires: mutter
[4704]22Requires: caribou
[915]23
[521]24BuildRequires: gnome-common
25BuildRequires: libtool
26BuildRequires: automake
27BuildRequires: autoconf
28
29BuildRequires: pkgconfig
30BuildRequires: gtk2-devel
31BuildRequires: clutter-devel
32BuildRequires: mutter-devel
33BuildRequires: gjs-devel
[4616]34BuildRequires: gnome-desktop3-devel
[521]35BuildRequires: gnome-menus-devel
36BuildRequires: libSM-devel
37BuildRequires: libffi-devel
38BuildRequires: GConf2-devel
39BuildRequires: startup-notification-devel
40BuildRequires: gnome-doc-utils
41BuildRequires: desktop-file-utils
42BuildRequires: libcroco-devel
43BuildRequires: librsvg2-devel
44BuildRequires: gobject-introspection-devel
45BuildRequires: gstreamer-devel
46BuildRequires: dbus-glib-devel
[4616]47BuildRequires: telepathy-logger-devel
48BuildRequires: polkit-devel
49BuildRequires: pulseaudio-libs-devel
50BuildRequires: evolution-data-server-devel
[4704]51BuildRequires: folks-devel
52BuildRequires: NetworkManager-glib-devel
[521]53BuildRequires: intltool
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56
57Vendor: Project Vine
58Distribution: Vine Linux
59Packager: Takemikaduchi
60
61
62%description
[4616]63GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
64It provides core interface functions like switching to windows and launching
65applications. GNOME Shell takes advantage of the capabilities of modern graphics
66hardware and introduces innovative user interface concepts to provide a delightful
67and easy to use experience.
[521]68
69
70%prep
71%setup -q
[4616]72%patch101 -p1 -b .vine
73%patch102 -p1 -b .vine
74%patch103 -p1 -b .old_po
[521]75
76%build
[4650]77libtoolize --copy --force
78autoreconf
[521]79%configure --disable-static
80%{__make} %{?_smp_mflags}
81
82
83%install
84%{__rm} -rf ${RPM_BUILD_ROOT}
85%{__make} install DESTDIR=${RPM_BUILD_ROOT}
86
[4616]87find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
88
[521]89%find_lang %{name}
90
91
92
93%clean
94%{__rm} -rf ${RPM_BUILD_ROOT}
95
96
97%post
98/sbin/ldconfig
99export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
100gconftool-2 --makefile-install-rule \
101    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
[4616]102    > /dev/null || :
[521]103touch --no-create %{_datadir}/icons/hicolor
104if [ -x /usr/bin/gtk-update-icon-cache ]; then
105  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
106fi
107
[4616]108%pre
[521]109if [ "$1" -gt 1 ]; then
110  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111  gconftool-2 --makefile-uninstall-rule \
112    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
113    > /dev/null || :
114fi
115
[4616]116%preun
[521]117if [ "$1" -eq 0 ]; then
118  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
119  gconftool-2 --makefile-uninstall-rule \
120    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
121    > /dev/null || :
122fi
123
124%postun
125scrollkeeper-update -q || :
126/sbin/ldconfig
127touch --no-create %{_datadir}/icons/hicolor
128if [ -x /usr/bin/gtk-update-icon-cache ]; then
129  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
130fi
[4616]131glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]132
[4616]133%posttrans
134glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]135
[4616]136
[521]137%files -f %{name}.lang
138%defattr(-,root,root)
[4616]139%doc COPYING NEWS README
140%{_sysconfdir}/gconf/schemas/gnome-shell.schemas
[521]141%{_bindir}/gnome-shell
[4616]142%{_bindir}/gnome-shell-extension-tool
[521]143%{_libdir}/gnome-shell/*
[4616]144%{_libexecdir}/gnome-shell-calendar-server
145%{_libexecdir}/gnome-shell-hotplug-sniffer
146%{_libexecdir}/gnome-shell-perf-helper
147%{_datadir}/applications/gnome-shell.desktop
148%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
149%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
150%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[521]151%{_datadir}/gnome-shell/*
[915]152%{_datadir}/man/man1/*.1.gz
[521]153
154
155%changelog
[4704]156* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
157- new upstream release
158- add BuildRequires: folks-devel, NetworkManager-glib-devel
159- add Requires: caribou
160- remove Patch0
161- update Patch101
162- update Patch102
163- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
164
[4650]165* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
166- rebuild with gnome-menus-3.1.5
167- add Patch0 (gnome-shell-git20110821.patch)
168
[4616]169* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
170- new upstream release
171- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
172- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
173- remove BuildRequires: xulrunner-devel
174- add Patch101 (gnome-shell-vine-settings.patch)
175- add Patch102 (gnome-shell-vine-customize.patch)
176- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
177
[915]178* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
179- add Requires: mutter
180
[914]181* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
182- new upstream release
183
[521]184* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
185- initial build for Vine Linux
186
Note: See TracBrowser for help on using the repository browser.