source: projects/specs/trunk/g/gnome-shell/gnome-shell-vl.spec @ 10721

Revision 10721, 11.0 KB checked in by Takemikaduchi, 8 years ago (diff)

gnome-shell:fix theme color
vine-themes: add icon file
task-gnome: update to 3.20.2
kernel: update to 4.4.16

RevLine 
[10716]1%define pkg_version 3.20.3
[10721]2%define pkg_release 2%{?_dist_release}
[521]3
[7474]4Summary:        Window management and application launching for GNOME
[9376]5Summary(ja):    GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
[7474]6Name:           gnome-shell
7Version:        %{pkg_version}
8Release:        %{pkg_release}
[10716]9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
[4616]10
11# settings for Vine
[9073]12Patch101:       gnome-shell-3.14.1-vine-settings.patch
[9484]13Patch102:       gnome-shell-3.16.0-revert-loginManager.patch
[9585]14Patch103:       gnome-shell-3.16.2-disable-packagekit.patch
[10721]15Patch104:       gnome-shell-3.20.3-vine-themes.patch
[4616]16
[7474]17License:        GPLv2+
18Group:          User Interface/Desktops
19URL:            http://live.gnome.org/GnomeShell
[521]20
[915]21Requires: mutter
[4704]22Requires: caribou
[6890]23Requires: ca-certificates
[6011]24Requires: at-spi2-atk
[7633]25Requires: telepathy-logger
26Requires: network-manager-applet
27Requires: gnome-tweak-tool
[915]28
[521]29BuildRequires: gnome-common
30BuildRequires: libtool
31BuildRequires: automake
32BuildRequires: autoconf
33
34BuildRequires: pkgconfig
35BuildRequires: gtk2-devel
36BuildRequires: clutter-devel
37BuildRequires: mutter-devel
38BuildRequires: gjs-devel
[4616]39BuildRequires: gnome-desktop3-devel
[521]40BuildRequires: gnome-menus-devel
41BuildRequires: libSM-devel
42BuildRequires: libffi-devel
43BuildRequires: startup-notification-devel
44BuildRequires: gnome-doc-utils
45BuildRequires: desktop-file-utils
46BuildRequires: libcroco-devel
47BuildRequires: librsvg2-devel
48BuildRequires: gobject-introspection-devel
[7633]49BuildRequires: control-center-devel
[6011]50BuildRequires: gcr-devel
[521]51BuildRequires: gstreamer-devel
52BuildRequires: dbus-glib-devel
[4616]53BuildRequires: telepathy-logger-devel
54BuildRequires: polkit-devel
55BuildRequires: pulseaudio-libs-devel
56BuildRequires: evolution-data-server-devel
[4704]57BuildRequires: folks-devel
58BuildRequires: NetworkManager-glib-devel
[7633]59BuildRequires: libnm-gtk-devel
[4812]60BuildRequires: libgudev1-devel
[6890]61BuildRequires: libcanberra-gtk3-devel
[7633]62BuildRequires: caribou-devel
[6890]63BuildRequires: ca-certificates
[9475]64BuildRequires: python3-devel
[521]65BuildRequires: intltool
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: Takemikaduchi
72
73
74%description
[4616]75GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
76It provides core interface functions like switching to windows and launching
77applications. GNOME Shell takes advantage of the capabilities of modern graphics
78hardware and introduces innovative user interface concepts to provide a delightful
79and easy to use experience.
[521]80
81
[7633]82%package        docs
83Summary:        Documentation for %{name}
84Summary(ja):    %{name} 用のドキュメント
85Group:          Documentation
86Requires:       %{name} = %{version}-%{release}
87BuildArch:              noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93
[521]94%prep
95%setup -q
[10716]96#%patch101 -p1 -b .vine
[9073]97%patch102 -p1 -b .vine
[9585]98%patch103 -p1 -b .vine
[10721]99%patch104 -p1 -b .vine
[521]100
101%build
[4812]102%configure \
[8353]103        --disable-static \
104        --disable-systemd
[4812]105
[9073]106%{__make} %{?_smp_mflags} V=1
[521]107
108
109%install
110%{__rm} -rf ${RPM_BUILD_ROOT}
111%{__make} install DESTDIR=${RPM_BUILD_ROOT}
112
[4616]113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
114
[521]115%find_lang %{name}
116
117
118
119%clean
120%{__rm} -rf ${RPM_BUILD_ROOT}
121
122
123%post
124/sbin/ldconfig
125touch --no-create %{_datadir}/icons/hicolor
126if [ -x /usr/bin/gtk-update-icon-cache ]; then
127  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128fi
129
130%postun
131/sbin/ldconfig
132touch --no-create %{_datadir}/icons/hicolor
133if [ -x /usr/bin/gtk-update-icon-cache ]; then
134  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
135fi
[4616]136glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]137
[4616]138%posttrans
139glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]140
[4616]141
[521]142%files -f %{name}.lang
[7633]143%defattr(-,root,root,-)
[4616]144%doc COPYING NEWS README
[521]145%{_bindir}/gnome-shell
[4616]146%{_bindir}/gnome-shell-extension-tool
[6011]147%{_bindir}/gnome-shell-extension-prefs
[6890]148%{_bindir}/gnome-shell-perf-tool
[7633]149%{_libdir}/%{name}/*
[4812]150%{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
[4616]151%{_libexecdir}/gnome-shell-calendar-server
152%{_libexecdir}/gnome-shell-hotplug-sniffer
153%{_libexecdir}/gnome-shell-perf-helper
[9073]154%{_libexecdir}/gnome-shell-portal-helper
[6011]155%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
[10716]156%{_datadir}/applications/org.gnome.Shell.desktop
[6011]157%{_datadir}/applications/gnome-shell-extension-prefs.desktop
[6890]158%{_datadir}/applications/evolution-calendar.desktop
[9073]159%{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
[6011]160%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
[7681]161%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
[7633]162%{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
163%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
[4616]164%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
165%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
[9073]166%{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
[4616]167%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
[7633]168%{_datadir}/%{name}/*
169%{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
170%{_mandir}/man1/%{name}.1.gz
171
172%files docs
173%defattr(-,root,root,-)
[6011]174%{_datadir}/gtk-doc/html/shell
175%{_datadir}/gtk-doc/html/st
[521]176
177
178%changelog
[10721]179* Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
180- new upstream release
181- add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
182
[10716]183* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
[10195]184- new upstream release
[10716]185- update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
[10195]186
[9821]187* Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
188- new upstream release
189
[9804]190* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
191- new upstream release
192
[9791]193* Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
194- new upstream release
195- update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
196
[9646]197* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
198- new upstream release
199
[9630]200* Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
201- add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
202
[9585]203* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
204- add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
205
[9569]206* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
207- new upstream release
208
[9520]209* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
210- new upstream release
211
[9484]212* Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
[9475]213- new upstream release
214- add BuildRequires: python3-devel
[9484]215- update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
[9475]216
[9376]217* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
218- rebuilt with libical 1.0.1
219
[9178]220* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
221- new upstream release
222
[9102]223* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
224- new upstream release
225
[9073]226* Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
227- new upstream release
228- update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
229- add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
230
[8447]231* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
232- new upstream release
233
[8369]234* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
235- new upstream release
236
[8353]237* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
238- new upstream release
239
[8219]240* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
241- new upstream release
242
[8011]243* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
244- new upstream release
245
[7938]246* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
247- new upstream release
248
[7756]249* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
250- new upstream release
251
[7712]252* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
253- new upstream release
254
[7681]255* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
256- new upstream release
257
[7633]258* Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
259- new upstream release
260- update Patch101 (gnome-shell-vine-settings.patch)
261- add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
262- add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
263- create %%{name}-docs subpackage
264
[7516]265* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
266- new upstream release
267- remove Source102 (gnome-shell.gnome-3-6.ja.po)
268
[7474]269* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
270- new upstream release
271- add Source102 (gnome-shell.gnome-3-6.ja.po)
272
[7119]273* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
274- new upstream release
275- remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
276
[7047]277* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
278- rebuild with telepathy-logger-0.6.0
279- add Patch0 (gnome-shell-3.4.1-git20121031.patch)
280
[6951]281* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
282- new upstream release
283
[6890]284* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
285- new upstream release
286- add Patch0 (gnome-shell-3.5.92-git20120921.patch)
287- update Patch101 (gnome-shell-vine-settings.patch)
288- change BuildRequires: ca-certificates instead of openssl
289- add BuildRequires: libcanberra-gtl3-devel
290
[6619]291* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
292- new upstream release
293- remove Patch103 (gnome-shell-ja.po-date.patch)
294
[6011]295* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
296- new upstream release
297- update Patch101,103
298- remove Patch0,102
299- add BuildRequires: gcr-devel
300- remove BuildRequires: GConf2-devel
301- add Requires: at-spi2-atk
302
[5448]303* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
304- new upstream release
305- remove Patch1
306
[5206]307* Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
308- add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
309- add Patch1 (gnome-shell-3.2.1-ja.po.patch)
310- rename Patch103 (gnome-shell-ja.po-date.patch)
311- drop Patch102
312
[5038]313* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
314- new upstream release
315
[4850]316* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
317- new upstream release
318
[4812]319* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
320- new upstream release
321- update Patch101
322- update Patch102
323- update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
324- add BuildRequires: libgudev1-devel, openssl
325
[4704]326* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
327- new upstream release
328- add BuildRequires: folks-devel, NetworkManager-glib-devel
329- add Requires: caribou
330- remove Patch0
331- update Patch101
332- update Patch102
333- update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
334
[4650]335* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
336- rebuild with gnome-menus-3.1.5
337- add Patch0 (gnome-shell-git20110821.patch)
338
[4616]339* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
340- new upstream release
341- add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
342- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
343- remove BuildRequires: xulrunner-devel
344- add Patch101 (gnome-shell-vine-settings.patch)
345- add Patch102 (gnome-shell-vine-customize.patch)
346- add Patch103 (gnome-shell-3.1.4-ja.po.patch)
347
[915]348* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
349- add Requires: mutter
350
[914]351* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
352- new upstream release
353
[521]354* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
355- initial build for Vine Linux
356
Note: See TracBrowser for help on using the repository browser.