source: projects/specs/trunk/g/gnome-shell-extensions/gnome-shell-extensions-vl.spec @ 4616

Revision 4616, 8.6 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Name:           gnome-shell-extensions
2Version:        3.1.4
3Release:        1%{?_dist_release}
4Summary:        Modify and extend GNOME Shell functionality and behavior
5Group:          User Interface/Desktops
6License:        GPLv2+
7URL:            http://live.gnome.org/GnomeShell/Extensions
8
9Source0:        gnome-shell-extensions-%{version}.tar.xz
10
11BuildRequires:  gnome-common
12BuildRequires:  intltool
13BuildRequires:  glib2-devel
14
15Requires:       gnome-shell >= 3.1.4
16BuildArch:      noarch
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: Takemikaduchi
21
22%description
23GNOME Shell Extensions is a collection of extensions providing additional
24and optional functionality to GNOME Shell.
25
26Enabled extensions:
27
28  * alternate-tab
29  * alternative-status-menu
30  * dock
31  * windowsNavigator
32  * user-theme
33  * auto-move-windows
34  * drive-menu
35  * places-menu
36  * native-window-placement
37# TODO: uncomment when enabling systemMonitor
38#  * systemMonitor
39
40%package        common
41Summary:        Files common to GNOME Shell Extensions
42Group:          User Interface/Desktops
43License:        GPLv2+
44%description    common
45GNOME Shell Extensions is a collection of extensions providing additional
46and optional functionality to GNOME Shell. Common files and directories
47needed by extensions are provided here.
48
49%package        alternate-tab
50Summary:        Classic Alt+Tab behavior. Window based instead of app based
51Group:          User Interface/Desktops
52License:        GPLv2+
53Requires:       %{name}-common = %{version}-%{release}
54
55%description    alternate-tab
56Lets you use classic Alt+Tab (window-based instead of app-based) in GNOME Shell. 
57GNOME Shell groups multiple instances of the same application together.
58This extension disables grouping. 
59
60%package        alternative-status-menu
61Summary:        For those who want a power off item visible at all the time
62Group:          User Interface/Desktops
63License:        GPLv2+
64Requires:       %{name}-common = %{version}-%{release}
65
66%description    alternative-status-menu
67For those who want a power off item visible at all the time, replaces
68GNOME Shell status menu with one featuring separate Suspend and Power Off.
69Adds the ability to hibernate as well.
70
71%package        dock
72Summary:        Shows a dock-style task switcher permanently
73Group:          User Interface/Desktops
74License:        GPLv2+
75Requires:       %{name}-common = %{version}-%{release}
76
77%description    dock
78Shows a dock-style task switcher on the right side of the screen permanently.
79
80%package        windowsNavigator
81Summary:        Keyboard selection of windows and work-spaces in overlay mode
82Group:          User Interface/Desktops
83License:        GPLv2+
84Requires:       %{name}-common = %{version}-%{release}
85
86%description    windowsNavigator
87Allow keyboard selection of windows and work-spaces in overlay mode in
88GNOME Shell.  Switch to overview mode (press the windows or alt+f1 key) and
89press the alt key to show numbers over windows.  Press any number to switch
90to the corresponding window.
91
92%package        user-theme
93Summary:        Lets the user select a custom theme for the shell
94Group:          User Interface/Desktops
95License:        GPLv2+
96Requires:       %{name}-common = %{version}-%{release}
97
98%description    user-theme
99Lets the user select a custom theme for the Gnome shell. It will allow you to
100apply a style from /.themes/[themeName]/gnome-shell/gnome-shell.css
101
102%package        auto-move-windows
103Summary:        Assign specific workspaces to applications
104Group:          User Interface/Desktops
105License:        GPLv2+
106Requires:       %{name}-common = %{version}-%{release}
107
108%description    auto-move-windows
109Lets you manage your workspaces more easily, assigning a specific workspace to
110each application as soon as it creates a window, in a manner configurable with a
111GSettings key.
112
113%package        drive-menu
114Summary:        Disk device manager in the system status area
115Group:          User Interface/Desktops
116License:        GPLv2+
117Requires:       %{name}-common = %{version}-%{release}
118
119%description    drive-menu
120Adds a menu in the system status area that tracks removable disk devices
121attached and offers to browse them and eject/unmount them.
122
123%package        places-menu
124Summary:        Places menu indicator in the system status area
125Group:          User Interface/Desktops
126License:        GPLv2+
127Requires:       %{name}-common = %{version}-%{release}
128
129%description    places-menu
130Adds a menu in the system status area that resembles the Places menu from
131GNOME 2.x
132
133%package        native-window-placement
134Summary:        Arrange windows in overview in a more native way
135Group:          User Interface/Desktops
136License:        GPLv2+
137Requires:       %{name}-common = %{version}-%{release}
138
139%description    native-window-placement
140This extension employs an algorithm (taken from KDE) for layouting the
141thumbnails in the overview that more closely reflects the positions and relative
142sizes of the actual windows, instead of using a fixed grid.
143
144# TODO: uncomment when enabling systemMonitor
145#%package        systemMonitor
146#Summary:        Monitor your system status
147#Group:          User Interface/Desktops
148#License:        GPLv2+
149#Requires:       %{name}-common = %{version}-%{release}
150#
151#%description    systemMonitor
152#Monitor your system status
153
154%prep
155%setup -q
156
157%build
158# since we build from a git checkout
159[ -x autogen.sh ] && NOCONFIGURE=1 ./autogen.sh
160
161# TODO: once libgtop2 >= 2.28.4 is available, enable systemMonitor extension
162# TODO: once gjs >= 0.7.15 is available, enable xrand-indicator extension
163%configure  --enable-extensions="alternate-tab alternative-status-menu dock windowsNavigator user-theme auto-move-windows drive-menu places-menu native-window-placement"
164make %{?_smp_mflags}
165
166%install
167rm -rf $RPM_BUILD_ROOT
168make install DESTDIR=$RPM_BUILD_ROOT
169
170%find_lang %{name}
171
172%files common -f %{name}.lang
173%defattr(-,root,root,-)
174%doc README
175%dir %{_datadir}/gnome-shell/extensions/
176
177%files alternate-tab
178%defattr(-,root,root,-)
179%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.alternate-tab.gschema.xml
180%{_datadir}/gnome-shell/extensions/alternate-tab*
181
182%files alternative-status-menu
183%defattr(-,root,root,-)
184%{_datadir}/gnome-shell/extensions/alternative-status-menu*
185
186%files dock
187%defattr(-,root,root,-)
188%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.dock.gschema.xml
189%{_datadir}/gnome-shell/extensions/dock*
190
191%files windowsNavigator
192%defattr(-,root,root,-)
193%{_datadir}/gnome-shell/extensions/windowsNavigator*
194
195%files user-theme
196%defattr(-,root,root,-)
197%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.user-theme.gschema.xml
198%{_datadir}/gnome-shell/extensions/user-theme*
199
200%files auto-move-windows
201%defattr(-,root,root,-)
202%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.auto-move-windows.gschema.xml
203%{_datadir}/gnome-shell/extensions/auto-move-windows*
204
205%files drive-menu
206%defattr(-,root,root,-)
207%{_datadir}/gnome-shell/extensions/drive-menu*
208
209%files places-menu
210%defattr(-,root,root,-)
211%{_datadir}/gnome-shell/extensions/places-menu*
212
213%files places-menu
214%defattr(-,root,root,-)
215%{_datadir}/gnome-shell/extensions/places-menu*
216
217%files auto-move-windows
218%defattr(-,root,root,-)
219%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.auto-move-windows.gschema.xml
220%{_datadir}/gnome-shell/extensions/auto-move-windows*
221
222%files native-window-placement
223%defattr(-,root,root,-)
224%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.native-window-placement.gschema.xml
225%{_datadir}/gnome-shell/extensions/native-window-placement*
226
227# TODO: uncomment when enabling systemMonitor
228#%files systemMonitor
229#%defattr(-,root,root,-)
230#%{_datadir}/gnome-shell/extensions/systemMonitor*
231
232%posttrans user-theme
233glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas || :
234
235%postun user-theme
236glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
237
238%posttrans auto-move-windows
239glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas || :
240
241%postun auto-move-windows
242glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
243
244%posttrans native-window-placement
245glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas || :
246
247%postun native-window-placement
248glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
249
250%posttrans dock
251glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas || :
252
253%postun dock
254glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
255
256%posttrans alternate-tab
257glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas || :
258
259%postun alternate-tab
260glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
261
262%changelog
263* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
264- initial build for Vine Linux
265
Note: See TracBrowser for help on using the repository browser.