source: projects/specs/trunk/g/gnome-settings-daemon/gnome-settings-daemon-vl.spec @ 623

Revision 623, 9.9 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1Summary:        The daemon sharing settings from GNOME to GTK+/KDE applications
2Summary(ja):    GNOME から GTK+/KDE のアプリケーションで設定を共有するためのデーモン
3
4Name:           gnome-settings-daemon
5Version:        2.28.2
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Daemons
9License:        GPLv2+
10URL:            http://ftp.gnome.org/pub/gnome/sources/%{name}
11Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/2.26/%{name}-%{version}.tar.bz2
12
13# from fedora
14# https://bugzilla.gnome.org/show_bug.cgi?id=596136
15Patch0: 0002-Use-a-rounded-instead-of-curved-rectangle.patch
16Patch1: 0003-Improve-the-media-keys-overlay-design.patch
17# https://bugzilla.gnome.org/show_bug.cgi?id=567249
18Patch4: 0001-Fix-bluriness-in-level-bar-and-popup.patch
19
20# https://bugzilla.redhat.com/show_bug.cgi?id=498249
21Patch2: left-handed-touchpad.patch
22
23# change font rendering
24Patch3: slight-hinting.patch
25
26# vine
27Patch100:       gnome-settings-daemon-2.28.1-default-font-setting.patch
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Requires(pre): GConf2 >= 2.14
32Requires(preun): GConf2 >= 2.14
33Requires(post): GConf2 >= 2.14
34
35BuildRequires:  dbus-glib-devel
36BuildRequires:  GConf2-devel
37BuildRequires:  gtk2-devel
38BuildRequires:  gnome-desktop-devel >= 2.26.3
39BuildRequires:  libgnome-devel
40BuildRequires:  xorg-x11-proto-devel
41BuildRequires:  libXrandr-devel
42BuildRequires:  fontconfig-devel
43BuildRequires:  gstreamer-devel
44BuildRequires:  gstreamer-plugins-base-devel
45BuildRequires:  pulseaudio-libs-devel
46BuildRequires:  libgnomekbd-devel >= 2.28.0
47BuildRequires:  libxklavier-devel >= 4.0
48BuildRequires:  libnotify-devel >= 0.4.3
49BuildRequires:  gettext
50BuildRequires:  perl-XML-Parser
51
52%description
53A daemon to share settings from GNOME to other applications. It also
54handles global keybindings, as well as a number of desktop-wide settings.
55
56%package        devel
57Summary:        Development files for %{name}
58Group:          Development/Libraries
59Requires:       %{name} = %{version}-%{release}
60Requires:       pkgconfig
61Requires:       dbus-glib-devel
62
63%description    devel
64The %{name}-devel package contains libraries and header files for
65developing applications that use %{name}.
66
67%prep
68%setup -q
69## %patch4 -p1 -b .blurry
70%patch0 -p1 -b .osd-rounded-rectangle
71%patch1 -p1 -b .osd-visual-refresh
72## %patch2 -p1 -b .left-handed-touchpad
73%patch3 -p1 -b .slight-hinting
74
75%patch100 -p1 -b .defaults
76
77%build
78%configure --enable-static=no --enable-profiling --disable-esd
79make %{?_smp_mflags}
80
81# strip unneeded translations from .mo files
82# ideally intltool (ha!) would do that for us
83# http://bugzilla.gnome.org/show_bug.cgi?id=474987
84cd po
85grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
86mv POTFILES.keep POTFILES.in
87intltool-update --pot
88for p in *.po; do
89  msgmerge $p %{name}.pot > $p.out
90  msgfmt -o `basename $p .po`.gmo $p.out
91done
92
93%install
94rm -rf $RPM_BUILD_ROOT
95make install DESTDIR=$RPM_BUILD_ROOT
96find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
97
98%find_lang %{name} --with-gnome
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post
104export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105gconftool-2 --makefile-install-rule \
106        %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
107        %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
108        %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
109        %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
110        %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
111        >& /dev/null || :
112touch %{_datadir}/icons/hicolor
113if [ -x /usr/bin/gtk-update-icon-cache ]; then
114  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
115fi
116 
117%pre
118if [ "$1" -gt 1 ]; then
119        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
120        if [ -f %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas ] ; then
121                gconftool-2 --makefile-uninstall-rule \
122                        %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
123                        >& /dev/null || :
124        fi
125        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
126        if [ -f %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas ] ; then
127                gconftool-2 --makefile-uninstall-rule \
128                        %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas \
129                        >& /dev/null || :
130        fi
131        gconftool-2 --makefile-uninstall-rule \
132                %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
133                %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
134                %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
135                %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
136                >& /dev/null || :
137fi
138
139%preun
140if [ "$1" -eq 0 ]; then
141        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142        if [ -f %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas ] ; then
143                gconftool-2 --makefile-uninstall-rule \
144                        %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
145                        >& /dev/null || :
146        fi
147        if [ -f %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas ] ; then
148                gconftool-2 --makefile-uninstall-rule \
149                        %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas \
150                        >& /dev/null || :
151        fi
152        gconftool-2 --makefile-uninstall-rule \
153                %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
154                %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
155                %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
156                %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
157                >& /dev/null || :
158fi
159
160%postun
161touch %{_datadir}/icons/hicolor
162if [ -x /usr/bin/gtk-update-icon-cache ]; then
163  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
164fi
165 
166%files -f %{name}.lang
167%defattr(-,root,root,-)
168%doc AUTHORS COPYING NEWS
169%{_sysconfdir}/gconf/schemas/*
170%{_sysconfdir}/xdg/autostart/gnome-settings-daemon.desktop
171%{_libdir}/gnome-settings-daemon-2.0
172%{_libexecdir}/gnome-settings-daemon
173%{_libexecdir}/gsd-locate-pointer
174%{_datadir}/gnome-settings-daemon/
175%{_datadir}/dbus-1/services/org.gnome.SettingsDaemon.service
176%{_datadir}/icons/hicolor/*/apps/gsd-xrandr.*
177%{_datadir}/gnome-control-center/keybindings/*.xml
178
179%files devel
180%defattr(-,root,root,-)
181%{_includedir}/gnome-settings-daemon-2.0
182%{_libdir}/pkgconfig/gnome-settings-daemon.pc
183
184%changelog
185* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
186- new upstream release
187- drop Patch2, Patch4
188
189* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
190- new upstream release
191- updated Patch100
192
193* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
194- import patches from fedora
195  - Patch10: listen for DeviceAdded
196  - Patch11,12: add support touchpads
197  - Patch13: Make custom keybindings work better
198  - Patch14: Don't rely on _BACKUP property for xkb initialization
199
200* Wed Apr 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.1-1
201- new upstream release
202
203* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
204- update Patch10
205  - change hinting type to "none" instead of "medium"
206
207* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
208- add Patch10 to set default dpi
209
210* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
211- new upstream release
212
213* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
214- new upstream release
215
216* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
217- new upstream release
218
219* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
220- build with pulseaudio
221- add patch6 to ignore the legacy ESD GConf preference if compiled
222  to use Pulseaudio
223
224* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.2.1-1
225- new upstream release
226
227* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.1-1vl5
228- new upstream release
229
230* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
231- Initial build for Vine Linux
232
233* Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.1-0.2008.03.26.3
234- Add patch for the mouse plugin not to eat multimedia key events (#438942)
235
236* Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.2
237- Rebuild
238
239* Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.1
240- Update to snapshot
241- Enable profiling
242
243* Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
244- apps_gnome_settings_daemon_default_editor.schemas is obsolete (#438937)
245
246* Thu Mar 20 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-2
247- Fix interaction between "Locate Pointer" and volume keys
248
249* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-1
250- Update to 2.22.0
251
252* Sun Mar  9 2008 Ray Strode <rstrode@redhat.com> - 2.21.92-3
253- Don't set keyboard model on startup from gconf if evdev is being used.
254  Evdev needs to use its own keyboard model to work right.
255
256* Sun Mar  2 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.92-2
257- Update randr patch to handle video key
258
259* Fri Feb 29 2008 Jon McCann <jmccann@redhat.com> - 2.21.92-1
260- Update to 2.21.92
261
262* Tue Feb 12 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.91-3
263- Add patch to make the xrandr plugin listen for client messages from
264  the control panel and reread the configuration file.
265
266* Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-2
267- Remove obsolete control-center translations
268
269* Mon Feb 11 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.91-1
270- Update to 2.21.91
271- Remove obsolete patches
272
273* Thu Feb  7 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.90.1-3
274- Load xkb settings initially
275
276* Thu Jan 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-2
277- Fix the path for g-s-d, from upstream patch
278
279* Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-1
280- Update to 2.21.90.1
281
282* Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90-1
283- Update to 2.21.90
284
285* Tue Jan 15 2008  Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-2
286- Incorporate review feedback (#428833)
287
288* Tue Jan 15 2008  Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-1
289- Update to 2.21.5.2
290
291* Tue Jan 15 2008  Matthias Clasen <mclasen@redhat.com> - 2.21.5.1-1
292- Update to 2.21.5.1
293- Fix up BuildRequires
294
295* Thu Dec 06 2007 - Bastien Nocera <bnocera@redhat.com> - 2.21.5-1
296- First package
297
Note: See TracBrowser for help on using the repository browser.