source: projects/specs/trunk/g/gnome-settings-daemon/gnome-settings-daemon-vl.spec @ 4616

Revision 4616, 8.8 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Summary:        The daemon sharing settings from GNOME to GTK+/KDE applications
2Summary(ja):    GNOME から GTK+/KDE のアプリケーションで設定を共有するためのデーモン
3
4Name:           gnome-settings-daemon
5Version:        3.1.4
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Daemons
9License:        GPLv2+
10URL:            http://ftp.gnome.org/pub/gnome/sources/%{name}
11Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/3.1/%{name}-%{version}.tar.xz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15Requires(pre): GConf2 >= 2.14
16Requires(preun): GConf2 >= 2.14
17Requires(post): GConf2 >= 2.14
18
19BuildRequires:  dbus-glib-devel
20BuildRequires:  GConf2-devel
21BuildRequires:  gtk3-devel
22BuildRequires:  gnome-desktop3-devel >= 3.0.0
23BuildRequires:  libgnome-devel
24BuildRequires:  xorg-x11-proto-devel
25BuildRequires:  libXrandr-devel
26BuildRequires:  fontconfig-devel
27BuildRequires:  gstreamer-devel
28BuildRequires:  gstreamer-plugins-base-devel
29BuildRequires:  pulseaudio-libs-devel
30BuildRequires:  libgnomekbd-devel >= 2.32.0
31BuildRequires:  libxklavier-devel >= 5.0
32BuildRequires:  libnotify-devel >= 0.4.3
33BuildRequires:  gettext
34BuildRequires:  perl-XML-Parser
35BuildRequires:  libSM-devel
36BuildRequires:  libgudev1-devel
37BuildRequires:  nss-devel
38BuildRequires:  polkit-devel
39BuildRequires:  cups-devel
40BuildRequires:  upower-devel >= 0.9.12
41BuildRequires:  libcanberra-gtk3-devel
42BuildRequires:  colord-devel
43BuildRequires:  lcms2-devel
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: Takemikaduchi
48
49%description
50A daemon to share settings from GNOME to other applications. It also
51handles global keybindings, as well as a number of desktop-wide settings.
52
53%package        devel
54Summary:        Development files for %{name}
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57Requires:       pkgconfig
58Requires:       dbus-glib-devel
59
60%description    devel
61The %{name}-devel package contains libraries and header files for
62developing applications that use %{name}.
63
64%prep
65%setup -q
66
67%build
68%configure \
69        --disable-static \
70        --disable-profiling \
71        --enable-pulse \
72        --disable-packagekit
73       
74make %{?_smp_mflags}
75
76# strip unneeded translations from .mo files
77# ideally intltool (ha!) would do that for us
78# http://bugzilla.gnome.org/show_bug.cgi?id=474987
79cd po
80grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
81mv POTFILES.keep POTFILES.in
82intltool-update --pot
83for p in *.po; do
84  msgmerge $p %{name}.pot > $p.out
85  msgfmt -o `basename $p .po`.gmo $p.out
86done
87
88%install
89rm -rf $RPM_BUILD_ROOT
90make install DESTDIR=$RPM_BUILD_ROOT
91find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
92
93%find_lang %{name} --with-gnome
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post
99touch %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
102fi
103 
104%postun
105touch %{_datadir}/icons/hicolor
106if [ -x /usr/bin/gtk-update-icon-cache ]; then
107  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
108fi
109glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
110
111%posttrans
112glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
113 
114%files -f %{name}.lang
115%defattr(-,root,root,-)
116%doc AUTHORS COPYING NEWS
117%{_sysconfdir}/dbus-1/system.d/org.gnome.SettingsDaemon.DateTimeMechanism.conf
118%{_sysconfdir}/xdg/autostart/gnome-fallback-mount-helper.desktop
119%{_sysconfdir}/xdg/autostart/gnome-settings-daemon.desktop
120%{_libdir}/gnome-settings-daemon-3.0
121%{_libexecdir}/*
122%{_datadir}/GConf/gsettings/gnome-settings-daemon.convert
123%{_datadir}/dbus-1/services/org.gnome.SettingsDaemon.service
124%{_datadir}/dbus-1/system-services/org.gnome.SettingsDaemon.DateTimeMechanism.service
125%{_datadir}/glib-2.0/schemas/*.xml
126%{_datadir}/gnome-settings-daemon/
127%{_datadir}/gnome-settings-daemon-3.0/
128%{_datadir}/icons/hicolor/*/apps/gsd-xrandr.*
129%{_datadir}/icons/hicolor/*/actions/touchpad*
130%{_mandir}/man1/gnome-settings-daemon.1.gz
131%{_datadir}/polkit-1/actions/org.gnome.settingsdaemon.datetimemechanism.policy
132
133%files devel
134%defattr(-,root,root,-)
135%{_includedir}/gnome-settings-daemon-3.0
136%{_libdir}/pkgconfig/gnome-settings-daemon.pc
137
138%changelog
139* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
140- new upstream release
141- add BuildRequires: libgudev1-devel, nss-devel, polkit-devel, cups-devel, upower-devel
142                     libcanberra-gtk3-devel, colord-devel, lcms2-devel
143- change BuildRequires: gtk3-devel instead of gtk2-devel
144- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
145- drop all Patches
146- fix configure option
147
148* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
149- new upstream release
150
151* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
152- new upstream release
153
154* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
155- rebuild with rpm-4.8.1 for pkg-config file
156
157* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
158- new upstream release
159
160* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
161- new upstream release
162
163* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
164- new upstream release
165- add BuildRequires: libSM-devel
166- drop Patch0, Patch1
167
168* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
169- new upstream release
170- drop Patch2, Patch4
171
172* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
173- new upstream release
174- updated Patch100
175
176* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
177- import patches from fedora
178  - Patch10: listen for DeviceAdded
179  - Patch11,12: add support touchpads
180  - Patch13: Make custom keybindings work better
181  - Patch14: Don't rely on _BACKUP property for xkb initialization
182
183* Wed Apr 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.1-1
184- new upstream release
185
186* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
187- update Patch10
188  - change hinting type to "none" instead of "medium"
189
190* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
191- add Patch10 to set default dpi
192
193* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
194- new upstream release
195
196* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
197- new upstream release
198
199* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
200- new upstream release
201
202* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
203- build with pulseaudio
204- add patch6 to ignore the legacy ESD GConf preference if compiled
205  to use Pulseaudio
206
207* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.2.1-1
208- new upstream release
209
210* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.1-1vl5
211- new upstream release
212
213* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
214- Initial build for Vine Linux
215
216* Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.1-0.2008.03.26.3
217- Add patch for the mouse plugin not to eat multimedia key events (#438942)
218
219* Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.2
220- Rebuild
221
222* Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.1
223- Update to snapshot
224- Enable profiling
225
226* Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
227- apps_gnome_settings_daemon_default_editor.schemas is obsolete (#438937)
228
229* Thu Mar 20 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-2
230- Fix interaction between "Locate Pointer" and volume keys
231
232* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-1
233- Update to 2.22.0
234
235* Sun Mar  9 2008 Ray Strode <rstrode@redhat.com> - 2.21.92-3
236- Don't set keyboard model on startup from gconf if evdev is being used.
237  Evdev needs to use its own keyboard model to work right.
238
239* Sun Mar  2 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.92-2
240- Update randr patch to handle video key
241
242* Fri Feb 29 2008 Jon McCann <jmccann@redhat.com> - 2.21.92-1
243- Update to 2.21.92
244
245* Tue Feb 12 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.91-3
246- Add patch to make the xrandr plugin listen for client messages from
247  the control panel and reread the configuration file.
248
249* Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-2
250- Remove obsolete control-center translations
251
252* Mon Feb 11 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.91-1
253- Update to 2.21.91
254- Remove obsolete patches
255
256* Thu Feb  7 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.90.1-3
257- Load xkb settings initially
258
259* Thu Jan 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-2
260- Fix the path for g-s-d, from upstream patch
261
262* Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-1
263- Update to 2.21.90.1
264
265* Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90-1
266- Update to 2.21.90
267
268* Tue Jan 15 2008  Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-2
269- Incorporate review feedback (#428833)
270
271* Tue Jan 15 2008  Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-1
272- Update to 2.21.5.2
273
274* Tue Jan 15 2008  Matthias Clasen <mclasen@redhat.com> - 2.21.5.1-1
275- Update to 2.21.5.1
276- Fix up BuildRequires
277
278* Thu Dec 06 2007 - Bastien Nocera <bnocera@redhat.com> - 2.21.5-1
279- First package
280
Note: See TracBrowser for help on using the repository browser.