source: projects/specs/trunk/g/gnome-session/gnome-session-vl.spec @ 4616

Revision 4616, 11.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define glib2_version 2.28.6
2%define pango_version 1.28.4
3%define gtk3_version 3.0.9
4%define gconf2_version 2.32.2
5%define dbus_glib_version 0.88
6%define dbus_version 1.4.0
7%define libnotify_version 0.4.5
8
9%define po_package gnome-session-3.0
10
11Summary: GNOME session manager
12Summary(ja): GNOME セッションマネージャ
13Name: gnome-session
14Version: 3.1.3
15Release: 1%{?_dist_release}
16URL: http://www.gnome.org/
17License: GPLv2+
18Group: User Interface/Desktops
19
20Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-session/3.1/%{name}-%{version}.tar.xz
21Source1: vine-default-session
22Source2: gnome.desktop
23Source3: gnome-session.gnome-2-32.ja.po
24
25# fixed upstream
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: pango-devel >= %{pango_version}
30BuildRequires: gtk2-devel >= %{gtk2_version}
31BuildRequires: GConf2-devel >= %{gconf2_version}
32BuildRequires: dbus-devel >= %{dbus_version}
33BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
34BuildRequires: libnotify-devel >= %{libnotify_version}
35BuildRequires: librsvg2-devel
36BuildRequires: usermode
37BuildRequires: startup-notification-devel
38BuildRequires: libSM-devel
39BuildRequires: desktop-file-utils
40BuildRequires: upower-devel
41
42Requires(post): GConf2 >= %{gconf2_version}
43Requires(pre): GConf2 >= %{gconf2_version}
44Requires(preun): GConf2 >= %{gconf2_version}
45Conflicts: gdm < 2.4.0.7
46Requires: vine-backgrounds >= 3.8
47Requires: control-center
48Requires: gsettings-desktop-schemas
49
50Vendor: Project Vine
51Distribution: Vine Linux
52Packager: Takemikaduchi
53
54%description
55gnome-session manages a GNOME desktop session. It starts up the other core
56GNOME components and handles logout and saving the session.
57
58
59%prep
60%setup -q
61#cp %{SOURCE3} po/ja.po
62
63%build
64#sed -i -e 's/GNOME_COMPILE_WARNINGS.*//' configure.in
65
66#aclocal
67#automake
68#intltoolize --force --copy
69#autoheader
70#autoconf
71
72%configure \
73    --enable-compile-warnings=no \
74    --enable-polkit \
75    --disable-schemas-install
76make %{?_smp_mflags}
77
78#    --with-halt-command=/usr/bin/poweroff \
79#    --with-reboot-command=/usr/bin/reboot \
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
85make install DESTDIR=$RPM_BUILD_ROOT
86unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
87
88desktop-file-install --vendor gnome --delete-original                   \
89  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
90  --add-only-show-in GNOME                                              \
91  $RPM_BUILD_ROOT%{_datadir}/applications/*
92#  --add-category Settings                                               \
93#  --add-category AdvancedSettings                                      \
94
95./mkinstalldirs ${RPM_BUILD_ROOT}%{_datadir}/xsessions/
96install -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}%{_datadir}/xsessions/
97
98#/bin/rm $RPM_BUILD_ROOT%{_datadir}/gnome/default.session
99./mkinstalldirs ${RPM_BUILD_ROOT}%{_datadir}/gnome/
100install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnome/default.session
101
102mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
103mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
104
105# remove gnome default splash screen
106#rm -rf $RPM_BUILD_ROOT%{_datadir}/pixmaps/splash/*
107mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/splash
108
109#
110rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
111
112%find_lang %{po_package}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118
119%postun
120/sbin/ldconfig
121glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
122
123%posttrans
124glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
125
126
127%files -f %{po_package}.lang
128%defattr(-,root,root)
129%doc AUTHORS COPYING ChangeLog NEWS README
130#doc %{_docdir}/%{name}/dbus/gnome-session.html
131%{_sysconfdir}/xdg/autostart
132%{_bindir}/*
133%{_libexecdir}/gnome-session-check-accelerated
134%{_libexecdir}/gnome-session-check-accelerated-helper
135%{_datadir}/GConf/gsettings/gnome-session.convert
136%{_datadir}/glib-2.0/schemas/org.gnome.SessionManager.gschema.xml
137%{_datadir}/gnome
138%{_datadir}/gnome-session/*.ui
139%{_datadir}/gnome-session/sessions/*
140%{_datadir}/applications/*
141%{_datadir}/xsessions/*
142%dir %{_datadir}/pixmaps/splash
143%{_datadir}/icons/hicolor/*
144%{_mandir}/man*/*
145
146
147%changelog
148* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
149- new upstream release
150- add BuildRequires: librsvg2-devel
151- add Requires: gsettings-desktop-schemas
152
153* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
154- new upstream release
155
156* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-2
157- update translation.
158
159* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
160- new upstream release
161- remove BuildRequires: libgnome-devel, libgnomeui-devel
162
163* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
164- new upstream release
165
166* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
167- new upstream release
168- remove BuildRequires: gnome-keyring
169- change BuildRequires: DeviceKit-power-devel -> upower-devel
170- add BuildRequires: startup-notification-devel, libSM-devel, desktop-file-utils
171
172* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
173- new upstream release
174- added BR: DeviceKit-power-devel
175- removed BR: PolicyKit-gnome-devel
176
177* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
178- new upstream release
179
180* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.1-1
181- new upstream release
182- added BuildRequires: PolicyKit-gnome-devel
183
184* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
185- new upstream release
186
187* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
188- new upstream release
189
190* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
191- new upstream release
192
193* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
194- add patch5,6,7,8 from upstream/fedora
195- remove gnome-volume-manager from vine-default-session
196
197* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
198- new upstream release
199
200* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
201- new upstream release
202
203* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
204- new upstream release
205
206* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
207- new upstream release
208- updated Patch100
209
210* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
211- new upstream release
212
213* Wed Jul  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
214- new upstream release
215
216* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
217- add BuildRequires: control-center-devel
218
219* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
220- new upstream release
221
222* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
223- new upstream release
224- remove default gnome-splash.png, use our splash.
225- add Requires: vine-backgrounds >= 3.8
226
227* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
228- new upstream release
229
230* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
231- new upstream release
232
233* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
234- new upstream release
235
236* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
237- new upstream release
238
239* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
240- new upstream release
241
242* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
243- new upstream release
244
245* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
246- new upstream version
247
248* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
249- new upstream release
250
251* Sun Oct 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
252- new upstream release
253
254* Sun Oct 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
255- rebuild with new environment
256
257* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
258- new upstream release
259
260* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
261- new upstream release
262- remove old gdm session file.
263
264* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
265- new upstream release
266
267* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
268- new upstream release
269
270* Tue Apr 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
271- new upstream release
272- import patch6,8 from rawhide release
273
274* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
275- new upstream release
276
277* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
278- new upstream release
279
280* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
281- new upstream release
282
283* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
284- new upstream release
285
286* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
287- build for Vine Linux
288- new upstream release from gnome-2.1.4
289
290* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
291- 2.1.2
292
293* Tue Sep  3 2002 Owen Taylor <otaylor@redhat.com>
294- Up purge delay for session manager to 5 minutes to avoid problem
295  with openoffice.org timing out
296
297* Wed Aug 28 2002 Havoc Pennington <hp@redhat.com>
298- put gdm session in here, conflict with old gdm
299- use DITHER_MAX for dithering to make splash screen look good in 16
300  bit
301
302* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
303- fix missing icons and misaligned text in splash
304
305* Fri Aug 23 2002 Tim Waugh <twaugh@redhat.com>
306- Fix login sound disabling (bug #71664).
307
308* Wed Aug 14 2002 Havoc Pennington <hp@redhat.com>
309- put rhn applet in default session
310
311* Wed Aug 14 2002 Havoc Pennington <hp@redhat.com>
312- fix the session file, should speed up login a lot
313- put magicdev in default session
314
315* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
316- 2.0.5 with more translations
317
318* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
319- 2.0.4
320- remove gnome-settings-daemon from default session
321
322* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
323- 2.0.3
324- remove splash screen, require redhat-artwork instead
325
326* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
327- Set GTK_RC_FILES so we can change the gtk1 theme
328
329* Tue Jul 16 2002 Havoc Pennington <hp@redhat.com>
330- pass --with-halt-command=/usr/bin/poweroff
331  --with-reboot-command=/usr/bin/reboot
332
333* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
334- Version 2.0.1, fixing missing po files
335
336* Wed Jun 19 2002 Havoc Pennington <hp@redhat.com>
337- put in new default session with pam-panel-icon
338- disable schema install in make install, fixes rebuild failure.
339
340* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
341- rebuild with new libraries
342
343* Thu Jun 13 2002 Havoc Pennington <hp@redhat.com>
344- rebuild in different environment
345
346* Thu Jun 13 2002 Havoc Pennington <hp@redhat.com>
347- add fix from Nalin to build require usermode
348
349* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
350- 2.0.0
351
352* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
353- install the schemas, so we get a logout dialog and splash
354- put in the splash from 7.3
355
356* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
357- rebuild in different environment
358
359* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
360- rebuild in new environment, require newer gtk2
361
362* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
363- remove obsoletes/provides gnome-core
364
365* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
366- rebuild in different environment
367
368* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
369- 1.5.21
370
371* Sun May 26 2002 Tim Powers <timp@redhat.com>
372- automated rebuild
373
374* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
375- rebuild in different environment
376
377* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
378- 1.5.19
379- add more build reqs to chill out build system
380- provide gnome-core
381
382* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
383- obsolete gnome-core
384- 1.5.18
385
386* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
387- default to metacity
388
389* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
390- Initial build.
391
392
Note: See TracBrowser for help on using the repository browser.