source: projects/specs/trunk/g/gnome-print/gnome-print-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define ver     0.37
3%define rel     2%{?_dist_release}
4%define name    gnome-print
5%define sover   15
6
7Summary:        Gnome Print - Printing libraries for GNOME.
8Summary(ja):    Gnome Print - GNOME用印刷ライブラリ
9Name:           %{name}
10Version:        %{ver}
11Release:        %{rel}
12License:        LGPL
13Group:          Applications/Publishing
14Source:         ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{ver}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gnome-libs-devel >= 1.4.2-2vl5
17BuildRequires:  libxml-devel
18BuildRequires:  gdk-pixbuf-devel
19BuildRequires:  freetype2-devel
20BuildRequires:  automake14, autoconf213
21Requires:       libgnomeprint%{sover} = %{version}
22Requires:       urw-fonts ghostscript-fonts
23Prereq:         libxml urw-fonts ghostscript-fonts
24
25Obsoletes:      gnome-print-beta < 0.26, gnome-print-bin < 0.26, gnome-print-beta-bin < 0.26, gnome-print-data < 0.26
26
27# RH patches
28Patch2:         gnome-print-0.30-nofontmaps.patch
29
30# for Vine
31Patch50:        gnome-print-0.34-fallback.patch
32Patch51:        gnome-print-0.35-dynamicfallback.patch
33Patch52:        gnome-print-0.37-ft2build.patch
34
35%description
36GNOME (GNU Network Object Model Environment) is a user-friendly set of
37applications and desktop tools to be used in conjunction with a window
38manager for the X Window System.  GNOME is similar in purpose and scope
39to CDE and KDE, but GNOME is based completely on free software.
40The gnome-print package contains libraries and fonts that are needed by
41GNOME applications wanting to print.
42
43You should install the gnome-print package if you intend on using any of
44the GNOME applications that can print. If you would like to develop GNOME
45applications that can print you will also need to install the gnome-print
46devel package.
47
48%description -l ja
49印刷できるGNOMEアプリケーションを使いたいなら、gnome-printパッケージを
50インストールする必要があります。もし印刷できるGNOMEアプリケーションを
51開発したいなら、gnome-print-develパッケージをインストールする必要が
52あります。
53
54%package -n libgnomeprint%{sover}
55Summary:        Printing libraries for GNOME
56Summary(ja):    GNOME用印刷ライブラリ
57Group:          System Environment/Libraries
58Obsoletes:      gnome-print-beta < 0.26
59
60%description -n libgnomeprint%{sover}
61This package contains the printing apparatus for GNOME, the complete
62graphical desktop environment based entirely on free software.
63
64%package devel
65Summary:        Libraries and include files for developing GNOME applications.
66Summary(ja):    GNOME用印刷アプリケーション開発用ライブラリとヘッダファイル
67Group:          Development/Libraries
68Obsoletes:      gnome-print-beta-devel < 0.26
69Requires:       %{name} = %{version}
70Requires:       libgnomeprint%{sover} = %{version}
71Requires:       gdk-pixbuf-devel
72
73%description devel
74GNOME (GNU Network Object Model Environment) is a user-friendly set of
75applications and desktop tools to be used in conjunction with a window
76manager for the X Window System.  GNOME is similar in purpose and scope
77to CDE and KDE, but GNOME is based completely on free software.
78The gnome-print-devel package includes the libraries and include files that
79you will need when developing applications that use the GNOME printing
80facilities.
81
82You should install the gnome-print-devel package if you would like to
83develop GNOME applications that will use the GNOME printing facilities.
84You don't need to install the gnome-print-devel package if you just want
85to use the GNOME desktop enviornment.
86
87#'
88%prep
89%setup -q
90%patch2 -p1 -b .nofontmaps
91%patch50 -p1 -b .fallback
92%patch51 -p1 -b .dynamic
93%patch52 -p1 -b .ft2build
94
95%build
96libtoolize --copy --force
97autoheader-2.13
98automake-1.4
99autoconf-2.13
100%configure --disable-static
101make LIBTOOL=/usr/bin/libtool
102%install
103[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
104%makeinstall LIBTOOL=/usr/bin/libtool
105./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
106./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gnome/fonts
107install -c fonts/*.font $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
108
109cat > $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install <<__EOF__
110#! /bin/sh
111%{_bindir}/gnome-font-install --clean \
112        --aliases=%{_datadir}/gnome-print/fonts/adobe-urw.font \
113        --target=%{_sysconfdir}/gnome/fonts/gnome-print-rpm.fontmap \
114        --recursive \
115        %{_prefix}/X11R6/lib/X11/fonts \
116        %{_datadir}/fonts
117__EOF__
118chmod a+x $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install
119
120%find_lang %{name}
121
122## remove unuse files
123rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
124
125%clean
126[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
127
128%post -p %{_bindir}/vine-update-gnome-font-install
129
130%post -n libgnomeprint%{sover} -p /sbin/ldconfig
131
132%postun -n libgnomeprint%{sover} -p /sbin/ldconfig
133
134
135%files -f %{name}.lang
136%defattr(-, root, root)
137%doc AUTHORS COPYING ChangeLog NEWS README
138%dir %{_datadir}/gnome-print
139%dir %{_datadir}/gnome-print/profiles
140%dir %{_sysconfdir}/gnome/fonts
141%{_datadir}/gnome-print/profiles/*
142%{_bindir}/*
143%{_datadir}/fonts/afms/adobe/*
144%{_datadir}/gnome-print/fonts
145
146%files -n libgnomeprint%{sover}
147%defattr(-, root, root)
148%{_libdir}/*.so.%{sover}.*
149%{_libdir}/*.so.%{sover}
150
151%files devel
152%defattr(-, root, root)
153%{_libdir}/*.so
154#{_libdir}/*.a
155#{_libdir}/*.la
156%{_libdir}/*.sh
157%{_includedir}/*
158
159%changelog
160* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-2
161- rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6.21)
162- removed *.a
163
164* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.37-1vl5
165- applied new versioning policy, spec in utf-8
166- removed *.la
167
168* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl2
169- rebuilt with db4-4.3.29
170
171* Mon Oct 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl1
172- updated to 0.37
173- rebuilt with db4-4.2.52
174- added Patch52 to build with freetype2
175- s/Copyright/License/
176- fixed %post, %postun section
177
178* Fri Jan 17 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.35-0vl2
179- rebuilt with db4 environment
180- added BuildPreReq: automake14, autoconf213
181
182* Wed Mar 20 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.35-0vl1
183- New upstream release.
184- vine-update-gnome-font-install: added a wrapper script for generating
185  gnome-print's fontmap. it will helps us if font packages will calls it
186  with %%post and %%postun.
187- %%post: changed calling vine-update-gnome-font-install.
188- gnome-print-0.35-dynamicfallback.patch:
189  generate hash using NAMES file.
190
191* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl3
192- Fixed fontmap generation.
193  Note: don't remove --clean option. when gnome-font-install regenerate
194  fontmap, it don't add the fonts which already exists.
195
196* Wed Dec 26 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.34-0vl2
197- added PreReq: freetype2 for gnome-font-install invoked from %%post section
198- commented out Requires: %%{name} >= %%{ver} from libgnomeprint15
199
200* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl1
201- New upstream release.
202
203* Sun Apr  1 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl3
204- Added Obsolates to libgnomeprint11.
205- Added some build requires.
206
207* Mon Mar 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl2
208- New upstream release.
209
210* Tue Jan 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl6
211- Fixed -devel conflicts.
212
213* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl5
214- Added Conflicts: line in -devel.
215
216* Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl4
217- separated binary and data packages.
218
219* Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
220- added prereq urw-fonts
221
222* Wed May 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
223- modified jahack pach to fix threshold value of MB_CUR_MAX for glibc 2.1.3.
224
225* Mon May 30 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
226- updated to 0.20
227
228* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
229- modified jahack patch for satbility of memory allocation.
230- modified jahack patch to fix text alignment.
231
232* Sat May 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
233- modified jahack patch for preview.
234- added i18n_fix for nls.
235- added orignal ja.po.
236
237* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
238- updated to 0.19
239
240* Mon May  1 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
241- updated to 0.18
242
243* Wed Feb 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
244- updated to 0.12
245
246* Mon Jan 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
247- added "quick hacked" ja patch.
248
249* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatotu.org>
250- add Provides: libgnomeprint.so.2
251
252* Sat Oct 13 1999 Kazuhito Nishi <nishi@imasy.or.jp>
253- Added Prereq: zlib
254
255* Sun Aug 01 1999 Gregory McLean <gregm@comstar.net>
256- Undo my draconian uninstall stuff.
257
258* Tue Jul 20 1999 Gregory McLean <gregm@comstar.net>
259- Stab at cleaning up properly when we uninstall.
260
261* Fri Jul 16 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
262- fixed typo in spec
263
264* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
265- Added fonts to the spec.
266
267* Mon Jul 05 1999 Gregory McLean <gregm@comstar.net>
268- Fleshed out the descriptions.
Note: See TracBrowser for help on using the repository browser.