source: projects/specs/trunk/g/gnome-print/gnome-print-vl.spec @ 1929

Revision 1929, 9.1 KB checked in by owa, 14 years ago (diff)

rebuilt bonobo, gnome-print, gtk+

Line 
1# Note that this is NOT a relocatable package
2%define ver     0.37
3%define rel     3%{?_dist_release}
4%define name    gnome-print
5%define sover   15
6
7Summary:        Gnome Print - Printing libraries for GNOME.
8Summary(ja):    Gnome Print - GNOME用印刷ライブラリ
9Name:           %{name}
10Version:        %{ver}
11Release:        %{rel}
12License:        LGPL
13Group:          Applications/Publishing
14Source:         ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{ver}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gnome-libs-devel >= 1.4.2-2vl5
17BuildRequires:  libxml-devel
18BuildRequires:  gdk-pixbuf-devel
19BuildRequires:  freetype2-devel
20BuildRequires:  automake14, autoconf213
21Requires:       libgnomeprint%{sover} = %{version}
22Requires:       urw-fonts ghostscript-fonts
23#Prereq:                libxml urw-fonts ghostscript-fonts
24Requires:               libxml urw-fonts ghostscript-fonts
25
26Obsoletes:      gnome-print-beta < 0.26, gnome-print-bin < 0.26, gnome-print-beta-bin < 0.26, gnome-print-data < 0.26
27
28# RH patches
29Patch2:         gnome-print-0.30-nofontmaps.patch
30
31# for Vine
32Patch50:        gnome-print-0.34-fallback.patch
33Patch51:        gnome-print-0.35-dynamicfallback.patch
34Patch52:        gnome-print-0.37-ft2build.patch
35
36Patch60: gnome-print-0.37-config.patch
37Patch61: gnome-print-0.37-parseTT.patch
38
39%description
40GNOME (GNU Network Object Model Environment) is a user-friendly set of
41applications and desktop tools to be used in conjunction with a window
42manager for the X Window System.  GNOME is similar in purpose and scope
43to CDE and KDE, but GNOME is based completely on free software.
44The gnome-print package contains libraries and fonts that are needed by
45GNOME applications wanting to print.
46
47You should install the gnome-print package if you intend on using any of
48the GNOME applications that can print. If you would like to develop GNOME
49applications that can print you will also need to install the gnome-print
50devel package.
51
52%description -l ja
53印刷できるGNOMEアプリケーションを使いたいなら、gnome-printパッケージを
54インストールする必要があります。もし印刷できるGNOMEアプリケーションを
55開発したいなら、gnome-print-develパッケージをインストールする必要が
56あります。
57
58%package -n libgnomeprint%{sover}
59Summary:        Printing libraries for GNOME
60Summary(ja):    GNOME用印刷ライブラリ
61Group:          System Environment/Libraries
62Obsoletes:      gnome-print-beta < 0.26
63
64%description -n libgnomeprint%{sover}
65This package contains the printing apparatus for GNOME, the complete
66graphical desktop environment based entirely on free software.
67
68%package devel
69Summary:        Libraries and include files for developing GNOME applications.
70Summary(ja):    GNOME用印刷アプリケーション開発用ライブラリとヘッダファイル
71Group:          Development/Libraries
72Obsoletes:      gnome-print-beta-devel < 0.26
73Requires:       %{name} = %{version}
74Requires:       libgnomeprint%{sover} = %{version}
75Requires:       gdk-pixbuf-devel
76
77%description devel
78GNOME (GNU Network Object Model Environment) is a user-friendly set of
79applications and desktop tools to be used in conjunction with a window
80manager for the X Window System.  GNOME is similar in purpose and scope
81to CDE and KDE, but GNOME is based completely on free software.
82The gnome-print-devel package includes the libraries and include files that
83you will need when developing applications that use the GNOME printing
84facilities.
85
86You should install the gnome-print-devel package if you would like to
87develop GNOME applications that will use the GNOME printing facilities.
88You don't need to install the gnome-print-devel package if you just want
89to use the GNOME desktop enviornment.
90
91%prep
92%setup -q
93%patch2 -p1 -b .nofontmaps
94%patch50 -p1 -b .fallback
95%patch51 -p1 -b .dynamic
96%patch52 -p1 -b .ft2build
97
98%patch60 -p0 -b .config
99%patch61 -p0 -b .parseTT
100
101%build
102libtoolize --copy --force
103autoheader-2.13
104automake-1.4
105autoconf-2.13
106%configure --disable-static
107make LIBTOOL=/usr/bin/libtool
108%install
109[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
110%makeinstall LIBTOOL=/usr/bin/libtool
111./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
112./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gnome/fonts
113install -c fonts/*.font $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
114
115cat > $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install <<__EOF__
116#! /bin/sh
117%{_bindir}/gnome-font-install --clean \
118        --aliases=%{_datadir}/gnome-print/fonts/adobe-urw.font \
119        --target=%{_sysconfdir}/gnome/fonts/gnome-print-rpm.fontmap \
120        --recursive \
121        %{_prefix}/X11R6/lib/X11/fonts \
122        %{_datadir}/fonts
123__EOF__
124chmod a+x $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install
125
126%find_lang %{name}
127
128## remove unuse files
129rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
130
131%clean
132[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
133
134%post -p %{_bindir}/vine-update-gnome-font-install
135
136%post -n libgnomeprint%{sover} -p /sbin/ldconfig
137
138%postun -n libgnomeprint%{sover} -p /sbin/ldconfig
139
140
141%files -f %{name}.lang
142%defattr(-, root, root)
143%doc AUTHORS COPYING ChangeLog NEWS README
144%dir %{_datadir}/gnome-print
145%dir %{_datadir}/gnome-print/profiles
146%dir %{_sysconfdir}/gnome/fonts
147%{_datadir}/gnome-print/profiles/*
148%{_bindir}/*
149%{_datadir}/fonts/afms/adobe/*
150%{_datadir}/gnome-print/fonts
151
152%files -n libgnomeprint%{sover}
153%defattr(-, root, root)
154%{_libdir}/*.so.%{sover}.*
155%{_libdir}/*.so.%{sover}
156
157%files devel
158%defattr(-, root, root)
159%{_libdir}/*.so
160#{_libdir}/*.a
161#{_libdir}/*.la
162%{_libdir}/*.sh
163%{_includedir}/*
164
165%changelog
166* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.37-3
167- added Patch60: gnome-print-0.37-config.patch
168- added Patch61: gnome-print-0.37-parseTT.patch
169
170* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-2
171- rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6.21)
172- removed *.a
173
174* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.37-1vl5
175- applied new versioning policy, spec in utf-8
176- removed *.la
177
178* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl2
179- rebuilt with db4-4.3.29
180
181* Mon Oct 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl1
182- updated to 0.37
183- rebuilt with db4-4.2.52
184- added Patch52 to build with freetype2
185- s/Copyright/License/
186- fixed %post, %postun section
187
188* Fri Jan 17 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.35-0vl2
189- rebuilt with db4 environment
190- added BuildPreReq: automake14, autoconf213
191
192* Wed Mar 20 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.35-0vl1
193- New upstream release.
194- vine-update-gnome-font-install: added a wrapper script for generating
195  gnome-print's fontmap. it will helps us if font packages will calls it
196  with %%post and %%postun.
197- %%post: changed calling vine-update-gnome-font-install.
198- gnome-print-0.35-dynamicfallback.patch:
199  generate hash using NAMES file.
200
201* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl3
202- Fixed fontmap generation.
203  Note: don't remove --clean option. when gnome-font-install regenerate
204  fontmap, it don't add the fonts which already exists.
205
206* Wed Dec 26 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.34-0vl2
207- added PreReq: freetype2 for gnome-font-install invoked from %%post section
208- commented out Requires: %%{name} >= %%{ver} from libgnomeprint15
209
210* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl1
211- New upstream release.
212
213* Sun Apr  1 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl3
214- Added Obsolates to libgnomeprint11.
215- Added some build requires.
216
217* Mon Mar 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl2
218- New upstream release.
219
220* Tue Jan 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl6
221- Fixed -devel conflicts.
222
223* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl5
224- Added Conflicts: line in -devel.
225
226* Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl4
227- separated binary and data packages.
228
229* Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
230- added prereq urw-fonts
231
232* Wed May 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
233- modified jahack pach to fix threshold value of MB_CUR_MAX for glibc 2.1.3.
234
235* Mon May 30 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
236- updated to 0.20
237
238* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
239- modified jahack patch for satbility of memory allocation.
240- modified jahack patch to fix text alignment.
241
242* Sat May 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
243- modified jahack patch for preview.
244- added i18n_fix for nls.
245- added orignal ja.po.
246
247* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
248- updated to 0.19
249
250* Mon May  1 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
251- updated to 0.18
252
253* Wed Feb 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
254- updated to 0.12
255
256* Mon Jan 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
257- added "quick hacked" ja patch.
258
259* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatotu.org>
260- add Provides: libgnomeprint.so.2
261
262* Sat Oct 13 1999 Kazuhito Nishi <nishi@imasy.or.jp>
263- Added Prereq: zlib
264
265* Sun Aug 01 1999 Gregory McLean <gregm@comstar.net>
266- Undo my draconian uninstall stuff.
267
268* Tue Jul 20 1999 Gregory McLean <gregm@comstar.net>
269- Stab at cleaning up properly when we uninstall.
270
271* Fri Jul 16 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
272- fixed typo in spec
273
274* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
275- Added fonts to the spec.
276
277* Mon Jul 05 1999 Gregory McLean <gregm@comstar.net>
278- Fleshed out the descriptions.
Note: See TracBrowser for help on using the repository browser.