source: projects/specs/trunk/g/gnome-power-manager/gnome-power-manager-vl.spec @ 6011

Revision 6011, 10.3 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define dbus_version 1.4.16
2%define dbus_glib_version 0.96
3%define gnome_panel_version 3.4.0
4
5Summary: GNOME power management service
6Summary(ja): GNOME 電源管理ツール
7Name: gnome-power-manager
8Version: 3.4.0
9Release: 1%{?_dist_release}
10License: GPLv2+ and GFDL
11Group: Applications/System
12URL: http://projects.gnome.org/gnome-power-manager/
13
14Source0: http://download.gnome.org/sources/gnome-power-manager/3.4/gnome-power-manager-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: autoconf >= 2.65
18BuildRequires: gtk3-devel
19BuildRequires: libgnomeui-devel
20BuildRequires: libglade2-devel
21BuildRequires: libwnck-devel
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: libnotify-devel
24BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
25BuildRequires: scrollkeeper
26BuildRequires: gnome-doc-utils >= 0.3.2
27BuildRequires: desktop-file-utils
28BuildRequires: gettext
29BuildRequires: libtool
30BuildRequires: cairo-devel
31BuildRequires: libcanberra-gtk3-devel
32BuildRequires: unique3-devel >= 3.0.0
33## BuildRequires: DeviceKit-power-devel >= 008
34BuildRequires: upower-devel >= 0.9.0
35BuildRequires: control-center-devel
36BuildRequires: intltool
37BuildRequires: docbook-utils
38Requires: gtk3 >= 3.0.0
39Requires: gnome-mime-data
40Requires: gnome-icon-theme
41Requires: libnotify >= 0.4.3
42Requires: dbus-glib >= %{dbus_glib_version}
43Requires: dbus-x11 >= %{dbus_version}
44Requires: libcanberra-gtk3 >= 0.10
45Requires: unique3 >= 3.0.0
46Requires: upower >= 0.9.0
47Requires(post,postun): scrollkeeper
48Requires(post,pre,preun): GConf2
49
50Obsoletes: gnome-power-manager-extra < 3.0.0
51Provides:  gnome-power-manager-extra
52
53Vendor:       Project Vine
54Distribution: Vine Linux
55Packager:     daisuke, Takemikaduchi
56
57%description
58GNOME Power Manager uses the information and facilities provided by HAL
59displaying icons and handling user callbacks in an interactive GNOME session.
60GNOME Power Preferences allows authorised users to set policy and
61change preferences.
62
63%prep
64%setup -q
65
66
67%build
68%configure \
69        --disable-scrollkeeper
70make
71
72%install
73rm -rf $RPM_BUILD_ROOT
74export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
75make install DESTDIR=$RPM_BUILD_ROOT
76unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
77
78#desktop-file-install --vendor gnome --delete-original                   \
79#  --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart                    \
80#  $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
81
82# save space by linking identical images in translated docs
83helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
84for f in $helpdir/C/figures/*.png; do
85  b="$(basename $f)"
86  for d in $helpdir/*; do
87    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
88      g="$d/figures/$b"
89      if [ -f "$g" ]; then
90        if cmp -s $f $g; then
91          rm "$g"; ln -s "../../C/figures/$b" "$g"
92        fi
93      fi
94    fi
95  done
96done
97
98%find_lang %name --with-gnome
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post
104scrollkeeper-update -q &> /dev/null || :
105touch --no-create %{_datadir}/icons/hicolor
106if [ -x /usr/bin/gtk-update-icon-cache ]; then
107    gtk-update-icon-cache -q %{_datadir}/icons/hicolor
108fi
109
110%postun
111scrollkeeper-update -q &> /dev/null || :
112touch --no-create %{_datadir}/icons/hicolor
113if [ -x /usr/bin/gtk-update-icon-cache ]; then
114    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
115fi
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121%files -f %{name}.lang
122%defattr(-,root,root)
123%doc AUTHORS COPYING README
124%{_bindir}/gnome-power-statistics
125%dir %{_datadir}/gnome-power-manager
126%{_datadir}/applications/gnome-power-statistics.desktop
127%{_datadir}/glib-2.0/schemas/*.xml
128%{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
129%{_datadir}/icons/hicolor/*/apps/*
130%{_mandir}/man1/gnome-power-statistics.1.gz
131
132%changelog
133* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
134- new upstream release
135
136* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
137- new upstream release
138
139* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
140- new upstream release
141
142* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
143- new upstream release
144
145* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
146- new upstream release
147
148* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
149- new upstream release
150- add BuildRequires: gtk3-devel, control-center-devel
151- change BuildRequires: libcanberra-gtk3-devel instead of licanberra-devel
152- change BuildRequires: unique3-devel instead of unique-devel
153- delete -extra sub package
154
155* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
156- add Source101(gnome-power-manager.gnome-2-32.ja.po)
157
158* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
159- new upstream release
160- change BuildRequires: gnome-panel-devel instead of gnome-panel
161- fix %files
162
163* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
164- new upstream release
165
166* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
167- new upstream release
168- remove Patch1, Patch2, Patch3
169- change BuildRequires: DeviceKit-power-devel -> upower-devel
170- change Requires: DeviceKit-power -> upower
171
172* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
173- new upstream release
174- change BuildRequires: xmlto -> docbook-utils
175- remove BuildReuiqres: hal-devel
176
177* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
178- new upstream release
179
180* Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
181- merge spec file from FC package
182- add Patch1, Patch2 and Patch3 from FC package
183- add Patch10 and Patch11 for Vine Linux
184- remove configure option --enable-policykit
185- add new package (extra)
186
187* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
188- new upstream release
189
190* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
191- new upstream release
192
193* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
194- new upstream release
195
196* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
197- new upstream release
198
199* Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
200- new upstream release
201
202* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
203- rebuild with new environment/toolchain
204
205* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
206- new upstream release
207- drop Patch10 to enable suspend-to-ram.
208
209* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
210- new upstream release
211
212* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
213- new upstream release
214
215* Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
216- new upstream release
217
218* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
219- new upstream release
220
221* Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
222- new upstream release
223
224* Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
225- new upstream release
226
227* Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
228- new upstream release
229
230* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
231- new upstream release
232
233* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
234- add Patch10 to disable suspend-to-ram by default.
235
236* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
237- update ja.po from CVS head.
238
239* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
240- new upstream release
241
242* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
243- initial build for Vine Linux based on FC package
244
245* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
246- fix the fix in -2 and -3
247
248* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
249- fix the fix in -2
250
251* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
252- fix icon in bubbles (bug 184192).
253
254* Fri Mar  3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
255- Update to 2.13.93
256- ignore d-bus timeout errors
257
258* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
259- Add patch from Richard Hughes to potentially fix a
260  crasher bug (bug 183127)
261
262* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
263- Buildrequires: gnome-doc-utils
264
265* Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
266- Update to 2.13.92
267
268* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
269- Update to 2.13.91
270- Drop upstreamed patch
271
272* Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
273- Update to 2.13.90
274- Require dbus-x11 (#176656)
275
276* Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
277- remove Hibernate and Suspend from menus as part of
278  panel/g-p-m integration effort
279
280* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
281- bump again for double-long bug on ppc(64)
282
283* Tue Feb  7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
284- pull cvs snapshot from HEAD and drop the patches caillon
285  just added
286
287* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
288- Install into the autostart directory
289- Don't suspend on lid close while on AC power
290
291* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
292- rebuilt for new gcc4.1 snapshot and glibc changes
293
294* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
295- rebuild
296
297* Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
298- packaging tweaks
299
300* Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
301- Update to 2.13.5
302
303* Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
304- Left clicking on the applet should bring up the menu
305
306* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
307- update to 0.3.4
308- disable updating scrollkeeper database in buildroot
309  (move to %%post)
310
311* Fri Jan  6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
312- update to a cvs snap so that it works with hal cvs snap
313- make sure we use libnotify
314
315* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
316- rebuilt
317
318* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
319- rebuild for new dbus
320
321* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
322- Update to 0.3.1
323
324* Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
325- Update to 0.3.0
326
327* Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
328- update to 0.2.8
329
330* Wed Oct  3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
331- update to 0.2.6
332
333* Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
334- update to 0.2.4
335
336* Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
337- Initial import based on an SRPM from Richard Hughes
338
Note: See TracBrowser for help on using the repository browser.