source: projects/specs/trunk/g/gnome-power-manager/gnome-power-manager-vl.spec @ 4704

Revision 4704, 10.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1%define dbus_version 1.4.0
2%define dbus_glib_version 0.88
3%define gnome_panel_version 2.32.0
4
5Summary: GNOME power management service
6Summary(ja): GNOME 電源管理ツール
7Name: gnome-power-manager
8Version: 3.1.90
9Release: 1%{?_dist_release}
10License: GPLv2+ and GFDL
11Group: Applications/System
12URL: http://projects.gnome.org/gnome-power-manager/
13
14Source0: http://download.gnome.org/sources/gnome-power-manager/3.1/gnome-power-manager-%{version}.tar.xz
15# ja.po from l10n
16Source101: gnome-power-manager.gnome-2-32.ja.po
17
18# for Vine Linux
19Patch10: gnome-power-manager-2.28.2-warningflags.patch
20Patch11: gnome-power-manager-2.28.2-math.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: autoconf >= 2.65
24BuildRequires: gtk3-devel
25BuildRequires: libgnomeui-devel
26BuildRequires: libglade2-devel
27BuildRequires: libwnck-devel
28BuildRequires: dbus-devel >= %{dbus_version}
29BuildRequires: libnotify-devel
30BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
31BuildRequires: scrollkeeper
32BuildRequires: gnome-doc-utils >= 0.3.2
33BuildRequires: desktop-file-utils
34BuildRequires: gettext
35BuildRequires: libtool
36BuildRequires: cairo-devel
37BuildRequires: libcanberra-gtk3-devel
38BuildRequires: unique3-devel >= 3.0.0
39## BuildRequires: DeviceKit-power-devel >= 008
40BuildRequires: upower-devel >= 0.9.0
41BuildRequires: control-center-devel
42BuildRequires: intltool
43BuildRequires: docbook-utils
44Requires: gtk3 >= 3.0.0
45Requires: gnome-mime-data
46Requires: gnome-icon-theme
47Requires: libnotify >= 0.4.3
48Requires: dbus-glib >= %{dbus_glib_version}
49Requires: dbus-x11 >= %{dbus_version}
50Requires: libcanberra-gtk3 >= 0.10
51Requires: unique3 >= 3.0.0
52Requires: upower >= 0.9.0
53Requires(post,postun): scrollkeeper
54Requires(post,pre,preun): GConf2
55
56Obsoletes: gnome-power-manager-extra < 3.0.0
57Provides:  gnome-power-manager-extra
58
59Vendor:       Project Vine
60Distribution: Vine Linux
61Packager:     daisuke, Takemikaduchi
62
63%description
64GNOME Power Manager uses the information and facilities provided by HAL
65displaying icons and handling user callbacks in an interactive GNOME session.
66GNOME Power Preferences allows authorised users to set policy and
67change preferences.
68
69%prep
70%setup -q
71#%setup -q -n %{?name}-%{?version}-%{?alphatag}
72## %patch10 -p1 -b .warnings
73## %patch11 -p1 -b .math
74
75# copy ja.po
76#cp -f %{SOURCE101} po/ja.po
77
78# autoreconf -i
79
80%build
81%configure \
82        --disable-scrollkeeper
83make
84
85# strip unneeded translations from .mo files
86# ideally intltool (ha!) would do that for us
87# http://bugzilla.gnome.org/show_bug.cgi?id=474987
88#cd po
89#grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
90#mv POTFILES.keep POTFILES.in
91#intltool-update --pot
92#for p in *.po; do
93#  msgmerge $p %{name}.pot > $p.out
94#  msgfmt -o `basename $p .po`.gmo $p.out
95#done
96
97%install
98rm -rf $RPM_BUILD_ROOT
99export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
100make install DESTDIR=$RPM_BUILD_ROOT
101unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
102
103#desktop-file-install --vendor gnome --delete-original                   \
104#  --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart                    \
105#  $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
106
107# save space by linking identical images in translated docs
108helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
109for f in $helpdir/C/figures/*.png; do
110  b="$(basename $f)"
111  for d in $helpdir/*; do
112    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
113      g="$d/figures/$b"
114      if [ -f "$g" ]; then
115        if cmp -s $f $g; then
116          rm "$g"; ln -s "../../C/figures/$b" "$g"
117        fi
118      fi
119    fi
120  done
121done
122
123%find_lang %name --with-gnome
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post
129scrollkeeper-update -q &> /dev/null || :
130touch --no-create %{_datadir}/icons/hicolor
131if [ -x /usr/bin/gtk-update-icon-cache ]; then
132    gtk-update-icon-cache -q %{_datadir}/icons/hicolor
133fi
134
135%postun
136scrollkeeper-update -q &> /dev/null || :
137touch --no-create %{_datadir}/icons/hicolor
138if [ -x /usr/bin/gtk-update-icon-cache ]; then
139    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
140fi
141glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
142
143%posttrans
144glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
145
146%files -f %{name}.lang
147%defattr(-,root,root)
148%doc AUTHORS COPYING README
149%{_bindir}/gnome-power-statistics
150%dir %{_datadir}/gnome-power-manager
151%{_datadir}/gnome-power-manager/gpm-statistics.ui
152%{_datadir}/applications/gnome-power-statistics.desktop
153%{_datadir}/glib-2.0/schemas/*.xml
154%{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
155%{_datadir}/icons/hicolor/*/apps/*
156%{_datadir}/icons/gnome/scalable/status/keyboard-brightness-symbolic.svg
157%{_mandir}/man1/gnome-power-statistics.1.gz
158
159%changelog
160* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
161- new upstream release
162
163* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
164- new upstream release
165- add BuildRequires: gtk3-devel, control-center-devel
166- change BuildRequires: libcanberra-gtk3-devel instead of licanberra-devel
167- change BuildRequires: unique3-devel instead of unique-devel
168- delete -extra sub package
169
170* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
171- add Source101(gnome-power-manager.gnome-2-32.ja.po)
172
173* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
174- new upstream release
175- change BuildRequires: gnome-panel-devel instead of gnome-panel
176- fix %files
177
178* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
179- new upstream release
180
181* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
182- new upstream release
183- remove Patch1, Patch2, Patch3
184- change BuildRequires: DeviceKit-power-devel -> upower-devel
185- change Requires: DeviceKit-power -> upower
186
187* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
188- new upstream release
189- change BuildRequires: xmlto -> docbook-utils
190- remove BuildReuiqres: hal-devel
191
192* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
193- new upstream release
194
195* Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
196- merge spec file from FC package
197- add Patch1, Patch2 and Patch3 from FC package
198- add Patch10 and Patch11 for Vine Linux
199- remove configure option --enable-policykit
200- add new package (extra)
201
202* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
203- new upstream release
204
205* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
206- new upstream release
207
208* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
209- new upstream release
210
211* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
212- new upstream release
213
214* Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
215- new upstream release
216
217* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
218- rebuild with new environment/toolchain
219
220* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
221- new upstream release
222- drop Patch10 to enable suspend-to-ram.
223
224* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
225- new upstream release
226
227* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
228- new upstream release
229
230* Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
231- new upstream release
232
233* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
234- new upstream release
235
236* Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
237- new upstream release
238
239* Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
240- new upstream release
241
242* Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
243- new upstream release
244
245* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
246- new upstream release
247
248* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
249- add Patch10 to disable suspend-to-ram by default.
250
251* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
252- update ja.po from CVS head.
253
254* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
255- new upstream release
256
257* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
258- initial build for Vine Linux based on FC package
259
260* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
261- fix the fix in -2 and -3
262
263* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
264- fix the fix in -2
265
266* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
267- fix icon in bubbles (bug 184192).
268
269* Fri Mar  3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
270- Update to 2.13.93
271- ignore d-bus timeout errors
272
273* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
274- Add patch from Richard Hughes to potentially fix a
275  crasher bug (bug 183127)
276
277* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
278- Buildrequires: gnome-doc-utils
279
280* Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
281- Update to 2.13.92
282
283* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
284- Update to 2.13.91
285- Drop upstreamed patch
286
287* Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
288- Update to 2.13.90
289- Require dbus-x11 (#176656)
290
291* Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
292- remove Hibernate and Suspend from menus as part of
293  panel/g-p-m integration effort
294
295* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
296- bump again for double-long bug on ppc(64)
297
298* Tue Feb  7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
299- pull cvs snapshot from HEAD and drop the patches caillon
300  just added
301
302* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
303- Install into the autostart directory
304- Don't suspend on lid close while on AC power
305
306* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
307- rebuilt for new gcc4.1 snapshot and glibc changes
308
309* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
310- rebuild
311
312* Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
313- packaging tweaks
314
315* Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
316- Update to 2.13.5
317
318* Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
319- Left clicking on the applet should bring up the menu
320
321* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
322- update to 0.3.4
323- disable updating scrollkeeper database in buildroot
324  (move to %%post)
325
326* Fri Jan  6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
327- update to a cvs snap so that it works with hal cvs snap
328- make sure we use libnotify
329
330* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
331- rebuilt
332
333* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
334- rebuild for new dbus
335
336* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
337- Update to 0.3.1
338
339* Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
340- Update to 0.3.0
341
342* Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
343- update to 0.2.8
344
345* Wed Oct  3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
346- update to 0.2.6
347
348* Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
349- update to 0.2.4
350
351* Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
352- Initial import based on an SRPM from Richard Hughes
353
Note: See TracBrowser for help on using the repository browser.