source: projects/specs/trunk/g/gnome-power-manager/gnome-power-manager-vl.spec @ 2041

Revision 2041, 11.8 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define dbus_version 1.4.0
2%define dbus_glib_version 0.88
3%define gnome_panel_version 2.32.0
4
5Summary: GNOME power management service
6Summary(ja): GNOME 電源管理ツール
7Name: gnome-power-manager
8Version: 2.32.0
9Release: 1%{?_dist_release}
10License: GPLv2+ and GFDL
11Group: Applications/System
12URL: http://projects.gnome.org/gnome-power-manager/
13
14Source: http://download.gnome.org/sources/gnome-power-manager/2.32/gnome-power-manager-%{version}.tar.bz2
15
16# for Vine Linux
17Patch10: gnome-power-manager-2.28.2-warningflags.patch
18Patch11: gnome-power-manager-2.28.2-math.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: autoconf >= 2.65
22BuildRequires: libgnomeui-devel
23BuildRequires: libglade2-devel
24BuildRequires: libwnck-devel
25BuildRequires: dbus-devel >= %{dbus_version}
26BuildRequires: libnotify-devel
27BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
28BuildRequires: scrollkeeper
29BuildRequires: gnome-doc-utils >= 0.3.2
30BuildRequires: desktop-file-utils
31BuildRequires: gettext
32BuildRequires: libtool
33BuildRequires: cairo-devel
34BuildRequires: libcanberra-devel >= 0.10
35BuildRequires: unique-devel >= 1.1.6
36## BuildRequires: DeviceKit-power-devel >= 008
37BuildRequires: upower-devel >= 0.9.0
38BuildRequires: intltool
39BuildRequires: docbook-utils
40Requires: gtk2 >= 2.10.0
41Requires: gnome-mime-data
42Requires: gnome-icon-theme
43Requires: libnotify >= 0.4.3
44Requires: dbus-glib >= %{dbus_glib_version}
45Requires: dbus-x11 >= %{dbus_version}
46Requires: libcanberra-gtk2 >= 0.10
47Requires: unique >= 1.1.6
48Requires: upower >= 0.9.0
49Requires(post,postun): scrollkeeper
50Requires(post,pre,preun): GConf2
51
52Vendor:       Project Vine
53Distribution: Vine Linux
54Packager:     daisuke, Takemikaduchi
55
56%description
57GNOME Power Manager uses the information and facilities provided by HAL
58displaying icons and handling user callbacks in an interactive GNOME session.
59GNOME Power Preferences allows authorised users to set policy and
60change preferences.
61
62%package extra
63Summary: GNOME Power Manager extra utility programs
64Group: Applications/System
65Requires: %{name} = %{version}-%{release}
66
67%description extra
68Extra GNOME power management applications that are not normally needed.
69
70%prep
71%setup -q
72#%setup -q -n %{?name}-%{?version}-%{?alphatag}
73## %patch10 -p1 -b .warnings
74## %patch11 -p1 -b .math
75autoreconf -i
76
77%build
78%configure \
79        --disable-scrollkeeper
80make
81
82# strip unneeded translations from .mo files
83# ideally intltool (ha!) would do that for us
84# http://bugzilla.gnome.org/show_bug.cgi?id=474987
85cd po
86grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
87mv POTFILES.keep POTFILES.in
88intltool-update --pot
89for p in *.po; do
90  msgmerge $p %{name}.pot > $p.out
91  msgfmt -o `basename $p .po`.gmo $p.out
92done
93
94%install
95rm -rf $RPM_BUILD_ROOT
96export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
97make install DESTDIR=$RPM_BUILD_ROOT
98unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
99
100desktop-file-install --vendor gnome --delete-original                   \
101  --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart                     \
102  $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
103
104# save space by linking identical images in translated docs
105helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
106for f in $helpdir/C/figures/*.png; do
107  b="$(basename $f)"
108  for d in $helpdir/*; do
109    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
110      g="$d/figures/$b"
111      if [ -f "$g" ]; then
112        if cmp -s $f $g; then
113          rm "$g"; ln -s "../../C/figures/$b" "$g"
114        fi
115      fi
116    fi
117  done
118done
119
120%find_lang %name --with-gnome
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post
126export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
127gconftool-2 --makefile-install-rule \
128        %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
129scrollkeeper-update -q &> /dev/null || :
130touch --no-create %{_datadir}/icons/hicolor
131if [ -x /usr/bin/gtk-update-icon-cache ]; then
132    gtk-update-icon-cache -q %{_datadir}/icons/hicolor
133fi
134
135%pre
136if [ "$1" -gt 1 ]; then
137    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
138    gconftool-2 --makefile-uninstall-rule \
139      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
140fi
141
142%preun
143if [ "$1" -eq 0 ]; then
144    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
145    gconftool-2 --makefile-uninstall-rule \
146      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
147fi
148
149%postun
150scrollkeeper-update -q &> /dev/null || :
151touch --no-create %{_datadir}/icons/hicolor
152if [ -x /usr/bin/gtk-update-icon-cache ]; then
153    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
154fi
155
156%files -f %{name}.lang
157%defattr(-,root,root)
158%doc AUTHORS COPYING README
159%{_bindir}/gnome-power-bugreport.sh
160%{_bindir}/gnome-power-manager
161%{_bindir}/gnome-power-preferences
162%{_sbindir}/gnome-power-backlight-helper
163%dir %{_datadir}/gnome-power-manager
164%{_datadir}/gnome-power-manager/acme.ui
165%{_datadir}/gnome-power-manager/gpm-prefs.ui
166%{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
167%{_mandir}/man1/gnome-power-manager.1.gz
168%{_mandir}/man1/gnome-power-preferences.1.gz
169%{_sysconfdir}/gconf/schemas/*.schemas
170%{_datadir}/dbus-1/services/gnome-power-manager.service
171#%{_datadir}/omf/gnome-power-manager
172%{_sysconfdir}/xdg/autostart/*.desktop
173%{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
174%{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
175%{_datadir}/applications/gnome-power-preferences.desktop
176%{_libexecdir}/gnome-brightness-applet
177%{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
178%{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
179%{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
180%{_datadir}/polkit-1/actions/org.gnome.power.policy
181
182%files extra
183%defattr(-,root,root,-)
184%doc AUTHORS COPYING NEWS README
185%{_bindir}/gnome-power-statistics
186%{_mandir}/man1/gnome-power-statistics.1.gz
187%{_datadir}/gnome-power-manager/gpm-statistics.ui
188%{_datadir}/applications/gnome-power-statistics.desktop
189%{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
190%{_libexecdir}/gnome-inhibit-applet
191%{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
192%{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
193%{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
194
195%changelog
196* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
197- new upstream release
198- change BuildRequires: gnome-panel-devel instead of gnome-panel
199- fix %files
200
201* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
202- new upstream release
203
204* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
205- new upstream release
206- remove Patch1, Patch2, Patch3
207- change BuildRequires: DeviceKit-power-devel -> upower-devel
208- change Requires: DeviceKit-power -> upower
209
210* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
211- new upstream release
212- change BuildRequires: xmlto -> docbook-utils
213- remove BuildReuiqres: hal-devel
214
215* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
216- new upstream release
217
218* Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
219- merge spec file from FC package
220- add Patch1, Patch2 and Patch3 from FC package
221- add Patch10 and Patch11 for Vine Linux
222- remove configure option --enable-policykit
223- add new package (extra)
224
225* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
226- new upstream release
227
228* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
229- new upstream release
230
231* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
232- new upstream release
233
234* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
235- new upstream release
236
237* Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
238- new upstream release
239
240* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
241- rebuild with new environment/toolchain
242
243* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
244- new upstream release
245- drop Patch10 to enable suspend-to-ram.
246
247* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
248- new upstream release
249
250* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
251- new upstream release
252
253* Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
254- new upstream release
255
256* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
257- new upstream release
258
259* Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
260- new upstream release
261
262* Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
263- new upstream release
264
265* Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
266- new upstream release
267
268* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
269- new upstream release
270
271* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
272- add Patch10 to disable suspend-to-ram by default.
273
274* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
275- update ja.po from CVS head.
276
277* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
278- new upstream release
279
280* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
281- initial build for Vine Linux based on FC package
282
283* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
284- fix the fix in -2 and -3
285
286* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
287- fix the fix in -2
288
289* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
290- fix icon in bubbles (bug 184192).
291
292* Fri Mar  3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
293- Update to 2.13.93
294- ignore d-bus timeout errors
295
296* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
297- Add patch from Richard Hughes to potentially fix a
298  crasher bug (bug 183127)
299
300* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
301- Buildrequires: gnome-doc-utils
302
303* Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
304- Update to 2.13.92
305
306* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
307- Update to 2.13.91
308- Drop upstreamed patch
309
310* Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
311- Update to 2.13.90
312- Require dbus-x11 (#176656)
313
314* Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
315- remove Hibernate and Suspend from menus as part of
316  panel/g-p-m integration effort
317
318* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
319- bump again for double-long bug on ppc(64)
320
321* Tue Feb  7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
322- pull cvs snapshot from HEAD and drop the patches caillon
323  just added
324
325* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
326- Install into the autostart directory
327- Don't suspend on lid close while on AC power
328
329* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
330- rebuilt for new gcc4.1 snapshot and glibc changes
331
332* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
333- rebuild
334
335* Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
336- packaging tweaks
337
338* Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
339- Update to 2.13.5
340
341* Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
342- Left clicking on the applet should bring up the menu
343
344* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
345- update to 0.3.4
346- disable updating scrollkeeper database in buildroot
347  (move to %%post)
348
349* Fri Jan  6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
350- update to a cvs snap so that it works with hal cvs snap
351- make sure we use libnotify
352
353* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
354- rebuilt
355
356* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
357- rebuild for new dbus
358
359* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
360- Update to 0.3.1
361
362* Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
363- Update to 0.3.0
364
365* Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
366- update to 0.2.8
367
368* Wed Oct  3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
369- update to 0.2.6
370
371* Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
372- update to 0.2.4
373
374* Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
375- Initial import based on an SRPM from Richard Hughes
376
Note: See TracBrowser for help on using the repository browser.