source: projects/specs/trunk/g/gnome-phone-manager/gnome-phone-manager-vl.spec @ 9686

Revision 9686, 9.0 KB checked in by Takemikaduchi, 9 years ago (diff)

gnome-phone-manager: update
others: rebuild

Line 
1Name:           gnome-phone-manager
2Summary:        Gnome Phone Manager
3Summary(ja): Gnome Phone マネージャー
4Version:        0.69
5Release:        1%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/System
8Source:         http://ftp.gnome.org/pub/GNOME/sources/gnome-phone-manager/%{version}/%{name}-%{version}.tar.xz
9URL:            http://usefulinc.com/software/phonemgr/
10#----------------------------------------------------------------------------
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15
16BuildRequires:  gtk3-devel >= 3.0.0
17BuildRequires:  gnome-bluetooth-devel >= 3.0.0
18BuildRequires:  bluez-libs-devel
19BuildRequires:  GConf2-devel
20
21BuildRequires:  gnokii-devel >= 0.6.28
22
23BuildRequires:  gstreamer-devel >= 0.10
24BuildRequires:  gnome-icon-theme >= 2.19.1
25# For libebook (evolution address book)
26BuildRequires:  evolution-data-server-devel >= 3.0.0
27BuildRequires:  gtkspell-devel
28BuildRequires:  telepathy-glib-devel
29BuildRequires:  libcanberra-gtk3-devel
30
31# search telepathy
32# empathy - GNOME インスタントメッセージクラアイント
33# libtelepathy - Telepathy クライアントを簡単に記述するための GLibライブラリ
34# libtelepathy-devel - Development files for libtelepathy
35# telepathy-filesystem - Telepathy ファイルシステムレイアウト
36# telepathy-gabble - Jabber/XMPP 接続マネージャ
37# telepathy-glib - Telepathy の GLib バインディング
38# telepathy-glib-devel - Development files for telepathy-glib
39# telepathy-haze - マルチプロトコル Libpurple 接続マネージャ
40# telepathy-mission-control - Central control for Telepathy connection manager
41# telepathy-mission-control-devel - Development files for telepathy-mission-control
42# telepathy-salut - Link-local XMPP telepathy 接続マネージャ
43# telepathy-stream-engine - メディアストリーミングを扱うための Telepathy クライア ント
44
45BuildRequires:  perl(XML::Parser)
46BuildRequires:  gettext
47BuildRequires:  desktop-file-utils
48
49Requires(post,pre,preun): GConf2
50
51# https://bugzilla.redhat.com/show_bug.cgi?id=436773
52Patch0: gpm-telepathy-workaround.patch
53Patch1: gnome-phone-manager-0.68-eds.patch
54Patch2: gnome-phone-manager-0.69-drop-plugin.patch
55
56
57#----------------------------------------------------------------------------
58%description
59This program will connect to your mobile phone over a serial port,
60either via a cable, infrared (IrDA) or Bluetooth connection.
61
62For example it listens for text messages, and when they arrive,
63displays them on the desktop. A visual indicator is displayed in
64the notification area, if one is presently added to the panel.
65
66#----------------------------------------------------------------------------
67%package telepathy
68Summary: Telepathy connection manager to send and receive SMSes
69Group: Applications/System
70
71%description telepathy
72This program will connect to your mobile phone over a serial port,
73either via a cable, infrared (IrDA) or Bluetooth connection.
74
75This plugin to Telepathy allows you to send and receive messages using any
76Instant Messaging application that uses Telepathy, such as Empathy.
77
78#----------------------------------------------------------------------------
79%prep
80%setup -q
81## %patch0 -p0
82%patch1 -p1 -b .eds
83%patch2 -p0 -b .plugins
84
85%build
86%configure
87make %{?_smp_mflags}
88
89#----------------------------------------------------------------------------
90%install
91%{__rm} -rf $RPM_BUILD_ROOT
92make DESTDIR=$RPM_BUILD_ROOT install
93
94# This should be in empathy instead
95install -m0644 -D telepathy/sms.profile $RPM_BUILD_ROOT%{_datadir}/mission-control/profiles/sms.profile
96
97find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
98find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
99
100desktop-file-install \
101  --delete-original \
102  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
103  --add-category X-VineLinux \
104  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-phone-manager.desktop
105
106%find_lang %{name}
107
108%post
109export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110gconftool-2 --makefile-install-rule \
111        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
112        >& /dev/null || :
113
114%pre
115if [ "$1" -gt 1 ]; then
116    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
117    gconftool-2 --makefile-uninstall-rule                               \
118        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
119        >& /dev/null || :
120fi
121
122%preun
123if [ "$1" -eq 0 ]; then
124    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125    gconftool-2 --makefile-uninstall-rule                               \
126        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
127        >& /dev/null || :
128fi
129
130%clean
131%{__rm} -rf $RPM_BUILD_ROOT
132
133%files -f %{name}.lang
134%defattr(-, root, root, -)
135%doc AUTHORS COPYING ChangeLog NEWS README TODO
136%{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas
137%{_bindir}/gnome-phone-manager
138%{_libdir}/gnome-bluetooth/plugins/libphonemgr.so
139%{_datadir}/applications/*.desktop
140%{_datadir}/gnome-phone-manager/
141%{_mandir}/man1/gnome-phone-manager.1.gz
142
143%files telepathy
144%{_libexecdir}/telepathy-phoney
145%{_datadir}/telepathy/managers/*
146%{_datadir}/dbus-1/services/*
147%{_datadir}/mission-control/profiles/*
148
149#----------------------------------------------------------------------------
150# Maintainers: babasaki@mindgear.org
151#
152#----------------------------------------------------------------------------
153%changelog
154* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.69-1
155- update to 0.69
156- add Patch1,2 from fedora
157
158* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.68-1
159- new upstream release
160
161* Sun Sep 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.67-2
162- rebuild with evolution-data-server-3.1.90
163
164* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.67-1
165- new upstream release
166- change BuildRequires: gtk3-devel instead of gtk2-devel
167- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
168
169* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-2
170- rebuils with evolution-data-server-2.32.0 and gnome-bluetooth-2.32.0
171
172* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-1
173- new upstream release
174- add BuildRequires: libcanberra-devel
175- drop Patch0
176
177* Mon Oct 27 2008 Seiichirou Babasaki - 0.60-4
178- Import gnome-phone-manager - Packager: Babasaki
179- Updated specfile
180
181#----------------------------------------------------------------------------
182* Tue Oct 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-3
183- Rebuild for new libgnokii
184
185* Thu Sep 11 2008  Matthias Clasen  <mclasen@redhat.com>
186- Rebuild
187
188* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-1
189- Update to 0.60
190- Remove vendor from desktop file
191
192* Wed May 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-2
193- Rebuild
194
195* Fri Mar 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-1
196- Update to 0.51
197
198* Fri Mar 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-3
199- Add a patch from upstream to fix connection to serial devices (#356861)
200
201* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-2
202- Work-around for telepathy brokeness
203
204* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-1
205- Update to 0.50
206
207* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.40-3
208- Autorebuild for GCC 4.3
209
210* Wed Dec 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-2
211- Rebuild against new release of gnokii
212
213* Wed Nov 14 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-1
214- Update to 0.40
215- Add experimental telepathy backend in a subpackage
216
217* Mon Oct 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.30-1
218- Update to 0.30
219- Fix sending non-ASCII texts (for real)
220- Add debugging improvements
221
222* Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 0.20-1
223- Update to 0.20
224
225* Sun Aug 19 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
226- Update to 0.10 (#253400)
227- Remove obsolete work-arounds and dependencies
228- Update BRs
229- Add GConf scriptlets
230
231* Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.8-6
232- Update license field from GPL to GPLv2+
233
234* Wed Nov 15 2006 Linus Walleij <triad@df.lth.se> 0.8-5
235- Rebuild to pick up libbtctl i/f bump.
236
237* Sun Oct 29 2006 Linus Walleij <triad@df.lth.se> 0.8-4
238- Rebuild to pick up libedataserver i/f bump.
239
240* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-3
241- Pick up intltool.
242
243* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-2
244- Pick up libtool.
245
246* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-1
247- New upstream version including patch.
248- The icon is an an even weirder place now!
249- Have to run som autotools on this one to get it working.
250
251* Tue Sep 5 2006 Linus Walleij <triad@df.lth.se> 0.7-5
252- Patch to compile with new version of E-D-S.
253
254* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> 0.7-4
255- Missing BR
256
257* Thu Aug 3 2006 Linus Walleij <triad@df.lth.se> 0.7-3
258- Updated after feedback from Chris Weyl
259- Bogus problem with cellphone.png icon image
260
261* Sat Jul 29 2006 Linus Walleij <triad@df.lth.se> 0.7-2
262- Updated after feedback from Parag and Paul
263
264* Tue Jun 27 2006 Linus Walleij <triad@df.lth.se> 0.7-1
265- 0.7 Release
266- Took Matthews nrpm package and Fedora Extrasificated it
267
268* Fri Sep 09 2005 Matthew Hall <matt@nrpms.net> 0.6-1
269- 0.6 Release
270
271* Mon Jun 20 2005 Matthew Hall <matt@nrpms.net> 0.4-1
272- 0.4 Release
Note: See TracBrowser for help on using the repository browser.