source: projects/specs/trunk/g/gnome-phone-manager/gnome-phone-manager-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           gnome-phone-manager
2Summary:        Gnome Phone Manager
3Summary(ja): Gnome Phone マネージャー
4Version:        0.60
5Release:        4%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/System
8Source:         http://ftp.gnome.org/pub/GNOME/sources/gnome-phone-manager/%{version}/%{name}-%{version}.tar.bz2
9URL:            http://usefulinc.com/software/phonemgr/
10#----------------------------------------------------------------------------
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15
16BuildRequires:  gtk2-devel
17BuildRequires:  libgnomeui-devel
18BuildRequires:  libgnome-devel
19BuildRequires:  gnome-bluetooth-devel
20BuildRequires:  libbtctl-devel
21BuildRequires:  bluez-libs-devel
22
23BuildRequires:  gnokii-devel
24
25BuildRequires:  gstreamer-devel >= 0.10
26BuildRequires:  gnome-icon-theme >= 2.19.1
27# For libebook (evolution address book)
28BuildRequires:  evolution-data-server-devel
29BuildRequires:  gtkspell-devel
30BuildRequires:  telepathy-glib-devel
31
32# search telepathy
33# empathy - GNOME インスタントメッセージクラアイント
34# libtelepathy - Telepathy クライアントを簡単に記述するための GLibライブラリ
35# libtelepathy-devel - Development files for libtelepathy
36# telepathy-filesystem - Telepathy ファイルシステムレイアウト
37# telepathy-gabble - Jabber/XMPP 接続マネージャ
38# telepathy-glib - Telepathy の GLib バインディング
39# telepathy-glib-devel - Development files for telepathy-glib
40# telepathy-haze - マルチプロトコル Libpurple 接続マネージャ
41# telepathy-mission-control - Central control for Telepathy connection manager
42# telepathy-mission-control-devel - Development files for telepathy-mission-control
43# telepathy-salut - Link-local XMPP telepathy 接続マネージャ
44# telepathy-stream-engine - メディアストリーミングを扱うための Telepathy クライア ント
45
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  gettext
48BuildRequires:  desktop-file-utils
49
50
51# https://bugzilla.redhat.com/show_bug.cgi?id=436773
52Patch0:         gpm-telepathy-workaround.patch
53
54#----------------------------------------------------------------------------
55%description
56This program will connect to your mobile phone over a serial port,
57either via a cable, infrared (IrDA) or Bluetooth connection.
58
59For example it listens for text messages, and when they arrive,
60displays them on the desktop. A visual indicator is displayed in
61the notification area, if one is presently added to the panel.
62
63#----------------------------------------------------------------------------
64%package telepathy
65Summary: Telepathy connection manager to send and receive SMSes
66Group: Applications/System
67
68%description telepathy
69This program will connect to your mobile phone over a serial port,
70either via a cable, infrared (IrDA) or Bluetooth connection.
71
72This plugin to Telepathy allows you to send and receive messages using any
73Instant Messaging application that uses Telepathy, such as Empathy.
74
75#----------------------------------------------------------------------------
76%prep
77%setup -q
78%patch0 -p0
79
80%build
81%configure
82make %{?_smp_mflags}
83
84#----------------------------------------------------------------------------
85%install
86%{__rm} -rf $RPM_BUILD_ROOT
87make DESTDIR=$RPM_BUILD_ROOT install
88
89# This should be in empathy instead
90install -m0644 -D telepathy/sms.profile $RPM_BUILD_ROOT%{_datadir}/mission-control/profiles/sms.profile
91
92%find_lang %{name}
93desktop-file-install \
94  --delete-original \
95  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
96  --add-category X-VineLinux \
97  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-phone-manager.desktop
98
99%post
100export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
101gconftool-2 --makefile-install-rule \
102        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
103        >& /dev/null || :
104
105%pre
106if [ "$1" -gt 1 ]; then
107    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
108    gconftool-2 --makefile-uninstall-rule                               \
109        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
110        >& /dev/null || :
111fi
112
113%preun
114if [ "$1" -eq 0 ]; then
115    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
116    gconftool-2 --makefile-uninstall-rule                               \
117        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
118        >& /dev/null || :
119fi
120
121%clean
122%{__rm} -rf $RPM_BUILD_ROOT
123
124%files -f %{name}.lang
125%defattr(-, root, root, -)
126%doc AUTHORS COPYING ChangeLog NEWS README TODO
127%{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas
128%{_bindir}/gnome-phone-manager
129%{_datadir}/applications/*.desktop
130%{_datadir}/gnome-phone-manager/
131%{_mandir}/man1/gnome-phone-manager.1.gz
132
133%files telepathy
134%{_libexecdir}/telepathy-phoney
135%{_datadir}/telepathy/managers/*
136%{_datadir}/dbus-1/services/*
137%{_datadir}/mission-control/profiles/*
138
139#----------------------------------------------------------------------------
140# Maintainers: babasaki@mindgear.org
141#
142#----------------------------------------------------------------------------
143%changelog
144* Mon Oct 27 2008 Seiichirou Babasaki - 0.60-4
145- Import gnome-phone-manager - Packager: Babasaki
146- Updated specfile
147
148#----------------------------------------------------------------------------
149* Tue Oct 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-3
150- Rebuild for new libgnokii
151
152* Thu Sep 11 2008  Matthias Clasen  <mclasen@redhat.com>
153- Rebuild
154
155* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-1
156- Update to 0.60
157- Remove vendor from desktop file
158
159* Wed May 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-2
160- Rebuild
161
162* Fri Mar 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-1
163- Update to 0.51
164
165* Fri Mar 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-3
166- Add a patch from upstream to fix connection to serial devices (#356861)
167
168* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-2
169- Work-around for telepathy brokeness
170
171* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-1
172- Update to 0.50
173
174* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.40-3
175- Autorebuild for GCC 4.3
176
177* Wed Dec 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-2
178- Rebuild against new release of gnokii
179
180* Wed Nov 14 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-1
181- Update to 0.40
182- Add experimental telepathy backend in a subpackage
183
184* Mon Oct 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.30-1
185- Update to 0.30
186- Fix sending non-ASCII texts (for real)
187- Add debugging improvements
188
189* Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 0.20-1
190- Update to 0.20
191
192* Sun Aug 19 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
193- Update to 0.10 (#253400)
194- Remove obsolete work-arounds and dependencies
195- Update BRs
196- Add GConf scriptlets
197
198* Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.8-6
199- Update license field from GPL to GPLv2+
200
201* Sun Nov 15 2006 Linus Walleij <triad@df.lth.se> 0.8-5
202- Rebuild to pick up libbtctl i/f bump.
203
204* Sun Oct 29 2006 Linus Walleij <triad@df.lth.se> 0.8-4
205- Rebuild to pick up libedataserver i/f bump.
206
207* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-3
208- Pick up intltool.
209
210* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-2
211- Pick up libtool.
212
213* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-1
214- New upstream version including patch.
215- The icon is an an even weirder place now!
216- Have to run som autotools on this one to get it working.
217
218* Tue Sep 5 2006 Linus Walleij <triad@df.lth.se> 0.7-5
219- Patch to compile with new version of E-D-S.
220
221* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> 0.7-4
222- Missing BR
223
224* Thu Aug 3 2006 Linus Walleij <triad@df.lth.se> 0.7-3
225- Updated after feedback from Chris Weyl
226- Bogus problem with cellphone.png icon image
227
228* Sat Jul 29 2006 Linus Walleij <triad@df.lth.se> 0.7-2
229- Updated after feedback from Parag and Paul
230
231* Tue Jun 27 2006 Linus Walleij <triad@df.lth.se> 0.7-1
232- 0.7 Release
233- Took Matthews nrpm package and Fedora Extrasificated it
234
235* Fri Sep 09 2005 Matthew Hall <matt@nrpms.net> 0.6-1
236- 0.6 Release
237
238* Mon Jun 20 2005 Matthew Hall <matt@nrpms.net> 0.4-1
239- 0.4 Release
Note: See TracBrowser for help on using the repository browser.