source: projects/specs/trunk/g/gnome-phone-manager/gnome-phone-manager-vl.spec @ 4713

Revision 4713, 8.6 KB checked in by Takemikaduchi, 13 years ago (diff)

gnome-phone-manager: rebuild, others: new upstream release

Line 
1Name:           gnome-phone-manager
2Summary:        Gnome Phone Manager
3Summary(ja): Gnome Phone マネージャー
4Version:        0.67
5Release:        2%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/System
8Source:         http://ftp.gnome.org/pub/GNOME/sources/gnome-phone-manager/%{version}/%{name}-%{version}.tar.xz
9URL:            http://usefulinc.com/software/phonemgr/
10#----------------------------------------------------------------------------
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15
16BuildRequires:  gtk3-devel >= 3.0.0
17BuildRequires:  gnome-bluetooth-devel >= 3.0.0
18BuildRequires:  bluez-libs-devel
19
20BuildRequires:  gnokii-devel >= 0.6.28
21
22BuildRequires:  gstreamer-devel >= 0.10
23BuildRequires:  gnome-icon-theme >= 2.19.1
24# For libebook (evolution address book)
25BuildRequires:  evolution-data-server-devel >= 3.0.0
26BuildRequires:  gtkspell-devel
27BuildRequires:  telepathy-glib-devel
28BuildRequires:  libcanberra-gtk3-devel
29
30# search telepathy
31# empathy - GNOME インスタントメッセージクラアイント
32# libtelepathy - Telepathy クライアントを簡単に記述するための GLibライブラリ
33# libtelepathy-devel - Development files for libtelepathy
34# telepathy-filesystem - Telepathy ファイルシステムレイアウト
35# telepathy-gabble - Jabber/XMPP 接続マネージャ
36# telepathy-glib - Telepathy の GLib バインディング
37# telepathy-glib-devel - Development files for telepathy-glib
38# telepathy-haze - マルチプロトコル Libpurple 接続マネージャ
39# telepathy-mission-control - Central control for Telepathy connection manager
40# telepathy-mission-control-devel - Development files for telepathy-mission-control
41# telepathy-salut - Link-local XMPP telepathy 接続マネージャ
42# telepathy-stream-engine - メディアストリーミングを扱うための Telepathy クライア ント
43
44BuildRequires:  perl(XML::Parser)
45BuildRequires:  gettext
46BuildRequires:  desktop-file-utils
47
48
49# https://bugzilla.redhat.com/show_bug.cgi?id=436773
50Patch0:         gpm-telepathy-workaround.patch
51
52#----------------------------------------------------------------------------
53%description
54This program will connect to your mobile phone over a serial port,
55either via a cable, infrared (IrDA) or Bluetooth connection.
56
57For example it listens for text messages, and when they arrive,
58displays them on the desktop. A visual indicator is displayed in
59the notification area, if one is presently added to the panel.
60
61#----------------------------------------------------------------------------
62%package telepathy
63Summary: Telepathy connection manager to send and receive SMSes
64Group: Applications/System
65
66%description telepathy
67This program will connect to your mobile phone over a serial port,
68either via a cable, infrared (IrDA) or Bluetooth connection.
69
70This plugin to Telepathy allows you to send and receive messages using any
71Instant Messaging application that uses Telepathy, such as Empathy.
72
73#----------------------------------------------------------------------------
74%prep
75%setup -q
76## %patch0 -p0
77
78%build
79%configure
80make %{?_smp_mflags}
81
82#----------------------------------------------------------------------------
83%install
84%{__rm} -rf $RPM_BUILD_ROOT
85make DESTDIR=$RPM_BUILD_ROOT install
86
87# This should be in empathy instead
88install -m0644 -D telepathy/sms.profile $RPM_BUILD_ROOT%{_datadir}/mission-control/profiles/sms.profile
89
90find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
91find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
92
93desktop-file-install \
94  --delete-original \
95  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
96  --add-category X-VineLinux \
97  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-phone-manager.desktop
98
99%find_lang %{name}
100
101%post
102export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103gconftool-2 --makefile-install-rule \
104        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
105        >& /dev/null || :
106
107%pre
108if [ "$1" -gt 1 ]; then
109    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110    gconftool-2 --makefile-uninstall-rule                               \
111        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
112        >& /dev/null || :
113fi
114
115%preun
116if [ "$1" -eq 0 ]; then
117    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
118    gconftool-2 --makefile-uninstall-rule                               \
119        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
120        >& /dev/null || :
121fi
122
123%clean
124%{__rm} -rf $RPM_BUILD_ROOT
125
126%files -f %{name}.lang
127%defattr(-, root, root, -)
128%doc AUTHORS COPYING ChangeLog NEWS README TODO
129%{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas
130%{_bindir}/gnome-phone-manager
131%{_libdir}/gnome-bluetooth/plugins/libphonemgr.so
132%{_datadir}/applications/*.desktop
133%{_datadir}/gnome-phone-manager/
134%{_mandir}/man1/gnome-phone-manager.1.gz
135
136%files telepathy
137%{_libexecdir}/telepathy-phoney
138%{_datadir}/telepathy/managers/*
139%{_datadir}/dbus-1/services/*
140%{_datadir}/mission-control/profiles/*
141
142#----------------------------------------------------------------------------
143# Maintainers: babasaki@mindgear.org
144#
145#----------------------------------------------------------------------------
146%changelog
147* Sun Sep 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.67-2
148- rebuild with evolution-data-server-3.1.90
149
150* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.67-1
151- new upstream release
152- change BuildRequires: gtk3-devel instead of gtk2-devel
153- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
154
155* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-2
156- rebuils with evolution-data-server-2.32.0 and gnome-bluetooth-2.32.0
157
158* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-1
159- new upstream release
160- add BuildRequires: libcanberra-devel
161- drop Patch0
162
163* Mon Oct 27 2008 Seiichirou Babasaki - 0.60-4
164- Import gnome-phone-manager - Packager: Babasaki
165- Updated specfile
166
167#----------------------------------------------------------------------------
168* Tue Oct 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-3
169- Rebuild for new libgnokii
170
171* Thu Sep 11 2008  Matthias Clasen  <mclasen@redhat.com>
172- Rebuild
173
174* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-1
175- Update to 0.60
176- Remove vendor from desktop file
177
178* Wed May 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-2
179- Rebuild
180
181* Fri Mar 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-1
182- Update to 0.51
183
184* Fri Mar 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-3
185- Add a patch from upstream to fix connection to serial devices (#356861)
186
187* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-2
188- Work-around for telepathy brokeness
189
190* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-1
191- Update to 0.50
192
193* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.40-3
194- Autorebuild for GCC 4.3
195
196* Wed Dec 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-2
197- Rebuild against new release of gnokii
198
199* Wed Nov 14 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-1
200- Update to 0.40
201- Add experimental telepathy backend in a subpackage
202
203* Mon Oct 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.30-1
204- Update to 0.30
205- Fix sending non-ASCII texts (for real)
206- Add debugging improvements
207
208* Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 0.20-1
209- Update to 0.20
210
211* Sun Aug 19 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
212- Update to 0.10 (#253400)
213- Remove obsolete work-arounds and dependencies
214- Update BRs
215- Add GConf scriptlets
216
217* Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.8-6
218- Update license field from GPL to GPLv2+
219
220* Sun Nov 15 2006 Linus Walleij <triad@df.lth.se> 0.8-5
221- Rebuild to pick up libbtctl i/f bump.
222
223* Sun Oct 29 2006 Linus Walleij <triad@df.lth.se> 0.8-4
224- Rebuild to pick up libedataserver i/f bump.
225
226* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-3
227- Pick up intltool.
228
229* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-2
230- Pick up libtool.
231
232* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-1
233- New upstream version including patch.
234- The icon is an an even weirder place now!
235- Have to run som autotools on this one to get it working.
236
237* Tue Sep 5 2006 Linus Walleij <triad@df.lth.se> 0.7-5
238- Patch to compile with new version of E-D-S.
239
240* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> 0.7-4
241- Missing BR
242
243* Thu Aug 3 2006 Linus Walleij <triad@df.lth.se> 0.7-3
244- Updated after feedback from Chris Weyl
245- Bogus problem with cellphone.png icon image
246
247* Sat Jul 29 2006 Linus Walleij <triad@df.lth.se> 0.7-2
248- Updated after feedback from Parag and Paul
249
250* Tue Jun 27 2006 Linus Walleij <triad@df.lth.se> 0.7-1
251- 0.7 Release
252- Took Matthews nrpm package and Fedora Extrasificated it
253
254* Fri Sep 09 2005 Matthew Hall <matt@nrpms.net> 0.6-1
255- 0.6 Release
256
257* Mon Jun 20 2005 Matthew Hall <matt@nrpms.net> 0.4-1
258- 0.4 Release
Note: See TracBrowser for help on using the repository browser.