source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 805

Revision 805, 24.7 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.30.0
6%define glib2_version 2.24.0
7%define gtk2_version 2.20.0
8%define libgnome_version 2.30.0
9%define libgnomeui_version 2.24.3
10%define orbit_version 2.14.17
11%define libwnck_version 2.30.0
12%define gconf_version 2.28.0
13%define gnome_menus_version 2.30.0
14%define evolution_data_server_version 2.30.0
15%define cairo_version 1.8.10
16%define dbus_version 1.2.24
17%define dbus_glib_version 0.82
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.0
20%define libcanberra_version 0.22
21
22Summary: GNOME panel
23Summary(ja): GNOME パネル
24Name: gnome-panel
25Version: 2.30.0
26Release: 1%{_dist_release}
27URL: http://www.gnome.org/
28License: GPL
29Group: User Interface/Desktops
30
31Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.30/%{name}-%{version}.tar.bz2
32# Remove this line and next line when upstream adopt Source1
33Source1: clock.gnome-2-28.ja.po
34Source2: vine-panel-default-setup.entries
35# Remove this line and next line when upstream adopt Source3
36Source3: fish.help.Makefile.am
37# Remove this line and next line when upstream adopt Source4
38Source4: gnome-panel.fish.gnome-2-28.ja.po
39Source5: vine-panel-backwards-compat-config.schemas
40Source10: add-translations.sh
41Source12: gnome-compiler-flags.m4
42
43Patch0: gnome-panel-2.28.0-vendor.patch
44Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
45Patch2: gnome-panel-2.28.0-about-vine.patch
46
47# the next three patches belong together
48# http://bugzilla.gnome.org/show_bug.cgi?id=470966
49Patch8: launcher-desktop-files.patch
50Patch9: desktop-file-monitoring.patch
51Patch10: preferred-apps.patch
52
53# don't pop up an error dialog if an applet from the
54# default configuration is missing; we don't want to
55# add a hard dependency on e.g. tomboy
56Patch11: applet-error.patch
57
58BuildRoot: %{_tmppath}/%{name}-%{version}-root
59
60Requires: gnome-desktop >= %{gnome_desktop_version}
61Requires: libwnck >= %{libwnck_version}
62Requires: gnome-menus >= %{gnome_menus_version}
63Requires: vine-menus >= 1.1
64Requires(post,postun): scrollkeeper, gtk2
65Requires(post,pre,preun): GConf2
66
67Provides: %{name}-devel = %{version}-%{release}
68
69%if %{use_eds}
70Requires: evolution-data-server
71%endif
72Requires: libSM
73
74BuildRequires: libxml2-python
75BuildRequires: intltool
76BuildRequires: gettext
77BuildRequires: automake
78BuildRequires: autoconf
79BuildRequires: libtool
80BuildRequires: scrollkeeper
81BuildRequires: libxslt
82BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
83BuildRequires: gtk2-devel >= %{gtk2_version}
84BuildRequires: libgnome-devel >= %{libgnome_version}
85BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
86BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
87BuildRequires: libwnck-devel >= %{libwnck_version}
88BuildRequires: GConf2-devel >= %{gconf_version}
89BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
90BuildRequires: cairo-devel >= %{cairo_version}
91BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
92BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
93BuildRequires: gtk-doc
94BuildRequires: pango-devel
95BuildRequires: libbonobo-devel
96BuildRequires: libX11-devel
97BuildRequires: libXau-devel
98%if %{use_eds}
99BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
100BuildRequires: ORBit2-devel >= %{orbit_version}
101BuildRequires: dbus-devel >= %{dbus_version}
102%endif
103BuildRequires: libgweather-devel >= %{libgweather_version}
104BuildRequires: libcanberra-devel >= %{libcanberra_versino}
105BuildRequires: librsvg2-devel
106BuildRequires: polkit-gnome-devel
107BuildRequires: NetworkManager-devel
108BuildRequires: libSM-devel
109BuildRequires(install): desktop-file-utils
110
111%description
112
113The GNOME panel provides the window list, workspace switcher, menus, and other
114features for the GNOME desktop.
115
116%description -l ja
117
118GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
119特徴を GNOME デスクトップに提供します。
120
121%prep
122%setup -q
123
124# Remove this line and next line when upstream adopt Source1
125cp -f %{SOURCE1} help/clock/ja/ja.po
126# Remove next line when upstream adopt Source3
127cp -f %{SOURCE3} help/fish/Makefile.am
128# Remove next line when upstream adopt Source4
129mkdir help/fish/ja
130# Remove next line when upstream adopt Source4
131cp -f %{SOURCE4} help/fish/ja/ja.po
132
133cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
134cp -f %{SOURCE12} m4
135cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
136
137%patch0 -p1 -b .vendor
138%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
139%patch2 -p1 -b .about-vine
140%patch8 -p1 -b .launcher-desktop-files
141%patch9 -p1 -b .desktop-file-monitoring
142%patch10 -p1 -b .preferred-apps
143%patch11 -p1 -b .applet-error
144
145libtoolize --force --copy
146
147. %{SOURCE10}
148
149%build
150# gpm-integration patches Makefile.am and configure.in
151aclocal -I m4
152automake --add-missing
153autoheader
154autoconf
155%configure --disable-scrollkeeper \
156           --disable-schemas-install \
157           --disable-gtk-doc \
158           --with-in-process-applets=clock:fish \
159%if %{use_eds}
160           --enable-eds=yes
161%else
162           --enable-eds=no
163%endif
164make
165
166%install
167rm -rf $RPM_BUILD_ROOT
168
169export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
170%makeinstall
171unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
172
173#
174# Create pager and tasklist schemas for compatibility with older
175# configurations which reference the old schema names
176#
177sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
178sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
179
180
181## blow away stuff we don't want
182/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
183#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
184/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
185
186/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
187
188sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
189
190desktop-file-install --delete-original \
191  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
192  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
193
194%find_lang %{gettext_package} --all-name --with-gnome
195#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
196
197%clean
198rm -rf $RPM_BUILD_ROOT
199
200%post
201touch --no-create %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
204fi
205
206export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
207
208#
209# Clear out the old defaults
210#
211gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
212gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
213
214# install schemas
215SCHEMAS="clock.schemas fish.schemas pager.schemas \
216        panel-compatibility.schemas panel-general.schemas \
217        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
218        tasklist.schemas window-list.schemas workspace-switcher.schemas"
219for S in $SCHEMAS; do
220    echo %{_sysconfdir}/gconf/schemas/$S ; done \
221    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
222
223#
224# Install the default setup into /apps/panel and /apps/panel/default_setup
225#
226gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
227gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
228
229/sbin/ldconfig
230scrollkeeper-update > /dev/null 2>&1 || :
231
232%pre
233if [ "$1" -gt 1 ]; then
234  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
235  SCHEMAS="clock.schemas fish.schemas pager.schemas \
236          panel-compatibility.schemas panel-general.schemas \
237          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
238          tasklist.schemas window-list.schemas workspace-switcher.schemas"
239  for S in $SCHEMAS; do
240      echo %{_sysconfdir}/gconf/schemas/$S ; done \
241      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
242fi
243
244%preun
245if [ "$1" -eq 0 ]; then
246  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
247  SCHEMAS="clock.schemas fish.schemas pager.schemas \
248          panel-compatibility.schemas panel-general.schemas \
249          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
250          tasklist.schemas window-list.schemas workspace-switcher.schemas"
251  for S in $SCHEMAS; do
252      echo %{_sysconfdir}/gconf/schemas/$S ; done \
253      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
254fi
255
256%postun
257/sbin/ldconfig
258scrollkeeper-update > /dev/null 2>&1 || :
259touch --no-create %{_datadir}/icons/hicolor
260if [ -x /usr/bin/gtk-update-icon-cache ]; then
261  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
262fi
263 
264%files -f %{gettext_package}.lang
265%defattr(-,root,root)
266%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
267%{_datadir}/applications/*.desktop
268%{_datadir}/icons/*
269%{_datadir}/gnome-panel
270%exclude %{_datadir}/gnome-panelrc
271%{_datadir}/idl/gnome-panel-2.0
272%{_datadir}/gnome-2.0/ui/*
273%{_mandir}/man*/*
274%{_bindir}/*
275%{_libexecdir}/*
276%{_libdir}/bonobo/servers/*.server
277%{_libdir}/*.so.*
278%{_sysconfdir}/gconf/schemas/*.schemas
279%{_sysconfdir}/gconf/schemas/*.entries
280
281%{_sysconfdir}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
282%{_datadir}/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
283%{_datadir}/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
284
285# theoretically a devel package, but just doesn't seem worth it
286%{_libdir}/pkgconfig/*.pc
287%{_includedir}/panel-2.0
288%{_libdir}/*.so
289%{_datadir}/gtk-doc
290
291%changelog
292* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
293- new upstream release
294- update Patch8, Patch9 (from FC package)
295- add BuildRequires: libcanberra-devel
296
297* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
298- update translation of clock applet manual
299- add translation of fish applet manual
300
301* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
302- add libSM(-devel) to (Build)Requires
303- add desktop-file-utils to BuildRequires
304
305* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
306- update translation of clock applet manual
307
308* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
309- new upstream release
310- updated Patch0 and 2
311
312* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
313- new upstream release
314
315* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
316- rebuild with gtk2-2.16.3
317
318* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
319- add empty gconf entries to vine-panel-default-setup.entries
320
321* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
322- new upstream release
323
324* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
325- new upstream release
326
327* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
328- update vine-panel-default-setup.entries again..
329
330* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
331- update vine-panel-default-setup.entries
332
333* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
334- remove mixer applets from default panel setup
335
336* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
337- new upstream release
338
339* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
340- new upstream release
341- added BuildRequires: PolicyKit-gnome-devel
342
343* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
344- new upstream release
345
346* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
347- new upstream release
348
349* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
350- new upstream release
351
352* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
353- new upstream release
354
355* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
356- new upstream release
357- removed Patch25,26,27,29 and 30 (merged into upstream)
358
359* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
360- added Patches from FC
361  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
362  - Fix editing of locations in the clock applet
363  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
364  - Convert the edit and find location windows to dialogs
365  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
366  - Improve the time settings window
367  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
368  - Make the find-location window of the clock larger
369  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
370  - Only save the session when the users wants it
371  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
372  - Populate the location list before showing the preference window
373  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
374  - Add "About This Computer" item to System menu if it exists
375  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
376  - Try harder to avoid resizing the popup
377- updated BuildRequires
378
379* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
380- new upstream release
381- added BuildRequires: libgweather-devel
382
383* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
384- new upstream release
385- updated %post and %postun section
386- added %pre and %preun section
387- added Patches from Fedora
388  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
389  - Sharper icons
390  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
391  - Make it possible to start s-c-d from the clock menu again (#316921)
392  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
393  - Don't pop up an error if an applet from the default
394    configuration is missing 
395  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
396  - Turns out we need requires for applets in the default config (#293261)
397  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
398  - Drop the requires for fast-user-switch-applet (#253831)
399
400* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
401- new upstream release
402- dropped Patch22 (merged into upstream)
403
404* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
405- new upstream release
406
407* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
408- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
409
410* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
411- new upstream release
412- fix panel-default-setup.entries to change the name of
413  firefox desktopfile (<BTS:229>)
414
415* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
416- add patch 11 to fix disappearing of recent documents list.
417  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
418
419* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
420- new upstream release
421
422* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
423- new upstream release
424
425* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
426- run gtk-update-icon-cache in %%post script.
427
428* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
429- new upstream release
430
431* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
432- update vine-panel-default-setup.entries
433  - replace mozilla by firefox
434  - remove nautilus
435  - add notification area applet on top panel
436  - add trashbox applet on bottom panel
437- cleanup %%post script
438
439* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
440- new upstream release
441
442* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
443- new upstream release
444- added Prereq: scroolkeeper, GConf2
445
446* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
447- new upstream release
448
449* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
450- new upstream release
451
452* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
453- new upstream release
454
455* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
456- new upstream release
457
458* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
459- new upstream release
460
461* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
462- disable evolution-data-server
463
464* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
465- new upstream release
466
467* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
468- add Patch10 to fix hard-coded desktop file name.
469
470* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
471- new upstream version
472
473* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
474- new upstream release
475- run scrollkeeper at %post, %postun
476
477* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
478- new upstream release
479
480* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
481- add Patch10 to fix egg-recent-model.c.
482  save old umask value before create ".recently-used" file.
483 
484* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
485- fix location of nautilus launcher in panel-default-setup.entries.
486- do not add wireless monitor in %%post when no interfaces are available.
487- add Japanese summary and description
488- add BuildRequires: startup-notification-devel, gcc-c++.
489- disable libtoolize: version mismatch is bad
490
491* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
492- new upstream release
493
494* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
495- new upstream release
496
497* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
498- rebuilt against new toolchain
499
500* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
501- add --disable-schemas-install option to %%configure
502
503* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
504- new upstream release
505
506* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
507- add missing files
508- add vine default panel entries
509
510* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
511- new upstream release
512
513* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
514- new upstream release
515
516* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
517- new upstream release
518
519* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
520- remove vine's panel-per-panel-config.schemas
521  This should be added again in a future version.
522
523* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
524- new upstream release
525
526* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
527- new upstream release
528- remove old ja.po
529
530* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
531- new upstream release
532
533* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
534- remove clockaddon, system-tray-applet
535
536* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
537- new upstream release
538
539* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
540- add patch1 from rawhide package.
541
542* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
543- new upstream release
544
545* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
546- add system-tray-applet
547- modify default panel menu.
548- update ja.po
549
550* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
551- add Requires: vine-menus
552
553* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
554- new upstream release
555
556* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
557- remove redhatize patch.
558
559* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
560- build for Vine Linux
561- new upstream release from gnome-2.1.4
562
563* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
564- fix postun script
565
566* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
567- 2.0.9 with menu edit stuff
568- system-tray-applet 0.15 that doesn't crash all the time
569- merge/remove patches as appropriate
570
571* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
572- Fix problem with "hold down print screen" (71432)
573
574* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
575- panel-properties OnlyShowIn=GNOME;
576- somehow the po file got screwed up.  Works now
577- update po files
578
579* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
580- fix from #71762 for clock applet popdown key
581- no WIN_POS_MOUSE fixes #72167
582- fix for #72540 from George
583
584* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
585- system tray applet 0.11 with a small memleak fix and a couple translations
586
587* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
588- menu tweaks
589
590* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
591- bump release
592
593* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
594- put battery applet on panel for laptops (#67296)
595
596* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
597- 2.0.6 final from gnome 2.0.1
598- remove gnome-panel-screenshot patch now upstream
599
600* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
601- new system-tray-applet version
602- Fix gnome-panel-screenshot
603
604* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
605- 2.0.4
606- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
607  for the foot menu
608
609* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
610- fix desktop (logout/lock) menu item location
611  in Alt+F1 and in new menu applets
612- remove Screenshot... menu item
613
614* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
615- move around default applets, remove some of them
616- system tray 0.9
617- change default menu flags
618- blow unpackaged files out of build root
619
620* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
621- 2.0.3
622- own libexecdir stuff
623
624* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
625- new system tray that's prettier and doesn't clip the icon
626
627* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
628- system tray 0.7 that doesn't crash on startup
629- get Mozilla desktop file right so we get web browser launcher
630
631* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
632- system tray 0.6 with server file fixed (work dammit)
633
634* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
635- tweak applet positions but I think it's just broken
636- system tray 0.5 moved back to libdir not libexecdir
637
638* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
639- remove ltmain.sh hack
640- new system-tray-applet that works
641
642* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
643- put office suite stuff on the panel
644
645* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
646- 2.0.2.90 cvs snap
647
648* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
649- update the clock patch to be a little smarter in a couple ways
650
651* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
652- Fix problem where system tray applet was being looked for in /unst
653- Fix a crash in the system tray applet
654
655* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
656- Fix typo in the pt_BR translation that was causing GConf problems
657
658* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
659- add the system tray applet
660- add system tray applet by default
661- add more launcher by default
662
663* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
664- automated rebuild
665
666* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
667- use correct gettext package name, and add check for missing translations
668
669* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
670- add the calendar and configuration patch
671
672* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
673- 2.0.0
674- add control center desktop file to file list
675- add gnome-panelrc to file list
676- try fixing panel size (blind, no text box at home)
677
678* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
679- rebuild in different environment
680
681* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
682- updates to default configuration
683
684* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
685- fix schemas installation
686
687* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
688- unset old panel schemas when installing new ones
689- put in a broken panel config to see errors about
690- add a patch to give some decent error messages about what's wrong
691  with the default panel config
692
693* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
694- rebuild in different environment
695
696* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
697- don't provide/obsolete gnome-core
698
699* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
700- rebuild in different environment
701
702* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
703- 1.5.24
704- ldconfig
705
706* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
707- rebuild in different environment
708
709* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
710- 1.5.23
711
712* Sun May 26 2002 Tim Powers <timp@redhat.com>
713- automated rebuild
714
715* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
716- rebuild in different environment
717
718* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
719- 1.5.22
720- provide gnome-core
721- add a bunch of extra build requires so build system
722  won't get confused
723
724* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
725- 1.5.19
726
727* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
728- add the keep-libtool-from-relinking hack so
729  we get the gen util applet
730
731* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
732- obsoletes gnome-core-devel
733- include libdir/*.so
734
735* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
736- get libpanel-applet in the package
737
738* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
739- Initial build.
740
741
Note: See TracBrowser for help on using the repository browser.