source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 686

Revision 686, 24.3 KB checked in by yasumichi, 14 years ago (diff)
  • update translation of clock applet manual
  • add translation of fish applet manual
Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.26.0
6%define glib2_version 2.20.0
7%define gtk2_version 2.16.0
8%define libgnome_version 2.26.0
9%define libgnomeui_version 2.24.1
10%define orbit_version 2.14.0
11%define libwnck_version 2.26.0
12%define gconf_version 2.26.0
13%define gnome_menus_version 2.26.0
14%define evolution_data_server_version 2.26.0
15%define cairo_version 1.8.6
16%define dbus_version 1.2
17%define dbus_glib_version 0.73
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.26.0
20
21Summary: GNOME panel
22Summary(ja): GNOME パネル
23Name: gnome-panel
24Version: 2.28.0
25Release: 4%{_dist_release}
26URL: http://www.gnome.org/
27License: GPL
28Group: User Interface/Desktops
29
30Source0: %{name}-%{version}.tar.bz2
31# Remove this line and next line when upstream adopt Source1
32Source1: clock.gnome-2-28.ja.po
33Source2: vine-panel-default-setup.entries
34# Remove this line and next line when upstream adopt Source3
35Source3: fish.help.Makefile.am
36# Remove this line and next line when upstream adopt Source4
37Source4: gnome-panel.fish.gnome-2-28.ja.po
38Source5: vine-panel-backwards-compat-config.schemas
39Source10: add-translations.sh
40Source12: gnome-compiler-flags.m4
41
42Patch0: gnome-panel-2.28.0-vendor.patch
43Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
44Patch2: gnome-panel-2.28.0-about-vine.patch
45
46# the next three patches belong together
47# http://bugzilla.gnome.org/show_bug.cgi?id=470966
48Patch8: launcher-desktop-files.patch
49Patch9: desktop-file-monitoring.patch
50Patch10: preferred-apps.patch
51
52# don't pop up an error dialog if an applet from the
53# default configuration is missing; we don't want to
54# add a hard dependency on e.g. tomboy
55Patch11: applet-error.patch
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59Requires: gnome-desktop >= %{gnome_desktop_version}
60Requires: libwnck >= %{libwnck_version}
61Requires: gnome-menus >= %{gnome_menus_version}
62Requires: vine-menus >= 1.1
63Requires(post,postun): scrollkeeper, gtk2
64Requires(post,pre,preun): GConf2
65
66Provides: %{name}-devel = %{version}-%{release}
67
68%if %{use_eds}
69Requires: evolution-data-server
70%endif
71Requires: libSM
72
73BuildRequires: libxml2-python
74BuildRequires: intltool
75BuildRequires: gettext
76BuildRequires: automake
77BuildRequires: autoconf
78BuildRequires: libtool
79BuildRequires: scrollkeeper
80BuildRequires: libxslt
81BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
82BuildRequires: gtk2-devel >= %{gtk2_version}
83BuildRequires: libgnome-devel >= %{libgnome_version}
84BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
85BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
86BuildRequires: libwnck-devel >= %{libwnck_version}
87BuildRequires: GConf2-devel >= %{gconf_version}
88BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
89BuildRequires: cairo-devel >= %{cairo_version}
90BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
91BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
92BuildRequires: gtk-doc
93BuildRequires: pango-devel
94BuildRequires: libbonobo-devel
95BuildRequires: libX11-devel
96BuildRequires: libXau-devel
97%if %{use_eds}
98BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
99BuildRequires: ORBit2-devel >= %{orbit_version}
100BuildRequires: dbus-devel >= %{dbus_version}
101%endif
102BuildRequires: libgweather-devel >= %{libgweather_version}
103BuildRequires: librsvg2-devel
104BuildRequires: polkit-gnome-devel
105BuildRequires: NetworkManager-devel
106BuildRequires: libSM-devel
107BuildRequires(install): desktop-file-utils
108
109%description
110
111The GNOME panel provides the window list, workspace switcher, menus, and other
112features for the GNOME desktop.
113
114%description -l ja
115
116GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
117特徴を GNOME デスクトップに提供します。
118
119%prep
120%setup -q
121
122# Remove this line and next line when upstream adopt Source1
123cp -f %{SOURCE1} help/clock/ja/ja.po
124# Remove next line when upstream adopt Source3
125cp -f %{SOURCE3} help/fish/Makefile.am
126# Remove next line when upstream adopt Source4
127mkdir help/fish/ja
128# Remove next line when upstream adopt Source4
129cp -f %{SOURCE4} help/fish/ja/ja.po
130
131cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
132cp -f %{SOURCE12} m4
133cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
134
135%patch0 -p1 -b .vendor
136%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
137%patch2 -p1 -b .about-vine
138%patch8 -p1 -b .launcher-desktop-files
139%patch9 -p1 -b .desktop-file-monitoring
140%patch10 -p1 -b .preferred-apps
141%patch11 -p1 -b .applet-error
142
143libtoolize --force --copy
144
145. %{SOURCE10}
146
147%build
148# gpm-integration patches Makefile.am and configure.in
149aclocal -I m4
150automake --add-missing
151autoheader
152autoconf
153%configure --disable-scrollkeeper \
154           --disable-schemas-install \
155           --disable-gtk-doc \
156           --with-in-process-applets=clock:fish \
157%if %{use_eds}
158           --enable-eds=yes
159%else
160           --enable-eds=no
161%endif
162make
163
164%install
165rm -rf $RPM_BUILD_ROOT
166
167export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
168%makeinstall
169unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
170
171#
172# Create pager and tasklist schemas for compatibility with older
173# configurations which reference the old schema names
174#
175sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
176sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
177
178
179## blow away stuff we don't want
180/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
181#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
182/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
183
184/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
185
186sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
187
188desktop-file-install --delete-original \
189  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
190  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
191
192%find_lang %{gettext_package} --all-name --with-gnome
193#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
194
195%clean
196rm -rf $RPM_BUILD_ROOT
197
198%post
199touch --no-create %{_datadir}/icons/hicolor
200if [ -x /usr/bin/gtk-update-icon-cache ]; then
201  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
202fi
203
204export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
205
206#
207# Clear out the old defaults
208#
209gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
210gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
211
212# install schemas
213SCHEMAS="clock.schemas fish.schemas pager.schemas \
214        panel-compatibility.schemas panel-general.schemas \
215        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
216        tasklist.schemas window-list.schemas workspace-switcher.schemas"
217for S in $SCHEMAS; do
218    echo %{_sysconfdir}/gconf/schemas/$S ; done \
219    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
220
221#
222# Install the default setup into /apps/panel and /apps/panel/default_setup
223#
224gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
225gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
226
227/sbin/ldconfig
228scrollkeeper-update > /dev/null 2>&1 || :
229
230%pre
231if [ "$1" -gt 1 ]; then
232  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
233  SCHEMAS="clock.schemas fish.schemas pager.schemas \
234          panel-compatibility.schemas panel-general.schemas \
235          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
236          tasklist.schemas window-list.schemas workspace-switcher.schemas"
237  for S in $SCHEMAS; do
238      echo %{_sysconfdir}/gconf/schemas/$S ; done \
239      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
240fi
241
242%preun
243if [ "$1" -eq 0 ]; then
244  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
245  SCHEMAS="clock.schemas fish.schemas pager.schemas \
246          panel-compatibility.schemas panel-general.schemas \
247          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
248          tasklist.schemas window-list.schemas workspace-switcher.schemas"
249  for S in $SCHEMAS; do
250      echo %{_sysconfdir}/gconf/schemas/$S ; done \
251      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
252fi
253
254%postun
255/sbin/ldconfig
256scrollkeeper-update > /dev/null 2>&1 || :
257touch --no-create %{_datadir}/icons/hicolor
258if [ -x /usr/bin/gtk-update-icon-cache ]; then
259  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
260fi
261 
262%files -f %{gettext_package}.lang
263%defattr(-,root,root)
264%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
265%{_datadir}/applications/*.desktop
266%{_datadir}/icons/*
267%{_datadir}/gnome-panel
268%exclude %{_datadir}/gnome-panelrc
269%{_datadir}/idl/gnome-panel-2.0
270%{_datadir}/gnome-2.0/ui/*
271%{_mandir}/man*/*
272%{_bindir}/*
273%{_libexecdir}/*
274%{_libdir}/bonobo/servers/*.server
275%{_libdir}/*.so.*
276%{_sysconfdir}/gconf/schemas/*.schemas
277%{_sysconfdir}/gconf/schemas/*.entries
278
279%{_sysconfdir}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
280%{_datadir}/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
281%{_datadir}/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
282
283# theoretically a devel package, but just doesn't seem worth it
284%{_libdir}/pkgconfig/*.pc
285%{_includedir}/panel-2.0
286%{_libdir}/*.so
287%{_datadir}/gtk-doc
288
289%changelog
290* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
291- update translation of clock applet manual
292- add translation of fish applet manual
293
294* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
295- add libSM(-devel) to (Build)Requires
296- add desktop-file-utils to BuildRequires
297
298* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
299- update translation of clock applet manual
300
301* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
302- new upstream release
303- updated Patch0 and 2
304
305* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
306- new upstream release
307
308* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
309- rebuild with gtk2-2.16.3
310
311* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
312- add empty gconf entries to vine-panel-default-setup.entries
313
314* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
315- new upstream release
316
317* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
318- new upstream release
319
320* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
321- update vine-panel-default-setup.entries again..
322
323* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
324- update vine-panel-default-setup.entries
325
326* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
327- remove mixer applets from default panel setup
328
329* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
330- new upstream release
331
332* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
333- new upstream release
334- added BuildRequires: PolicyKit-gnome-devel
335
336* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
337- new upstream release
338
339* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
340- new upstream release
341
342* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
343- new upstream release
344
345* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
346- new upstream release
347
348* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
349- new upstream release
350- removed Patch25,26,27,29 and 30 (merged into upstream)
351
352* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
353- added Patches from FC
354  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
355  - Fix editing of locations in the clock applet
356  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
357  - Convert the edit and find location windows to dialogs
358  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
359  - Improve the time settings window
360  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
361  - Make the find-location window of the clock larger
362  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
363  - Only save the session when the users wants it
364  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
365  - Populate the location list before showing the preference window
366  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
367  - Add "About This Computer" item to System menu if it exists
368  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
369  - Try harder to avoid resizing the popup
370- updated BuildRequires
371
372* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
373- new upstream release
374- added BuildRequires: libgweather-devel
375
376* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
377- new upstream release
378- updated %post and %postun section
379- added %pre and %preun section
380- added Patches from Fedora
381  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
382  - Sharper icons
383  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
384  - Make it possible to start s-c-d from the clock menu again (#316921)
385  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
386  - Don't pop up an error if an applet from the default
387    configuration is missing 
388  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
389  - Turns out we need requires for applets in the default config (#293261)
390  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
391  - Drop the requires for fast-user-switch-applet (#253831)
392
393* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
394- new upstream release
395- dropped Patch22 (merged into upstream)
396
397* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
398- new upstream release
399
400* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
401- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
402
403* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
404- new upstream release
405- fix panel-default-setup.entries to change the name of
406  firefox desktopfile (<BTS:229>)
407
408* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
409- add patch 11 to fix disappearing of recent documents list.
410  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
411
412* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
413- new upstream release
414
415* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
416- new upstream release
417
418* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
419- run gtk-update-icon-cache in %%post script.
420
421* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
422- new upstream release
423
424* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
425- update vine-panel-default-setup.entries
426  - replace mozilla by firefox
427  - remove nautilus
428  - add notification area applet on top panel
429  - add trashbox applet on bottom panel
430- cleanup %%post script
431
432* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
433- new upstream release
434
435* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
436- new upstream release
437- added Prereq: scroolkeeper, GConf2
438
439* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
440- new upstream release
441
442* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
443- new upstream release
444
445* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
446- new upstream release
447
448* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
449- new upstream release
450
451* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
452- new upstream release
453
454* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
455- disable evolution-data-server
456
457* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
458- new upstream release
459
460* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
461- add Patch10 to fix hard-coded desktop file name.
462
463* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
464- new upstream version
465
466* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
467- new upstream release
468- run scrollkeeper at %post, %postun
469
470* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
471- new upstream release
472
473* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
474- add Patch10 to fix egg-recent-model.c.
475  save old umask value before create ".recently-used" file.
476 
477* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
478- fix location of nautilus launcher in panel-default-setup.entries.
479- do not add wireless monitor in %%post when no interfaces are available.
480- add Japanese summary and description
481- add BuildRequires: startup-notification-devel, gcc-c++.
482- disable libtoolize: version mismatch is bad
483
484* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
485- new upstream release
486
487* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
488- new upstream release
489
490* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
491- rebuilt against new toolchain
492
493* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
494- add --disable-schemas-install option to %%configure
495
496* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
497- new upstream release
498
499* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
500- add missing files
501- add vine default panel entries
502
503* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
504- new upstream release
505
506* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
507- new upstream release
508
509* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
510- new upstream release
511
512* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
513- remove vine's panel-per-panel-config.schemas
514  This should be added again in a future version.
515
516* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
517- new upstream release
518
519* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
520- new upstream release
521- remove old ja.po
522
523* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
524- new upstream release
525
526* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
527- remove clockaddon, system-tray-applet
528
529* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
530- new upstream release
531
532* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
533- add patch1 from rawhide package.
534
535* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
536- new upstream release
537
538* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
539- add system-tray-applet
540- modify default panel menu.
541- update ja.po
542
543* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
544- add Requires: vine-menus
545
546* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
547- new upstream release
548
549* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
550- remove redhatize patch.
551
552* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
553- build for Vine Linux
554- new upstream release from gnome-2.1.4
555
556* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
557- fix postun script
558
559* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
560- 2.0.9 with menu edit stuff
561- system-tray-applet 0.15 that doesn't crash all the time
562- merge/remove patches as appropriate
563
564* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
565- Fix problem with "hold down print screen" (71432)
566
567* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
568- panel-properties OnlyShowIn=GNOME;
569- somehow the po file got screwed up.  Works now
570- update po files
571
572* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
573- fix from #71762 for clock applet popdown key
574- no WIN_POS_MOUSE fixes #72167
575- fix for #72540 from George
576
577* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
578- system tray applet 0.11 with a small memleak fix and a couple translations
579
580* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
581- menu tweaks
582
583* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
584- bump release
585
586* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
587- put battery applet on panel for laptops (#67296)
588
589* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
590- 2.0.6 final from gnome 2.0.1
591- remove gnome-panel-screenshot patch now upstream
592
593* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
594- new system-tray-applet version
595- Fix gnome-panel-screenshot
596
597* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
598- 2.0.4
599- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
600  for the foot menu
601
602* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
603- fix desktop (logout/lock) menu item location
604  in Alt+F1 and in new menu applets
605- remove Screenshot... menu item
606
607* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
608- move around default applets, remove some of them
609- system tray 0.9
610- change default menu flags
611- blow unpackaged files out of build root
612
613* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
614- 2.0.3
615- own libexecdir stuff
616
617* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
618- new system tray that's prettier and doesn't clip the icon
619
620* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
621- system tray 0.7 that doesn't crash on startup
622- get Mozilla desktop file right so we get web browser launcher
623
624* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
625- system tray 0.6 with server file fixed (work dammit)
626
627* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
628- tweak applet positions but I think it's just broken
629- system tray 0.5 moved back to libdir not libexecdir
630
631* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
632- remove ltmain.sh hack
633- new system-tray-applet that works
634
635* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
636- put office suite stuff on the panel
637
638* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
639- 2.0.2.90 cvs snap
640
641* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
642- update the clock patch to be a little smarter in a couple ways
643
644* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
645- Fix problem where system tray applet was being looked for in /unst
646- Fix a crash in the system tray applet
647
648* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
649- Fix typo in the pt_BR translation that was causing GConf problems
650
651* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
652- add the system tray applet
653- add system tray applet by default
654- add more launcher by default
655
656* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
657- automated rebuild
658
659* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
660- use correct gettext package name, and add check for missing translations
661
662* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
663- add the calendar and configuration patch
664
665* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
666- 2.0.0
667- add control center desktop file to file list
668- add gnome-panelrc to file list
669- try fixing panel size (blind, no text box at home)
670
671* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
672- rebuild in different environment
673
674* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
675- updates to default configuration
676
677* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
678- fix schemas installation
679
680* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
681- unset old panel schemas when installing new ones
682- put in a broken panel config to see errors about
683- add a patch to give some decent error messages about what's wrong
684  with the default panel config
685
686* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
687- rebuild in different environment
688
689* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
690- don't provide/obsolete gnome-core
691
692* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
693- rebuild in different environment
694
695* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
696- 1.5.24
697- ldconfig
698
699* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
700- rebuild in different environment
701
702* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
703- 1.5.23
704
705* Sun May 26 2002 Tim Powers <timp@redhat.com>
706- automated rebuild
707
708* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
709- rebuild in different environment
710
711* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
712- 1.5.22
713- provide gnome-core
714- add a bunch of extra build requires so build system
715  won't get confused
716
717* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
718- 1.5.19
719
720* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
721- add the keep-libtool-from-relinking hack so
722  we get the gen util applet
723
724* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
725- obsoletes gnome-core-devel
726- include libdir/*.so
727
728* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
729- get libpanel-applet in the package
730
731* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
732- Initial build.
733
734
Note: See TracBrowser for help on using the repository browser.