source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 6201

Revision 6201, 26.1 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-themes: fix Vine theme
metacity: fix theme
others: new upstream release

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 3.4.1
6%define glib2_version 2.32.1
7%define gtk3_version 3.4.1
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.0.0
11%define gconf_version 2.32.0
12%define gnome_menus_version 2.30.4
13%define evolution_data_server_version 2.32.0
14%define cairo_version 1.10.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define gnome_doc_utils_version 0.3.2
18%define libgweather_version 2.30.3
19%define libcanberra_version 0.25
20%define gobject_introspection_version 0.9.8
21
22Summary: GNOME panel
23Summary(ja): GNOME パネル
24Name: gnome-panel
25Version: 3.4.2.1
26Release: 1%{_dist_release}
27URL: http://www.gnome.org/
28License: GPL
29Group: User Interface/Desktops
30
31Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.4/%{name}-%{version}.tar.xz
32# Remove this line and next line when upstream adopt Source1
33Source1: clock.gnome-2-32.ja.po
34Source2: vine6-panel-default-setup.entries
35Source5: vine-panel-backwards-compat-config.schemas
36Source10: add-translations.sh
37Source12: gnome-compiler-flags.m4
38
39Patch0: gnome-panel-3.0.2-configure.patch
40
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42
43Requires: %{name}-libs = %{version}-%{release}
44Requires: gnome-desktop3 >= %{gnome_desktop3_version}
45Requires: libwnck3 >= %{libwnck3_version}
46Requires: gnome-menus >= %{gnome_menus_version}
47Requires: vine-menus >= 1.1
48Requires(post,postun): scrollkeeper, gtk3
49Requires(post,pre,preun): GConf2
50
51%if %{use_eds}
52Requires: evolution-data-server >= 2.30.2
53%endif
54Requires: libSM
55
56BuildRequires: libxml2-python
57BuildRequires: intltool
58BuildRequires: gettext
59BuildRequires: automake
60BuildRequires: autoconf
61BuildRequires: libtool
62BuildRequires: scrollkeeper
63BuildRequires: libxslt
64BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
65BuildRequires: gtk3-devel >= %{gtk3_version}
66BuildRequires: libgnome-devel >= %{libgnome_version}
67BuildRequires: libwnck3-devel >= %{libwnck3_version}
68BuildRequires: GConf2-devel >= %{gconf_version}
69BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
70BuildRequires: cairo-devel >= %{cairo_version}
71BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
72BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
73BuildRequires: gtk-doc
74BuildRequires: pango-devel
75BuildRequires: libX11-devel
76BuildRequires: libXau-devel
77%if %{use_eds}
78BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
79BuildRequires: ORBit2-devel >= %{orbit_version}
80BuildRequires: dbus-devel >= %{dbus_version}
81%endif
82BuildRequires: libgweather-devel >= %{libgweather_version}
83BuildRequires: libcanberra-devel >= %{libcanberra_versino}
84BuildRequires: librsvg2-devel
85BuildRequires: NetworkManager-devel
86BuildRequires: libSM-devel
87BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
88BuildRequires: dconf-devel
89BuildRequires: polkit-devel
90BuildRequires: telepathy-glib-devel
91BuildRequires: desktop-file-utils
92
93Obsoletes: gnome-netstatus < 2.29
94
95%description
96
97The GNOME panel provides the window list, workspace switcher, menus, and other
98features for the GNOME desktop.
99
100%description -l ja
101
102GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
103特徴を GNOME デスクトップに提供します。
104
105%package libs
106Summary: Libraries for use in panel applets of GNOME
107Summary(ja): GNOME のパネルアップレットで使用するライブラリ
108Group: System Environment/Libraries
109
110%description libs
111Libraries for use in panel applets of GNOME.
112
113%description libs -l ja
114GNOME のパネルアップレットで使用するライブラリ
115
116%package devel
117Summary: Development environment for panel applets of GNOME
118Summary(ja): GNOME のパネルアップレット用開発環境
119Group: Development/Libraries
120Requires: %{name}-libs = %{version}-%{release}
121Requires: pkgconfig
122Requires: glib2-devel >= %{glib2_version}
123Requires: gtk3-devel >= %{gtk3_version}
124Requires: GConf2-devel >= %{gconf_version}
125
126%description devel
127Header files and libraries for building a panel applets of GNOME.
128
129%description devel -l ja
130GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
131
132
133%prep
134%setup -q
135%patch0 -p1
136
137# Remove this line and next line when upstream adopt Source1
138#cp -f %{SOURCE1} help/clock/ja/ja.po
139
140cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
141cp -f %{SOURCE12} m4
142cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
143
144. %{SOURCE10}
145
146%build
147# gpm-integration patches Makefile.am and configure.in
148#aclocal -I m4
149#automake --add-missing
150#autoheader
151#autoconf
152%configure --disable-scrollkeeper \
153           --disable-schemas-install \
154           --disable-gtk-doc \
155           --with-in-process-applets=clock:fish \
156           --enable-introspection=yes \
157           --enable-telepathy-glib=yes \
158%if %{use_eds}
159           --enable-eds=yes
160%else
161           --enable-eds=no
162%endif
163make
164
165%install
166rm -rf $RPM_BUILD_ROOT
167
168export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
169make install DESTDIR=$RPM_BUILD_ROOT
170unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
171
172#
173# Create pager and tasklist schemas for compatibility with older
174# configurations which reference the old schema names
175#
176#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
177#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
178
179
180## blow away stuff we don't want
181/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
182#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
183/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
184
185/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
186
187sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
188
189desktop-file-install --delete-original \
190  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
191  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
192
193%find_lang %{gettext_package} --all-name --with-gnome
194#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
195
196%clean
197rm -rf $RPM_BUILD_ROOT
198
199%post
200touch --no-create %{_datadir}/icons/hicolor
201if [ -x /usr/bin/gtk-update-icon-cache ]; then
202  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
203fi
204
205export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
206
207#
208# Clear out the old defaults
209#
210gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
211gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
212
213# install schemas
214SCHEMAS="clock.schemas"
215for S in $SCHEMAS; do
216    echo %{_sysconfdir}/gconf/schemas/$S ; done \
217    | xargs gconftool-2 --makefile-install-rule >& /dev/null 2>&1 ||:
218
219#
220# Install the default setup into /apps/panel and /apps/panel/default_setup
221#
222gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/clock.schemas > /dev/null 2>&1 || :
223
224/sbin/ldconfig
225scrollkeeper-update > /dev/null 2>&1 || :
226
227%pre
228if [ "$1" -gt 1 ]; then
229  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
230  SCHEMAS="clock.schemas"
231  for S in $SCHEMAS; do
232      echo %{_sysconfdir}/gconf/schemas/$S ; done \
233      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
234fi
235
236%preun
237if [ "$1" -eq 0 ]; then
238  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
239  SCHEMAS="clock.schemas"
240  for S in $SCHEMAS; do
241      echo %{_sysconfdir}/gconf/schemas/$S ; done \
242      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
243fi
244
245%postun
246/sbin/ldconfig
247scrollkeeper-update > /dev/null 2>&1 || :
248touch --no-create %{_datadir}/icons/hicolor
249if [ -x /usr/bin/gtk-update-icon-cache ]; then
250  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
251fi
252 
253%files -f %{gettext_package}.lang
254%defattr(-,root,root)
255%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
256%{_bindir}/*
257%exclude %{_bindir}/panel-test-applets
258%{_libexecdir}/*
259%{_sysconfdir}/gconf/schemas/*.schemas
260%{_datadir}/applications/*.desktop
261%{_datadir}/icons/hicolor/*/*/*
262%{_datadir}/glib-2.0/schemas/*.xml
263%{_datadir}/gnome-panel
264%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
265%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
266%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
267%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
268%{_mandir}/man*/*
269
270%files libs
271%{_libdir}/*.so.*
272%{_libdir}/girepository-1.0/*.typelib
273
274%files devel
275%{_bindir}/panel-test-applets
276%{_libdir}/pkgconfig/*.pc
277%{_includedir}/gnome-panel*
278%{_libdir}/*.so
279%{_datadir}/gtk-doc
280%{_datadir}/gir-1.0/*.gir
281
282
283%changelog
284* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
285- new upstream release
286
287* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
288- new upstream release
289- add BuildRequires: polkit-devel
290
291* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
292- new upstream release
293
294* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
295- new upstream release
296
297* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
298- new upstream release
299- remove BuildRequires: polkit-gnome-devel
300
301* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
302- rebuild with evolution-data-server-3.1.90
303
304* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
305- new upstream release
306
307* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
308- new upstream release
309- drop old Patches
310- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
311- change BuildRequires: libwnck3-devel instead of libwnck-devel
312- add BuildRequires: dconf-devel, telepathy-glib-devel
313- add Obsoletes: gnome-netstatus
314- add Patch0 (gnome-panel-3.0.2-configure.patch)
315
316* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
317- update SOURCE2(vine6-panel-default-setup.entries)
318  - remove bottom panel
319  - move window_list and workspace_switcher applet to top panel
320
321* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
322- update Source1 (clock.gnome-2.32.ja.po)
323
324* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
325- remove Provides: gnome-panel-devel
326
327* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
328- new upstream release
329
330* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
331- new upstream release
332- add BuildRequires: gobject-introspection-devel
333- remove BuildRequires: libgnomeui-devel
334- remove SOURCE3 and SOURCE4
335- drop Patch11
336- add configure option (--enable-introspection=yes)
337
338* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
339- rebuild with rpm-4.8.1 for pkg-config file
340
341* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
342- create -libs and -devel package
343
344* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
345- new upstream release
346
347* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
348- rebuild with evolution-data-server-2.30.2
349
350* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
351- new upstream release
352- update Patch8, Patch9 (from FC package)
353- add BuildRequires: libcanberra-devel
354
355* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
356- update translation of clock applet manual
357- add translation of fish applet manual
358
359* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
360- add libSM(-devel) to (Build)Requires
361- add desktop-file-utils to BuildRequires
362
363* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
364- update translation of clock applet manual
365
366* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
367- new upstream release
368- updated Patch0 and 2
369
370* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
371- new upstream release
372
373* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
374- rebuild with gtk2-2.16.3
375
376* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
377- add empty gconf entries to vine-panel-default-setup.entries
378
379* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
380- new upstream release
381
382* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
383- new upstream release
384
385* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
386- update vine-panel-default-setup.entries again..
387
388* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
389- update vine-panel-default-setup.entries
390
391* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
392- remove mixer applets from default panel setup
393
394* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
395- new upstream release
396
397* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
398- new upstream release
399- added BuildRequires: PolicyKit-gnome-devel
400
401* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
402- new upstream release
403
404* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
405- new upstream release
406
407* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
408- new upstream release
409
410* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
411- new upstream release
412
413* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
414- new upstream release
415- removed Patch25,26,27,29 and 30 (merged into upstream)
416
417* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
418- added Patches from FC
419  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
420  - Fix editing of locations in the clock applet
421  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
422  - Convert the edit and find location windows to dialogs
423  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
424  - Improve the time settings window
425  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
426  - Make the find-location window of the clock larger
427  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
428  - Only save the session when the users wants it
429  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
430  - Populate the location list before showing the preference window
431  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
432  - Add "About This Computer" item to System menu if it exists
433  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
434  - Try harder to avoid resizing the popup
435- updated BuildRequires
436
437* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
438- new upstream release
439- added BuildRequires: libgweather-devel
440
441* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
442- new upstream release
443- updated %post and %postun section
444- added %pre and %preun section
445- added Patches from Fedora
446  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
447  - Sharper icons
448  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
449  - Make it possible to start s-c-d from the clock menu again (#316921)
450  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
451  - Don't pop up an error if an applet from the default
452    configuration is missing 
453  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
454  - Turns out we need requires for applets in the default config (#293261)
455  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
456  - Drop the requires for fast-user-switch-applet (#253831)
457
458* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
459- new upstream release
460- dropped Patch22 (merged into upstream)
461
462* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
463- new upstream release
464
465* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
466- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
467
468* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
469- new upstream release
470- fix panel-default-setup.entries to change the name of
471  firefox desktopfile (<BTS:229>)
472
473* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
474- add patch 11 to fix disappearing of recent documents list.
475  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
476
477* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
478- new upstream release
479
480* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
481- new upstream release
482
483* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
484- run gtk-update-icon-cache in %%post script.
485
486* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
487- new upstream release
488
489* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
490- update vine-panel-default-setup.entries
491  - replace mozilla by firefox
492  - remove nautilus
493  - add notification area applet on top panel
494  - add trashbox applet on bottom panel
495- cleanup %%post script
496
497* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
498- new upstream release
499
500* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
501- new upstream release
502- added Prereq: scroolkeeper, GConf2
503
504* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
505- new upstream release
506
507* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
508- new upstream release
509
510* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
511- new upstream release
512
513* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
514- new upstream release
515
516* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
517- new upstream release
518
519* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
520- disable evolution-data-server
521
522* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
523- new upstream release
524
525* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
526- add Patch10 to fix hard-coded desktop file name.
527
528* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
529- new upstream version
530
531* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
532- new upstream release
533- run scrollkeeper at %post, %postun
534
535* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
536- new upstream release
537
538* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
539- add Patch10 to fix egg-recent-model.c.
540  save old umask value before create ".recently-used" file.
541 
542* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
543- fix location of nautilus launcher in panel-default-setup.entries.
544- do not add wireless monitor in %%post when no interfaces are available.
545- add Japanese summary and description
546- add BuildRequires: startup-notification-devel, gcc-c++.
547- disable libtoolize: version mismatch is bad
548
549* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
550- new upstream release
551
552* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
553- new upstream release
554
555* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
556- rebuilt against new toolchain
557
558* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
559- add --disable-schemas-install option to %%configure
560
561* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
562- new upstream release
563
564* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
565- add missing files
566- add vine default panel entries
567
568* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
569- new upstream release
570
571* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
572- new upstream release
573
574* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
575- new upstream release
576
577* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
578- remove vine's panel-per-panel-config.schemas
579  This should be added again in a future version.
580
581* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
582- new upstream release
583
584* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
585- new upstream release
586- remove old ja.po
587
588* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
589- new upstream release
590
591* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
592- remove clockaddon, system-tray-applet
593
594* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
595- new upstream release
596
597* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
598- add patch1 from rawhide package.
599
600* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
601- new upstream release
602
603* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
604- add system-tray-applet
605- modify default panel menu.
606- update ja.po
607
608* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
609- add Requires: vine-menus
610
611* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
612- new upstream release
613
614* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
615- remove redhatize patch.
616
617* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
618- build for Vine Linux
619- new upstream release from gnome-2.1.4
620
621* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
622- fix postun script
623
624* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
625- 2.0.9 with menu edit stuff
626- system-tray-applet 0.15 that doesn't crash all the time
627- merge/remove patches as appropriate
628
629* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
630- Fix problem with "hold down print screen" (71432)
631
632* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
633- panel-properties OnlyShowIn=GNOME;
634- somehow the po file got screwed up.  Works now
635- update po files
636
637* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
638- fix from #71762 for clock applet popdown key
639- no WIN_POS_MOUSE fixes #72167
640- fix for #72540 from George
641
642* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
643- system tray applet 0.11 with a small memleak fix and a couple translations
644
645* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
646- menu tweaks
647
648* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
649- bump release
650
651* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
652- put battery applet on panel for laptops (#67296)
653
654* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
655- 2.0.6 final from gnome 2.0.1
656- remove gnome-panel-screenshot patch now upstream
657
658* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
659- new system-tray-applet version
660- Fix gnome-panel-screenshot
661
662* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
663- 2.0.4
664- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
665  for the foot menu
666
667* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
668- fix desktop (logout/lock) menu item location
669  in Alt+F1 and in new menu applets
670- remove Screenshot... menu item
671
672* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
673- move around default applets, remove some of them
674- system tray 0.9
675- change default menu flags
676- blow unpackaged files out of build root
677
678* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
679- 2.0.3
680- own libexecdir stuff
681
682* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
683- new system tray that's prettier and doesn't clip the icon
684
685* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
686- system tray 0.7 that doesn't crash on startup
687- get Mozilla desktop file right so we get web browser launcher
688
689* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
690- system tray 0.6 with server file fixed (work dammit)
691
692* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
693- tweak applet positions but I think it's just broken
694- system tray 0.5 moved back to libdir not libexecdir
695
696* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
697- remove ltmain.sh hack
698- new system-tray-applet that works
699
700* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
701- put office suite stuff on the panel
702
703* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
704- 2.0.2.90 cvs snap
705
706* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
707- update the clock patch to be a little smarter in a couple ways
708
709* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
710- Fix problem where system tray applet was being looked for in /unst
711- Fix a crash in the system tray applet
712
713* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
714- Fix typo in the pt_BR translation that was causing GConf problems
715
716* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
717- add the system tray applet
718- add system tray applet by default
719- add more launcher by default
720
721* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
722- automated rebuild
723
724* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
725- use correct gettext package name, and add check for missing translations
726
727* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
728- add the calendar and configuration patch
729
730* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
731- 2.0.0
732- add control center desktop file to file list
733- add gnome-panelrc to file list
734- try fixing panel size (blind, no text box at home)
735
736* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
737- rebuild in different environment
738
739* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
740- updates to default configuration
741
742* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
743- fix schemas installation
744
745* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
746- unset old panel schemas when installing new ones
747- put in a broken panel config to see errors about
748- add a patch to give some decent error messages about what's wrong
749  with the default panel config
750
751* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
752- rebuild in different environment
753
754* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
755- don't provide/obsolete gnome-core
756
757* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
758- rebuild in different environment
759
760* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
761- 1.5.24
762- ldconfig
763
764* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
765- rebuild in different environment
766
767* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
768- 1.5.23
769
770* Sun May 26 2002 Tim Powers <timp@redhat.com>
771- automated rebuild
772
773* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
774- rebuild in different environment
775
776* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
777- 1.5.22
778- provide gnome-core
779- add a bunch of extra build requires so build system
780  won't get confused
781
782* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
783- 1.5.19
784
785* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
786- add the keep-libtool-from-relinking hack so
787  we get the gen util applet
788
789* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
790- obsoletes gnome-core-devel
791- include libdir/*.so
792
793* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
794- get libpanel-applet in the package
795
796* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
797- Initial build.
798
799
Note: See TracBrowser for help on using the repository browser.