source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 6078

Revision 6078, 26.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 3.4.1
6%define glib2_version 2.32.1
7%define gtk3_version 3.4.1
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.0.0
11%define gconf_version 2.32.0
12%define gnome_menus_version 2.30.4
13%define evolution_data_server_version 2.32.0
14%define cairo_version 1.10.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define gnome_doc_utils_version 0.3.2
18%define libgweather_version 2.30.3
19%define libcanberra_version 0.25
20%define gobject_introspection_version 0.9.8
21
22Summary: GNOME panel
23Summary(ja): GNOME パネル
24Name: gnome-panel
25Version: 3.4.1
26Release: 1%{_dist_release}
27URL: http://www.gnome.org/
28License: GPL
29Group: User Interface/Desktops
30
31Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.4/%{name}-%{version}.tar.xz
32# Remove this line and next line when upstream adopt Source1
33Source1: clock.gnome-2-32.ja.po
34Source2: vine6-panel-default-setup.entries
35Source5: vine-panel-backwards-compat-config.schemas
36Source10: add-translations.sh
37Source12: gnome-compiler-flags.m4
38
39Patch0: gnome-panel-3.0.2-configure.patch
40
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42
43Requires: %{name}-libs = %{version}-%{release}
44Requires: gnome-desktop3 >= %{gnome_desktop3_version}
45Requires: libwnck3 >= %{libwnck3_version}
46Requires: gnome-menus >= %{gnome_menus_version}
47Requires: vine-menus >= 1.1
48Requires(post,postun): scrollkeeper, gtk3
49Requires(post,pre,preun): GConf2
50
51%if %{use_eds}
52Requires: evolution-data-server >= 2.30.2
53%endif
54Requires: libSM
55
56BuildRequires: libxml2-python
57BuildRequires: intltool
58BuildRequires: gettext
59BuildRequires: automake
60BuildRequires: autoconf
61BuildRequires: libtool
62BuildRequires: scrollkeeper
63BuildRequires: libxslt
64BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
65BuildRequires: gtk3-devel >= %{gtk3_version}
66BuildRequires: libgnome-devel >= %{libgnome_version}
67BuildRequires: libwnck3-devel >= %{libwnck3_version}
68BuildRequires: GConf2-devel >= %{gconf_version}
69BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
70BuildRequires: cairo-devel >= %{cairo_version}
71BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
72BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
73BuildRequires: gtk-doc
74BuildRequires: pango-devel
75BuildRequires: libX11-devel
76BuildRequires: libXau-devel
77%if %{use_eds}
78BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
79BuildRequires: ORBit2-devel >= %{orbit_version}
80BuildRequires: dbus-devel >= %{dbus_version}
81%endif
82BuildRequires: libgweather-devel >= %{libgweather_version}
83BuildRequires: libcanberra-devel >= %{libcanberra_versino}
84BuildRequires: librsvg2-devel
85BuildRequires: NetworkManager-devel
86BuildRequires: libSM-devel
87BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
88BuildRequires: dconf-devel
89BuildRequires: polkit-devel
90BuildRequires: telepathy-glib-devel
91BuildRequires: desktop-file-utils
92
93Obsoletes: gnome-netstatus < 2.29
94
95%description
96
97The GNOME panel provides the window list, workspace switcher, menus, and other
98features for the GNOME desktop.
99
100%description -l ja
101
102GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
103特徴を GNOME デスクトップに提供します。
104
105%package libs
106Summary: Libraries for use in panel applets of GNOME
107Summary(ja): GNOME のパネルアップレットで使用するライブラリ
108Group: System Environment/Libraries
109
110%description libs
111Libraries for use in panel applets of GNOME.
112
113%description libs -l ja
114GNOME のパネルアップレットで使用するライブラリ
115
116%package devel
117Summary: Development environment for panel applets of GNOME
118Summary(ja): GNOME のパネルアップレット用開発環境
119Group: Development/Libraries
120Requires: %{name}-libs = %{version}-%{release}
121Requires: pkgconfig
122Requires: glib2-devel >= %{glib2_version}
123Requires: gtk3-devel >= %{gtk3_version}
124Requires: GConf2-devel >= %{gconf_version}
125
126%description devel
127Header files and libraries for building a panel applets of GNOME.
128
129%description devel -l ja
130GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
131
132
133%prep
134%setup -q
135%patch0 -p1
136
137# Remove this line and next line when upstream adopt Source1
138#cp -f %{SOURCE1} help/clock/ja/ja.po
139
140cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
141cp -f %{SOURCE12} m4
142cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
143
144. %{SOURCE10}
145
146%build
147# gpm-integration patches Makefile.am and configure.in
148#aclocal -I m4
149#automake --add-missing
150#autoheader
151#autoconf
152%configure --disable-scrollkeeper \
153           --disable-schemas-install \
154           --disable-gtk-doc \
155           --with-in-process-applets=clock:fish \
156           --enable-introspection=yes \
157           --enable-telepathy-glib=yes \
158%if %{use_eds}
159           --enable-eds=yes
160%else
161           --enable-eds=no
162%endif
163make
164
165%install
166rm -rf $RPM_BUILD_ROOT
167
168export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
169make install DESTDIR=$RPM_BUILD_ROOT
170unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
171
172#
173# Create pager and tasklist schemas for compatibility with older
174# configurations which reference the old schema names
175#
176#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
177#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
178
179
180## blow away stuff we don't want
181/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
182#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
183/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
184
185/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
186
187sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
188
189desktop-file-install --delete-original \
190  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
191  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
192
193%find_lang %{gettext_package} --all-name --with-gnome
194#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
195
196%clean
197rm -rf $RPM_BUILD_ROOT
198
199%post
200touch --no-create %{_datadir}/icons/hicolor
201if [ -x /usr/bin/gtk-update-icon-cache ]; then
202  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
203fi
204
205export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
206
207#
208# Clear out the old defaults
209#
210gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
211gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
212
213# install schemas
214SCHEMAS="clock.schemas"
215for S in $SCHEMAS; do
216    echo %{_sysconfdir}/gconf/schemas/$S ; done \
217    | xargs gconftool-2 --makefile-install-rule >& /dev/null 2>&1 ||:
218
219#
220# Install the default setup into /apps/panel and /apps/panel/default_setup
221#
222gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/clock.schemas > /dev/null 2>&1 || :
223
224/sbin/ldconfig
225scrollkeeper-update > /dev/null 2>&1 || :
226
227%pre
228if [ "$1" -gt 1 ]; then
229  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
230  SCHEMAS="clock.schemas"
231  for S in $SCHEMAS; do
232      echo %{_sysconfdir}/gconf/schemas/$S ; done \
233      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
234fi
235
236%preun
237if [ "$1" -eq 0 ]; then
238  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
239  SCHEMAS="clock.schemas"
240  for S in $SCHEMAS; do
241      echo %{_sysconfdir}/gconf/schemas/$S ; done \
242      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
243fi
244
245%postun
246/sbin/ldconfig
247scrollkeeper-update > /dev/null 2>&1 || :
248touch --no-create %{_datadir}/icons/hicolor
249if [ -x /usr/bin/gtk-update-icon-cache ]; then
250  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
251fi
252 
253%files -f %{gettext_package}.lang
254%defattr(-,root,root)
255%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
256%{_bindir}/*
257%exclude %{_bindir}/panel-test-applets
258%{_libexecdir}/*
259%{_sysconfdir}/gconf/schemas/*.schemas
260%{_datadir}/applications/*.desktop
261%{_datadir}/icons/hicolor/*/*/*
262%{_datadir}/glib-2.0/schemas/*.xml
263%{_datadir}/gnome-panel
264%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
265%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
266%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
267%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
268%{_mandir}/man*/*
269
270%files libs
271%{_libdir}/*.so.*
272%{_libdir}/girepository-1.0/*.typelib
273
274%files devel
275%{_bindir}/panel-test-applets
276%{_libdir}/pkgconfig/*.pc
277%{_includedir}/gnome-panel*
278%{_libdir}/*.so
279%{_datadir}/gtk-doc
280%{_datadir}/gir-1.0/*.gir
281
282
283%changelog
284* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
285- new upstream release
286- add BuildRequires: polkit-devel
287
288* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
289- new upstream release
290
291* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
292- new upstream release
293
294* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
295- new upstream release
296- remove BuildRequires: polkit-gnome-devel
297
298* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
299- rebuild with evolution-data-server-3.1.90
300
301* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
302- new upstream release
303
304* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
305- new upstream release
306- drop old Patches
307- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
308- change BuildRequires: libwnck3-devel instead of libwnck-devel
309- add BuildRequires: dconf-devel, telepathy-glib-devel
310- add Obsoletes: gnome-netstatus
311- add Patch0 (gnome-panel-3.0.2-configure.patch)
312
313* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
314- update SOURCE2(vine6-panel-default-setup.entries)
315  - remove bottom panel
316  - move window_list and workspace_switcher applet to top panel
317
318* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
319- update Source1 (clock.gnome-2.32.ja.po)
320
321* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
322- remove Provides: gnome-panel-devel
323
324* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
325- new upstream release
326
327* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
328- new upstream release
329- add BuildRequires: gobject-introspection-devel
330- remove BuildRequires: libgnomeui-devel
331- remove SOURCE3 and SOURCE4
332- drop Patch11
333- add configure option (--enable-introspection=yes)
334
335* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
336- rebuild with rpm-4.8.1 for pkg-config file
337
338* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
339- create -libs and -devel package
340
341* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
342- new upstream release
343
344* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
345- rebuild with evolution-data-server-2.30.2
346
347* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
348- new upstream release
349- update Patch8, Patch9 (from FC package)
350- add BuildRequires: libcanberra-devel
351
352* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
353- update translation of clock applet manual
354- add translation of fish applet manual
355
356* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
357- add libSM(-devel) to (Build)Requires
358- add desktop-file-utils to BuildRequires
359
360* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
361- update translation of clock applet manual
362
363* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
364- new upstream release
365- updated Patch0 and 2
366
367* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
368- new upstream release
369
370* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
371- rebuild with gtk2-2.16.3
372
373* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
374- add empty gconf entries to vine-panel-default-setup.entries
375
376* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
377- new upstream release
378
379* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
380- new upstream release
381
382* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
383- update vine-panel-default-setup.entries again..
384
385* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
386- update vine-panel-default-setup.entries
387
388* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
389- remove mixer applets from default panel setup
390
391* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
392- new upstream release
393
394* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
395- new upstream release
396- added BuildRequires: PolicyKit-gnome-devel
397
398* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
399- new upstream release
400
401* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
402- new upstream release
403
404* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
405- new upstream release
406
407* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
408- new upstream release
409
410* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
411- new upstream release
412- removed Patch25,26,27,29 and 30 (merged into upstream)
413
414* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
415- added Patches from FC
416  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
417  - Fix editing of locations in the clock applet
418  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
419  - Convert the edit and find location windows to dialogs
420  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
421  - Improve the time settings window
422  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
423  - Make the find-location window of the clock larger
424  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
425  - Only save the session when the users wants it
426  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
427  - Populate the location list before showing the preference window
428  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
429  - Add "About This Computer" item to System menu if it exists
430  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
431  - Try harder to avoid resizing the popup
432- updated BuildRequires
433
434* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
435- new upstream release
436- added BuildRequires: libgweather-devel
437
438* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
439- new upstream release
440- updated %post and %postun section
441- added %pre and %preun section
442- added Patches from Fedora
443  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
444  - Sharper icons
445  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
446  - Make it possible to start s-c-d from the clock menu again (#316921)
447  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
448  - Don't pop up an error if an applet from the default
449    configuration is missing 
450  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
451  - Turns out we need requires for applets in the default config (#293261)
452  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
453  - Drop the requires for fast-user-switch-applet (#253831)
454
455* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
456- new upstream release
457- dropped Patch22 (merged into upstream)
458
459* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
460- new upstream release
461
462* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
463- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
464
465* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
466- new upstream release
467- fix panel-default-setup.entries to change the name of
468  firefox desktopfile (<BTS:229>)
469
470* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
471- add patch 11 to fix disappearing of recent documents list.
472  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
473
474* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
475- new upstream release
476
477* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
478- new upstream release
479
480* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
481- run gtk-update-icon-cache in %%post script.
482
483* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
484- new upstream release
485
486* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
487- update vine-panel-default-setup.entries
488  - replace mozilla by firefox
489  - remove nautilus
490  - add notification area applet on top panel
491  - add trashbox applet on bottom panel
492- cleanup %%post script
493
494* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
495- new upstream release
496
497* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
498- new upstream release
499- added Prereq: scroolkeeper, GConf2
500
501* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
502- new upstream release
503
504* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
505- new upstream release
506
507* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
508- new upstream release
509
510* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
511- new upstream release
512
513* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
514- new upstream release
515
516* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
517- disable evolution-data-server
518
519* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
520- new upstream release
521
522* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
523- add Patch10 to fix hard-coded desktop file name.
524
525* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
526- new upstream version
527
528* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
529- new upstream release
530- run scrollkeeper at %post, %postun
531
532* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
533- new upstream release
534
535* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
536- add Patch10 to fix egg-recent-model.c.
537  save old umask value before create ".recently-used" file.
538 
539* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
540- fix location of nautilus launcher in panel-default-setup.entries.
541- do not add wireless monitor in %%post when no interfaces are available.
542- add Japanese summary and description
543- add BuildRequires: startup-notification-devel, gcc-c++.
544- disable libtoolize: version mismatch is bad
545
546* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
547- new upstream release
548
549* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
550- new upstream release
551
552* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
553- rebuilt against new toolchain
554
555* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
556- add --disable-schemas-install option to %%configure
557
558* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
559- new upstream release
560
561* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
562- add missing files
563- add vine default panel entries
564
565* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
566- new upstream release
567
568* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
569- new upstream release
570
571* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
572- new upstream release
573
574* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
575- remove vine's panel-per-panel-config.schemas
576  This should be added again in a future version.
577
578* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
579- new upstream release
580
581* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
582- new upstream release
583- remove old ja.po
584
585* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
586- new upstream release
587
588* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
589- remove clockaddon, system-tray-applet
590
591* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
592- new upstream release
593
594* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
595- add patch1 from rawhide package.
596
597* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
598- new upstream release
599
600* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
601- add system-tray-applet
602- modify default panel menu.
603- update ja.po
604
605* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
606- add Requires: vine-menus
607
608* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
609- new upstream release
610
611* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
612- remove redhatize patch.
613
614* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
615- build for Vine Linux
616- new upstream release from gnome-2.1.4
617
618* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
619- fix postun script
620
621* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
622- 2.0.9 with menu edit stuff
623- system-tray-applet 0.15 that doesn't crash all the time
624- merge/remove patches as appropriate
625
626* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
627- Fix problem with "hold down print screen" (71432)
628
629* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
630- panel-properties OnlyShowIn=GNOME;
631- somehow the po file got screwed up.  Works now
632- update po files
633
634* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
635- fix from #71762 for clock applet popdown key
636- no WIN_POS_MOUSE fixes #72167
637- fix for #72540 from George
638
639* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
640- system tray applet 0.11 with a small memleak fix and a couple translations
641
642* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
643- menu tweaks
644
645* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
646- bump release
647
648* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
649- put battery applet on panel for laptops (#67296)
650
651* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
652- 2.0.6 final from gnome 2.0.1
653- remove gnome-panel-screenshot patch now upstream
654
655* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
656- new system-tray-applet version
657- Fix gnome-panel-screenshot
658
659* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
660- 2.0.4
661- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
662  for the foot menu
663
664* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
665- fix desktop (logout/lock) menu item location
666  in Alt+F1 and in new menu applets
667- remove Screenshot... menu item
668
669* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
670- move around default applets, remove some of them
671- system tray 0.9
672- change default menu flags
673- blow unpackaged files out of build root
674
675* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
676- 2.0.3
677- own libexecdir stuff
678
679* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
680- new system tray that's prettier and doesn't clip the icon
681
682* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
683- system tray 0.7 that doesn't crash on startup
684- get Mozilla desktop file right so we get web browser launcher
685
686* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
687- system tray 0.6 with server file fixed (work dammit)
688
689* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
690- tweak applet positions but I think it's just broken
691- system tray 0.5 moved back to libdir not libexecdir
692
693* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
694- remove ltmain.sh hack
695- new system-tray-applet that works
696
697* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
698- put office suite stuff on the panel
699
700* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
701- 2.0.2.90 cvs snap
702
703* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
704- update the clock patch to be a little smarter in a couple ways
705
706* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
707- Fix problem where system tray applet was being looked for in /unst
708- Fix a crash in the system tray applet
709
710* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
711- Fix typo in the pt_BR translation that was causing GConf problems
712
713* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
714- add the system tray applet
715- add system tray applet by default
716- add more launcher by default
717
718* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
719- automated rebuild
720
721* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
722- use correct gettext package name, and add check for missing translations
723
724* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
725- add the calendar and configuration patch
726
727* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
728- 2.0.0
729- add control center desktop file to file list
730- add gnome-panelrc to file list
731- try fixing panel size (blind, no text box at home)
732
733* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
734- rebuild in different environment
735
736* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
737- updates to default configuration
738
739* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
740- fix schemas installation
741
742* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
743- unset old panel schemas when installing new ones
744- put in a broken panel config to see errors about
745- add a patch to give some decent error messages about what's wrong
746  with the default panel config
747
748* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
749- rebuild in different environment
750
751* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
752- don't provide/obsolete gnome-core
753
754* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
755- rebuild in different environment
756
757* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
758- 1.5.24
759- ldconfig
760
761* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
762- rebuild in different environment
763
764* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
765- 1.5.23
766
767* Sun May 26 2002 Tim Powers <timp@redhat.com>
768- automated rebuild
769
770* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
771- rebuild in different environment
772
773* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
774- 1.5.22
775- provide gnome-core
776- add a bunch of extra build requires so build system
777  won't get confused
778
779* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
780- 1.5.19
781
782* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
783- add the keep-libtool-from-relinking hack so
784  we get the gen util applet
785
786* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
787- obsoletes gnome-core-devel
788- include libdir/*.so
789
790* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
791- get libpanel-applet in the package
792
793* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
794- Initial build.
795
796
Note: See TracBrowser for help on using the repository browser.