source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 521

Revision 521, 23.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.26.0
6%define glib2_version 2.20.0
7%define gtk2_version 2.16.0
8%define libgnome_version 2.26.0
9%define libgnomeui_version 2.24.1
10%define orbit_version 2.14.0
11%define libwnck_version 2.26.0
12%define gconf_version 2.26.0
13%define gnome_menus_version 2.26.0
14%define evolution_data_server_version 2.26.0
15%define cairo_version 1.8.6
16%define dbus_version 1.2
17%define dbus_glib_version 0.73
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.26.0
20
21Summary: GNOME panel
22Summary(ja): GNOME パネル
23Name: gnome-panel
24Version: 2.28.0
25Release: 1%{_dist_release}
26URL: http://www.gnome.org/
27License: GPL
28Group: User Interface/Desktops
29
30Source0: %{name}-%{version}.tar.bz2
31Source2: vine-panel-default-setup.entries
32Source5: vine-panel-backwards-compat-config.schemas
33Source10: add-translations.sh
34Source12: gnome-compiler-flags.m4
35
36Patch0: gnome-panel-2.28.0-vendor.patch
37Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
38Patch2: gnome-panel-2.28.0-about-vine.patch
39
40# the next three patches belong together
41# http://bugzilla.gnome.org/show_bug.cgi?id=470966
42Patch8: launcher-desktop-files.patch
43Patch9: desktop-file-monitoring.patch
44Patch10: preferred-apps.patch
45
46# don't pop up an error dialog if an applet from the
47# default configuration is missing; we don't want to
48# add a hard dependency on e.g. tomboy
49Patch11: applet-error.patch
50
51BuildRoot: %{_tmppath}/%{name}-%{version}-root
52
53Requires: gnome-desktop >= %{gnome_desktop_version}
54Requires: libwnck >= %{libwnck_version}
55Requires: gnome-menus >= %{gnome_menus_version}
56Requires: vine-menus >= 1.1
57Requires(post,postun): scrollkeeper, gtk2
58Requires(post,pre,preun): GConf2
59
60Provides: %{name}-devel = %{version}-%{release}
61
62%if %{use_eds}
63Requires: evolution-data-server
64%endif
65
66BuildRequires: libxml2-python
67BuildRequires: intltool
68BuildRequires: gettext
69BuildRequires: automake
70BuildRequires: autoconf
71BuildRequires: libtool
72BuildRequires: scrollkeeper
73BuildRequires: libxslt
74BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
75BuildRequires: gtk2-devel >= %{gtk2_version}
76BuildRequires: libgnome-devel >= %{libgnome_version}
77BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
78BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
79BuildRequires: libwnck-devel >= %{libwnck_version}
80BuildRequires: GConf2-devel >= %{gconf_version}
81BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
82BuildRequires: cairo-devel >= %{cairo_version}
83BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
84BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
85BuildRequires: gtk-doc
86BuildRequires: pango-devel
87BuildRequires: libbonobo-devel
88BuildRequires: libX11-devel
89BuildRequires: libXau-devel
90%if %{use_eds}
91BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
92BuildRequires: ORBit2-devel >= %{orbit_version}
93BuildRequires: dbus-devel >= %{dbus_version}
94%endif
95BuildRequires: libgweather-devel >= %{libgweather_version}
96BuildRequires: librsvg2-devel
97BuildRequires: polkit-gnome-devel
98BuildRequires: NetworkManager-devel
99
100%description
101
102The GNOME panel provides the window list, workspace switcher, menus, and other
103features for the GNOME desktop.
104
105%description -l ja
106
107GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
108特徴を GNOME デスクトップに提供します。
109
110%prep
111%setup -q
112
113cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
114cp -f %{SOURCE12} m4
115cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
116
117%patch0 -p1 -b .vendor
118%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
119%patch2 -p1 -b .about-vine
120%patch8 -p1 -b .launcher-desktop-files
121%patch9 -p1 -b .desktop-file-monitoring
122%patch10 -p1 -b .preferred-apps
123%patch11 -p1 -b .applet-error
124
125libtoolize --force --copy
126
127. %{SOURCE10}
128
129%build
130# gpm-integration patches Makefile.am and configure.in
131aclocal -I m4
132automake --add-missing
133autoheader
134autoconf
135%configure --disable-scrollkeeper \
136           --disable-schemas-install \
137           --disable-gtk-doc \
138           --with-in-process-applets=clock:fish \
139%if %{use_eds}
140           --enable-eds=yes
141%else
142           --enable-eds=no
143%endif
144make
145
146%install
147rm -rf $RPM_BUILD_ROOT
148
149export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
150%makeinstall
151unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
152
153#
154# Create pager and tasklist schemas for compatibility with older
155# configurations which reference the old schema names
156#
157sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
158sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
159
160
161## blow away stuff we don't want
162/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
163#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
164/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
165
166/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
167
168sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
169
170desktop-file-install --delete-original \
171  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
172  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
173
174%find_lang %{gettext_package} --all-name --with-gnome
175#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
176
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180%post
181touch --no-create %{_datadir}/icons/hicolor
182if [ -x /usr/bin/gtk-update-icon-cache ]; then
183  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
184fi
185
186export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
187
188#
189# Clear out the old defaults
190#
191gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
192gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
193
194# install schemas
195SCHEMAS="clock.schemas fish.schemas pager.schemas \
196        panel-compatibility.schemas panel-general.schemas \
197        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
198        tasklist.schemas window-list.schemas workspace-switcher.schemas"
199for S in $SCHEMAS; do
200    echo %{_sysconfdir}/gconf/schemas/$S ; done \
201    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
202
203#
204# Install the default setup into /apps/panel and /apps/panel/default_setup
205#
206gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
207gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
208
209/sbin/ldconfig
210scrollkeeper-update > /dev/null 2>&1 || :
211
212%pre
213if [ "$1" -gt 1 ]; then
214  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
215  SCHEMAS="clock.schemas fish.schemas pager.schemas \
216          panel-compatibility.schemas panel-general.schemas \
217          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
218          tasklist.schemas window-list.schemas workspace-switcher.schemas"
219  for S in $SCHEMAS; do
220      echo %{_sysconfdir}/gconf/schemas/$S ; done \
221      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
222fi
223
224%preun
225if [ "$1" -eq 0 ]; then
226  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
227  SCHEMAS="clock.schemas fish.schemas pager.schemas \
228          panel-compatibility.schemas panel-general.schemas \
229          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
230          tasklist.schemas window-list.schemas workspace-switcher.schemas"
231  for S in $SCHEMAS; do
232      echo %{_sysconfdir}/gconf/schemas/$S ; done \
233      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
234fi
235
236%postun
237/sbin/ldconfig
238scrollkeeper-update > /dev/null 2>&1 || :
239touch --no-create %{_datadir}/icons/hicolor
240if [ -x /usr/bin/gtk-update-icon-cache ]; then
241  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
242fi
243 
244%files -f %{gettext_package}.lang
245%defattr(-,root,root)
246%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
247%{_datadir}/applications/*.desktop
248%{_datadir}/icons/*
249%{_datadir}/gnome-panel
250%exclude %{_datadir}/gnome-panelrc
251%{_datadir}/idl/gnome-panel-2.0
252%{_datadir}/gnome-2.0/ui/*
253%{_mandir}/man*/*
254%{_bindir}/*
255%{_libexecdir}/*
256%{_libdir}/bonobo/servers/*.server
257%{_libdir}/*.so.*
258%{_sysconfdir}/gconf/schemas/*.schemas
259%{_sysconfdir}/gconf/schemas/*.entries
260
261%{_sysconfdir}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
262%{_datadir}/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
263%{_datadir}/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
264
265# theoretically a devel package, but just doesn't seem worth it
266%{_libdir}/pkgconfig/*.pc
267%{_includedir}/panel-2.0
268%{_libdir}/*.so
269%{_datadir}/gtk-doc
270
271%changelog
272* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
273- new upstream release
274- updated Patch0 and 2
275
276* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
277- new upstream release
278
279* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
280- rebuild with gtk2-2.16.3
281
282* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
283- add empty gconf entries to vine-panel-default-setup.entries
284
285* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
286- new upstream release
287
288* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
289- new upstream release
290
291* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
292- update vine-panel-default-setup.entries again..
293
294* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
295- update vine-panel-default-setup.entries
296
297* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
298- remove mixer applets from default panel setup
299
300* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
301- new upstream release
302
303* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
304- new upstream release
305- added BuildRequires: PolicyKit-gnome-devel
306
307* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
308- new upstream release
309
310* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
311- new upstream release
312
313* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
314- new upstream release
315
316* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
317- new upstream release
318
319* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
320- new upstream release
321- removed Patch25,26,27,29 and 30 (merged into upstream)
322
323* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
324- added Patches from FC
325  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
326  - Fix editing of locations in the clock applet
327  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
328  - Convert the edit and find location windows to dialogs
329  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
330  - Improve the time settings window
331  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
332  - Make the find-location window of the clock larger
333  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
334  - Only save the session when the users wants it
335  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
336  - Populate the location list before showing the preference window
337  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
338  - Add "About This Computer" item to System menu if it exists
339  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
340  - Try harder to avoid resizing the popup
341- updated BuildRequires
342
343* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
344- new upstream release
345- added BuildRequires: libgweather-devel
346
347* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
348- new upstream release
349- updated %post and %postun section
350- added %pre and %preun section
351- added Patches from Fedora
352  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
353  - Sharper icons
354  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
355  - Make it possible to start s-c-d from the clock menu again (#316921)
356  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
357  - Don't pop up an error if an applet from the default
358    configuration is missing 
359  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
360  - Turns out we need requires for applets in the default config (#293261)
361  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
362  - Drop the requires for fast-user-switch-applet (#253831)
363
364* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
365- new upstream release
366- dropped Patch22 (merged into upstream)
367
368* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
369- new upstream release
370
371* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
372- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
373
374* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
375- new upstream release
376- fix panel-default-setup.entries to change the name of
377  firefox desktopfile (<BTS:229>)
378
379* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
380- add patch 11 to fix disappearing of recent documents list.
381  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
382
383* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
384- new upstream release
385
386* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
387- new upstream release
388
389* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
390- run gtk-update-icon-cache in %%post script.
391
392* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
393- new upstream release
394
395* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
396- update vine-panel-default-setup.entries
397  - replace mozilla by firefox
398  - remove nautilus
399  - add notification area applet on top panel
400  - add trashbox applet on bottom panel
401- cleanup %%post script
402
403* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
404- new upstream release
405
406* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
407- new upstream release
408- added Prereq: scroolkeeper, GConf2
409
410* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
411- new upstream release
412
413* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
414- new upstream release
415
416* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
417- new upstream release
418
419* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
420- new upstream release
421
422* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
423- new upstream release
424
425* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
426- disable evolution-data-server
427
428* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
429- new upstream release
430
431* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
432- add Patch10 to fix hard-coded desktop file name.
433
434* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
435- new upstream version
436
437* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
438- new upstream release
439- run scrollkeeper at %post, %postun
440
441* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
442- new upstream release
443
444* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
445- add Patch10 to fix egg-recent-model.c.
446  save old umask value before create ".recently-used" file.
447 
448* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
449- fix location of nautilus launcher in panel-default-setup.entries.
450- do not add wireless monitor in %%post when no interfaces are available.
451- add Japanese summary and description
452- add BuildRequires: startup-notification-devel, gcc-c++.
453- disable libtoolize: version mismatch is bad
454
455* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
456- new upstream release
457
458* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
459- new upstream release
460
461* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
462- rebuilt against new toolchain
463
464* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
465- add --disable-schemas-install option to %%configure
466
467* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
468- new upstream release
469
470* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
471- add missing files
472- add vine default panel entries
473
474* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
475- new upstream release
476
477* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
478- new upstream release
479
480* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
481- new upstream release
482
483* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
484- remove vine's panel-per-panel-config.schemas
485  This should be added again in a future version.
486
487* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
488- new upstream release
489
490* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
491- new upstream release
492- remove old ja.po
493
494* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
495- new upstream release
496
497* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
498- remove clockaddon, system-tray-applet
499
500* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
501- new upstream release
502
503* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
504- add patch1 from rawhide package.
505
506* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
507- new upstream release
508
509* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
510- add system-tray-applet
511- modify default panel menu.
512- update ja.po
513
514* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
515- add Requires: vine-menus
516
517* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
518- new upstream release
519
520* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
521- remove redhatize patch.
522
523* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
524- build for Vine Linux
525- new upstream release from gnome-2.1.4
526
527* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
528- fix postun script
529
530* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
531- 2.0.9 with menu edit stuff
532- system-tray-applet 0.15 that doesn't crash all the time
533- merge/remove patches as appropriate
534
535* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
536- Fix problem with "hold down print screen" (71432)
537
538* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
539- panel-properties OnlyShowIn=GNOME;
540- somehow the po file got screwed up.  Works now
541- update po files
542
543* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
544- fix from #71762 for clock applet popdown key
545- no WIN_POS_MOUSE fixes #72167
546- fix for #72540 from George
547
548* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
549- system tray applet 0.11 with a small memleak fix and a couple translations
550
551* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
552- menu tweaks
553
554* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
555- bump release
556
557* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
558- put battery applet on panel for laptops (#67296)
559
560* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
561- 2.0.6 final from gnome 2.0.1
562- remove gnome-panel-screenshot patch now upstream
563
564* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
565- new system-tray-applet version
566- Fix gnome-panel-screenshot
567
568* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
569- 2.0.4
570- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
571  for the foot menu
572
573* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
574- fix desktop (logout/lock) menu item location
575  in Alt+F1 and in new menu applets
576- remove Screenshot... menu item
577
578* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
579- move around default applets, remove some of them
580- system tray 0.9
581- change default menu flags
582- blow unpackaged files out of build root
583
584* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
585- 2.0.3
586- own libexecdir stuff
587
588* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
589- new system tray that's prettier and doesn't clip the icon
590
591* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
592- system tray 0.7 that doesn't crash on startup
593- get Mozilla desktop file right so we get web browser launcher
594
595* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
596- system tray 0.6 with server file fixed (work dammit)
597
598* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
599- tweak applet positions but I think it's just broken
600- system tray 0.5 moved back to libdir not libexecdir
601
602* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
603- remove ltmain.sh hack
604- new system-tray-applet that works
605
606* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
607- put office suite stuff on the panel
608
609* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
610- 2.0.2.90 cvs snap
611
612* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
613- update the clock patch to be a little smarter in a couple ways
614
615* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
616- Fix problem where system tray applet was being looked for in /unst
617- Fix a crash in the system tray applet
618
619* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
620- Fix typo in the pt_BR translation that was causing GConf problems
621
622* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
623- add the system tray applet
624- add system tray applet by default
625- add more launcher by default
626
627* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
628- automated rebuild
629
630* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
631- use correct gettext package name, and add check for missing translations
632
633* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
634- add the calendar and configuration patch
635
636* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
637- 2.0.0
638- add control center desktop file to file list
639- add gnome-panelrc to file list
640- try fixing panel size (blind, no text box at home)
641
642* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
643- rebuild in different environment
644
645* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
646- updates to default configuration
647
648* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
649- fix schemas installation
650
651* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
652- unset old panel schemas when installing new ones
653- put in a broken panel config to see errors about
654- add a patch to give some decent error messages about what's wrong
655  with the default panel config
656
657* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
658- rebuild in different environment
659
660* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
661- don't provide/obsolete gnome-core
662
663* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
664- rebuild in different environment
665
666* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
667- 1.5.24
668- ldconfig
669
670* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
671- rebuild in different environment
672
673* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
674- 1.5.23
675
676* Sun May 26 2002 Tim Powers <timp@redhat.com>
677- automated rebuild
678
679* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
680- rebuild in different environment
681
682* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
683- 1.5.22
684- provide gnome-core
685- add a bunch of extra build requires so build system
686  won't get confused
687
688* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
689- 1.5.19
690
691* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
692- add the keep-libtool-from-relinking hack so
693  we get the gen util applet
694
695* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
696- obsoletes gnome-core-devel
697- include libdir/*.so
698
699* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
700- get libpanel-applet in the package
701
702* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
703- Initial build.
704
705
Note: See TracBrowser for help on using the repository browser.