source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 4850

Revision 4850, 25.7 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 3.2.0
6%define glib2_version 2.30.0
7%define gtk3_version 3.2.0
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.0.0
11%define gconf_version 2.32.0
12%define gnome_menus_version 2.30.4
13%define evolution_data_server_version 2.32.0
14%define cairo_version 1.10.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define gnome_doc_utils_version 0.3.2
18%define libgweather_version 2.30.3
19%define libcanberra_version 0.25
20%define gobject_introspection_version 0.9.8
21
22Summary: GNOME panel
23Summary(ja): GNOME パネル
24Name: gnome-panel
25Version: 3.2.0
26Release: 1%{_dist_release}
27URL: http://www.gnome.org/
28License: GPL
29Group: User Interface/Desktops
30
31Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.2/%{name}-%{version}.tar.xz
32# Remove this line and next line when upstream adopt Source1
33Source1: clock.gnome-2-32.ja.po
34Source2: vine6-panel-default-setup.entries
35Source5: vine-panel-backwards-compat-config.schemas
36Source10: add-translations.sh
37Source12: gnome-compiler-flags.m4
38
39Patch0: gnome-panel-3.0.2-configure.patch
40
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42
43Requires: %{name}-libs = %{version}-%{release}
44Requires: gnome-desktop3 >= %{gnome_desktop3_version}
45Requires: libwnck3 >= %{libwnck3_version}
46Requires: gnome-menus >= %{gnome_menus_version}
47Requires: vine-menus >= 1.1
48Requires(post,postun): scrollkeeper, gtk3
49Requires(post,pre,preun): GConf2
50
51%if %{use_eds}
52Requires: evolution-data-server >= 2.30.2
53%endif
54Requires: libSM
55
56BuildRequires: libxml2-python
57BuildRequires: intltool
58BuildRequires: gettext
59BuildRequires: automake
60BuildRequires: autoconf
61BuildRequires: libtool
62BuildRequires: scrollkeeper
63BuildRequires: libxslt
64BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
65BuildRequires: gtk3-devel >= %{gtk3_version}
66BuildRequires: libgnome-devel >= %{libgnome_version}
67BuildRequires: libwnck3-devel >= %{libwnck3_version}
68BuildRequires: GConf2-devel >= %{gconf_version}
69BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
70BuildRequires: cairo-devel >= %{cairo_version}
71BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
72BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
73BuildRequires: gtk-doc
74BuildRequires: pango-devel
75BuildRequires: libX11-devel
76BuildRequires: libXau-devel
77%if %{use_eds}
78BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
79BuildRequires: ORBit2-devel >= %{orbit_version}
80BuildRequires: dbus-devel >= %{dbus_version}
81%endif
82BuildRequires: libgweather-devel >= %{libgweather_version}
83BuildRequires: libcanberra-devel >= %{libcanberra_versino}
84BuildRequires: librsvg2-devel
85BuildRequires: NetworkManager-devel
86BuildRequires: libSM-devel
87BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
88BuildRequires: dconf-devel
89BuildRequires: telepathy-glib-devel
90BuildRequires(install): desktop-file-utils
91
92Obsoletes: gnome-netstatus < 2.29
93
94%description
95
96The GNOME panel provides the window list, workspace switcher, menus, and other
97features for the GNOME desktop.
98
99%description -l ja
100
101GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
102特徴を GNOME デスクトップに提供します。
103
104%package libs
105Summary: Libraries for use in panel applets of GNOME
106Summary(ja): GNOME のパネルアップレットで使用するライブラリ
107Group: System Environment/Libraries
108
109%description libs
110Libraries for use in panel applets of GNOME.
111
112%description libs -l ja
113GNOME のパネルアップレットで使用するライブラリ
114
115%package devel
116Summary: Development environment for panel applets of GNOME
117Summary(ja): GNOME のパネルアップレット用開発環境
118Group: Development/Libraries
119Requires: %{name}-libs = %{version}-%{release}
120Requires: pkgconfig
121Requires: glib2-devel >= %{glib2_version}
122Requires: gtk3-devel >= %{gtk3_version}
123Requires: GConf2-devel >= %{gconf_version}
124
125%description devel
126Header files and libraries for building a panel applets of GNOME.
127
128%description devel -l ja
129GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
130
131
132%prep
133%setup -q
134%patch0 -p1
135
136# Remove this line and next line when upstream adopt Source1
137#cp -f %{SOURCE1} help/clock/ja/ja.po
138
139cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
140cp -f %{SOURCE12} m4
141cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
142
143. %{SOURCE10}
144
145%build
146# gpm-integration patches Makefile.am and configure.in
147#aclocal -I m4
148#automake --add-missing
149#autoheader
150#autoconf
151%configure --disable-scrollkeeper \
152           --disable-schemas-install \
153           --disable-gtk-doc \
154           --with-in-process-applets=clock:fish \
155           --enable-introspection=yes \
156           --enable-telepathy-glib=yes \
157%if %{use_eds}
158           --enable-eds=yes
159%else
160           --enable-eds=no
161%endif
162make
163
164%install
165rm -rf $RPM_BUILD_ROOT
166
167export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
168make install DESTDIR=$RPM_BUILD_ROOT
169unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
170
171#
172# Create pager and tasklist schemas for compatibility with older
173# configurations which reference the old schema names
174#
175#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
176#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
177
178
179## blow away stuff we don't want
180/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
181#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
182/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
183
184/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
185
186sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
187
188desktop-file-install --delete-original \
189  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
190  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
191
192%find_lang %{gettext_package} --all-name --with-gnome
193#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
194
195%clean
196rm -rf $RPM_BUILD_ROOT
197
198%post
199touch --no-create %{_datadir}/icons/hicolor
200if [ -x /usr/bin/gtk-update-icon-cache ]; then
201  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
202fi
203
204export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
205
206#
207# Clear out the old defaults
208#
209gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
210gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
211
212# install schemas
213SCHEMAS="clock.schemas"
214for S in $SCHEMAS; do
215    echo %{_sysconfdir}/gconf/schemas/$S ; done \
216    | xargs gconftool-2 --makefile-install-rule >& /dev/null 2>&1 ||:
217
218#
219# Install the default setup into /apps/panel and /apps/panel/default_setup
220#
221gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/clock.schemas > /dev/null 2>&1 || :
222
223/sbin/ldconfig
224scrollkeeper-update > /dev/null 2>&1 || :
225
226%pre
227if [ "$1" -gt 1 ]; then
228  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
229  SCHEMAS="clock.schemas"
230  for S in $SCHEMAS; do
231      echo %{_sysconfdir}/gconf/schemas/$S ; done \
232      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
233fi
234
235%preun
236if [ "$1" -eq 0 ]; then
237  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
238  SCHEMAS="clock.schemas"
239  for S in $SCHEMAS; do
240      echo %{_sysconfdir}/gconf/schemas/$S ; done \
241      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
242fi
243
244%postun
245/sbin/ldconfig
246scrollkeeper-update > /dev/null 2>&1 || :
247touch --no-create %{_datadir}/icons/hicolor
248if [ -x /usr/bin/gtk-update-icon-cache ]; then
249  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
250fi
251 
252%files -f %{gettext_package}.lang
253%defattr(-,root,root)
254%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
255%{_bindir}/*
256%exclude %{_bindir}/panel-test-applets
257%{_libexecdir}/*
258%{_sysconfdir}/gconf/schemas/*.schemas
259%{_datadir}/applications/*.desktop
260%{_datadir}/icons/hicolor/*/*/*
261%{_datadir}/glib-2.0/schemas/*.xml
262%{_datadir}/gnome-panel
263%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
264%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
265%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
266%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
267%{_mandir}/man*/*
268
269%files libs
270%{_libdir}/*.so.*
271%{_libdir}/girepository-1.0/*.typelib
272
273%files devel
274%{_bindir}/panel-test-applets
275%{_libdir}/pkgconfig/*.pc
276%{_includedir}/gnome-panel*
277%{_libdir}/*.so
278%{_datadir}/gtk-doc
279%{_datadir}/gir-1.0/*.gir
280
281
282%changelog
283* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
284- new upstream release
285
286* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
287- new upstream release
288- remove BuildRequires: polkit-gnome-devel
289
290* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
291- rebuild with evolution-data-server-3.1.90
292
293* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
294- new upstream release
295
296* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
297- new upstream release
298- drop old Patches
299- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
300- change BuildRequires: libwnck3-devel instead of libwnck-devel
301- add BuildRequires: dconf-devel, telepathy-glib-devel
302- add Obsoletes: gnome-netstatus
303- add Patch0 (gnome-panel-3.0.2-configure.patch)
304
305* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
306- update SOURCE2(vine6-panel-default-setup.entries)
307  - remove bottom panel
308  - move window_list and workspace_switcher applet to top panel
309
310* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
311- update Source1 (clock.gnome-2.32.ja.po)
312
313* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
314- remove Provides: gnome-panel-devel
315
316* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
317- new upstream release
318
319* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
320- new upstream release
321- add BuildRequires: gobject-introspection-devel
322- remove BuildRequires: libgnomeui-devel
323- remove SOURCE3 and SOURCE4
324- drop Patch11
325- add configure option (--enable-introspection=yes)
326
327* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
328- rebuild with rpm-4.8.1 for pkg-config file
329
330* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
331- create -libs and -devel package
332
333* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
334- new upstream release
335
336* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
337- rebuild with evolution-data-server-2.30.2
338
339* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
340- new upstream release
341- update Patch8, Patch9 (from FC package)
342- add BuildRequires: libcanberra-devel
343
344* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
345- update translation of clock applet manual
346- add translation of fish applet manual
347
348* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
349- add libSM(-devel) to (Build)Requires
350- add desktop-file-utils to BuildRequires
351
352* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
353- update translation of clock applet manual
354
355* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
356- new upstream release
357- updated Patch0 and 2
358
359* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
360- new upstream release
361
362* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
363- rebuild with gtk2-2.16.3
364
365* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
366- add empty gconf entries to vine-panel-default-setup.entries
367
368* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
369- new upstream release
370
371* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
372- new upstream release
373
374* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
375- update vine-panel-default-setup.entries again..
376
377* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
378- update vine-panel-default-setup.entries
379
380* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
381- remove mixer applets from default panel setup
382
383* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
384- new upstream release
385
386* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
387- new upstream release
388- added BuildRequires: PolicyKit-gnome-devel
389
390* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
391- new upstream release
392
393* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
394- new upstream release
395
396* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
397- new upstream release
398
399* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
400- new upstream release
401
402* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
403- new upstream release
404- removed Patch25,26,27,29 and 30 (merged into upstream)
405
406* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
407- added Patches from FC
408  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
409  - Fix editing of locations in the clock applet
410  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
411  - Convert the edit and find location windows to dialogs
412  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
413  - Improve the time settings window
414  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
415  - Make the find-location window of the clock larger
416  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
417  - Only save the session when the users wants it
418  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
419  - Populate the location list before showing the preference window
420  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
421  - Add "About This Computer" item to System menu if it exists
422  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
423  - Try harder to avoid resizing the popup
424- updated BuildRequires
425
426* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
427- new upstream release
428- added BuildRequires: libgweather-devel
429
430* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
431- new upstream release
432- updated %post and %postun section
433- added %pre and %preun section
434- added Patches from Fedora
435  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
436  - Sharper icons
437  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
438  - Make it possible to start s-c-d from the clock menu again (#316921)
439  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
440  - Don't pop up an error if an applet from the default
441    configuration is missing 
442  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
443  - Turns out we need requires for applets in the default config (#293261)
444  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
445  - Drop the requires for fast-user-switch-applet (#253831)
446
447* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
448- new upstream release
449- dropped Patch22 (merged into upstream)
450
451* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
452- new upstream release
453
454* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
455- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
456
457* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
458- new upstream release
459- fix panel-default-setup.entries to change the name of
460  firefox desktopfile (<BTS:229>)
461
462* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
463- add patch 11 to fix disappearing of recent documents list.
464  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
465
466* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
467- new upstream release
468
469* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
470- new upstream release
471
472* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
473- run gtk-update-icon-cache in %%post script.
474
475* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
476- new upstream release
477
478* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
479- update vine-panel-default-setup.entries
480  - replace mozilla by firefox
481  - remove nautilus
482  - add notification area applet on top panel
483  - add trashbox applet on bottom panel
484- cleanup %%post script
485
486* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
487- new upstream release
488
489* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
490- new upstream release
491- added Prereq: scroolkeeper, GConf2
492
493* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
494- new upstream release
495
496* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
497- new upstream release
498
499* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
500- new upstream release
501
502* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
503- new upstream release
504
505* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
506- new upstream release
507
508* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
509- disable evolution-data-server
510
511* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
512- new upstream release
513
514* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
515- add Patch10 to fix hard-coded desktop file name.
516
517* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
518- new upstream version
519
520* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
521- new upstream release
522- run scrollkeeper at %post, %postun
523
524* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
525- new upstream release
526
527* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
528- add Patch10 to fix egg-recent-model.c.
529  save old umask value before create ".recently-used" file.
530 
531* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
532- fix location of nautilus launcher in panel-default-setup.entries.
533- do not add wireless monitor in %%post when no interfaces are available.
534- add Japanese summary and description
535- add BuildRequires: startup-notification-devel, gcc-c++.
536- disable libtoolize: version mismatch is bad
537
538* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
539- new upstream release
540
541* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
542- new upstream release
543
544* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
545- rebuilt against new toolchain
546
547* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
548- add --disable-schemas-install option to %%configure
549
550* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
551- new upstream release
552
553* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
554- add missing files
555- add vine default panel entries
556
557* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
558- new upstream release
559
560* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
561- new upstream release
562
563* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
564- new upstream release
565
566* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
567- remove vine's panel-per-panel-config.schemas
568  This should be added again in a future version.
569
570* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
571- new upstream release
572
573* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
574- new upstream release
575- remove old ja.po
576
577* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
578- new upstream release
579
580* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
581- remove clockaddon, system-tray-applet
582
583* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
584- new upstream release
585
586* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
587- add patch1 from rawhide package.
588
589* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
590- new upstream release
591
592* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
593- add system-tray-applet
594- modify default panel menu.
595- update ja.po
596
597* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
598- add Requires: vine-menus
599
600* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
601- new upstream release
602
603* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
604- remove redhatize patch.
605
606* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
607- build for Vine Linux
608- new upstream release from gnome-2.1.4
609
610* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
611- fix postun script
612
613* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
614- 2.0.9 with menu edit stuff
615- system-tray-applet 0.15 that doesn't crash all the time
616- merge/remove patches as appropriate
617
618* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
619- Fix problem with "hold down print screen" (71432)
620
621* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
622- panel-properties OnlyShowIn=GNOME;
623- somehow the po file got screwed up.  Works now
624- update po files
625
626* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
627- fix from #71762 for clock applet popdown key
628- no WIN_POS_MOUSE fixes #72167
629- fix for #72540 from George
630
631* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
632- system tray applet 0.11 with a small memleak fix and a couple translations
633
634* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
635- menu tweaks
636
637* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
638- bump release
639
640* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
641- put battery applet on panel for laptops (#67296)
642
643* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
644- 2.0.6 final from gnome 2.0.1
645- remove gnome-panel-screenshot patch now upstream
646
647* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
648- new system-tray-applet version
649- Fix gnome-panel-screenshot
650
651* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
652- 2.0.4
653- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
654  for the foot menu
655
656* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
657- fix desktop (logout/lock) menu item location
658  in Alt+F1 and in new menu applets
659- remove Screenshot... menu item
660
661* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
662- move around default applets, remove some of them
663- system tray 0.9
664- change default menu flags
665- blow unpackaged files out of build root
666
667* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
668- 2.0.3
669- own libexecdir stuff
670
671* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
672- new system tray that's prettier and doesn't clip the icon
673
674* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
675- system tray 0.7 that doesn't crash on startup
676- get Mozilla desktop file right so we get web browser launcher
677
678* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
679- system tray 0.6 with server file fixed (work dammit)
680
681* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
682- tweak applet positions but I think it's just broken
683- system tray 0.5 moved back to libdir not libexecdir
684
685* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
686- remove ltmain.sh hack
687- new system-tray-applet that works
688
689* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
690- put office suite stuff on the panel
691
692* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
693- 2.0.2.90 cvs snap
694
695* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
696- update the clock patch to be a little smarter in a couple ways
697
698* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
699- Fix problem where system tray applet was being looked for in /unst
700- Fix a crash in the system tray applet
701
702* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
703- Fix typo in the pt_BR translation that was causing GConf problems
704
705* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
706- add the system tray applet
707- add system tray applet by default
708- add more launcher by default
709
710* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
711- automated rebuild
712
713* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
714- use correct gettext package name, and add check for missing translations
715
716* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
717- add the calendar and configuration patch
718
719* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
720- 2.0.0
721- add control center desktop file to file list
722- add gnome-panelrc to file list
723- try fixing panel size (blind, no text box at home)
724
725* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
726- rebuild in different environment
727
728* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
729- updates to default configuration
730
731* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
732- fix schemas installation
733
734* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
735- unset old panel schemas when installing new ones
736- put in a broken panel config to see errors about
737- add a patch to give some decent error messages about what's wrong
738  with the default panel config
739
740* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
741- rebuild in different environment
742
743* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
744- don't provide/obsolete gnome-core
745
746* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
747- rebuild in different environment
748
749* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
750- 1.5.24
751- ldconfig
752
753* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
754- rebuild in different environment
755
756* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
757- 1.5.23
758
759* Sun May 26 2002 Tim Powers <timp@redhat.com>
760- automated rebuild
761
762* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
763- rebuild in different environment
764
765* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
766- 1.5.22
767- provide gnome-core
768- add a bunch of extra build requires so build system
769  won't get confused
770
771* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
772- 1.5.19
773
774* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
775- add the keep-libtool-from-relinking hack so
776  we get the gen util applet
777
778* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
779- obsoletes gnome-core-devel
780- include libdir/*.so
781
782* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
783- get libpanel-applet in the package
784
785* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
786- Initial build.
787
788
Note: See TracBrowser for help on using the repository browser.