source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 10716

Revision 10716, 24.2 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 2.91.0
6%define glib2_version 2.25.2
7%define gtk3_version 3.15.2
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.4.6
11%define gconf_version 2.32.0
12%define gnome_menus_version 3.7.90
13%define evolution_data_server_version 3.5.3
14%define cairo_version 1.0.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define libgweather_version 3.17.1
18%define libcanberra_version 0.25
19%define gobject_introspection_version 0.9.8
20
21Summary: GNOME panel
22Summary(ja): GNOME パネル
23Name: gnome-panel
24Version: 3.20.0
25Release: 1%{_dist_release}
26URL: http://www.gnome.org/
27License: GPL
28Group: User Interface/Desktops
29
30Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.20/%{name}-%{version}.tar.xz
31# Remove this line and next line when upstream adopt Source1
32Source2: vine6-panel-default-setup.entries
33Source5: vine-panel-backwards-compat-config.schemas
34Source10: add-translations.sh
35Source12: gnome-compiler-flags.m4
36Source13: panel-default-layout.layout.vine
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40Requires: %{name}-libs = %{version}-%{release}
41Requires: gnome-desktop3 >= %{gnome_desktop3_version}
42Requires: libwnck3 >= %{libwnck3_version}
43Requires: gnome-menus >= %{gnome_menus_version}
44Requires: vine-menus >= 1.1
45Requires(post,postun): gtk3
46
47%if %{use_eds}
48Requires: evolution-data-server >= %{evolution_data_server_version}
49%endif
50Requires: libSM
51
52BuildRequires: libxml2-python
53BuildRequires: intltool
54BuildRequires: gettext
55BuildRequires: automake
56BuildRequires: autoconf
57BuildRequires: libtool
58BuildRequires: libxslt
59BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
60BuildRequires: gtk3-devel >= %{gtk3_version}
61BuildRequires: libgnome-devel >= %{libgnome_version}
62BuildRequires: libwnck3-devel >= %{libwnck3_version}
63BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
64BuildRequires: cairo-devel >= %{cairo_version}
65BuildRequires: yelp-tools
66BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
67BuildRequires: gtk-doc
68BuildRequires: pango-devel
69BuildRequires: libX11-devel
70BuildRequires: libXau-devel
71%if %{use_eds}
72BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
73BuildRequires: ORBit2-devel >= %{orbit_version}
74BuildRequires: dbus-devel >= %{dbus_version}
75%endif
76BuildRequires: libgweather-devel >= %{libgweather_version}
77BuildRequires: libcanberra-devel >= %{libcanberra_versino}
78BuildRequires: librsvg2-devel
79BuildRequires: NetworkManager-devel
80BuildRequires: libSM-devel
81BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
82BuildRequires: dconf-devel
83BuildRequires: polkit-devel
84BuildRequires: telepathy-glib-devel
85BuildRequires: desktop-file-utils
86
87Obsoletes: gnome-netstatus < 2.29
88
89%description
90
91The GNOME panel provides the window list, workspace switcher, menus, and other
92features for the GNOME desktop.
93
94%description -l ja
95
96GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
97特徴を GNOME デスクトップに提供します。
98
99%package libs
100Summary: Libraries for use in panel applets of GNOME
101Summary(ja): GNOME のパネルアップレットで使用するライブラリ
102Group: System Environment/Libraries
103
104%description libs
105Libraries for use in panel applets of GNOME.
106
107%description libs -l ja
108GNOME のパネルアップレットで使用するライブラリ
109
110%package devel
111Summary: Development environment for panel applets of GNOME
112Summary(ja): GNOME のパネルアップレット用開発環境
113Group: Development/Libraries
114Requires: %{name}-libs = %{version}-%{release}
115Requires: pkgconfig
116Requires: glib2-devel >= %{glib2_version}
117Requires: gtk3-devel >= %{gtk3_version}
118
119%description devel
120Header files and libraries for building a panel applets of GNOME.
121
122%description devel -l ja
123GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
124
125
126%prep
127%setup -q
128
129cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
130cp -f %{SOURCE12} m4
131cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
132cp -f %{SOURCE13} data/panel-default-layout.layout
133
134. %{SOURCE10}
135
136for a in ca cs de el es fr gu hu it lt nb pl pt pt_BR ru sk sr sv th vi zh_TW;
137do
138    sed -i "s|^$a$||" po/LINGUAS
139    rm -f po/$a.po
140done
141
142%build
143%configure \
144           --disable-gtk-doc \
145           --enable-introspection=yes \
146%if %{use_eds}
147           --enable-eds=yes
148%else
149           --enable-eds=no
150%endif
151make
152
153%install
154rm -rf $RPM_BUILD_ROOT
155
156make install DESTDIR=$RPM_BUILD_ROOT
157
158#
159# Create pager and tasklist schemas for compatibility with older
160# configurations which reference the old schema names
161#
162#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
163#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
164
165
166find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
167
168/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
169
170%find_lang %{gettext_package} --all-name --with-gnome
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post
176/sbin/ldconfig
177touch --no-create %{_datadir}/icons/hicolor
178if [ -x /usr/bin/gtk-update-icon-cache ]; then
179  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
180fi
181
182%postun
183/sbin/ldconfig
184touch --no-create %{_datadir}/icons/hicolor
185if [ -x /usr/bin/gtk-update-icon-cache ]; then
186  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
187fi
188update-desktop-database -q &> /dev/null ||:
189
190%posttrans
191update-desktop-database -q &> /dev/null ||:
192 
193%files -f %{gettext_package}.lang
194%defattr(-,root,root)
195%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
196%{_bindir}/*
197%exclude %{_bindir}/panel-test-applets
198%{_libdir}/%{name}/5.0/libclock-applet.so
199%{_libdir}/%{name}/5.0/libfish-applet.so
200%{_libdir}/%{name}/5.0/libnotification-area-applet.so
201%{_libdir}/%{name}/5.0/libwnck-applet.so
202%{_datadir}/applications/*.desktop
203%{_datadir}/icons/hicolor/*/*/*
204%{_datadir}/glib-2.0/schemas/*.xml
205%{_datadir}/gnome-panel
206%{_mandir}/man*/*
207
208%files libs
209%{_libdir}/*.so.*
210%{_libdir}/girepository-1.0/*.typelib
211
212%files devel
213%{_bindir}/panel-test-applets
214%{_libdir}/pkgconfig/*.pc
215%{_includedir}/gnome-panel*
216%{_libdir}/*.so
217%{_datadir}/gtk-doc
218%{_datadir}/gir-1.0/*.gir
219
220
221%changelog
222* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
223- new upstream release
224
225* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
226- new upstream release
227- add Source13 (panel-default-layout.layout.vine)
228
229* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
230- new upstream release
231
232* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
233- new upstream release
234- remove Patch0 (gnome-panel-3.5.91-configure.patch)
235- change BuildRequires: yelp-tools instead of gnome-doc-utils
236
237* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
238- new upstream release
239
240* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
241- new upstream release
242- add BuildRequires: polkit-devel
243
244* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
245- new upstream release
246
247* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
248- new upstream release
249
250* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
251- new upstream release
252- remove BuildRequires: polkit-gnome-devel
253
254* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
255- rebuild with evolution-data-server-3.1.90
256
257* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
258- new upstream release
259
260* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
261- new upstream release
262- drop old Patches
263- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
264- change BuildRequires: libwnck3-devel instead of libwnck-devel
265- add BuildRequires: dconf-devel, telepathy-glib-devel
266- add Obsoletes: gnome-netstatus
267- add Patch0 (gnome-panel-3.0.2-configure.patch)
268
269* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
270- update SOURCE2(vine6-panel-default-setup.entries)
271  - remove bottom panel
272  - move window_list and workspace_switcher applet to top panel
273
274* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
275- update Source1 (clock.gnome-2.32.ja.po)
276
277* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
278- remove Provides: gnome-panel-devel
279
280* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
281- new upstream release
282
283* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
284- new upstream release
285- add BuildRequires: gobject-introspection-devel
286- remove BuildRequires: libgnomeui-devel
287- remove SOURCE3 and SOURCE4
288- drop Patch11
289- add configure option (--enable-introspection=yes)
290
291* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
292- rebuild with rpm-4.8.1 for pkg-config file
293
294* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
295- create -libs and -devel package
296
297* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
298- new upstream release
299
300* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
301- rebuild with evolution-data-server-2.30.2
302
303* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
304- new upstream release
305- update Patch8, Patch9 (from FC package)
306- add BuildRequires: libcanberra-devel
307
308* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
309- update translation of clock applet manual
310- add translation of fish applet manual
311
312* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
313- add libSM(-devel) to (Build)Requires
314- add desktop-file-utils to BuildRequires
315
316* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
317- update translation of clock applet manual
318
319* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
320- new upstream release
321- updated Patch0 and 2
322
323* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
324- new upstream release
325
326* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
327- rebuild with gtk2-2.16.3
328
329* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
330- add empty gconf entries to vine-panel-default-setup.entries
331
332* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
333- new upstream release
334
335* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
336- new upstream release
337
338* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
339- update vine-panel-default-setup.entries again..
340
341* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
342- update vine-panel-default-setup.entries
343
344* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
345- remove mixer applets from default panel setup
346
347* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
348- new upstream release
349
350* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
351- new upstream release
352- added BuildRequires: PolicyKit-gnome-devel
353
354* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
355- new upstream release
356
357* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
358- new upstream release
359
360* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
361- new upstream release
362
363* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
364- new upstream release
365
366* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
367- new upstream release
368- removed Patch25,26,27,29 and 30 (merged into upstream)
369
370* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
371- added Patches from FC
372  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
373  - Fix editing of locations in the clock applet
374  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
375  - Convert the edit and find location windows to dialogs
376  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
377  - Improve the time settings window
378  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
379  - Make the find-location window of the clock larger
380  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
381  - Only save the session when the users wants it
382  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
383  - Populate the location list before showing the preference window
384  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
385  - Add "About This Computer" item to System menu if it exists
386  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
387  - Try harder to avoid resizing the popup
388- updated BuildRequires
389
390* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
391- new upstream release
392- added BuildRequires: libgweather-devel
393
394* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
395- new upstream release
396- updated %post and %postun section
397- added %pre and %preun section
398- added Patches from Fedora
399  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
400  - Sharper icons
401  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
402  - Make it possible to start s-c-d from the clock menu again (#316921)
403  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
404  - Don't pop up an error if an applet from the default
405    configuration is missing 
406  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
407  - Turns out we need requires for applets in the default config (#293261)
408  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
409  - Drop the requires for fast-user-switch-applet (#253831)
410
411* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
412- new upstream release
413- dropped Patch22 (merged into upstream)
414
415* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
416- new upstream release
417
418* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
419- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
420
421* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
422- new upstream release
423- fix panel-default-setup.entries to change the name of
424  firefox desktopfile (<BTS:229>)
425
426* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
427- add patch 11 to fix disappearing of recent documents list.
428  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
429
430* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
431- new upstream release
432
433* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
434- new upstream release
435
436* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
437- run gtk-update-icon-cache in %%post script.
438
439* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
440- new upstream release
441
442* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
443- update vine-panel-default-setup.entries
444  - replace mozilla by firefox
445  - remove nautilus
446  - add notification area applet on top panel
447  - add trashbox applet on bottom panel
448- cleanup %%post script
449
450* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
451- new upstream release
452
453* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
454- new upstream release
455- added Prereq: scroolkeeper, GConf2
456
457* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
458- new upstream release
459
460* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
461- new upstream release
462
463* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
464- new upstream release
465
466* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
467- new upstream release
468
469* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
470- new upstream release
471
472* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
473- disable evolution-data-server
474
475* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
476- new upstream release
477
478* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
479- add Patch10 to fix hard-coded desktop file name.
480
481* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
482- new upstream version
483
484* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
485- new upstream release
486- run scrollkeeper at %post, %postun
487
488* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
489- new upstream release
490
491* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
492- add Patch10 to fix egg-recent-model.c.
493  save old umask value before create ".recently-used" file.
494 
495* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
496- fix location of nautilus launcher in panel-default-setup.entries.
497- do not add wireless monitor in %%post when no interfaces are available.
498- add Japanese summary and description
499- add BuildRequires: startup-notification-devel, gcc-c++.
500- disable libtoolize: version mismatch is bad
501
502* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
503- new upstream release
504
505* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
506- new upstream release
507
508* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
509- rebuilt against new toolchain
510
511* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
512- add --disable-schemas-install option to %%configure
513
514* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
515- new upstream release
516
517* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
518- add missing files
519- add vine default panel entries
520
521* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
522- new upstream release
523
524* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
525- new upstream release
526
527* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
528- new upstream release
529
530* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
531- remove vine's panel-per-panel-config.schemas
532  This should be added again in a future version.
533
534* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
535- new upstream release
536
537* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
538- new upstream release
539- remove old ja.po
540
541* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
542- new upstream release
543
544* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
545- remove clockaddon, system-tray-applet
546
547* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
548- new upstream release
549
550* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
551- add patch1 from rawhide package.
552
553* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
554- new upstream release
555
556* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
557- add system-tray-applet
558- modify default panel menu.
559- update ja.po
560
561* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
562- add Requires: vine-menus
563
564* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
565- new upstream release
566
567* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
568- remove redhatize patch.
569
570* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
571- build for Vine Linux
572- new upstream release from gnome-2.1.4
573
574* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
575- fix postun script
576
577* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
578- 2.0.9 with menu edit stuff
579- system-tray-applet 0.15 that doesn't crash all the time
580- merge/remove patches as appropriate
581
582* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
583- Fix problem with "hold down print screen" (71432)
584
585* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
586- panel-properties OnlyShowIn=GNOME;
587- somehow the po file got screwed up.  Works now
588- update po files
589
590* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
591- fix from #71762 for clock applet popdown key
592- no WIN_POS_MOUSE fixes #72167
593- fix for #72540 from George
594
595* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
596- system tray applet 0.11 with a small memleak fix and a couple translations
597
598* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
599- menu tweaks
600
601* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
602- bump release
603
604* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
605- put battery applet on panel for laptops (#67296)
606
607* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
608- 2.0.6 final from gnome 2.0.1
609- remove gnome-panel-screenshot patch now upstream
610
611* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
612- new system-tray-applet version
613- Fix gnome-panel-screenshot
614
615* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
616- 2.0.4
617- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
618  for the foot menu
619
620* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
621- fix desktop (logout/lock) menu item location
622  in Alt+F1 and in new menu applets
623- remove Screenshot... menu item
624
625* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
626- move around default applets, remove some of them
627- system tray 0.9
628- change default menu flags
629- blow unpackaged files out of build root
630
631* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
632- 2.0.3
633- own libexecdir stuff
634
635* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
636- new system tray that's prettier and doesn't clip the icon
637
638* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
639- system tray 0.7 that doesn't crash on startup
640- get Mozilla desktop file right so we get web browser launcher
641
642* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
643- system tray 0.6 with server file fixed (work dammit)
644
645* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
646- tweak applet positions but I think it's just broken
647- system tray 0.5 moved back to libdir not libexecdir
648
649* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
650- remove ltmain.sh hack
651- new system-tray-applet that works
652
653* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
654- put office suite stuff on the panel
655
656* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
657- 2.0.2.90 cvs snap
658
659* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
660- update the clock patch to be a little smarter in a couple ways
661
662* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
663- Fix problem where system tray applet was being looked for in /unst
664- Fix a crash in the system tray applet
665
666* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
667- Fix typo in the pt_BR translation that was causing GConf problems
668
669* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
670- add the system tray applet
671- add system tray applet by default
672- add more launcher by default
673
674* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
675- automated rebuild
676
677* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
678- use correct gettext package name, and add check for missing translations
679
680* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
681- add the calendar and configuration patch
682
683* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
684- 2.0.0
685- add control center desktop file to file list
686- add gnome-panelrc to file list
687- try fixing panel size (blind, no text box at home)
688
689* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
690- rebuild in different environment
691
692* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
693- updates to default configuration
694
695* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
696- fix schemas installation
697
698* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
699- unset old panel schemas when installing new ones
700- put in a broken panel config to see errors about
701- add a patch to give some decent error messages about what's wrong
702  with the default panel config
703
704* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
705- rebuild in different environment
706
707* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
708- don't provide/obsolete gnome-core
709
710* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
711- rebuild in different environment
712
713* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
714- 1.5.24
715- ldconfig
716
717* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
718- rebuild in different environment
719
720* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
721- 1.5.23
722
723* Sun May 26 2002 Tim Powers <timp@redhat.com>
724- automated rebuild
725
726* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
727- rebuild in different environment
728
729* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
730- 1.5.22
731- provide gnome-core
732- add a bunch of extra build requires so build system
733  won't get confused
734
735* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
736- 1.5.19
737
738* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
739- add the keep-libtool-from-relinking hack so
740  we get the gen util applet
741
742* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
743- obsoletes gnome-core-devel
744- include libdir/*.so
745
746* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
747- get libpanel-applet in the package
748
749* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
750- Initial build.
751
752
Note: See TracBrowser for help on using the repository browser.