source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 9791

Revision 9791, 24.1 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 2.91.0
6%define glib2_version 2.25.2
7%define gtk3_version 3.15.2
8%define libgnome_version 2.32.0
9%define orbit_version 2.14.19
10%define libwnck3_version 3.4.6
11%define gconf_version 2.32.0
12%define gnome_menus_version 3.7.90
13%define evolution_data_server_version 3.5.3
14%define cairo_version 1.0.0
15%define dbus_version 1.4.0
16%define dbus_glib_version 0.88
17%define libgweather_version 3.17.1
18%define libcanberra_version 0.25
19%define gobject_introspection_version 0.9.8
20
21Summary: GNOME panel
22Summary(ja): GNOME パネル
23Name: gnome-panel
24Version: 3.18.1
25Release: 1%{_dist_release}
26URL: http://www.gnome.org/
27License: GPL
28Group: User Interface/Desktops
29
30Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.18/%{name}-%{version}.tar.xz
31# Remove this line and next line when upstream adopt Source1
32Source2: vine6-panel-default-setup.entries
33Source5: vine-panel-backwards-compat-config.schemas
34Source10: add-translations.sh
35Source12: gnome-compiler-flags.m4
36Source13: panel-default-layout.layout.vine
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40Requires: %{name}-libs = %{version}-%{release}
41Requires: gnome-desktop3 >= %{gnome_desktop3_version}
42Requires: libwnck3 >= %{libwnck3_version}
43Requires: gnome-menus >= %{gnome_menus_version}
44Requires: vine-menus >= 1.1
45Requires(post,postun): gtk3
46
47%if %{use_eds}
48Requires: evolution-data-server >= %{evolution_data_server_version}
49%endif
50Requires: libSM
51
52BuildRequires: libxml2-python
53BuildRequires: intltool
54BuildRequires: gettext
55BuildRequires: automake
56BuildRequires: autoconf
57BuildRequires: libtool
58BuildRequires: libxslt
59BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
60BuildRequires: gtk3-devel >= %{gtk3_version}
61BuildRequires: libgnome-devel >= %{libgnome_version}
62BuildRequires: libwnck3-devel >= %{libwnck3_version}
63BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
64BuildRequires: cairo-devel >= %{cairo_version}
65BuildRequires: yelp-tools
66BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
67BuildRequires: gtk-doc
68BuildRequires: pango-devel
69BuildRequires: libX11-devel
70BuildRequires: libXau-devel
71%if %{use_eds}
72BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
73BuildRequires: ORBit2-devel >= %{orbit_version}
74BuildRequires: dbus-devel >= %{dbus_version}
75%endif
76BuildRequires: libgweather-devel >= %{libgweather_version}
77BuildRequires: libcanberra-devel >= %{libcanberra_versino}
78BuildRequires: librsvg2-devel
79BuildRequires: NetworkManager-devel
80BuildRequires: libSM-devel
81BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
82BuildRequires: dconf-devel
83BuildRequires: polkit-devel
84BuildRequires: telepathy-glib-devel
85BuildRequires: desktop-file-utils
86
87Obsoletes: gnome-netstatus < 2.29
88
89%description
90
91The GNOME panel provides the window list, workspace switcher, menus, and other
92features for the GNOME desktop.
93
94%description -l ja
95
96GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
97特徴を GNOME デスクトップに提供します。
98
99%package libs
100Summary: Libraries for use in panel applets of GNOME
101Summary(ja): GNOME のパネルアップレットで使用するライブラリ
102Group: System Environment/Libraries
103
104%description libs
105Libraries for use in panel applets of GNOME.
106
107%description libs -l ja
108GNOME のパネルアップレットで使用するライブラリ
109
110%package devel
111Summary: Development environment for panel applets of GNOME
112Summary(ja): GNOME のパネルアップレット用開発環境
113Group: Development/Libraries
114Requires: %{name}-libs = %{version}-%{release}
115Requires: pkgconfig
116Requires: glib2-devel >= %{glib2_version}
117Requires: gtk3-devel >= %{gtk3_version}
118
119%description devel
120Header files and libraries for building a panel applets of GNOME.
121
122%description devel -l ja
123GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
124
125
126%prep
127%setup -q
128
129cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
130cp -f %{SOURCE12} m4
131cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
132cp -f %{SOURCE13} data/panel-default-layout.layout
133
134. %{SOURCE10}
135
136for a in ca cs el es gu hu it pl pt_BR ru sr sv th zh_TW;
137do
138    sed -i "s|^$a$||" po/LINGUAS
139    rm -f po/$a.po
140done
141
142%build
143%configure \
144           --disable-gtk-doc \
145           --enable-introspection=yes \
146%if %{use_eds}
147           --enable-eds=yes
148%else
149           --enable-eds=no
150%endif
151make
152
153%install
154rm -rf $RPM_BUILD_ROOT
155
156make install DESTDIR=$RPM_BUILD_ROOT
157
158#
159# Create pager and tasklist schemas for compatibility with older
160# configurations which reference the old schema names
161#
162#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
163#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
164
165
166find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
167
168/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
169
170%find_lang %{gettext_package} --all-name --with-gnome
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post
176/sbin/ldconfig
177touch --no-create %{_datadir}/icons/hicolor
178if [ -x /usr/bin/gtk-update-icon-cache ]; then
179  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
180fi
181
182%postun
183/sbin/ldconfig
184touch --no-create %{_datadir}/icons/hicolor
185if [ -x /usr/bin/gtk-update-icon-cache ]; then
186  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
187fi
188update-desktop-database -q &> /dev/null ||:
189
190%posttrans
191update-desktop-database -q &> /dev/null ||:
192 
193%files -f %{gettext_package}.lang
194%defattr(-,root,root)
195%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
196%{_bindir}/*
197%exclude %{_bindir}/panel-test-applets
198%{_libdir}/%{name}/5.0/libclock-applet.so
199%{_libdir}/%{name}/5.0/libfish-applet.so
200%{_libdir}/%{name}/5.0/libnotification-area-applet.so
201%{_libdir}/%{name}/5.0/libwnck-applet.so
202%{_datadir}/applications/*.desktop
203%{_datadir}/icons/hicolor/*/*/*
204%{_datadir}/glib-2.0/schemas/*.xml
205%{_datadir}/gnome-panel
206%{_mandir}/man*/*
207
208%files libs
209%{_libdir}/*.so.*
210%{_libdir}/girepository-1.0/*.typelib
211
212%files devel
213%{_bindir}/panel-test-applets
214%{_libdir}/pkgconfig/*.pc
215%{_includedir}/gnome-panel*
216%{_libdir}/*.so
217%{_datadir}/gtk-doc
218%{_datadir}/gir-1.0/*.gir
219
220
221%changelog
222* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
223- new upstream release
224- add Source13 (panel-default-layout.layout.vine)
225
226* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
227- new upstream release
228
229* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
230- new upstream release
231- remove Patch0 (gnome-panel-3.5.91-configure.patch)
232- change BuildRequires: yelp-tools instead of gnome-doc-utils
233
234* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
235- new upstream release
236
237* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
238- new upstream release
239- add BuildRequires: polkit-devel
240
241* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
242- new upstream release
243
244* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
245- new upstream release
246
247* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
248- new upstream release
249- remove BuildRequires: polkit-gnome-devel
250
251* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-2
252- rebuild with evolution-data-server-3.1.90
253
254* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
255- new upstream release
256
257* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
258- new upstream release
259- drop old Patches
260- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
261- change BuildRequires: libwnck3-devel instead of libwnck-devel
262- add BuildRequires: dconf-devel, telepathy-glib-devel
263- add Obsoletes: gnome-netstatus
264- add Patch0 (gnome-panel-3.0.2-configure.patch)
265
266* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
267- update SOURCE2(vine6-panel-default-setup.entries)
268  - remove bottom panel
269  - move window_list and workspace_switcher applet to top panel
270
271* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
272- update Source1 (clock.gnome-2.32.ja.po)
273
274* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
275- remove Provides: gnome-panel-devel
276
277* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
278- new upstream release
279
280* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
281- new upstream release
282- add BuildRequires: gobject-introspection-devel
283- remove BuildRequires: libgnomeui-devel
284- remove SOURCE3 and SOURCE4
285- drop Patch11
286- add configure option (--enable-introspection=yes)
287
288* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
289- rebuild with rpm-4.8.1 for pkg-config file
290
291* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
292- create -libs and -devel package
293
294* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
295- new upstream release
296
297* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
298- rebuild with evolution-data-server-2.30.2
299
300* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
301- new upstream release
302- update Patch8, Patch9 (from FC package)
303- add BuildRequires: libcanberra-devel
304
305* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
306- update translation of clock applet manual
307- add translation of fish applet manual
308
309* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
310- add libSM(-devel) to (Build)Requires
311- add desktop-file-utils to BuildRequires
312
313* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
314- update translation of clock applet manual
315
316* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
317- new upstream release
318- updated Patch0 and 2
319
320* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
321- new upstream release
322
323* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
324- rebuild with gtk2-2.16.3
325
326* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
327- add empty gconf entries to vine-panel-default-setup.entries
328
329* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
330- new upstream release
331
332* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
333- new upstream release
334
335* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
336- update vine-panel-default-setup.entries again..
337
338* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
339- update vine-panel-default-setup.entries
340
341* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
342- remove mixer applets from default panel setup
343
344* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
345- new upstream release
346
347* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
348- new upstream release
349- added BuildRequires: PolicyKit-gnome-devel
350
351* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
352- new upstream release
353
354* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
355- new upstream release
356
357* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
358- new upstream release
359
360* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
361- new upstream release
362
363* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
364- new upstream release
365- removed Patch25,26,27,29 and 30 (merged into upstream)
366
367* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
368- added Patches from FC
369  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
370  - Fix editing of locations in the clock applet
371  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
372  - Convert the edit and find location windows to dialogs
373  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
374  - Improve the time settings window
375  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
376  - Make the find-location window of the clock larger
377  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
378  - Only save the session when the users wants it
379  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
380  - Populate the location list before showing the preference window
381  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
382  - Add "About This Computer" item to System menu if it exists
383  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
384  - Try harder to avoid resizing the popup
385- updated BuildRequires
386
387* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
388- new upstream release
389- added BuildRequires: libgweather-devel
390
391* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
392- new upstream release
393- updated %post and %postun section
394- added %pre and %preun section
395- added Patches from Fedora
396  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
397  - Sharper icons
398  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
399  - Make it possible to start s-c-d from the clock menu again (#316921)
400  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
401  - Don't pop up an error if an applet from the default
402    configuration is missing 
403  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
404  - Turns out we need requires for applets in the default config (#293261)
405  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
406  - Drop the requires for fast-user-switch-applet (#253831)
407
408* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
409- new upstream release
410- dropped Patch22 (merged into upstream)
411
412* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
413- new upstream release
414
415* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
416- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
417
418* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
419- new upstream release
420- fix panel-default-setup.entries to change the name of
421  firefox desktopfile (<BTS:229>)
422
423* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
424- add patch 11 to fix disappearing of recent documents list.
425  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
426
427* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
428- new upstream release
429
430* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
431- new upstream release
432
433* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
434- run gtk-update-icon-cache in %%post script.
435
436* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
437- new upstream release
438
439* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
440- update vine-panel-default-setup.entries
441  - replace mozilla by firefox
442  - remove nautilus
443  - add notification area applet on top panel
444  - add trashbox applet on bottom panel
445- cleanup %%post script
446
447* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
448- new upstream release
449
450* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
451- new upstream release
452- added Prereq: scroolkeeper, GConf2
453
454* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
455- new upstream release
456
457* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
458- new upstream release
459
460* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
461- new upstream release
462
463* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
464- new upstream release
465
466* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
467- new upstream release
468
469* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
470- disable evolution-data-server
471
472* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
473- new upstream release
474
475* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
476- add Patch10 to fix hard-coded desktop file name.
477
478* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
479- new upstream version
480
481* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
482- new upstream release
483- run scrollkeeper at %post, %postun
484
485* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
486- new upstream release
487
488* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
489- add Patch10 to fix egg-recent-model.c.
490  save old umask value before create ".recently-used" file.
491 
492* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
493- fix location of nautilus launcher in panel-default-setup.entries.
494- do not add wireless monitor in %%post when no interfaces are available.
495- add Japanese summary and description
496- add BuildRequires: startup-notification-devel, gcc-c++.
497- disable libtoolize: version mismatch is bad
498
499* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
500- new upstream release
501
502* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
503- new upstream release
504
505* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
506- rebuilt against new toolchain
507
508* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
509- add --disable-schemas-install option to %%configure
510
511* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
512- new upstream release
513
514* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
515- add missing files
516- add vine default panel entries
517
518* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
519- new upstream release
520
521* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
522- new upstream release
523
524* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
525- new upstream release
526
527* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
528- remove vine's panel-per-panel-config.schemas
529  This should be added again in a future version.
530
531* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
532- new upstream release
533
534* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
535- new upstream release
536- remove old ja.po
537
538* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
539- new upstream release
540
541* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
542- remove clockaddon, system-tray-applet
543
544* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
545- new upstream release
546
547* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
548- add patch1 from rawhide package.
549
550* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
551- new upstream release
552
553* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
554- add system-tray-applet
555- modify default panel menu.
556- update ja.po
557
558* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
559- add Requires: vine-menus
560
561* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
562- new upstream release
563
564* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
565- remove redhatize patch.
566
567* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
568- build for Vine Linux
569- new upstream release from gnome-2.1.4
570
571* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
572- fix postun script
573
574* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
575- 2.0.9 with menu edit stuff
576- system-tray-applet 0.15 that doesn't crash all the time
577- merge/remove patches as appropriate
578
579* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
580- Fix problem with "hold down print screen" (71432)
581
582* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
583- panel-properties OnlyShowIn=GNOME;
584- somehow the po file got screwed up.  Works now
585- update po files
586
587* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
588- fix from #71762 for clock applet popdown key
589- no WIN_POS_MOUSE fixes #72167
590- fix for #72540 from George
591
592* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
593- system tray applet 0.11 with a small memleak fix and a couple translations
594
595* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
596- menu tweaks
597
598* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
599- bump release
600
601* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
602- put battery applet on panel for laptops (#67296)
603
604* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
605- 2.0.6 final from gnome 2.0.1
606- remove gnome-panel-screenshot patch now upstream
607
608* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
609- new system-tray-applet version
610- Fix gnome-panel-screenshot
611
612* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
613- 2.0.4
614- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
615  for the foot menu
616
617* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
618- fix desktop (logout/lock) menu item location
619  in Alt+F1 and in new menu applets
620- remove Screenshot... menu item
621
622* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
623- move around default applets, remove some of them
624- system tray 0.9
625- change default menu flags
626- blow unpackaged files out of build root
627
628* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
629- 2.0.3
630- own libexecdir stuff
631
632* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
633- new system tray that's prettier and doesn't clip the icon
634
635* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
636- system tray 0.7 that doesn't crash on startup
637- get Mozilla desktop file right so we get web browser launcher
638
639* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
640- system tray 0.6 with server file fixed (work dammit)
641
642* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
643- tweak applet positions but I think it's just broken
644- system tray 0.5 moved back to libdir not libexecdir
645
646* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
647- remove ltmain.sh hack
648- new system-tray-applet that works
649
650* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
651- put office suite stuff on the panel
652
653* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
654- 2.0.2.90 cvs snap
655
656* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
657- update the clock patch to be a little smarter in a couple ways
658
659* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
660- Fix problem where system tray applet was being looked for in /unst
661- Fix a crash in the system tray applet
662
663* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
664- Fix typo in the pt_BR translation that was causing GConf problems
665
666* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
667- add the system tray applet
668- add system tray applet by default
669- add more launcher by default
670
671* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
672- automated rebuild
673
674* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
675- use correct gettext package name, and add check for missing translations
676
677* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
678- add the calendar and configuration patch
679
680* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
681- 2.0.0
682- add control center desktop file to file list
683- add gnome-panelrc to file list
684- try fixing panel size (blind, no text box at home)
685
686* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
687- rebuild in different environment
688
689* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
690- updates to default configuration
691
692* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
693- fix schemas installation
694
695* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
696- unset old panel schemas when installing new ones
697- put in a broken panel config to see errors about
698- add a patch to give some decent error messages about what's wrong
699  with the default panel config
700
701* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
702- rebuild in different environment
703
704* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
705- don't provide/obsolete gnome-core
706
707* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
708- rebuild in different environment
709
710* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
711- 1.5.24
712- ldconfig
713
714* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
715- rebuild in different environment
716
717* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
718- 1.5.23
719
720* Sun May 26 2002 Tim Powers <timp@redhat.com>
721- automated rebuild
722
723* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
724- rebuild in different environment
725
726* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
727- 1.5.22
728- provide gnome-core
729- add a bunch of extra build requires so build system
730  won't get confused
731
732* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
733- 1.5.19
734
735* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
736- add the keep-libtool-from-relinking hack so
737  we get the gen util applet
738
739* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
740- obsoletes gnome-core-devel
741- include libdir/*.so
742
743* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
744- get libpanel-applet in the package
745
746* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
747- Initial build.
748
749
Note: See TracBrowser for help on using the repository browser.