source: projects/specs/trunk/g/gnome-online-accounts/gnome-online-accounts-vl.spec @ 6201

Revision 6201, 3.5 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-themes: fix Vine theme
metacity: fix theme
others: new upstream release

Line 
1%define         package_version 3.4.2
2%define         package_release 1%{?_dist_release}
3
4Name:           gnome-online-accounts
5Version:        %{package_version}
6Release:        %{package_release}
7Summary:        GNOME applications and libraries to access the user's online accounts
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.4/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  glib2-devel
17BuildRequires:  gobject-introspection-devel
18BuildRequires:  gtk3-devel
19BuildRequires:  WebKit3-gtk-devel
20BuildRequires:  json-glib-devel
21BuildRequires:  libgnome-keyring-devel
22BuildRequires:  libnotify-devel
23BuildRequires:  rest-devel
24BuildRequires:  gtk-doc
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Takemikaduchi
29
30%description
31Gnome-online-accounts provides interfaces so applications and
32libraries in GNOME can access the user's online accounts
33
34%package devel
35Summary:        Development tools for gnome-online-accounts
36Summary(ja):    gnome-online-accounts の開発環境
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       pkgconfig
40Requires:       gtk3-devel
41
42%description devel
43Header files and libraries for building a extension library for the
44gnome-online-accounts.
45
46
47%package        doc
48Summary:        Documentation for gnome-online-accounts
49Summary(ja):    gnome-online-accounts 用のドキュメント
50Group:          Documentation
51Requires:       %{name} = %{version}-%{release}
52BuildArch:      noarch
53
54
55%description    doc
56This package contains documentation for gnome-online-accounts.
57
58
59%prep
60%setup -q
61
62%build
63%configure \
64        --enable-gtk-doc \
65        --disable-static \
66        --enable-introspection=yes
67
68make %{?_smp_mflags}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72#make DESTDIR=$RPM_BUILD_ROOT install
73make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
74
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
76
77%find_lang %{name}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post
83/sbin/ldconfig
84touch --no-create %{_datadir}/icons/
85
86%postun
87if [ $1 -eq 0 ] ; then
88    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
89    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
90fi
91
92%posttrans
93gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
94
95
96%files -f %{name}.lang
97%defattr(-,root,root,-)
98%doc ChangeLog AUTHORS COPYING NEWS README
99%{_libdir}/*.so.*
100%{_libexecdir}/goa-daemon
101%{_libdir}/girepository-1.0/*.typelib
102%{_datadir}/dbus-1/services/org.gnome.OnlineAccounts.service
103%{_datadir}/icons/hicolor/*/apps/*.png
104%{_mandir}/man8/goa-daemon.8.gz
105
106%files devel
107%defattr(-, root, root)
108%{_includedir}/goa-1.0
109%{_libdir}/*.so
110%{_libdir}/pkgconfig/*.pc
111%{_datadir}/gir-1.0/*.gir
112
113%files doc
114%defattr(-, root, root)
115%{_datadir}/gtk-doc/html/goa
116
117
118%changelog
119* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
120- new upstream release
121
122* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
123- new upstream release
124
125* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
126- new upstream release
127
128* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
129- new upstream release
130
131* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.91-1
132- new upstream release
133
134* Sun Sep 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
135- new upstream release
136
137* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
138- initial build for Vine Linux
139
Note: See TracBrowser for help on using the repository browser.