source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 9214

Revision 9214, 16.2 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1#TODO: Nautilus extention
2%global with_nautilus 0
3%global with_my_japo 0
4#% global svnrevision 2475
5#% global rcversion 1
6%global pretestversion b
7
8Name:           gnome-mplayer
9Version:        1.0.9
10Release:        2%{?pretestversion:.%pretestversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
11Summary:        MPlayer GUI, full-featured binary
12Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
13Group:          Applications/Multimedia
14License:        GPLv2+
15URL:            http://kdekorte.googlepages.com/gnomemplayer
16Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?pretestversion:%pretestversion}%{?svnrevision:.svn%svnrevision}%{?rcversion:.rc%rcversion}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
17Source10:       gnome-mplayer-snapshot.sh
18
19## vine
20%if %{with_my_japo}
21Source100:      gnome-mplayer-1.0.8a.svn2411-ja.po
22%endif
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  gmtk-devel >= 1.0.7
27BuildRequires:  alsa-lib-devel
28BuildRequires:  pulseaudio-libs-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  desktop-file-utils
31BuildRequires:  GConf2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34BuildRequires:  gtk3-devel
35# BuildRequires:  gtk2-devel
36#BuildRequires:  libcurl-devel
37BuildRequires:  curl-devel
38BuildRequires:  libgpod-devel
39BuildRequires:  libmusicbrainz3-devel
40#BuildRequires:  libmusicbrainz-devel
41BuildRequires:  libnotify-devel
42BuildRequires:  libXScrnSaver-devel
43BuildRequires:  gnome-power-manager
44
45Requires:       gvfs-fuse
46Requires:       gnome-power-manager
47#Requires:       mencoder
48#Requires:       self-build-mplayer
49
50Requires(pre):  GConf2
51Requires(post): GConf2
52Requires(preun): GConf2
53
54Distribution:   Vine Linux
55Vendor:         Project Vine
56Packager:       munepi
57
58
59%description
60GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
61player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
62a rich API that is exposed via DBus. Using DBus you can control a single or
63multiple instances of GNOME MPlayer from a single command.
64
65%description -l ja
66GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
67インターフェースです。とても引き締まったていて,
68MPlayer への簡単でかつ明確なインターフェースを提供します.
69GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
70DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
71GNOME MPlayer のインスタンスを制御できます.
72
73gnome-mplayer を使うためには,別途 mplayer が必要です.
74
75
76%if %{with_nautilus}
77%package nautilus
78Summary:        A Nautilus extention of %{name}
79Summary(ja):    %{name} の Nautilus 拡張
80Group:          Applications/Multimedia
81Requires:       %{name} = %{version}-%{release}
82Requires:       nautilus-extensions
83
84%description nautilus
85GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
86player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
87a rich API that is exposed via DBus. Using DBus you can control a single or
88multiple instances of GNOME MPlayer from a single command.
89
90This package provides a nautilus extension, which shows properties of audio and
91video files in the properties dialogue.
92
93%description nautilus -l ja
94GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
95インターフェースです。とても引き締まったていて,
96MPlayer への簡単でかつ明確なインターフェースを提供します.
97GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
98DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
99GNOME MPlayer のインスタンスを制御できます.
100
101このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
102プロパティを示すに Nautilus 拡張を提供します.
103%endif
104
105%prep
106#% setup -q %{?rcversion:-n %{name}-%{version}.rc%{rcversion}}
107%setup -q %{?pretestversion:-n %{name}-%{version}%pretestversion}
108
109## vine
110%if %{with_my_japo}
111%__install -m644 %{SOURCE100} po/ja.po
112%endif
113
114
115%build
116%configure \
117    --enable-gtk3 \
118    %if !%{with_nautilus}
119    --disable-nautilus \
120    %endif
121    --disable-schemas-compile \
122    \
123    --with-dbus \
124    --with-alsa \
125    --with-pulseaudio \
126    --with-libnotify \
127    --with-libgpod \
128    %if %{?_dist_release} != "vl5"
129    --with-libmusicbrainz3 \
130    %endif
131    ;
132
133%__make %{?_smp_mflags}
134
135
136%install
137%__rm -rf $RPM_BUILD_ROOT
138
139export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
140%__make install DESTDIR=$RPM_BUILD_ROOT
141
142desktop-file-install --vendor=vine \
143       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
144       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
145
146%find_lang %{name}
147
148# remove intrusive docs
149%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
150
151# remove unpackaged files
152find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
153
154
155# %pre
156# if [ "$1" -gt 1 ]; then
157#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
158#     gconftool-2 --makefile-uninstall-rule \
159#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
160#     # If the schema file has ever been renamed::
161#     #gconftool-2 --makefile-uninstall-rule \
162#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
163# fi
164
165
166%post
167touch --no-create %{_datadir}/icons/hicolor
168if [ -x %{_bindir}/gtk-update-icon-cache ]; then
169  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
170fi
171update-desktop-database &> /dev/null || :
172
173# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
174# gconftool-2 --makefile-install-rule \
175#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
176
177%posttrans
178glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
179# update-desktop-database %{_datadir}/applications/
180
181# %preun
182# if [ "$1" -eq 0 ]; then
183#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
184#     gconftool-2 --makefile-uninstall-rule \
185#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
186# fi
187
188%postun
189if [ $1 -eq 0 ]; then
190  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
191  update-desktop-database %{_datadir}/applications/
192fi
193
194touch --no-create %{_datadir}/icons/hicolor
195if [ -x %{_bindir}/gtk-update-icon-cache ]; then
196  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
197fi
198update-desktop-database &> /dev/null || :
199
200
201%clean
202%__rm -rf $RPM_BUILD_ROOT
203
204
205%files -f %{name}.lang
206%defattr(-,root,root,-)
207%{_bindir}/gnome-mplayer
208%{_datadir}/applications/*-gnome-mplayer.desktop
209%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
210%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
211# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
212%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
213%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
214%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
215%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
216%{_mandir}/man1/gnome-mplayer.1.gz
217
218%if %{with_nautilus}
219%files nautilus
220%{_libdir}/nautilus/extensions-2.0/*.so.*
221%{_libdir}/nautilus/extensions-2.0/*.so
222%endif
223
224
225%changelog
226* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.9-2.b
227- updated to 1.0.9b; this is the second alpha version
228
229* Tue Sep 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.9-1.a
230- updated to 1.0.9a; this is the first alpha version
231
232* Thu Mar  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-4
233- new upstream release
234
235* Wed Feb 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-3.b
236- updated to 1.0.8b (beta)
237
238* Sun Feb 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-2.a.svn2411
239- update to svn2411
240- updated ja.po: gnome-mplayer-1.0.8a.svn2411-ja.po
241
242* Fri Feb  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-1.a.svn2398
243- update to svn2398
244- updated ja.po: gnome-mplayer-1.0.8a.svn2398-ja.po
245
246* Thu Nov  1 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-1
247- new upstream release
248
249* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-4
250- dropped a wrapper of /usr/bin/gnome-mplayer
251
252* Mon Apr 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-3
253- new upstream release
254
255* Thu Apr  5 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-2.b1.svn2227
256- source 1.0.6b1 svn2227
257- updated ja.po
258
259* Sat Mar 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-1.b1
260- new upstream release
261
262* Tue Feb 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
263- updated ja.po
264
265* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
266- updated ja.po
267
268* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
269- new upstream release
270
271* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1.b1.svn2180
272- source 1.0.5b1
273- updated ja.po
274- added BuildRequires: gmtk-devel >= 1.0.5
275  - dropped --disable-static from %%configure
276- enable gtk3 for vl7
277  - added BuildRequires: gtk3-devel
278  - added --enable-gtk3 in %%configure
279
280* Sun Sep 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-4
281- rebuilt with libnotify-0.7.4
282
283* Mon Jul 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-3
284- new upstream release
285
286* Fri Jun 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2.b2
287- source 1.0.4b2
288
289* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
290- source snapshot 1.0.4b1 r2124
291- use gsettings
292
293* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
294- new upstream release
295
296* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
297- source snapshot 1.0.3beta r1992
298
299* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
300- source snapshot 1.0.3beta r1989
301  - added --disable-schemas-compile in configure options
302  - use GSettings (%%posttrans, %%postun)
303- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
304
305* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
306- new upstream release
307
308* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
309- source snapshot 1.0.1b1 r1912
310
311* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
312- source snapshot 1.0.1b1 r1892
313- added BuildRequires: pulseaudio-libs-devel
314
315* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
316- new upstream release
317- added BuildRequires:
318  - libmusicbrainz3-devel (only vl6)
319  - gnome-power-manager
320- added Requires: gnome-power-manager
321
322* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
323- source 0.9.99.rc3
324
325* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
326- source 0.9.99.rc1
327  - applied gnome-mplayer-0.9.99.rc1-ja.po
328  - entry ja in gnome-mplayer.desktop
329
330* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
331- source snapshot r1729
332
333* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
334- fixed gnome-mplayer.sh.in
335
336* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
337- source snapshot r1685
338- added gnome-mplayer.sh.in
339  - this script is a wrapper to check MPlayer binary existance
340
341* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
342- source snapshot r1673
343  - Rework vdpau codec selection and deinterlace (r1673)
344
345* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
346- new upstream release
347
348* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
349- new upstream release
350- added gnome-mplayer-snapshot.sh
351
352* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
353- source snapshot r1619
354- added gnome-mplayer-0.9.9.svn1619-ja.po
355
356* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
357- source snapshot r1599
358- added BuildRequires: libXScrnSaver-devel
359
360* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
361- source snapshot r1583
362- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
363
364* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
365- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
366  - fix hidden cursor over menus (r1576)
367
368* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
369- new upstream release
370
371* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
372- source snapshot r1540
373
374* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
375- source snapshot r1538
376  - updated the latest up-to-date ja.po
377
378* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
379- new upstream release
380
381* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
382- source snapshot r1493
383
384* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
385- source snapshot r1486
386  - updated the latest up-to-date ja.po
387- added gtk-update-icon-cache actions in %%post, %%postun
388
389* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
390- rebuild with libgpod-0.7.2
391- gconf uninstall rule in %%preun, not %%postun
392
393* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
394- new upstream release
395
396* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
397- source snapshot r1298
398  - updated the latest up-to-date ja.po
399
400* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
401- dropped Requires: self-build-mplayer
402
403* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
404- source snapshot r1236
405- updated the latest up-to-date ja.po
406
407* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
408- new upstream release
409
410* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
411- dropped a Nautilus plugin once
412
413* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
414- source snapshot r1184
415- dropped gnome-mplayer-0.9.4-ja.patch
416  - committed Japanese translation
417- applied gnome-mplayer-0.9.4.r1184-ja.po
418  - update the latest up-to-date ja.po
419
420* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
421- added Summary(ja), %%description -l ja
422- updated gnome-mplayer-0.9.4-ja.patch
423
424* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
425- new upstream release
426- updated gnome-mplayer-0.9.4-ja.patch
427- updated gnome-mplayer-0.9.4-ja.po
428- updated the URL tag
429
430* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
431- initial build
432- added ja.po
433
434* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
435- Added patch fixing rpmfusion bug #238 from SVN
436- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
437
438* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
439- Updated to 0.9.3
440
441* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
442- Refactored the spec to allow building both minimal and full-featured versions
443- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
444
445* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
446- Updated to 0.9.2
447- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
448- Provide gnome-mplayer-core-functionality
449
450* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
451- Updated to 0.9.1
452
453* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
454- Updated to 0.9.0
455- Added libnotify-devel to BuildRequires
456- Added gvfs-fuse to Requires
457
458* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
459- Updated to 0.8.0
460
461* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
462- Added alsa-lib-devel to BuildRequires (livna bug #2084)
463
464* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
465- Updated to 0.7.0
466
467* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
468- rebuild for buildsys cflags issue
469
470* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
471- Updated to 0.6.3
472
473* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
474- Added mencoder to Requires (bug #1991)
475
476* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
477- Updated to 0.6.2
478
479* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
480- Updated to 0.6.1
481- Updated URL and Source0
482
483* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
484- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.