source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 8772

Revision 8772, 16.3 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild package

Line 
1#TODO: Nautilus extention
2%global with_nautilus 0
3%global with_my_japo 0
4#% global svnrevision 2411
5#% global rcversion 1
6%global pretestversion a
7
8Name:           gnome-mplayer
9Version:        1.0.9
10Release:        2%{?pretestversion:.%pretestversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
11Summary:        An MPlayer GUI, a full-featured binary
12Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
13Group:          Applications/Multimedia
14License:        GPLv2+
15URL:            http://kdekorte.googlepages.com/gnomemplayer
16Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?pretestversion:%pretestversion}%{?svnrevision:.svn%svnrevision}%{?rcversion:.rc%rcversion}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
17Source10:       gnome-mplayer-snapshot.sh
18
19## vine
20%if %{with_my_japo}
21Source100:      gnome-mplayer-1.0.8a.svn2411-ja.po
22%endif
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  gmtk-devel >= 1.0.7
27BuildRequires:  alsa-lib-devel
28BuildRequires:  pulseaudio-libs-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  desktop-file-utils
31BuildRequires:  GConf2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34%if %{?_dist_release} == "vl7"
35BuildRequires:  gtk3-devel
36%else
37%if %{?_dist_release} == "vl6"
38BuildRequires:  gtk2-devel
39%endif
40%endif
41#BuildRequires:  libcurl-devel
42BuildRequires:  curl-devel
43BuildRequires:  libgpod-devel
44%if %{?_dist_release} != "vl5"
45BuildRequires:  libmusicbrainz3-devel
46%endif
47#BuildRequires:  libmusicbrainz-devel
48BuildRequires:  libnotify-devel
49BuildRequires:  libXScrnSaver-devel
50BuildRequires:  gnome-power-manager
51
52Requires:       gvfs-fuse
53Requires:       gnome-power-manager
54#Requires:       mencoder
55#Requires:       self-build-mplayer
56
57Requires(pre):  GConf2
58Requires(post): GConf2
59Requires(preun): GConf2
60
61Distribution:   Vine Linux
62Vendor:         Project Vine
63Packager:       munepi
64
65
66%description
67GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
68player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
69a rich API that is exposed via DBus. Using DBus you can control a single or
70multiple instances of GNOME MPlayer from a single command.
71
72%description -l ja
73GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
74インターフェースです。とても引き締まったていて,
75MPlayer への簡単でかつ明確なインターフェースを提供します.
76GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
77DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
78GNOME MPlayer のインスタンスを制御できます.
79
80gnome-mplayer を使うためには,mplayer が必要です.
81
82
83%if %{with_nautilus}
84%package nautilus
85Summary:        A Nautilus extention of %{name}
86Summary(ja):    %{name} の Nautilus 拡張
87Group:          Applications/Multimedia
88Requires:       %{name} = %{version}-%{release}
89Requires:       nautilus-extensions
90
91%description nautilus
92GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
93player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
94a rich API that is exposed via DBus. Using DBus you can control a single or
95multiple instances of GNOME MPlayer from a single command.
96
97This package provides a nautilus extension, which shows properties of audio and
98video files in the properties dialogue.
99
100%description nautilus -l ja
101GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
102インターフェースです。とても引き締まったていて,
103MPlayer への簡単でかつ明確なインターフェースを提供します.
104GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
105DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
106GNOME MPlayer のインスタンスを制御できます.
107
108このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
109プロパティを示すに Nautilus 拡張を提供します.
110%endif
111
112%prep
113#% setup -q %{?rcversion:-n %{name}-%{version}.rc%{rcversion}}
114%setup -q %{?pretestversion:-n %{name}-%{version}%pretestversion}
115
116## vine
117%if %{with_my_japo}
118%__install -m644 %{SOURCE100} po/ja.po
119%endif
120
121
122%build
123%configure \
124    %if %{?_dist_release} == "vl7"
125    --enable-gtk3 \
126    %endif
127    %if !%{with_nautilus}
128    --disable-nautilus \
129    %endif
130    --disable-schemas-compile \
131    \
132    --with-dbus \
133    --with-alsa \
134    --with-pulseaudio \
135    --with-libnotify \
136    --with-libgpod \
137    %if %{?_dist_release} != "vl5"
138    --with-libmusicbrainz3 \
139    %endif
140    ;
141%__make %{?_smp_mflags}
142
143
144%install
145%__rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148%__make install DESTDIR=$RPM_BUILD_ROOT
149
150desktop-file-install --vendor=vine \
151       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
152       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
153
154%find_lang %{name}
155
156# remove intrusive docs
157%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
158
159# remove unpackaged files
160find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
161
162
163# %pre
164# if [ "$1" -gt 1 ]; then
165#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
166#     gconftool-2 --makefile-uninstall-rule \
167#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
168#     # If the schema file has ever been renamed::
169#     #gconftool-2 --makefile-uninstall-rule \
170#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
171# fi
172
173
174%post
175touch --no-create %{_datadir}/icons/hicolor
176if [ -x %{_bindir}/gtk-update-icon-cache ]; then
177  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
178fi
179update-desktop-database &> /dev/null || :
180
181# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
182# gconftool-2 --makefile-install-rule \
183#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
184
185%posttrans
186glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
187# update-desktop-database %{_datadir}/applications/
188
189# %preun
190# if [ "$1" -eq 0 ]; then
191#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
192#     gconftool-2 --makefile-uninstall-rule \
193#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
194# fi
195
196%postun
197if [ $1 -eq 0 ]; then
198  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
199  update-desktop-database %{_datadir}/applications/
200fi
201
202touch --no-create %{_datadir}/icons/hicolor
203if [ -x %{_bindir}/gtk-update-icon-cache ]; then
204  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
205fi
206update-desktop-database &> /dev/null || :
207
208
209%clean
210%__rm -rf $RPM_BUILD_ROOT
211
212
213%files -f %{name}.lang
214%defattr(-,root,root,-)
215%{_bindir}/gnome-mplayer
216%{_datadir}/applications/*-gnome-mplayer.desktop
217%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
218%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
219# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
220%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
221%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
222%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
223%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
224%{_mandir}/man1/gnome-mplayer.1.gz
225
226%if %{with_nautilus}
227%files nautilus
228%{_libdir}/nautilus/extensions-2.0/*.so.*
229%{_libdir}/nautilus/extensions-2.0/*.so
230%endif
231
232
233%changelog
234* Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-2.a
235- rebuild with libplist-1.11
236
237* Tue Sep 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.9-1.a
238- updated to 1.0.9a; this is first alpha version
239
240* Thu Mar  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-4
241- new upstream release
242
243* Wed Feb 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-3.b
244- updated to 1.0.8b (beta)
245
246* Sun Feb 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-2.a.svn2411
247- update to svn2411
248- updated ja.po: gnome-mplayer-1.0.8a.svn2411-ja.po
249
250* Fri Feb  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-1.a.svn2398
251- update to svn2398
252- updated ja.po: gnome-mplayer-1.0.8a.svn2398-ja.po
253
254* Thu Nov  1 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-1
255- new upstream release
256
257* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-4
258- dropped a wrapper of /usr/bin/gnome-mplayer
259
260* Mon Apr 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-3
261- new upstream release
262
263* Thu Apr  5 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-2.b1.svn2227
264- source 1.0.6b1 svn2227
265- updated ja.po
266
267* Sat Mar 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-1.b1
268- new upstream release
269
270* Tue Feb 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
271- updated ja.po
272
273* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
274- updated ja.po
275
276* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
277- new upstream release
278
279* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1.b1.svn2180
280- source 1.0.5b1
281- updated ja.po
282- added BuildRequires: gmtk-devel >= 1.0.5
283  - dropped --disable-static from %%configure
284- enable gtk3 for vl7
285  - added BuildRequires: gtk3-devel
286  - added --enable-gtk3 in %%configure
287
288* Sun Sep 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-4
289- rebuilt with libnotify-0.7.4
290
291* Mon Jul 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-3
292- new upstream release
293
294* Fri Jun 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2.b2
295- source 1.0.4b2
296
297* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
298- source snapshot 1.0.4b1 r2124
299- use gsettings
300
301* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
302- new upstream release
303
304* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
305- source snapshot 1.0.3beta r1992
306
307* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
308- source snapshot 1.0.3beta r1989
309  - added --disable-schemas-compile in configure options
310  - use GSettings (%%posttrans, %%postun)
311- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
312
313* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
314- new upstream release
315
316* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
317- source snapshot 1.0.1b1 r1912
318
319* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
320- source snapshot 1.0.1b1 r1892
321- added BuildRequires: pulseaudio-libs-devel
322
323* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
324- new upstream release
325- added BuildRequires:
326  - libmusicbrainz3-devel (only vl6)
327  - gnome-power-manager
328- added Requires: gnome-power-manager
329
330* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
331- source 0.9.99.rc3
332
333* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
334- source 0.9.99.rc1
335  - applied gnome-mplayer-0.9.99.rc1-ja.po
336  - entry ja in gnome-mplayer.desktop
337
338* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
339- source snapshot r1729
340
341* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
342- fixed gnome-mplayer.sh.in
343
344* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
345- source snapshot r1685
346- added gnome-mplayer.sh.in
347  - this script is a wrapper to check MPlayer binary existance
348
349* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
350- source snapshot r1673
351  - Rework vdpau codec selection and deinterlace (r1673)
352
353* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
354- new upstream release
355
356* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
357- new upstream release
358- added gnome-mplayer-snapshot.sh
359
360* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
361- source snapshot r1619
362- added gnome-mplayer-0.9.9.svn1619-ja.po
363
364* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
365- source snapshot r1599
366- added BuildRequires: libXScrnSaver-devel
367
368* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
369- source snapshot r1583
370- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
371
372* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
373- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
374  - fix hidden cursor over menus (r1576)
375
376* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
377- new upstream release
378
379* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
380- source snapshot r1540
381
382* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
383- source snapshot r1538
384  - updated the latest up-to-date ja.po
385
386* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
387- new upstream release
388
389* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
390- source snapshot r1493
391
392* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
393- source snapshot r1486
394  - updated the latest up-to-date ja.po
395- added gtk-update-icon-cache actions in %%post, %%postun
396
397* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
398- rebuild with libgpod-0.7.2
399- gconf uninstall rule in %%preun, not %%postun
400
401* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
402- new upstream release
403
404* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
405- source snapshot r1298
406  - updated the latest up-to-date ja.po
407
408* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
409- dropped Requires: self-build-mplayer
410
411* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
412- source snapshot r1236
413- updated the latest up-to-date ja.po
414
415* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
416- new upstream release
417
418* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
419- dropped a Nautilus plugin once
420
421* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
422- source snapshot r1184
423- dropped gnome-mplayer-0.9.4-ja.patch
424  - committed Japanese translation
425- applied gnome-mplayer-0.9.4.r1184-ja.po
426  - update the latest up-to-date ja.po
427
428* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
429- added Summary(ja), %%description -l ja
430- updated gnome-mplayer-0.9.4-ja.patch
431
432* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
433- new upstream release
434- updated gnome-mplayer-0.9.4-ja.patch
435- updated gnome-mplayer-0.9.4-ja.po
436- updated the URL tag
437
438* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
439- initial build
440- added ja.po
441
442* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
443- Added patch fixing rpmfusion bug #238 from SVN
444- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
445
446* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
447- Updated to 0.9.3
448
449* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
450- Refactored the spec to allow building both minimal and full-featured versions
451- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
452
453* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
454- Updated to 0.9.2
455- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
456- Provide gnome-mplayer-core-functionality
457
458* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
459- Updated to 0.9.1
460
461* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
462- Updated to 0.9.0
463- Added libnotify-devel to BuildRequires
464- Added gvfs-fuse to Requires
465
466* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
467- Updated to 0.8.0
468
469* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
470- Added alsa-lib-devel to BuildRequires (livna bug #2084)
471
472* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
473- Updated to 0.7.0
474
475* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
476- rebuild for buildsys cflags issue
477
478* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
479- Updated to 0.6.3
480
481* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
482- Added mencoder to Requires (bug #1991)
483
484* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
485- Updated to 0.6.2
486
487* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
488- Updated to 0.6.1
489- Updated URL and Source0
490
491* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
492- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.